15:01:51 <adamw> #startmeeting Fedora QA meeting
15:01:51 <zodbot> Meeting started Mon Jul 14 15:01:51 2014 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:54 <adamw> #meetingname fedora-qa
15:01:54 <zodbot> The meeting name has been set to 'fedora-qa'
15:01:58 <adamw> #topic Roll call
15:02:04 <adamw> ahoyhoy, who's here for some quality quality?
15:02:35 * tflink is here
15:02:55 <tflink> the brno qe folks are not likely to be here - teambuilding today and tomorrow
15:03:51 <adamw> lucky bar stewards
15:03:54 <adamw> #chair tflink
15:03:54 <zodbot> Current chairs: adamw tflink
15:04:23 * roshi is here
15:06:52 <adamw> brunowolff: satellit: around?
15:07:04 <adamw> cmurf: ditto
15:07:33 <cmurf> ?
15:07:50 <adamw> cmurf: just pingin' to see if we have more than three people for the meeting :)
15:08:06 <cmurf> OIC well I'm distracted, TDF.
15:08:19 <adamw> rgr
15:09:30 <cmurf> but yes if you put cmurf in the line then the irc client slaps me
15:09:36 * pwhalen is here
15:09:41 <cmurf> so you have three
15:09:53 <adamw> cmurf: you might want to dial it down from 'physical chastisement' to 'polite beep'
15:09:57 <adamw> i'm just sayin'
15:10:13 <adamw> hey pwhalen
15:10:23 <adamw> pwhalen: thanks for keeping turning out to these things, btw!
15:10:24 <pwhalen> adamw, good day
15:10:35 <tflink> getting an irc client to interact with the physical world is rather impressive, though
15:10:52 <pwhalen> adamw, gotta represent :)
15:10:58 * tflink has been having trouble just getting a client to send emails or make noises :)
15:11:31 <adamw> tflink: the way I understand it works is that whenever you have a problem like this you say "arduino!" and the magic arduino fairy comes and solves it for you
15:12:19 * tflink wonders what happens when you say it 3 times in front of a mirror at night
15:12:30 <roshi> you get assimilated
15:13:41 <tflink> hrm, that might help get systems up faster ...
15:14:11 <adamw> you BECOME the arduino
15:14:26 <adamw> alrighty
15:14:37 <adamw> #topic Previous meeting follow-up
15:15:07 <adamw> #info "adamw to look at how the Install, Base and Desktop matrices should be adjusted for Fedora.next" and "adamw to, uh, completely revise / write all the backing process documentation for Fedora.next testing, that'll be easy" - well, i kinda sorta did those
15:15:28 <adamw> or at least, i think we got all the relevant stuff to an acceptable state for Alpha, I still need to do Beta and Final
15:16:30 <adamw> #info see https://lists.fedoraproject.org/pipermail/test/2014-July/121881.html , https://lists.fedoraproject.org/pipermail/test/2014-July/121884.html , https://lists.fedoraproject.org/pipermail/test/2014-July/121888.html , https://lists.fedoraproject.org/pipermail/test/2014-July/121894.html for the summaries of the work done
15:17:32 <adamw> #info "roshi to run a blocker review meeting some time this week" - that got done too, thanks to everyone who attended and helped weed the initial pile of blockers: https://lists.fedoraproject.org/pipermail/test/2014-July/121901.html
15:18:24 <adamw> i think that's it for follow-up
15:18:31 <roshi> looks like it to me
15:18:45 <adamw> #topic Fedora 21 status
15:19:16 <adamw> so it looks like we're still waiting on TC1, releng is figuring out the new compose process
15:19:30 <roshi> any rough ETA?
15:19:33 <adamw> #info Alpha TC1 has still not yet landed, releng is working out the kinks in the new compose process
15:19:42 <adamw> they sounded fairly close on Friday, but i'm not sure
15:19:44 <adamw> nirik: around?
15:21:43 <adamw> i guess not. so, yeah, it's just my impression that they're fairly close.
15:21:52 <roshi> good to hear
15:22:03 <adamw> we do already have some decent testing based on the rawhide/branched nightlies, though
15:22:08 <nirik> yes, but doing 5 things. ;)
15:22:21 <brunowolff> I was doing some other stuff, but can pay attention now.
15:22:22 <adamw> nirik: ah, can you say quickly what the status/eta of tc1 compose is, if known?
15:22:23 <nirik> dgilmore said he was running into tooling issues... hopes to have something sometime today tho
15:22:30 <adamw> awesome, thanks
15:22:51 <adamw> #info releng hitting tooling issues with Alpha TC1 compose, but hope to have something today
15:23:23 <adamw> brunowolff: (insert timezone-appropriate greeting)
15:24:17 <adamw> so i believe the selinux bug - https://bugzilla.redhat.com/show_bug.cgi?id=1116450 - should be resolved with recent nightlies (notwithstanding the POST status, the fixed lorax build was completed on 2014-07-12: http://koji.fedoraproject.org/koji/buildinfo?buildID=543406 )
15:24:22 <adamw> so that's something we can check
15:24:41 <pwhalen> nice
15:26:46 <adamw> ditto anaconda depending on networkmanager-wifi, i think, though that's a less serious issue for most folks
15:27:24 <adamw> it would be great for people to keep testing the nightlies until we finally do get tc1, make sure no new showstoppers are showing up etc
15:27:26 <brunowolff> I plan on doing a fresh install of TC1 on a laptop that want to have F21 on for a trip at the start of August. So I'll be trying it out, soon after it's available.
15:27:33 <adamw> awesome, thanks
15:27:54 <adamw> #info please keep testing nightlies until TC1 lands, and report any newly-found blockers
15:28:58 <brunowolff> I have bisecting a kernel bug that affects on of my two i686 machines. At this point I don't think it is the video card. But until I know what it is I don't know if it affects many or few machines.
15:29:13 <adamw> what's the symptom?
15:29:23 <brunowolff> Crash very early in the boot.
15:30:06 <brunowolff> I have a bug filed in Fedora. I have some pictures of the traceback. (Crash is before netconsole works.) and the bisect log so far.
15:30:38 <adamw> OK. thanks for looking into it, if the diagnosis looks like it'd affect a reasonable number of machines, do stick it up as a blocker...
15:30:39 <brunowolff> I'll file a bug upstream when I know more about which subsystem seems to have the problem.
15:31:56 <adamw> awesome
15:32:22 <adamw> so, another bug that's been floating around which i'm curious about - this 'journalctl' issue robert day posted about and a few others mentioned they'd seen
15:32:31 <adamw> something causing lots of journalctl processes to spawn and thrash the CPU
15:32:44 <adamw> is anyone else seeing that at present? been able to pin it down at all?
15:32:46 <roshi> yeah - I was wondering about that one as well
15:32:50 <nirik> I saw it once, but it never repeated, so no idea what caused it or what it was.
15:32:53 * roshi hasn't seen it
15:35:40 <adamw> welp, let's keep an eye out
15:35:44 <adamw> i guess i can run it by the abrt devs too
15:35:58 <adamw> #action adamw to ask abrt devs about the journalctl bug seen by Robert Day
15:36:36 <brunowolff> I haven't seen it, but I think I have some of the abort stuff turned off.
15:36:46 <adamw> so just to open things up more generally - does anyone have any concerns / issues / thoughts on f21 and the whole fedora.next thing which might need considering for alpha but which haven't been looked at already?
15:36:58 <adamw> sorry for the open ended question, just wanted to make sure no-one's sitting on any worries
15:38:55 <brunowolff> I filed some selinux bugs for AVCs I had been seeing and work seems to be happening on them.
15:39:15 * danofsatx-work is here, really....
15:39:22 <roshi> just so I'm clear - we're doing the normal lives/spins, workstation and server will have their own DVD equivilents? do we do delta-isos for live images?
15:39:24 <adamw> brunowolff: cool, thanks
15:39:30 <danofsatx-work> too much conversation in my office regarding this thing called "real job"
15:39:41 <adamw> roshi: the deliverables as i understand them are in the TC1 request ticket (are you cced on that?)
15:39:47 <roshi> yeah
15:40:06 <adamw> workstation live, desktop spins, server netinst and 'dvd', cloud disk images, arm disk images
15:40:09 <adamw> is broadly what i got listed
15:40:20 <brunowolff> The kernel / selinux bug that affects booting in enforcing mode with encrypted partitions has made some progress. The proposed patch appearantly needs work, though the version I tested fixed things.
15:40:24 <adamw> i don't believe workstation initially planned a traditional installer image, but they may change that plan
15:40:36 <adamw> brunowolff: i hadn't seen that one, what's the #?
15:40:36 <roshi> I'm just wondering how many places in the wiki we need to re-word things to not reference the DVD and delta-isos for the DVD
15:41:02 <nirik> there were some concerns about 'standard' users not having a dvd or netinstall... but thats not really a qa issue. (unless we decide somehow to make them and they need testing)
15:41:28 <adamw> roshi: so there's a couple of test cases which have 'DVD' in the name, i've left them that way for now as it didn't quite feel like it was necessary to rename them, but i did change the *wording* to refer a bit more generically to 'traditional installer images containing a package repository' or the like
15:41:33 <brunowolff> https://bugzilla.redhat.com/show_bug.cgi?id=1115120 It's an alpha blocker.
15:41:33 <adamw> which basically at present means 'server'
15:41:59 <roshi> sounds good - it was just something I was thinking about
15:42:09 <adamw> brunowolff: ah, missed that one. thanks for the info
15:42:26 <adamw> roshi: there may be places i didn't spot yet indeed, it'd be good to just poke through the whole process for 'DVD' cases
15:42:29 <adamw> (though tedious)
15:42:40 <adamw> i definitely hit up a few already, but there may be more
15:42:46 <roshi> we'll just keep an eye out I think
15:43:00 <adamw> the server offline install image is very much a DVD-type image, but it doesn't quite make sense to refer to it as 'the DVD image' any more, so yeah, we should adjust.
15:43:00 * roshi figured you probably had
15:43:11 <adamw> s/is/will be/, i guess.
15:43:29 <adamw> i'm expecting andre will be able to build delta ISOs for it, once it exists.
15:43:40 <adamw> we can't do delta ISOs for live images as they don't actually contain packages.
15:43:46 <danofsatx-work> adamw, roshi - y'all need anything from me? day job is calling, short notice taskers that need fixed
15:43:48 <adamw> deltas only make sense for DVD-type images.
15:44:04 <adamw> danofsatx-work: not unless you have any concerns regarding f21 that you think need to be addressed and currently aren't being
15:44:08 <roshi> just do all the work danofsatx-work - let us know when you're done
15:44:11 <adamw> otherwise, we're just spitballin' :)
15:44:15 <adamw> ++roshi
15:44:24 <danofsatx-work> not off hand, I'll post @test if I find something.
15:44:37 <roshi> and if you could plan out F22 while you're at it - that would be great too
15:44:49 <roshi> automate and move all the things to the cloud :p
15:45:02 <danofsatx-work> I already said I wanted to name F22 'Raptor'
15:45:07 <danofsatx-work> isn't that enough?
15:45:11 <roshi> haha
15:45:14 <roshi> +1
15:45:33 <brunowolff> Another bug I have that probably isn't broad enough to rise to blocker is that it looks like a ruby library used by Midori was built with SSE2 enabled for i686 without doing a run time test. This doesn't work well on AMD machines.
15:45:39 <adamw> we are moving our workloads to the cloud, where "cloud" is defined as "danofsatx"
15:45:51 <danofsatx-work> .fire adamw
15:45:52 <zodbot> adamw fires adamw
15:45:56 <adamw> brunowolff: probably not a blocker indeed, but nice catch, you're on fire
15:46:11 <danofsatx-work> ok, I'm out. be nice and have fun.
15:46:22 <roshi> later danofsatx-work
15:46:27 <adamw> yup, laters
15:49:47 <adamw> welp, i guess we've covered things...mostly we're waiting on alpha tc1, it looks like, but do keep testing nightlies (and karma'ing f19 and f20)
15:49:50 <adamw> #topic open floor
15:51:04 <robatino> https://fedoraproject.org/wiki/QA:Testcase_Mediakit_ISO_Size doesn't mention the new images, that'll have to be fixed once they appear
15:51:49 <robatino> i think the server DVD size target is 4 GB
15:52:30 <brunowolff> The Games spin is oversized right now, but I wanted to wait a bit and see if the size dropped from other work before removing some stuff.
15:52:59 <adamw> robatino: yeah indeed, good catch
15:53:11 <adamw> robatino: i guess the media sizes should be specified in the tech specs
15:53:19 <adamw> then we can have the test case refer to those
15:53:54 <robatino> thumb drives are powers-of-10, so that's 4,000,000,000 bytes
15:53:57 <adamw> #action adamw to contact Product WGs and ask them to specify maximum images sizes (in their tech specs or elsewhere) for https://fedoraproject.org/wiki/QA:Testcase_Mediakit_ISO_Size to refer to
15:54:33 * tflink didn't realize that the dvd isos were supposed to fit on 4g thumb drives
15:54:50 <adamw> tflink: as it stands they're not
15:54:52 <roshi> I thought the DVD size was 4.7GB, like a...well... DVD
15:55:03 <adamw> for the existing DVD that was the max, yeah.
15:55:06 <roshi> cloud has that defined
15:55:50 <roshi> qcow2 size under 200M and on-disk under 500M
15:55:58 <cmurf> we're not doing dual layer DVD?
15:55:59 <roshi> so I can add that in
15:56:28 <tflink> cmurf: it sounds like that may be just the server DVD
15:56:35 <tflink> or did I misunderstand?
15:56:44 <adamw> i'm expecting the server 'DVD' image will be much smaller than the fedora.last DVD anyway
15:56:56 <adamw> but it's mostly a theoretical entity at this point in time :P
15:57:14 <adamw> it referred to by Server WG as the 'offline install' image, not as a 'DVD'
15:57:18 <tflink> have we figured out how many images there are to test for f21?
15:57:27 <adamw> i don't know if they/we (as i have a server WG hat too...) have defined a size target for it yet
15:57:35 <adamw> tflink: all the ones i listed in the compose request, basically
15:58:05 <adamw> i believe the release blocking images are the Product images plus the KDE live spin plus possibly the ARM disk images (it still isn't clear to me whether the ARM disk images or ARM installer images have priority for F21)
15:58:13 <adamw> pwhalen: do you have notes on that?
15:58:38 <pwhalen> installer image is being looked at, but not sure there has been any progress
15:58:39 <tflink> that's a lot of stuff :-/
15:58:54 <pwhalen> we'll discuss it this week at our meeting
15:58:55 <tflink> isn't there a base boot.iso as well?
16:02:52 <adamw> tflink: not at present
16:02:57 <adamw> afaik, anyway
16:03:19 <tflink> I thought that's what we were telling folks to use if they didn't want to install one of the products
16:03:26 <adamw> pwhalen: ok, if we could get clarity on that it'd be good. i think we need to pick either the disk images or the installer images to be 'primary' for F21 (and any given release)
16:03:54 <adamw> tflink: i believe releng said that creating a generic boot.iso would require a separate installer tree and they didn't want three (or four, whichever it is)
16:04:27 <pwhalen> adamw, ok, will report back next week- but think we're going with the images
16:05:08 <pwhalen> er, disk images (as was for f20, minux vfat)
16:05:49 <adamw> roger.
16:05:54 <adamw> ok, we're over time...
16:05:59 <adamw> anything else important?
16:08:00 * roshi has nothing
16:08:27 <tflink> taskotron deployment is still waiting on a service provider ticket
16:08:43 <adamw> sorry, what's a service provider ticket?
16:09:09 <tflink> it can't be deployed until some firewall rules are changed, those changes are waiting on a service provider and tracked in a ticket
16:11:21 <adamw> gotcha. other than that, it's ready for initial deployment?
16:11:47 <tflink> stg is pretty much deployed, sans some tweaking after the firewall rules are changed
16:12:18 <tflink> production is ~20% deployed (enough to check on the firewall rules)
16:12:19 * satellit_e sorry I am late
16:12:34 <adamw> satellit: np, but we're about done :)
16:12:40 <adamw> tflink: cool.
16:13:02 <adamw> #info taskotron deployment is waiting on an external entity (firewall configuration needs changing)
16:13:09 * adamw sets a very short quantum fuse
16:15:17 <adamw> thanks for coming, folks!
16:15:19 <adamw> #endmeeting