15:05:16 <rdieter> #startmeeting kde-sig
15:05:16 <zodbot> Meeting started Tue Jul 22 15:05:16 2014 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:05:23 <rdieter> #meetingname kdesig
15:05:23 <zodbot> The meeting name has been set to 'kdesig'
15:05:28 <rdieter> #meetingname kde-sig
15:05:28 <zodbot> The meeting name has been set to 'kde-sig'
15:05:40 <rdieter> #topic roll call
15:05:41 * jgrulich is present as usual
15:05:45 <rdieter> hi all, who's present today?
15:05:50 <dvratil> present
15:05:56 <Kevin_Kofler> Present.
15:06:06 <than> present
15:06:10 * jreznik is semi-here
15:06:53 <rdieter> #info rdieter jgrulich dvratil Kevin_Kofler than jreznik present
15:07:00 <rdieter> #chair jgrulich dvratil Kevin_Kofler than jreznik
15:07:00 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich jreznik rdieter than
15:08:43 <rdieter> #topic agenda
15:08:50 <rdieter> alright, what to discuss today?
15:09:02 <pino|work> me (present)
15:09:12 <rdieter> #info pino|work present
15:09:14 <Kevin_Kofler> I can give a status update on GStreamer 1.0.
15:09:16 <rdieter> pino|work: hi
15:09:20 <Kevin_Kofler> *1.x, I mean.
15:09:51 <Kevin_Kofler> (Their versioning is ugly, they have libraries with "1.0" in the name and a version number of 1.2.)
15:10:57 <pino|work> that's the ABI version
15:11:19 <rdieter> we can discuss later :)  I can do a quick kde-4.13 status update too
15:11:34 <rdieter> dvratil: any kf5/plasma5 news to mention?
15:11:48 <dvratil> yeah, I can do a quick update
15:12:04 <rdieter> #topic gst-1.0 status update
15:12:08 <rdieter> Kevin_Kofler: ?
15:13:28 <Kevin_Kofler> So the status is that I have updated 2 packages in Rawhide (F22), 5 to go, and the F21 builds to go as well.
15:13:56 <tosky> hi
15:14:13 <Kevin_Kofler> I updated QtWebKit (4) with the openSUSE patch to enable GStreamer 1 support, and conditionalized it on F21+/RHEL8+.
15:14:41 <Kevin_Kofler> (We don't want to build the Qt stack with mixed GStreamer 0.10/1.x on e.g. F20 or RHEL 7, that will cause trouble for sure.)
15:14:48 <rdieter> tosky: hi
15:14:51 <rdieter> #info tosky present
15:15:12 <Kevin_Kofler> (Unfortunately, the patch is such that it has to be conditionally applied, they didn't go to the trouble of autodetecting the GStreamer version.)
15:15:38 <Kevin_Kofler> I also updated Phonon-GStreamer to a snapshot from the 1.0-porting-for-merge branch.
15:16:05 <rdieter> sorry, afk ~5 min, feel free to move on to next topic when/if ready before I get back
15:16:19 <dvratil> just fyi: we are going to make an official release of phonon-gstreamer-1 in Randa in couple weeks
15:16:21 <Kevin_Kofler> The snapshot has the GStreamer 1 porting, and is otherwise equivalent to 4.7.2.
15:16:44 <Kevin_Kofler> It supports both building against GStreamer 0.10 (where it should hopefully behave the same as stock 4.7.2) and against GStreamer 1.
15:17:04 <Kevin_Kofler> There too, I added conditionals for enabling GStreamer 1 support only where appropriate (F21+/RHEL8+).
15:17:37 <Kevin_Kofler> What is missing is the QtGStreamer and KDE-Telepathy stack. (It's really 2 stacks, but they intersect.)
15:18:15 <Kevin_Kofler> There are 5 packages to update there (and at least for some of them, the specfiles will be GStreamer-1-only, so we'll have to be careful with merging).
15:19:32 <Kevin_Kofler> I also looked into nucleo's complaint about the weird soname versioning of QtGStreamer: IMHO, we should follow upstream there, the naming is weird, but not broken.
15:20:15 <Kevin_Kofler> Concretely, the complaint was about the *-1.0.so.0 → *-1.0.so.1.2.0 symlinking (.0 vs. .1.*).
15:20:40 <pino|work> not "intuitive", but still fine
15:20:41 <rdieter> agreed
15:20:45 <Kevin_Kofler> It turns out that this will work just fine, the soname was bumped through the addition of that "-1.0" part, and it's fine to start at .so.0.
15:22:03 <Kevin_Kofler> And speaking of weird versioning, here too, we have the use of "-1.0" for 1.2.x versions as in GStreamer itself. This practice is also used in other libraries of the G* stack. It's counterintuitive, but we have to live with that.
15:22:25 <pino|work> version != ABI version
15:22:32 <Kevin_Kofler> I suppose they use that ".0" so that they can decide when they do 1.2 whether they want to change the ABI (and thus change to "1.2") or not.
15:22:47 <Kevin_Kofler> pino|work: Well, the thing is, "1" would be enough as the ABI version.
15:22:52 <Kevin_Kofler> (Similarly for GTK+.)
15:22:57 <pino|work> apparently not enough for them
15:23:30 <pino|work> so if a new version of the 1.x serie breaks the abi, they can bump the abi without issues
15:23:40 <Kevin_Kofler> They just don't have the balls to fix in advance that the ABI will never change throughout a major version, even though that's the goal (and so far was always the case for those GTK+ etc. libraries, GStreamer 0.x was different).
15:23:58 <Kevin_Kofler> Right. Then it should be a 2.x version and not a 1.x one. :-)
15:24:13 <rdieter> as long as it's blue
15:24:13 <Kevin_Kofler> But that's just IMHO and a bit off topic here. ;-)
15:24:59 <Kevin_Kofler> Oh, and about QtWebKit, if you were wondering about qt5-qtwebkit, that one is already built against GStreamer 1 wherever it is available.
15:25:28 <Kevin_Kofler> So, to sum up:
15:25:28 <rdieter> <nod> , I'd double checked that prior
15:25:51 <Kevin_Kofler> #info qtwebkit and phonon-gstreamer updated to build against GStreamer 1 on F21+ (and RHEL8+).
15:26:38 <Kevin_Kofler> #action Kevin_Kofler still has to update 5 packages (QtGStreamer and KDE-Telepathy stacks), and the F21 builds of all 7 packages remain to be made.
15:26:53 <Kevin_Kofler> I think that's it, or are there any questions?
15:28:07 <Kevin_Kofler> Let's move on, rdieter?
15:28:12 <rdieter> ok
15:28:18 <rdieter> #topic kf5/plasma5 status
15:28:20 <rdieter> dvratil: ?
15:28:55 <dvratil> KF5 is done completely, Plasma 5 is almost done, now waiting for Copr to start cooperating again and build the last few of them
15:29:17 <dvratil> if it goes as expected, it should be done tonight
15:29:42 <rdieter> dvratil: its becoming a FAQ, we should probably add something to #fedora-kde /topic about it
15:29:54 <rdieter> (not that anyone reads that much, but still :) )
15:30:00 <dvratil> +1 - maybe link to the Plasma copr?
15:30:38 <rdieter> either that, or a link to something that explains it all, that also includes such a link
15:31:03 <dvratil> there's upstream wiki page that documents availability of KF5/Plasma 5 in various distributions
15:31:05 <Kevin_Kofler> I'm a bit annoyed by how users are always pestering us for the bleeding-edge *.0.0 KDE Plasma releases; yet, if we ship them, they're complaining about that, too.
15:31:15 <Kevin_Kofler> We've had that with Fedora 9.
15:31:18 <jreznik> ship it!
15:31:20 <rdieter> where explanation includes why f20/f21 won't include this in stable repos, and its in a copr instead
15:31:28 <dvratil> if I manage to find it, I'll update it and we can link it that page
15:31:42 <rdieter> ok
15:31:46 <rdieter> great
15:32:08 <jgrulich> dvratil: https://community.kde.org/Plasma/Packages
15:32:19 <dvratil> thanks jgrulich
15:33:15 <rdieter> jgrulich wins, beat me to it
15:33:16 <Kevin_Kofler> Can we provide those for F19 also? I guess the KF5 stuff would have to come from a Copr there though, with F21 branched, I assume F19 isn't open for new branch requests anymore, is it?
15:33:34 <Kevin_Kofler> (We should have requested those right when we did the KF5 reviews. :-( )
15:33:51 <rdieter> most kf5 doesn't have f20 branches either, iirc
15:33:59 <dvratil> none do
15:33:59 <Kevin_Kofler> Indeed.
15:34:11 <Kevin_Kofler> I'd have expected the requests to obviously include all branches, so I didn't check. :-(
15:34:17 <dvratil> as (if I remember it correctly) we agreed that we will keep F20 in Copr
15:34:25 <dvratil> so I was only requesting rawhide
15:34:34 <Kevin_Kofler> There's no reason we don't want to ship those parallel-installable packages for stable Fedoras.
15:35:05 <Kevin_Kofler> We should definitely request at least F20. (I think it's too late for F19 unfortunately.)
15:35:09 <dvratil> I guess I can do some kind of mass-request for all kf5 to include F20 branch
15:35:29 <dvratil> and build F19 in Copr
15:35:37 <Kevin_Kofler> Yeah.
15:35:45 <dvratil> I'm just afraid that F19 might have too old cmake
15:36:01 <Kevin_Kofler> It's easy to upgrade CMake in Copr. :-)
15:36:06 <rdieter> f19/f20 cmake is the same, fyi
15:36:16 <rdieter> cmake-2.8.12.2-2.fc19, cmake-2.8.12.2-2.f20
15:36:16 <dvratil> ok, then it should be fine
15:36:39 <rdieter> but I would agree if there are priorities, f20 is more important, then f19 if time allows
15:37:14 <Kevin_Kofler> +1
15:37:20 <Kevin_Kofler> Newer releases first.
15:37:26 <Kevin_Kofler> So F22, F21, F20, F19 always in that order.
15:38:39 <dvratil> hmm, there does not seem to be any UI or CLI tool to mass-request branch
15:39:35 <rdieter> true, the SOP is still per pkg in bugzilla, unfortunately
15:40:04 <rdieter> anything else?  move on?
15:40:05 <Kevin_Kofler> Talk to #fedora-admin, maybe?
15:40:22 <rdieter> <nod>, worth asking anyway
15:41:02 <rdieter> ok, moving on...
15:41:11 <rdieter> #topic f20/kde-4.13.x status
15:41:28 <rdieter> nothing much to report, other than continued positive feedback
15:43:03 <rdieter> last batch of builds was pushed to -testing on jul 19, so I'd say wait a bit more before pushing stable
15:43:52 <rdieter> maybe late this week, or early next
15:45:03 <rdieter> that's all I have
15:45:07 <rdieter> #topic open discussion
15:45:12 <rdieter> anything else for today ?
15:46:12 <heliocastro> Is there any harm to upgrade cmake to 3 ?
15:46:19 <heliocastro> on f19 > i mean
15:46:45 <Kevin_Kofler> Are there things that need CMake 3 to build?
15:47:21 <heliocastro> No necessarly but have same cmake on all platforms make sense
15:48:02 <rdieter> I'd figure it *mostly* safe, I'm not aware of any issues with it
15:48:12 <Kevin_Kofler> Upgrading CMake to a new major version on F19, I'm not sure that's a good idea. Even for F20, you'll have to convince the primary maintainer, who tends to be a bit more conservative than me about upgrading stuff.
15:48:31 <Kevin_Kofler> (Orion Poplawski is the primary maintainer for CMake.)
15:48:53 <heliocastro> Well, just an idea
15:49:18 <Kevin_Kofler> But we can get it in for F20 (and maybe even F19) if we really need it.
15:49:58 <Kevin_Kofler> It's always a tradeoff about allowing to build new stuff vs. the risk of breaking the build of existing stuff.
15:50:06 <Kevin_Kofler> CMake is quite good at backwards compatibility, luckily.
15:50:10 <heliocastro> I know
15:50:12 <Kevin_Kofler> But there can still be surprises.
15:53:41 * rdieter will close meeting soon, if theres nothing else
15:54:12 <Kevin_Kofler> By the way, if you're wondering why I got only 2 of the 7 updates for GStreamer 1 done, blame the weather. :-) (Too hot to spend time on packaging.)
15:54:33 <Kevin_Kofler> This week should be more suitable for getting stuff done.
15:56:53 <rdieter> Kevin_Kofler: :)
15:56:56 <rdieter> ok, thanks everything
15:57:03 <rdieter> everyone, for everthing, that is
15:57:07 <rdieter> #endmeeting