15:01:48 <pknirsch> #startmeeting Fedora Base Design Working Group (2014-07-25)
15:01:48 <zodbot> Meeting started Fri Jul 25 15:01:48 2014 UTC.  The chair is pknirsch. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:56 <pknirsch> #meetingname  Fedora Base Design Working Group
15:01:56 <zodbot> The meeting name has been set to 'fedora_base_design_working_group'
15:02:01 <pknirsch> Hello and welcome everyone!
15:02:06 <vpavlin> Hi!
15:02:09 <jreznik> hey pknirsch
15:02:17 <msekleta> Hello everyone
15:02:20 <pknirsch> To this sunny and nice summer Friday afternoon :)
15:02:39 <jreznik> pknirsch: sunny and nice? rainy :(
15:02:40 <vpavlin> pknirsch: It's raining here...
15:02:43 <msekleta> Well, we have thunderstorm in Brno :(
15:02:43 <pknirsch> :(
15:02:57 <pknirsch> You'll get out nice weather then on the weekend!
15:03:00 <pknirsch> :)
15:03:05 <vpavlin> But rain is nice after all those hot days, right?:-)
15:03:10 * jreznik has hard stop in 40 minutes, has to go to the veterinary with our dog - hopes it will stop raining
15:03:11 <pknirsch> heh
15:03:26 <jreznik> vpavlin: yeah, it's nice unless you have to go out :D
15:03:30 <pknirsch> oh my, hope nothing too serious jreznik :(
15:03:57 <pknirsch> #chair jreznik msekleta
15:03:57 <zodbot> Current chairs: jreznik msekleta pknirsch
15:04:06 * vpavlin is safe home on the sofa;)
15:04:06 <pknirsch> moben, you around? ;)
15:04:14 <moben> pknirsch: sure
15:04:22 <pknirsch> alright, the lets get cracking :)
15:04:40 <pknirsch> #topic Status update builrequires cleanup
15:04:57 <pknirsch> all yours, moben :)
15:05:41 <haraldh> <-
15:09:15 <pknirsch> #chair haraldh
15:09:16 <moben> On the scripting side, I mostly did some refactoring to get it into a better shape and more easily add special cases in the future
15:09:16 <zodbot> Current chairs: haraldh jreznik msekleta pknirsch
15:09:16 <moben> I also submitted a couple bugs for low-hanging fruit, but haven't gotten feedback there yet
15:09:18 <moben> I also looked at reproducible builds some more, as that would greatly help my cause and submitted patches to epydoc and javadoc upstream and got in touch with the fedora maintainers of those
15:09:18 <moben> though for the former upstream seems dead and the latter doesn't seem to want to change the default to notimestamp :(
15:09:19 <moben> So I guess I'll have to talk to our java guys some more if we could/would do it anyway
15:12:02 <moben> on the bright side, emacs upstream doesn't write a timestamp to byte compiled .elc files anymore, so maybe we can add that to our emacs as well (bug filed)
15:12:02 <moben> the biggest culprit for actually cleaning up buildrequires are obviously documentation generation tools
15:12:02 <pknirsch> ah. thats for making sure your comparisons don't trigger false positives due to only changed timestamps?
15:12:02 <moben> pknirsch: exactly
15:12:02 <pknirsch> nice
15:12:09 <jreznik> if upstream is dead, then no other option than to carry our own patch
15:12:24 <pknirsch> and yea, we've had issues like that actually show up ages ago with multilib doc packages
15:12:32 <pknirsch> where doxygen used timestamps in docu as well
15:12:50 <pknirsch> much fail that
15:13:01 <moben> we also seem to repack .jar files in &__os_install_post for that reason
15:13:10 <moben> s/&/%
15:13:22 <pknirsch> O.o
15:13:27 <pknirsch> jesus :)
15:13:49 <moben> could add more workarounds in there to sed such things, but I'd rather change upstream defaults
15:13:55 <pknirsch> jup
15:14:11 <pknirsch> fix the root cause, not the symptoms :)
15:14:34 <moben> Would be nice to add a "should not contain timestamps
15:14:43 <moben> to packaging guidelines
15:15:10 <pknirsch> hm, have you thought about making a small documentation for FPC with all your findings? we could run that past the FPC then once you've got a good collection
15:15:13 <moben> I guess I'll have to write to packaging@ about that?
15:15:19 * pknirsch nods
15:15:20 <moben> heh
15:15:44 <pknirsch> but maybe do it all at once with a collected set of recommendations for buildrequires and reproducible builds
15:16:02 <pknirsch> so it's all on topic and the FPC can see the whole picture
15:16:07 <pknirsch> instead of small puzzle pieces
15:16:30 <pknirsch> (could even be a new section in the FPG)
15:16:45 * masta looks in
15:17:25 <moben> pknirsch: I guess I'll run that by you some tome soon then :)
15:17:36 <moben> *time
15:17:46 <moben> I've been thinking about prebuilt documentation as well. This affects quite a few packages and is mainly a workflow issue.
15:17:47 <pknirsch> yea :)
15:17:53 <pknirsch> aye
15:18:00 <pknirsch> that would be really great, too
15:18:14 <moben> would be nice to have a `prebuild-docs foo.src.rpm`
15:18:23 <pknirsch> +1000 :)
15:18:26 <moben> but I'm not sure how to achieve that yet
15:18:36 <pknirsch> yea, but food for thought
15:18:56 <msekleta> moben, have you looked at tools that SUSE guys use for comparing rpms?
15:19:13 <msekleta> I dug up this https://build.opensuse.org/package/show/openSUSE:Factory/build-compare
15:19:24 <moben> msekleta: saw it.
15:19:57 <moben> it's also just lots of special casing and sed, which I'd rather like avoid
15:20:11 <moben> though that won
15:20:18 <pknirsch> :)
15:20:19 <moben> 't be possible in all cases
15:21:13 <pknirsch> right
15:21:16 <moben> need to do some research on .pyc files for example. afaik they hardcode the timestamp of the source file to check if they need recompilation
15:22:36 <moben> maybe we could change to mtime of all .py files to the last changelog time in %__os_install_post, like we do for .jar contents
15:22:50 <pknirsch> hm
15:23:29 <moben> really only relevant in cases where we patch/sed/... py files
15:23:44 <moben> but those happen
15:24:02 <pknirsch> right
15:24:37 <moben> that's it from my side
15:24:48 <pknirsch> excellent. nice progress moben !
15:25:00 <pknirsch> finding s**t and fixing it ++ :)
15:25:27 <moben> -etoomuchshit
15:25:31 <pknirsch> hahhahaha
15:26:02 <masta> kinda like the idea of changing the mtime/atime of packaged files to be consistent, in a broadly general sense.
15:26:04 <pknirsch> alright, lets move to vpavlin discussion.
15:26:13 <pknirsch> #topic Really talk with Vaclav Pavlin as candidate for WG
15:26:17 <pknirsch> #chair masta
15:26:17 <zodbot> Current chairs: haraldh jreznik masta msekleta pknirsch
15:27:03 <pknirsch> So how about you introduce yourself vpavlin and tell us a bit about what why you want to be part of the Base WG?
15:27:13 <vpavlin> Ok
15:29:15 <vpavlin> Sincemy start in Red Hat two years ago I've been working on grub1, initscripts and systemd. Few months ago I was transfered from haraldh's team to work with Bill Nottingham, just before he quit
15:30:05 <vpavlin> Since then I take care of distribution bugs in RHEL. I've also joined Docker team and I maintain RHEL Docker base images
15:31:43 <vpavlin> I also cooperate with HSS on maintainers' process optimization - simply put how to make RHEL package maintainer's life easier
15:32:34 <vpavlin> I've joined Env&Stacks WG few weeks ago to help them figure out their place in Docker world
15:33:07 <vpavlin> Well, that's probably all what I can think about now:)
15:33:55 <pknirsch> Sounds nice! So where do you see your overlap or association with the Base WG? I suspect it's also the bigger picture for Docker?
15:35:25 <vpavlin> Definitely, I'd like to take care of Docker base images in Fedora as well - I've already presented some changes I did to ks files here two weeks ago
15:35:47 <pknirsch> mhm
15:36:08 <vpavlin> This tightly connects to moben's work (thanks for it!) on minimizing the dependency tree
15:36:33 <pknirsch> How about your collaboration and work in the Env and Stacks group? Would that overlap or conflict or (as i suspect) actually be a very nice exchange as well?
15:36:43 <pknirsch> And are they ok with you being on both WGs?
15:37:04 <vpavlin> I also try to look at Fedora distribution bugs, which touches Base, I'd say
15:37:13 <pknirsch> ah, cool!
15:37:37 <jreznik> for docker, there's really overlap of all groups (except workstation now)
15:37:44 * pknirsch nods
15:38:05 <pknirsch> I'd personally love to actually have someone spread it's wings between the different WGs on common topics
15:38:07 <pknirsch> :)
15:38:10 <vpavlin> They support this and I see it as a chance to get these two groups in collaboration
15:39:19 <pknirsch> ace
15:39:44 <pknirsch> alright, lets check around the room, any comments from folks here about vpavlin ?
15:41:17 <jreznik> well, I'd really like to see more communication between groups (and I have to admit I failed in that even I try sometimes to stop by at Env mtg, not so ofter Server and Cloud is out of my knowledge completely :D), so I'm really happy vpavlin could step into it
15:43:01 <msekleta> I'd really like to see vpavlin in, especially because he is member of Env&Stack WG. Also having someone looking at distribution bugs is always good.
15:43:19 <pknirsch> haraldh, masta, any comments from you guys?
15:43:37 <haraldh> +1
15:43:41 <pknirsch> :)
15:45:30 <pknirsch> ok, lets do a quick vote then.
15:45:37 <pknirsch> +1 for vpavlin
15:46:36 <haraldh> +1
15:46:38 <msekleta> +1
15:47:43 <pknirsch> i strongly suspect jreznik's comments were a +1, too ;)
15:47:51 <pknirsch> (as he probably already had to leave
15:47:58 <jreznik> +1
15:48:01 <pknirsch> :)
15:48:14 <pknirsch> masta, how about you?
15:48:14 <jreznik> pknirsch: uf, thanks for reminder, I forget!
15:48:21 <pknirsch> jreznik: :)
15:48:32 <pknirsch> jreznik: have a great weekend, and good luck at the vet!
15:48:53 <jreznik> pknirsch: it's just rabies vaccination
15:48:58 <pknirsch> alright :)
15:49:14 <jreznik> but it was due two weeks ago
15:52:14 <pknirsch> ok, i take it as a 0 from masta then :)
15:52:25 <pknirsch> so we got 4+ and one 0
15:52:55 <pknirsch> which iirc is a clear winner :)
15:53:30 <pknirsch> #agreed Vote for vpavlin as a WG member (+4:1:-0)
15:53:38 * vpavlin bows to thank:)
15:53:45 <pknirsch> #info Vpaling new member of the Base WG
15:53:50 <pknirsch> thank you vpavlin !
15:53:55 <pknirsch> and welcome to the club :)
15:54:20 <pknirsch> Now, as your first action you and mattdm already had a Open Floor topic, right?
15:54:23 <pknirsch> #topic Open Floor
15:54:26 <vpavlin> pknirsch: Hmm, you've just named someone else to be member of WG in your info;)
15:54:43 <pknirsch> ups
15:54:59 * pknirsch checks meetbot how to fix that
15:55:10 <mattdm> make this vpaling person do all the work!
15:55:16 <pknirsch> heheheh
15:55:54 <vpavlin> Yes - Base image ownership - it shouldn't definitely belong to Env&Stacks. Question is if it should be owned by Base or Cloud
15:57:48 <vpavlin> I will be a cross WG effort anyway, but someone should be responsible..
15:57:48 <pknirsch> #undo
15:57:48 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0xe82f210>
15:57:53 <pknirsch> #undo
15:57:53 <zodbot> Removing item from minutes: INFO by pknirsch at 15:53:45 : Vpaling new member of the Base WG
15:58:10 <pknirsch> #info vpavlin new member of Base WG
15:58:16 <pknirsch> #topic Open Floor
15:58:17 <pknirsch> there
15:58:20 <pknirsch> fixed
15:58:39 <vpavlin> btw - mattdm thanks for review of fakesystemd :)
15:58:39 <pknirsch> so what are arguments pro and con for base vs. cloud?
15:59:41 <vpavlin> Base WG should provide minimal system core - which basically equals to base images
16:00:26 <vpavlin> OTOH Docker images generally are connected to cloud
16:00:46 <pknirsch> mhm
16:01:03 <pknirsch> do we expect Docker images to be used on other products than Cloud though?
16:01:13 <vpavlin> Yes
16:01:28 <vpavlin> I'd like to see them used in testing automation
16:01:29 <pknirsch> as that for me would clearly indicate that they would more reasonably belong to Base than Cloud
16:01:46 <pknirsch> e.g. would Server and/or Workstation use these Docker images
16:01:49 <pknirsch> or QE
16:01:51 <pknirsch> right
16:02:05 <pknirsch> although QE resp test automation is more of a consumer
16:02:25 <vpavlin> I've proposed feature for building layered images in copr so that you can build a package and pull/download image with it inside and test it
16:02:45 <pknirsch> meaning they could use the Cloud product as their starting point
16:02:54 <vpavlin> sgallagh wants to use Docker in Server to replace Server Roles with Docker images
16:03:02 <pknirsch> Nice
16:03:23 <vpavlin> And all these images needs stable and minimal base image
16:03:27 <pknirsch> Those are good arguments for it being in Base.
16:03:47 <pknirsch> Any objections from anyone about that?
16:04:50 <msekleta> I think that base image doesn't provide any service to user per se. Thus I see them as part of Base WG effort. Cloud WG should build then layered images on top of that if they see fit
16:05:06 <vpavlin> Another thing is service sstarting in images - I believe that this is something which should be thought through and decided in Base, not Cloud
16:06:53 * pknirsch nods
16:07:03 <msekleta> vpavlin, this brings us to discussion about fakesystemd and systemd-container
16:07:20 <pknirsch> And you vpavlin and msekleta would take care of it then i guess?
16:07:42 <msekleta> pknirsch, yes
16:07:48 <pknirsch> cool :)
16:07:50 <vpavlin> pknirsch: yes :)
16:09:04 <pknirsch> msekleta: what about fakesystemd and systemd-container?
16:09:28 <msekleta> pknirsch, I was wondering if there is any chance of not shipping packages which are really meant to be used only in container environments in main repo
16:10:02 <vpavlin> we would need masta and dgilmore to step in here:)
16:10:18 * pknirsch nods
16:10:32 <pknirsch> i suppose quite a few of the necessary changes are rel-eng related at some point
16:10:46 <pknirsch> and you guys are already working with mattdm i suppose :)
16:11:20 <msekleta> he said that currently there is no way
16:11:34 <mattdm> vpavlin also connect with lsm5 if you haven't already?
16:12:02 <vpavlin> mattdm: Will do
16:12:16 <mattdm> see http://fedoraproject.org/wiki/Changes/Docker_Container_Image
16:12:36 <vpavlin> Yes, I've seen this
16:14:11 <dgilmore> hey
16:14:19 <dgilmore> I have to build a koji update todat
16:14:22 <dgilmore> today
16:14:30 <dgilmore> that has some patches needed for docker
16:15:00 <dgilmore> we have no way to not ship some packages
16:15:49 <vpavlin> Do we think this would be possible in future?
16:15:55 <dgilmore> no
16:16:03 <vpavlin> mhm
16:16:10 <dgilmore> its really not something we want to entertain
16:17:05 <vpavlin> Well, I didn't mean not ship entirely. Just maybe have main and extras repo where most of the people would use only main repo
16:17:36 <dgilmore> not something that I want to entertain
16:17:49 <vpavlin> ok
16:18:07 <pknirsch> Any other suggestions then how to maybe solve this then, dgilmore ?
16:18:59 <dgilmore> will need to setup thinsg so yum/dnf chose systemd and not something providing systemd
16:19:45 <dgilmore> I don't know if the others say they provide systemd
16:19:46 <vpavlin> mattdm has already suggested in BZ to add systemd to comps which should imho work
16:19:50 <msekleta> mattdm, suggested solution which should work for most cases https://bugzilla.redhat.com/show_bug.cgi?id=1118740#c5
16:20:22 <dgilmore> thats likely the best choice
16:20:29 * pknirsch nods
16:20:36 <dgilmore> it would mean containers can not include @core
16:21:20 <vpavlin> We don't want to include @core anyway
16:21:28 <pknirsch> mhm
16:21:28 <mattdm> dgilmore or they can do "-systemd", but yeah, mostly want --nocore anyway
16:21:32 <pknirsch> to keep it minimal
16:21:36 <dgilmore> so not a big deal
16:22:08 <vpavlin> I can take care of systemd addition to @core
16:22:42 <pknirsch> perfect, thanks!
16:22:50 <pknirsch> everyone happy with that plan?
16:23:47 <pknirsch> #info Discussion about Docker images belonging to Base or Cloud
16:23:49 <dgilmore> sure
16:24:18 <pknirsch> #info after bringing up the various points, general agreement that they do more likely belong to Base.
16:24:44 <pknirsch> #info vpavlin and msekleta taking care of those in Base then with exchange with cloud, env & stacks & rel-eng.
16:24:59 <mattdm> pretty sure cloud will be fine with that -- we can focus on stuff around and on top of that.
16:25:06 <pknirsch> #info Follow on discussion about how we handle fakesystemd
16:25:08 <mattdm> also gives base some kind of product :)
16:25:12 <pknirsch> yea
16:25:27 <pknirsch> #info Agreed on solution to add systemd to @core
16:25:37 <pknirsch> #action vpavlin adding systemd to @core
16:25:54 <pknirsch> #info Resolves minimal docker images
16:26:03 <pknirsch> Okdokie
16:26:17 <pknirsch> Any other topics for today then?
16:26:54 <dgilmore> Ill be in Brno next week
16:27:08 <vpavlin> Just a note - I added README to my base image dir on fedorapeople - https://vpavlin.fedorapeople.org/fedora-base-image/README.md
16:27:32 <pknirsch> ah, the docu i asked about 2 weeks ago vpavlin
16:27:33 <msekleta> As already advertised in BZ I'll be working on systemd-container for Fedora. Should be ready sometime next week.
16:27:34 * pknirsch goes checking
16:28:02 <pknirsch> vpavlin: nice, very brief.
16:28:11 * pknirsch likes short docus if sufficient ;)
16:28:14 <vpavlin> I'll push changes to ks when fakesystemd is in Fedora
16:28:19 <dgilmore> the kickstart there willnot work in koji
16:28:36 <dgilmore> we are using anaconda to make all x86 images
16:28:50 <mattdm> yeah. kickstart needs work
16:30:12 <dgilmore> vpavlin: kickstart needs to get into spin-kickstarts
16:30:55 <vpavlin> ah, ok
16:32:31 <mattdm> kickstart may need extra %post hacks to clean stuff up too
16:33:28 <vpavlin> dgilmore: Can we already build docker images in koji?
16:34:15 <vpavlin> I mean not the proper docker images with id and tags, but at least the tar.gz produced by Docker plugin for image factory?
16:34:44 <dgilmore> vpavlin: yes, but there is one patch we really nee
16:34:46 <dgilmore> need
16:35:18 <mattdm> dgilmore: patch that needs to be applied or patch thta needs to be written?
16:36:39 <dgilmore> mattdm: its upstream, just not in applied in what we are running
16:36:47 <vpavlin> ah, cool - would you mind letting me know when it's ready so that I can try to scratch build my ks changes?
16:36:51 <vpavlin> dgilmore: ^
16:37:26 <dgilmore> vpavlin: you need special permissions to build any type of image
16:40:02 <vpavlin> dgilmore: So the obvious question follows - how can I test the ks file? (Or another one - how can I get these permissions?:-) )
16:40:20 <pknirsch> can we give those to vpavlin dgilmore ? as it would be really cubersome and take lots of your time away if he'd always have to come and ask you do do that?
16:40:21 <pknirsch> ah
16:40:28 <pknirsch> see vpavlin's question:)
16:40:54 <dgilmore> vpavlin: using oz/imagefactory locally
16:41:11 <dgilmore> or I can send builds
16:42:25 <vpavlin> I'll look at imagefactory, don't want to bother you with it and it would be quite hard to sync as we are from different timezones
16:42:39 <dgilmore> vpavlin: ill be in .cz next week
16:44:52 <vpavlin> Yes, but from long term perspective it makes sense to have something that I can work on by myself
16:45:10 * pknirsch nods
16:45:20 <dgilmore> vpavlin: sure, but once its sorted out the maintainenece should be low
16:45:38 <dgilmore> vpavlin: and we will setup to build rawhide/branched images nightly
16:46:41 <vpavlin> dgilmore: Ok, I'll try IF and if it looks as too much work I'll bother you next week;)
16:47:13 <dgilmore> vpavlin: either way we should get together so we can get it in and nightly images built
16:47:22 <pknirsch> excellent :)
16:48:29 <vpavlin> dgilmore: Ok, I am on PTO from wednesday until the end of the week, but we can definitely sit down on Mon or Tue if you have time
16:50:11 <dgilmore> vpavlin: Tuesday
16:50:17 <dgilmore> I get in Monday afternoon
16:50:31 <vpavlin> dgilmore: ok, I'll ping you when I see you online
16:50:36 <dgilmore> vpavlin: cool
16:50:44 <vpavlin> I need to go now
16:50:58 <vpavlin> (It's almost 7pm here)
16:51:12 <pknirsch> alright
16:51:17 <pknirsch> great meeting everyone!
16:51:25 <pknirsch> lets close up for today then
16:51:27 <dgilmore> thanks all
16:51:45 <pknirsch> thanks everyone and have a great weekend
16:51:55 <pknirsch> #endmeeting