15:13:40 <rdieter> #startmeeting kde-sig
15:13:40 <zodbot> Meeting started Tue Aug  5 15:13:40 2014 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:13:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:13:45 <rdieter> #meetingname kde-sig
15:13:45 <zodbot> The meeting name has been set to 'kde-sig'
15:13:48 <rdieter> #topic roll call
15:13:54 <mbriza> hi
15:13:58 <jgrulich> Hi
15:13:59 <danofsatx-work> I am heah
15:14:01 <rdieter> hi, kde-sig meeting , who's around today?
15:14:09 <danofsatx-work> estoy aqui
15:14:16 <danofsatx-work> ans so on and so on
15:14:26 <than> present
15:14:31 <rdieter> dvratil: ping
15:14:37 <pino|work> metoo
15:14:41 <dvratil> sorry, I'm here
15:15:47 <rdieter> #info rdieter mbriza jgrulich danofsatx-work than pino|work dvratil present
15:15:57 <rdieter> #chair  mbriza jgrulich danofsatx-work than pino|work dvratil
15:15:57 <zodbot> Current chairs: danofsatx-work dvratil jgrulich mbriza pino|work rdieter than
15:16:15 <tosky> hi
15:16:27 <rdieter> #info tosky present
15:16:29 <rdieter> hi
15:16:31 <rdieter> #chair tosky
15:16:31 <zodbot> Current chairs: danofsatx-work dvratil jgrulich mbriza pino|work rdieter than tosky
15:16:40 <rdieter> alrighty...
15:16:42 <rdieter> #topic agenda
15:16:45 <rdieter> what to discuss today?
15:17:13 * rdieter has kde-4.13.97 status, formalize danofsatx-work as kde WG member
15:17:28 <mbriza> probably the qt5 inclusion
15:17:39 * danofsatx-work checks email real quick like
15:18:32 <danofsatx-work> nope, no agenda in fedora-kde@fp.o
15:18:52 <danofsatx-work> speaking of which, is there a super-secret ML I'm supposed to sub to now as a formal WG member?
15:19:13 <rdieter> danofsatx-work: no, kde@lists.fpo is where the action is (and irc)
15:19:48 <danofsatx-work> ok....that's where I waste most of my time anyhow ;)
15:20:41 <rdieter> #topic kde-4.13.97 status
15:21:05 <rdieter> alrighty, got started on importing kde-4.13.97 bits into rawhide last night, am through most of the core packages now
15:21:08 <mattdm> siddharth yes. well, not with nodebug. see builds at  http://koji.fedoraproject.org/koji/tasks?state=all&view=tree&method=image&order=-id
15:21:08 <mattdm> but note that they arent working right now -- there's a problem that should be fixed soon
15:21:14 <rdieter> will spam the rest here shortly
15:21:27 <rdieter> mattdm: wrong channel?
15:21:43 <rdieter> (or responding to old query?)
15:22:33 <rdieter> noticed there was no kactivities tarball, assuming that was on purpose... so am removing any versioned dependencies I see about it
15:22:53 <mattdm> rdieter wrong channel. very very laggy net on the train :)
15:22:53 <mattdm> sorry :)
15:23:11 <rdieter> np
15:23:14 <mattdm> sorry!
15:23:58 <rdieter> mattdm: as penance, you must be extra super awesome @ flock (and not just the usual normal level of awesome)
15:24:30 <rdieter> any questions/comments about 4.13.97 ?
15:24:53 <danofsatx-work> only for rawhide?
15:26:19 <rdieter> danofsatx-work: good question.  rawhide first for now, then will move on to f21 builds
15:26:34 <pino|work> rdieter: (since he's laggy, he'll reply when flock is already over ;) )
15:27:07 <rdieter> any preference for how fast/soon to push for 4.13.97 in f21?  right away?  wait a bit?
15:27:19 <danofsatx-work> ok. I'm testing the F21 builds as they come out. So far, KDE is the only one working properly ;)
15:28:11 <rdieter> danofsatx-work: only one what?  only spin/desktop ?
15:28:20 <danofsatx-work> yes
15:28:35 <rdieter> yay?!?
15:28:36 <danofsatx-work> Workstation doesn't work. KDE does.
15:28:37 <rdieter> :)
15:28:48 <danofsatx-work> down with GNOME!
15:29:01 <rdieter> danofsatx-work: meh, we don't need talk like that.
15:29:24 <rdieter> or are you channeling Kevin since hes not here?
15:29:37 <danofsatx-work> that was with tongue firmly in cheek ;)
15:29:42 <than> rdieter: hehe :)
15:30:08 <rdieter> still, we can and should be better than that, even in jest.
15:31:08 <danofsatx-work> ok, then.....Way to go team! We have the first working blocking desktop for Fedora Twenty One!
15:31:11 <rdieter> we want our community to be positive and welcoming
15:31:22 <rdieter> there we go!
15:31:36 <rdieter> moving on...
15:31:48 <rdieter> #topic formalize danofsatx-work as KDE WG member
15:32:20 <rdieter> we'd discussed this on irc and onlist over the past... well... awhile, and it's time to formalize it.
15:34:05 <rdieter> bleh, having trouble finding the wiki page about current members
15:34:46 <rdieter> please refer to kkofler's proposal onlist, if you recall.  any questions or comments before we vote?
15:35:11 <pino|work> iirc didn't kevin update the membership list last week?
15:35:29 <rdieter> https://lists.fedoraproject.org/pipermail/kde/2014-June/013631.html
15:35:33 <danofsatx-work> he did, but I can't find that page
15:35:33 <rdieter> oh, maybe
15:35:34 <jgrulich> here is the wiki page, already updated https://fedoraproject.org/wiki/Fedora_Plasma_Product_Governance
15:35:43 <rdieter> oh goodie, well, nevermind then
15:36:01 <danofsatx-work> oh, there it is - thanks jgrulich
15:36:06 <rdieter> moving on...
15:36:27 <rdieter> #topic qt5 packages on kde spin
15:36:44 <rdieter> mbriza mentioned in #fedora-kde earlier that sddm recently dropped support for qt4...
15:36:57 <danofsatx-work> it did? I missed that
15:37:08 <danofsatx-work> so, what does that mean for us?
15:37:48 <rdieter> and, given that the workstation/desktop group intends to include qt5 runtime packages ... it would be more than a little ironic if we (kde spin) didn't do the same
15:38:30 <pino|work> out of curiosity, why do they include qt5? what they need it for?
15:39:05 <rdieter> pino|work: so it is part of the default installed runtime
15:39:20 <dvratil> pino|work, because even they think Qt is cool :-)
15:39:34 <pino|work> so nothing actually using it?
15:39:37 <rdieter> ie, so it is considered part of the workstation platform
15:40:07 <rdieter> users/isv's etc... can expect it to be present without any extra work
15:40:10 <dvratil> given that various projects are switching to Qt, it makes lot of sense - at some point they will have some basic application depending on Qt
15:40:19 <pino|work> interesting
15:40:42 <pino|work> (some) people never finish to surprise me
15:40:44 <rdieter> Kevin thinks including qt5 like that is silly... fwiw
15:40:56 <pino|work> m(
15:41:15 <rdieter> and on some level, he's right, but I still think it a good worthwhile move we should adopt too
15:41:22 <tosky> ehm, how should Qt be included to be included in the non-silly way?
15:41:32 <tosky> I mean, if it's included it's included...
15:41:48 <mbriza> i guess it's silly because nothing depends on it
15:41:52 <rdieter> tosky: non silly would be to include some applications that actually use it, rather than just the libraries/runtime support only
15:42:16 <tosky> oh, but that's the first step
15:42:30 <rdieter> <nod>
15:42:43 <pino|work> better something than nothing at all, especially if the idea comes from their side and not from us
15:42:52 <rdieter> in our case, we would (probably) have at least one thing using Qt5 now: sddm
15:43:08 <pino|work> ("those pushy kde packagers want to push qt5 even if not used" etc)
15:43:35 <rdieter> pino|work: I'm not sure where the idea originated honestly, but I've been pushing for it regardless
15:43:37 <mbriza> well, we can switch other apps and non-KDE libraries too after this
15:43:47 <rdieter> (as well as for kde-runtime too)
15:45:18 <rdieter> anyway, mbriza, do you anticipate any issues switching sddm over to Qt5 for our purpose(s)?
15:45:49 <mbriza> i don't, really
15:45:58 <mbriza> it's the same program, basically
15:46:14 <rdieter> ok, I assumed so, but was asking just in case
15:46:15 <mbriza> there was only a problem with intel drivers and qt5 (?) but it seems to be fixed
15:47:34 <mbriza> i just don't understand why they pushed so hard to remove qt4 support, i don't think it was causing any problems
15:48:02 <rdieter> somebody apparently thought it worthwhile
15:48:05 <dvratil> you can use C++11 awesomeness
15:48:14 * dvratil can't wait to kill Qt 4 in Akonadi
15:48:26 <mbriza> dvratil: what C++11 awesomeness you can't use with qt4?
15:48:49 <mbriza> oh well, at least we'll be able to run the new awesome Plasma5 SDDM theme
15:48:50 <dvratil> list initializers, function pointers in slots, lambda functions...
15:49:16 <mbriza> list initializers and lambda functions were just fine
15:49:29 <dvratil> not with Qt containers
15:49:48 <rdieter> of course its now +1 better too
15:50:13 <danofsatx-work> Is there any difference in writing themes for SDDM on qt5?
15:50:42 <mbriza> danofsatx-work: yes, qtquick 2.0 is a bit richer
15:50:57 <mbriza> dvratil: oh, yeah
15:51:05 <dvratil> also you can now import some Plasma 5 modules to get battery information, etc.
15:51:06 <mbriza> i guess i ran into that too
15:53:08 <rdieter> ok, I'll take the task of getting a good default set of qt5 packages included on kde spin (to essentially match what workstation intends to include too)
15:53:28 <mbriza> (cough) and what sddm requires too [:
15:53:30 <rdieter> mbriza: and feel free to switch sddm over to Qt5 at your convenience
15:54:01 <rdieter> mbriza: I assume sddm will include the proper dependencies to pull in what it needs without any help :)
15:54:23 <mbriza> yeah, yeah :)
15:54:31 <rdieter> mbriza: but when you get a chance, do let me know it's specific requirements so that I can verify it is met
15:55:17 <mbriza> it's qt5-qttools, qt5-qtquick, qt5-qtbase-gui, i think
15:55:33 <rdieter> #action rdieter to implement getting a good default set of qt5 packages included on kde spin
15:55:50 <rdieter> #action mbriza to switch sddm over to Qt5
15:55:57 <mbriza> oh, qtquick is not a separate package, so qt5-qtdeclarative? well, i'll take a look when i'm switching sddm
15:56:26 <rdieter> theres a qt5-qtquick1 and qt5-qtdeclarative, yeah.  not confusing at all. :-/
15:57:05 <rdieter> anything else on the topic?
15:58:06 <rdieter> moving on...
15:58:10 <rdieter> #topic open discussion
15:58:23 <rdieter> anything else to discuss today?  else, we're about out of time anyway
15:58:37 <mbriza> is anybody here coming to flock, btw?
15:58:56 <rdieter> not I (unfortunately)
15:59:05 <dvratil> I created the kde-runtime update  for F20 with split packages, so please try it and ++karma it, so we can have smooth Plasma 5 installation soon :)
16:00:23 <rdieter> dvratil: thanks
16:01:22 * rdieter will end meeting in 2min
16:04:55 <rdieter> thanks all!
16:04:57 <rdieter> #endmeeting