14:02:20 <randomuser> #startmeeting
14:02:20 <zodbot> Meeting started Mon Aug 11 14:02:20 2014 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:02:22 <randomuser> #meetingname Fedora Docs
14:02:22 <zodbot> The meeting name has been set to 'fedora_docs'
14:02:24 <randomuser> #topic Roll Call
14:02:38 <bexelbie> .helloiam bex
14:02:57 * jjmcd 
14:02:57 * pbokoc was just about to start the meeting himself :)
14:03:02 * yruseva 
14:03:08 <randomuser> #chair pbokoc
14:03:08 <zodbot> Current chairs: pbokoc randomuser
14:03:29 <bexelbie> how does one properly answer roll call?
14:03:46 <jjmcd> however, but /me space space is minimal
14:03:55 * bexelbie 
14:04:02 <randomuser> #link http://fedoraproject.org/wiki/Docs_Project_meetings
14:04:07 <bexelbie> cool, there is a fas id command for zodbot I can't ever remember
14:04:18 <randomuser> .hellomynameis immanetize
14:04:18 <zodbot> randomuser: immanetize 'Pete Travis' <me@petetravis.com>
14:04:26 <randomuser> there it is :)
14:04:32 * rkratky is here
14:04:45 * pkovar is here
14:04:48 <bexelbie> .hellomynameis bex
14:04:49 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
14:04:56 <bexelbie> randomuser, ty
14:05:53 <pkovar> bexelbie: cauky
14:06:04 <bexelbie> pkovar, ahoi
14:06:07 * jhradilek is here.
14:06:17 * bexelbie wonders how long pkovar has been a sailor ...
14:06:33 <randomuser> hrmm... action items are a bit stale, i'll try and bring them up in line
14:06:46 <randomuser> #topic Flock
14:07:09 <randomuser> Some of you went - how was it, what can you teach us?
14:07:12 <pbokoc> so I heard there was drinking
14:07:48 <jjmcd> gasp
14:08:11 <randomuser> that about covers it, then
14:08:12 <pkovar> there was a docs hackfest
14:08:15 <pkovar> a publican talk
14:08:16 <randomuser> heh
14:08:19 <pkovar> a mallard talk
14:08:28 <pkovar> and a session on mallard
14:08:39 <pkovar> lots of interesting discussions
14:08:44 <randomuser> i watched the mallard talk and publican talk, nicely done jsmith and jhradilek
14:08:45 <pkovar> on developer docs and other topics
14:08:54 <bexelbie> pbokoc, I wasn't aware of any drinking.  Praha 6 is a dry district
14:09:26 <bexelbie> There was also a fedora magazine presentation that touched briefly on wiki too ... so a lot of people were thinking about docs/wiki issues
14:09:36 * Sparks is here
14:09:46 <pbokoc> "dry district": http://i.idnes.cz/12/081/cl6/TOP450268_7.JPG
14:09:49 * jsmith stumbles in
14:10:31 <randomuser> #link jsmiths publican presentation https://www.youtube.com/watch?v=4eDs74AbLnw
14:11:07 <randomuser> #link jhradilek and pkovar on mallard https://www.youtube.com/watch?v=mIzVYQG1JS0
14:11:41 <randomuser> thanks to everyone here that attended, for representing us
14:12:14 <randomuser> docs isn't at the forefront of people's minds a lot of the time
14:12:51 <randomuser> #topic New Writers
14:13:05 <jsmith> We had several new writers at Flock :-)
14:13:12 <randomuser> Do we have any new or slightly unfamiliar faces here today?
14:13:20 <randomuser> oh, great
14:13:49 <pbokoc> what about the guy from last week? randomuser, did you talk to him afterwards?
14:13:53 <randomuser> did you sponsor anyone, jsmith ? are they hooked?
14:14:04 <pbokoc> Bitwise_Operator, iirc
14:14:07 <jsmith> randomuser: They've already emailed me patches :-)
14:14:11 <jsmith> randomuser: I'd consider that hooked
14:14:20 <jsmith> randomuser: They're going to send me their fas info so I can sponsor them
14:14:23 <randomuser> win!
14:14:37 <jsmith> We even had adamw writing some docs :-)
14:14:44 <randomuser> pbokoc, briefly talked to him after the meeting - i think he's still testing the waters
14:16:08 <randomuser> #info We like new people! Say hello on the list or in #fedora-docs sometime
14:17:25 <randomuser> #topic Release note Beats
14:17:37 <randomuser> #link https://fedorapeople.org/groups/schedule/f-21/f-21-docs-tasks.html
14:18:13 <randomuser> We have just about a week to finish alpha release notes
14:18:30 <pbokoc> oh yeah, randomuser thanks for adding info to the installer beat
14:18:36 <randomuser> ...and I'm moving house this week, so it might be difficult to commit as much time as needed
14:18:44 <jjmcd> Alpha is typically a single page, anyone coordinating with marketing?
14:19:21 <randomuser> jjmcd, i've talked to them a little - i don't think suehle is shouldering all the marketing work these days, so we might have to be more involved
14:19:28 <randomuser> or should, that is
14:20:09 <randomuser> Can everyone please take a Change or two ?
14:21:01 * lnovich is here but occupied with other things at the moment
14:21:20 <randomuser> I think the Change coverage would get done fairly quickly if everyone just did a bit
14:21:33 <bexelbie> is there a list or are we doing discovery?
14:21:41 <pbokoc> bexelbie, https://fedoraproject.org/wiki/Releases/21/ChangeSet
14:21:50 * bexelbie has pto friday and is home for illness related reasons so he needs to be realistic
14:21:53 <randomuser> pbokoc++
14:22:13 <pbokoc> randomuser, how do I go about this? Add myself as Release note owner, clone the bug and assign it to myself?
14:22:27 * lnovich can get something written this week or next for the RN
14:22:35 <bexelbie> #link https://fedoraproject.org/wiki/Releases/21/ChangeSet list of changes
14:22:38 <randomuser> bexelbie, the changes have suggested copy from the developers - we check it over, add any info we feel is needed for users to understand the Change, and drop it in the wiki
14:22:53 <randomuser> pbokoc, in the Change bug, add yourself as the Docs contact
14:23:20 <bexelbie> randomuser, ok, I'll try to do a few
14:23:33 <randomuser> pbokoc, after you put the copy in the Beats wiki, you could optionally post in the bug for the Change owner to review
14:23:56 <randomuser> i should info this...
14:24:03 <pbokoc> randomuser, gotcha. (So no cloning then.)
14:24:06 <randomuser> #info Change writers needed!
14:24:22 <randomuser> yeah, cloning was tedious and people complained about the bz mails
14:24:39 <randomuser> #link https://fedoraproject.org/wiki/Category:Documentation_beats
14:24:58 <randomuser> and there's more of a shared sense of ownership this way
14:25:11 <pbokoc> yeah, it sounds better
14:25:22 <randomuser> #info Pick some changes, add yourself as the docs contact in the bz ticket for the change
14:25:40 <randomuser> #info review the Change Owner's release notes copy, ensure the content is thorough
14:26:03 <randomuser> #info write into the appropriate Beats, and signal the change owner for review
14:27:02 <randomuser> ok, that's thoroughly covered
14:27:14 <randomuser> #topic fedora.next updates
14:27:33 <randomuser> the talks I reviewed so far gave some good perspective on .next
14:28:06 <randomuser> did flock attendees get any feedback from the working groups on their documentation needs?
14:28:16 <randomuser> jsmith, you probably talked to people about it
14:28:38 <jsmith> randomuser: The cloud group said "Yeah, we need to get on that"
14:28:43 <randomuser> heh
14:28:53 <jsmith> randomuser: The server working group said "Please send an email to our mailing list"
14:30:35 <randomuser> zoglesby and I talked about server briefly during the last office hours; he's swamped at $DAYJOB i think
14:31:06 <pkovar> the env and stacks WG would love to see fedora wiki fixed
14:31:19 <pkovar> as in having the content properly categorized
14:31:22 <pkovar> updated
14:31:29 <pkovar> removed, archived, etc.
14:31:31 * randomuser nods
14:31:33 <lnovich> +1 good idea
14:31:45 <randomuser> we talked about some automated archiving - WIP, sort of
14:31:50 <pkovar> they are also interested in exploring new source content formats
14:32:00 <pkovar> besides docbook + publican toolchain
14:32:19 <pkovar> formats that wouldn't involve xml, though
14:32:22 <randomuser> pkovar, interesting - to what end?
14:32:37 <pkovar> devs don't like xml
14:32:46 <bexelbie> with regards to server we also need to be thinking about the roles
14:32:58 <pkovar> interested as in they are willing to work with us
14:33:04 <pkovar> on finding a solution
14:33:13 <bexelbie> I spoke with sgallagh briefly and it sounds like there will be some docs coming out around what the "best practice" setups are ... that could be very valuable
14:33:14 <pkovar> which leads to devassistant
14:34:01 <pkovar> jhradilek worked with bkabrda on getting docbook & publican support nto devassistant
14:34:11 <randomuser> nice
14:34:13 <pkovar> they have made some good progress so far
14:34:55 <randomuser> #info jhradilek and bkabrda working on publican support for devassistant
14:35:13 <pkovar> but devassistant team is also interested in adding support for more input formats
14:35:28 <pkovar> asciidoc, markdown, mallard would be good candidates
14:35:46 <randomuser> mallard is still xml :P
14:36:11 <bexelbie> sphinx ...
14:36:12 <pkovar> right, but the author of mallard is working on so called duck format
14:36:13 <bexelbie> rst
14:36:30 <pkovar> which is similar to asciidoc
14:36:40 <pkovar> and preserves semantic markup with no xml
14:36:47 <pkovar> a great idea, imho
14:37:05 <randomuser> we can convert all these with pandoc to use our existing publishing platform - but once converted, it's non-trivial for the original submitters to maintain in their chosen format
14:37:15 <pkovar> right
14:37:26 <randomuser> we would need a whole new website structure to accommodate
14:37:37 <pkovar> true
14:37:50 * yruseva pulls out a notebook
14:38:17 <pkovar> so all this would probably be for a developer docs site that fedora devs could easily contribute to
14:38:24 <randomuser> (which I proposed at some point and nobody really liked the idea)
14:38:46 <randomuser> ahh, internally targeted documentation
14:38:56 <pkovar> maybe it's time to bring that idea up again, not sure...
14:39:11 <bexelbie> I think we need this for more than just internally focussed docs
14:39:23 <bexelbie> for example, the fedora docker stuff is currently in a "medely" of markups
14:39:29 <bexelbie> and not yet contributed upstream ...
14:39:43 <randomuser> pkovar, this sounds like a good list discussion - can you summarize the env-n-stacks position and such there?
14:40:04 <pkovar> i plan to do it this week, yes
14:40:17 <randomuser> great
14:40:23 <pkovar> we should definitely have a list discussion about this
14:40:44 <randomuser> one part that we've been missing from these discussions is the "I'm not writing docs because..." bit
14:41:17 <pkovar> I'm not writing docs because i hate xml is what heard a lot ;)
14:41:53 <randomuser> i keep telling people that if they write it, I'll mark it up...
14:42:24 <bexelbie> that was said a lot by jsmith too
14:42:24 <pkovar> and particularly docbook that comes with its 450 elements...
14:42:35 <randomuser> rkratky, yruseva - are we still on for talking about the site later?
14:42:44 <yruseva> yes
14:42:51 <rkratky> randomuser, yes
14:43:03 <randomuser> awesome
14:44:11 <randomuser> pkovar, it makes a huge difference for one of our own to be active in other groups and keeping docs as part of their plans - thanks for doing that
14:45:31 <randomuser> #action pkovar to start list discussion on alternative formats
14:45:57 <randomuser> #topic Guide Status
14:46:35 <pkovar> yw - i hope more people, esp. devs, will share their ideas
14:46:52 <randomuser> i see bara_ did a lot with the security guide
14:47:47 * pbokoc decided to be really active and started refactoring the Install Guide, then had to go do something else and then he didn't have time to touch it again :(
14:48:01 <bara_> randomuser, I've just updated some sections about SELinux with content we have in SELinux guide for RHEL 7
14:53:16 <pbokoc> so, anything else?
14:53:37 <randomuser> seems pretty quiet about guides
14:53:42 <randomuser> #topic open floor
14:53:53 <jhradilek> What did I miss?
14:54:02 <randomuser> ha! that's what I was going to say
14:54:02 <jhradilek> Ah, good. Petr has mentioned the DevAssistant work. :)
14:56:01 <pbokoc> randomuser, btw, we don't really care about the status of the change tracking bugs, do we? I mean, some of them are NEW, even though they're accepted changes
14:56:05 <randomuser> pbokoc, oh - i've read some things about people being confused reading media creation instructions for macs
14:56:28 <bexelbie> randomuser, I have 50% of that answered in the ask thread
14:56:37 <bexelbie> I am waiting on a clean install mac to verify the source of the shasum checker
14:56:38 <pbokoc> randomuser, there are no media creation instructions for macs... but yeah, I see how that would confuse some people :))
14:56:42 <bexelbie> then I'll patch the book
14:56:52 <randomuser> pbokoc, i think jreznik closes any that don't make deadlines, or at least comments
14:57:09 <randomuser> pbokoc, the status isn't really for our part, no
14:57:22 <randomuser> bexelbie, +1 - i skimmed over that post, nice work
14:57:41 <randomuser> although, who knows what that guy's security concern is about...
14:57:43 <pbokoc> anyway I talked about macs&media creation with adamw some time ago. I'm planning to include a section on that
14:58:00 <bexelbie> randomuser, if we tell people to verify it is only fair that we aren't shocked when they do :P
14:58:10 * bexelbie opens his trench coat and offers to signs PGP keys
14:58:36 <bexelbie> pbokoc, what are you looking for in that section?
14:58:41 <bexelbie> just beefing up what we have?
14:59:46 <pbokoc> bexelbie, the problem is we don't really have anything. (There's something on the wiki, but afaik nobody actually tested it.) I need a step-by-step procedure that describes how to dd an ISO to a flash drive so it's bootable - on a mac
14:59:56 <randomuser> also, pbokoc - we're dropping readme-burning-isos, right?
15:00:04 <pbokoc> randomuser, that's the plan, yeah
15:00:24 <bexelbie> I'll dump my edits from it then :)
15:00:36 <bexelbie> pbokoc, I'll take a look at that ... I have a machine I can test on
15:00:36 <randomuser> #action randomuser to deadpackage readme-burning-isos, that's all covered in the IG
15:00:45 <bexelbie> pbokoc, do you have the url handy?
15:00:59 <bexelbie> do we have web stats?  Did people like the shortform better?
15:01:06 <randomuser> i have access to an *older* mac I can test with, if needed
15:01:27 <bexelbie> randomuser, how old is old? my mbp is about 3 years ...
15:01:31 <randomuser> older
15:01:43 <randomuser> let's move over to #fedora-docs, our meeting has gone over
15:01:48 <randomuser> thanks for coming, everyone
15:01:53 <randomuser> #endmeeting