17:03:21 <jzb> #startmeeting
17:03:21 <zodbot> Meeting started Fri Aug 29 17:03:21 2014 UTC.  The chair is jzb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:03:27 <jzb> #topic roll call
17:03:31 <oddshocks> .hellomynameis oddshocks
17:03:32 <zodbot> oddshocks: oddshocks 'David Gay' <dgay@redhat.com>
17:03:42 <jzb> .hellomynameis jzb
17:03:43 <dustymabe> .hellomynameis dustymabe
17:03:43 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@zonker.net>
17:03:46 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@gmail.com>
17:03:50 <roshi> .hellomynameis roshi
17:03:51 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:03:58 <frankieonuonga> .hellomynameis frankieonuonga
17:03:59 <zodbot> frankieonuonga: frankieonuonga 'Frankie Onuonga' <frankieonuonga@gmail.com>
17:04:09 <geppetto> .hellomynameis james
17:04:10 <zodbot> geppetto: james 'James Antill' <james.antill@redhat.com>
17:04:12 <frankieonuonga> man this thing is neat
17:04:13 <number80> .hellomynameis hguemar
17:04:15 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
17:04:29 <agrimm> .hellomynameis arg
17:04:29 <zodbot> agrimm: arg 'Andy Grimm' <agrimm@redhat.com>
17:04:44 * gholms isn't sure if he should chime in or not
17:04:49 <agrimm> full house today!
17:04:54 <jzb> gholms: why not?
17:05:01 <frankieonuonga> where is mattdm
17:05:01 <agrimm> o/ gholms.  join us!
17:05:08 <gholms> .hellomynameis gholms
17:05:09 <zodbot> gholms: gholms 'None' <garrett.holmstrom@gmail.com>
17:05:14 <gholms> Heh
17:05:17 <jzb> gholms: even if you're not officially part of the workgroup, we don't vote on most things
17:05:29 <gholms> Welp, I'm not using that again.  :/
17:05:34 <agrimm> jzb just orders us around...
17:05:36 <roshi> gholms, you're the default user in every distro!?
17:05:43 <jzb> gholms: we sort of do the Apache-like thing - reach consensus, etc.
17:05:47 <jzb> agrimm: ha!
17:05:55 * roshi always wondered who 'None' was
17:06:15 <gholms> roshi: Dang.  Now the secret's out.
17:06:38 <jzb> OK, lemme pull up tickets taggged meeting.
17:06:40 <jzb> er tagged
17:06:47 <roshi> for a fee, I would imagine we can all keep a secret :p
17:07:21 <jzb> ok, here we go
17:07:27 * gholms could not possibly buy enough beer to bribe you all
17:07:31 <jzb> #topic Trac tickets
17:07:39 <jzb> gholms: I go for quality, not quantity.
17:07:51 <jzb> there are a few beers that might be persuasive.
17:07:52 <gholms> :)
17:08:19 <jzb> I'm going to skip #36
17:08:20 <roshi> Pliney the Elder would be a good start :)
17:08:24 <roshi> or the Younger
17:08:32 <jzb> that's on my plate, and I'll look it over this weekend (website)
17:09:05 <jzb> #topic Automatic Smoketests on Image Build
17:09:11 <jzb> #link https://fedorahosted.org/cloud/ticket/38
17:09:16 <jzb> agrimm: I think this is yours?
17:09:23 <jzb> agrimm: anything to report this week?
17:09:42 <agrimm> jzb, unfortunately not
17:10:15 <jzb> by the way, you can follow along at home with this link:
17:10:18 <jzb> https://fedorahosted.org/cloud/report/9?sort=ticket&asc=1&page=1
17:10:28 <agrimm> but hey, at least roshi is around now to discuss that stuff
17:10:43 <roshi> I am :)
17:10:43 <agrimm> so I'll talk with him later
17:10:45 <jzb> agrimm: so, action is to discuss with roshi?
17:10:51 <jzb> agrimm: and report back to list/ticket?
17:10:52 <agrimm> yes
17:11:06 * roshi runs (gotta make it interesting...)
17:11:17 <jzb> #action agrimm discuss ticket #38 with roshi and report back to ticket/mailing list.
17:11:20 <jzb> ok
17:11:30 <jzb> #topic start communication/collaboration on cloud image updates
17:11:40 <jzb> #link https://fedorahosted.org/cloud/ticket/51
17:12:12 <jzb> currently owned by roshi , but the last update is from walters saying that agrimm will look at it.
17:12:21 <jzb> agrimm: were you informed you were looking at it?
17:12:27 <jzb> :-)
17:12:56 <agrimm> jzb, sadly, I cannot deny that I was present in that meeting
17:12:58 <roshi> another thing we can talk about I suppose
17:13:30 <jzb> so, action is ... discuss, report back?
17:13:30 <gholms> Heh
17:13:31 <agrimm> yeah, how often we can update depends on how solid our QA is
17:13:34 <agrimm> and how time-consuming
17:13:52 <roshi> for sure
17:14:00 <jzb> OK
17:14:24 <jzb> #action agrimm will meet with roshi on ticket #51 and report back to list/ticket.
17:14:32 <roshi> I'm going back to vacation if this keeps up :p
17:14:34 <jzb> agrimm: do you want to take ownership of the ticket?
17:14:35 * roshi kids
17:14:41 <jzb> or is it still roshi's?
17:14:49 <agrimm> jzb, were there any flock discussions that have a serious impact on update policies?
17:14:55 <roshi> it was me because I'm kinda the QA bridge for cloud
17:15:00 <jzb> agrimm: no
17:15:06 <jzb> roshi: OK
17:15:13 <roshi> I don't know if that's still the case though, I don't mind it being the case
17:15:24 <jzb> #topic Process for determining when and why Docker trusted images need to be rebuilt
17:15:30 <roshi> kinda went into a lull due to the slew of failed builds we had for a while there, iirc
17:15:32 <jzb> #link https://fedorahosted.org/cloud/ticket/59
17:15:45 <jzb> roshi: at least for atomic builds, I think we're close to having a TC
17:15:55 <jzb> OK, so this one's mine
17:16:05 <jzb> and I have done a draft and sent to the list + copied to the wiki
17:16:06 <roshi> sweet jzb
17:16:18 <jzb> #link ​https://fedoraproject.org/wiki/Cloud/Cloud_RFC_Docker_Trusted_Images_Rebuild_Policy
17:16:37 <jzb> scollier has sent me a number of questions, I looped mattdm in on those.
17:16:43 <jzb> may send to the list
17:16:51 <jzb> however, I need feedback/review from others
17:16:55 * jzb looks around the room
17:17:09 <jzb> please shoot me some feedback before next meeting?
17:17:35 <roshi> I'll take a look and give feedback if I see anything jzb :)
17:17:39 <jzb> roshi: thanks!
17:17:41 * gholms reads
17:17:52 <jzb> #topic next steps on test plan
17:18:06 <jzb> #link https://fedorahosted.org/cloud/ticket/61
17:18:37 <jzb> I took this ticket, but I haven't moved it in the last week (sorry)
17:18:42 <roshi> when we say test plan, what do we mean?
17:18:49 <jzb> roshi: I guess it's my turn to discuss with you & report back ;-)
17:18:57 <jzb> roshi: that's a good question :-D
17:19:11 <roshi> I drafted out a test plan on the wiki (but I don't know if anyone looked at it, never got any feedback on it)
17:19:31 <roshi> after that I learned that the "test plans" QA used to do, we don't really do anymore...
17:19:47 <roshi> so we've got pretty open possibilities for how we want to draft it
17:19:50 <jzb> #link https://fedoraproject.org/wiki/User:Roshi/QA/Cloud_Docs
17:19:59 <jzb> roshi: do we have an appropriate template?
17:20:26 <roshi> like this: https://fedoraproject.org/wiki/User:Roshi/QA/Cloud_Docs/Test_Plan
17:20:29 <roshi> ?
17:20:43 * roshi isn't sure what an "appropriate template" is exactly
17:22:19 <jzb> I think maybe next steps are to invite someone from QA and ask if we have what is needed
17:22:40 <jzb> maybe we can persuade adamw to join us next week, look over what we have, and tell us what we're missing?
17:22:40 <roshi> there's a lot of definitions we need for that :)
17:22:58 <roshi> works for me
17:23:23 <jzb> #action jzb to invite adamw to next week's meeting, make sure we have something to look over.
17:23:48 <adamw> a roshi isn't good enough for you? :)
17:24:02 <adamw> he's been doing most of the cloud stuff, he probably knows more than ,e
17:24:06 <roshi> I keep telling people I'm no adamw
17:24:08 <roshi> :p
17:24:21 <jzb> adamw: I think it's more about the form of the test plans than the specifics?
17:24:33 <jzb> adamw: to put it another way, I'm not sure what QA wants/expects.
17:24:40 <jzb> what's useful, what's not, etc.
17:25:14 <roshi> well, I also drafted out a "test overview" while talking to adamw - so we have stuff to look at for sure
17:25:21 <roshi> https://fedoraproject.org/wiki/User:Roshi/QA/Cloud_Docs/Test_Overview
17:25:55 <adamw> i can drop by next time for sure
17:26:01 <jzb> adamw: excellent
17:26:22 <jzb> adamw: if you have anything for  background before then, I'd love to look at it.
17:26:30 <jzb> adamw: sorry if I'm being dense :-)
17:26:35 <jzb> this is not my area of expertise.
17:27:03 <jzb> #topic tracker for Project Atomic
17:27:13 <jzb> #link https://fedorahosted.org/cloud/ticket/64
17:27:23 <jzb> this ticket is just the tracker for work going on for Atomic images
17:27:36 <jzb> I've been updating it with links to the minutes from the joint infra/atomic meetings on Tuesdays
17:27:50 * roshi should probably go to those...
17:27:53 <jzb> tl;dr is that we've been making some progress, and nirik was saying we are close to having TC
17:28:10 <jzb> once we do, he'll announce it widely and we can start trying it out.
17:28:26 <jzb> roshi: you're welcome to!
17:28:37 <oddshocks> Is this a good time to check in on the current status of metalink integration / atomic support in MM? I've missed the past couple meetings due to driving Rochester, NY --> Seattle, WA
17:28:46 <oddshocks> if not we can talk about it Tuesday
17:28:49 <jzb> oddshocks: you have an update?
17:28:57 <oddshocks> jzb: More like I was looking for one :P
17:29:08 <jzb> oddshocks: ah, then probably Tuesday :-D
17:29:31 <oddshocks> I have been told walters should be around this week so maybe he can give us an update at some point. Cool, Tuesday's fine with me. Just looking to jump back in on the MM stuff and I don't want to recreate any work that's been done since I was away
17:29:33 <agrimm> oddshocks, walters has been making progress, but he's not full time again until after next week
17:29:39 <oddshocks> agrimm: ahh ok thanks :)
17:30:01 <jzb> anything else on this ticket?
17:30:35 <oddshocks> not from me
17:30:39 <jzb> groovy
17:30:48 <jzb> #topic crucial questions on Docker image deliverable
17:30:55 <jzb> #link https://fedorahosted.org/cloud/ticket/65
17:31:02 <jzb> So, this one has no owner
17:31:14 <roshi> not it
17:31:19 <jzb> first item of business may be to see if someone wants to take this ticket and hug and cuddle it until completion.
17:31:22 * roshi doesn't know much about docker
17:31:51 <jzb> I know a little about Docker, but I am going to cowardly refuse to take on any new tickets until I close one. :-)
17:32:09 * frankieonuonga can help get roshi up to speed with docker
17:32:09 <roshi> just give some to agrimm :)
17:32:28 <frankieonuonga> I can help there....not much time on my hands though but I can try
17:32:39 <frankieonuonga> for sure 4 hours a week
17:32:53 <dustymabe> I know a decent amount about Docker.. but I think this ticket has more to do with what content is going to go in the image?
17:33:27 <jzb> dustymabe: seems right
17:33:42 <jzb> also, there's a comment in the ticket about "expect the docker image to be taken by the base wg"
17:34:09 <jzb> so I think first item of business is probably digging in and clarifying what's left to be done here.
17:34:25 <jzb> which probably means liasing with the base WG?
17:34:29 <jzb> or am I crazy?
17:34:37 <jzb> (Yes, I realize that's not an either/or)
17:34:50 <roshi> looks that way to me
17:35:14 <roshi> about liasing
17:35:34 <roshi> determining crazy hits too close to home for me to make a determination on that jzb :p
17:36:09 <jzb> OK, so who wants to take the bullet?
17:36:29 <jzb> Preferably with an eye to being aggressive about getting it cleared up by next meeting?
17:36:42 <jzb> we're getting close to alpha-time
17:37:56 <frankieonuonga> I would but by next meeting nope..maybe after next meeting.
17:38:13 <roshi> who's the contact with base?
17:38:48 <roshi> if it's just itemizing what needs done and we know who to talk to, it shouldn't be too hard...
17:38:56 <roshi> but then again, I don't know anything about docker
17:39:36 <jzb> roshi: http://fedoraproject.org/wiki/Base
17:39:39 <frankieonuonga> I can help you there rosho
17:39:47 <frankieonuonga> does not take much time to learn it
17:40:28 <jzb> I feel like I haven't picked on number80 today
17:40:29 <roshi> if there's no one else, I can try to track down some answers
17:40:49 <jzb> roshi: sold
17:40:54 <roshi> but I can't promise any form of result :p
17:41:10 <jzb> roshi: if you can 1) get status, and 2) point the way to what we need to do
17:41:15 <jzb> that should be quite a lot
17:41:26 <roshi> I can do that much I think
17:41:31 <jzb> it may be that base has it covered
17:41:36 <jzb> and will say "yeah, we've got this."
17:41:40 <number80> jzb: :)
17:41:43 * roshi crosses his fingers and knocks on wood
17:41:49 * jzb is a crazy dreamer
17:42:07 <roshi> me too man
17:42:22 <jzb> #action roshi will take ticket 65 and get answers, report back, and probably re-assign once we know what's left to do.
17:42:30 <jzb> ok
17:42:35 <jzb> #topic open floor
17:42:43 <jzb> any new business, discussion, etc/
17:43:02 <jzb> #chair number80 agrimm roshi frankieonuonga oddshocks
17:43:02 <zodbot> Current chairs: agrimm frankieonuonga jzb number80 oddshocks roshi
17:43:06 <gholms> #help Testers wanted for new python3-boto package in updates-testing
17:43:19 <dustymabe> number80: still waiting on email for  "dustymabe/number80 working on Digital Ocean support"
17:43:24 <number80> gholms: is it based on botocore ?
17:43:29 <gholms> (also an updated python-boto)
17:43:31 <jzb> #chair gholms
17:43:31 <zodbot> Current chairs: agrimm frankieonuonga gholms jzb number80 oddshocks roshi
17:43:35 <jzb> #chair dustymabe
17:43:35 <zodbot> Current chairs: agrimm dustymabe frankieonuonga gholms jzb number80 oddshocks roshi
17:43:38 <roshi> digital ocean support?
17:43:45 <number80> #action number80 help dustymabe on digitalocean
17:43:50 <gholms> number80: Nope, that'd be python-boto3.  ;)
17:43:55 <number80> ok
17:44:00 <roshi> I asked them in their support about support/testing and whatnot and they didn't really respond
17:44:45 <dustymabe> roshi: my adventures might be fruitless as well but we will see
17:45:01 <number80> gholms: I should be able to test it either this week-end or next week
17:45:06 <dustymabe> roshi: I work in the same building as them in NY so it might be hard to ignore me
17:45:10 <gholms> Thanks!
17:45:23 <roshi> awesome, dustymabe
17:45:46 * roshi was wanting to offer to help test on their infra with our cloud TC/RCs and whatnot
17:46:16 <dustymabe> also we had a couple action items from a couple weeks ago on HP/GCE/Rackspace items
17:46:19 <dustymabe> any updates on those
17:46:44 <jzb> dustymabe: any tickets?
17:47:15 * frankieonuonga recalls seeing something on GCE on email but now I can not recall what it was
17:47:21 <dustymabe> https://lists.fedoraproject.org/pipermail/cloud/2014-August/004165.html
17:47:27 <dustymabe> here are the minutes
17:47:38 <dustymabe> I don't know if any tickets were generated
17:48:03 <agrimm> re: GCE, I tried to make some connections on that via email
17:48:26 * agrimm looks back through his mail for the thread with imcleod
17:49:09 * dustymabe wants to know: what is the policy on re-visiting action items from earlier meetings?
17:49:19 <agrimm> yeah, imcleod sent and email to several folks at google explaining what we need clarification on
17:49:24 <agrimm> that was 8/19
17:49:28 <agrimm> no response
17:49:31 <dustymabe> seems necessary.. otherwise things get lost (unless you generated a ticket for it)
17:49:32 <agrimm> I'll bump the thread
17:50:06 <jzb> agrimm: can you forward me the email?
17:50:26 <jzb> agrimm: I think we can connect the dots, I just need to know what to put in front of the right people for GCE
17:51:33 <agrimm> jzb, yes, I will CC you on my next message.
17:51:46 <jzb> agrimm: woot, thanks sir
17:51:49 <jzb> OK
17:51:53 <jzb> anything else?
17:51:59 * roshi has nothing
17:52:27 * frankieonuonga has nothing 2
17:52:28 * dustymabe nothing.. other than question ^^
17:52:36 <jzb> dustymabe: sorry?
17:53:17 <dustymabe> should we consider re-visiting action items from earlier meetings as part of normal meeting process
17:53:28 <jzb> ah, that's a good idea
17:53:51 <dustymabe> so perhaps the very first thing is paste a link from last weeks meeting (minutes)
17:54:07 <dustymabe> then people update status, and then go to tickets
17:54:08 <dustymabe> etc
17:54:11 <frankieonuonga> I think we should brush up on those before proceeding.
17:54:20 <frankieonuonga> like the first 15 min
17:54:22 <jzb> dustymabe: there were no action items from last meeting :-)
17:54:37 <dustymabe> :) but there were from the previous one
17:54:52 <dustymabe> which we could have carried forward if we revisited them
17:55:20 <roshi> that sounds like more work dustymabe :p
17:55:32 <roshi> the trouble would be tracking them, imo
17:55:33 <jzb> heh
17:55:35 <dustymabe> roshi: indeed
17:55:43 <jzb> well, ideally we would make tickets for the action items.
17:55:59 <jzb> but, yes, I think we should do that next week
17:56:09 <roshi> sounds like a good idea to me
17:56:17 <dustymabe> jzb: ok. yeah I'm just trying to find the best solution where we does lose items
17:56:18 <jzb> OK
17:56:25 <jzb> dustymabe: absolutely
17:56:45 <jzb> OK
17:56:50 <dustymabe> jzb: thanks. :)
17:57:10 <jzb> I'm going to close the meeting unless there's anything else urgent
17:57:27 <jzb> and again, thanks to all for your work
17:57:33 <jzb> #endmeeting