14:02:59 <randomuser> #startmeeting
14:02:59 <zodbot> Meeting started Mon Sep  8 14:02:59 2014 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:03:23 <pbokoc> yo
14:03:30 <randomuser> #meetingname fedora docs weekly meeting
14:03:30 <zodbot> The meeting name has been set to 'fedora_docs_weekly_meeting'
14:03:37 <randomuser> #topic roll call
14:03:49 * bexelbie is here
14:04:05 <randomuser> #link https://fedoraproject.org/wiki/Docs_Project_meetings
14:04:19 * yruseva too
14:04:28 * jhradilek waves.
14:04:31 <randomuser> you... call each other rolls for a minute, I have to briefly step away
14:04:35 <bexelbie> .hellomynameis bex
14:04:36 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
14:05:34 * bara_ says hello
14:06:14 <bexelbie> jhradilek, you are a bagel.   yruseva you are a croissant.  bara you are a rholik.  Have I called everyone a roll yet?
14:06:31 <yruseva> I'm French, cool
14:07:06 <pbokoc> https://www.youtube.com/watch?v=CaFnKvwf4Sg
14:07:27 <bara_> bex I think you meant "rohlik" :)
14:07:49 <jhradilek> bexelbie: No more donuts for you, sir.
14:07:53 <bexelbie> bara_, technically that is a slovakian roll :P
14:07:56 <bexelbie> pbokoc, nice
14:08:12 <pbokoc> also: http://marthaandtom.com/wp-content/uploads/2009/05/img_5889.jpg
14:08:51 <pbokoc> oh and someone could be an eggroll, too
14:08:52 <bexelbie> pbokoc, your stock of roll related humor worries me
14:08:59 <bara_> bexelbie eee, no :) that's "rožok"  :P
14:09:10 <bexelbie> that looks strangely hungarian to me
14:09:11 <bexelbie> :P
14:09:12 <pbokoc> bexelbie, that's how I roll
14:09:20 <bexelbie> but then what do I know, I only speak freedom :P
14:09:49 <randomuser> well done!
14:10:14 <randomuser> I'm skipping action items for now, because I don't have the list in front of me
14:10:21 <randomuser> #topic New Writers
14:10:37 <randomuser> Have any new writers joined us today?
14:12:34 <randomuser> I imagine talking to pbokoc in person involves a lot of flashcards with amusing captioned photos
14:13:09 <pbokoc> http://x1.fjcdn.com/thumbnails/comments/4993027+_2d31abd88f4722930e2a2ca156d959a5.jpg
14:14:04 <bexelbie> randomuser, pbokoc means www.youtube.com/watch?v=E781QE7ZQK8
14:14:10 <randomuser> #topic beats
14:14:15 <randomuser> #undo
14:14:15 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0xf6871d0>
14:14:24 <randomuser> #topic Release Note Beats
14:14:52 <randomuser> and it doesn't appear that I can watch youtube here anymore; at least, theres an https redirect that I'm not brave enough to face
14:15:09 <randomuser> On the beats, I think we're doing fairly well
14:15:22 <yruseva> do we still have time for more?
14:15:34 <randomuser> pbokoc took care of a lot of the Changes, and I'm fairly sure other people have pitched in too
14:15:41 <randomuser> we absolutely do have time for more
14:15:52 <yruseva> really? cool
14:16:00 <randomuser> we're ahead of the game compared to the last two releases, i think
14:16:15 * yruseva needs to chase some developers around
14:16:24 <pbokoc> nice
14:16:37 <randomuser> now that I think about it...
14:16:54 <randomuser> #action randomuser to send state-of-beats mail to docs list
14:17:20 <pbokoc> randomuser, by the way, when do we plan to start moving beats from the wiki to the actual relnotes?
14:17:21 <randomuser> I should probably look through and see where we are *before* the meeting, but this will do
14:17:48 * randomuser checks the schedule
14:18:10 <randomuser> in two weeks time
14:18:16 <randomuser> https://fedorapeople.org/groups/schedule/f-21/f-21-docs-tree-tasks.html
14:18:24 <pbokoc> oh, it's in the schedule
14:18:36 <pbokoc> alright, I'll help with that
14:19:20 <randomuser> #link https://fedoraproject.org/wiki/Category:Documentation_beats?rd=Documentation_Beats
14:19:30 <randomuser> #info add what you know to the Beats
14:20:19 <randomuser> and while we're here, if you don't know, Workstation WG has decided not to ship a release notes RPM because the release notes are not an app
14:20:44 <randomuser> I don't think server is shipping them either, and definitely not cloud
14:20:57 <randomuser> the spins might or might not, but they have never been compelled to
14:21:16 * lnovich is here
14:21:27 <randomuser> and here's a fun one: no more generic installation dvd or netinstall
14:21:48 <lnovich> great - any more suprises?
14:22:13 <randomuser> if people want a choose-your-own-adventure experience, they MUST take a product netinstall - whose statii are unknown now - and personally append a repo= arg at boot
14:22:30 <lnovich> do we really need to supply DVDs?
14:22:55 <pbokoc> wait a minute
14:23:33 <pbokoc> if you use the netinstall iso, you can't choose a different source? It's always going to grab packages from download.fp.o?
14:23:39 <pbokoc> I mean, in the GUI
14:24:12 <randomuser> oh, good question pbokoc
14:24:31 <randomuser> lnovich, I'm not sure I understand your question the way you intend it
14:25:09 <lnovich> do customers need / use DVDs?
14:25:45 <randomuser> afaik the generic install images have always been popular; not everyone goes for the live images
14:26:23 <pbokoc> I would assume so, the full install DVD was making a lot of the advanced installation paths a lot easier
14:26:33 <randomuser> does that answer your question, lnovich ?
14:26:45 <lnovich> ok
14:27:02 <pbokoc> well, anyway, we're gonna have to deal with it I guess
14:27:27 <randomuser> indeed
14:27:31 <pbokoc> it shouldn't impact any documentation other than relnotes and Install Guide
14:27:33 <bexelbie> isn't the thought htat dvds go away because of the various workstation/server/etc variants?
14:27:37 <lnovich> with me not even having a dvd  reader in my laptop- it just made me wonder
14:27:57 <randomuser> #info no more generic install images - check your guides
14:28:08 <pbokoc> lnovich, you can transfer the DVD image onto an USB drive and boot from that :)
14:28:13 <randomuser> lnovich, we are talking about the type of installation image, not the physical media
14:28:17 <pbokoc> (any boot image, actually)
14:28:53 <lnovich> ok
14:29:04 <lnovich> just trying to cut down overhead if needed
14:29:16 <lnovich> or if possible
14:29:38 <pbokoc> let's move on
14:30:15 <lnovich> +1
14:30:16 <randomuser> #topic Guide Status
14:30:32 <pbokoc> I need a bunch of volunteers!
14:30:43 * lnovich hides in the corner
14:30:51 <randomuser> it seems like there's been a lot more work on guides, compared to the last couple releases. yay!
14:31:14 <lnovich> that's great as I have not been able to do much at the moment
14:31:44 <bexelbie> what do you need volunteers for?
14:31:49 <randomuser> pbokoc, you have a task list in bz, right?
14:32:14 <pbokoc> oh yeah
14:32:22 <pbokoc> http://red.ht/1s2GmSK
14:32:52 <pbokoc> there are several mostly self-contained tasks in there for separate chapters that need updating
14:33:09 <pbokoc> e.g. review/update the Network Install chapter
14:33:17 * randomuser ahem
14:33:22 <pbokoc> (which you might want to assign to yourself, randomuser :)
14:33:33 <pbokoc> https://bugzilla.redhat.com/show_bug.cgi?id=1136037
14:33:56 <pbokoc> also, does anyone have experience with FedUp? I need someone to write about that
14:34:20 <lnovich> what does FedUp do?
14:34:36 * lnovich wonders who names these things
14:34:41 <pbokoc> lnovich, it's a tool that can automatically upgrade your system to the next release
14:34:47 <randomuser> FedoraUpgrade
14:34:50 <jhradilek> yruseva: Don't you have some experience with that?
14:34:56 <yruseva> ah :)
14:34:56 <pbokoc> e.g. you run it on Fedora 19 and it will automatically update your system to F20
14:35:00 <lnovich> but seriously FedUp?
14:35:09 * pbokoc likes the name
14:35:12 <yruseva> jhradilek, yes, once it made my laptop forget it had a touchpad
14:35:18 <pbokoc> :D
14:35:18 <jhradilek> :D
14:35:30 * bexelbie is back
14:35:32 <yruseva> next time it worked better :)
14:35:43 <randomuser> hey, whoever takes fedup should ask for watchbugs ACLs in pkgdb in the short term
14:36:08 <pbokoc> also I'm not sure how much of the rhelup documentation will apply to fedup as well, that might be a problem
14:36:13 <randomuser> also, in the upgrade section, we should have an admonition about fedora-release-{standard,server,workstation,cloud}
14:36:34 <pbokoc> and also the update section should not only document FedUp, but a manual upgrade as well
14:36:57 <yruseva> I suspect it would be very different..
14:36:58 <randomuser> pbokoc, riiiisky
14:37:20 <pbokoc> randomuser, in my experience it's way less risky than FedUp, plus someone was asking for that
14:37:33 <randomuser> nobody has ever supported a distro-sync upgrade, in docs or devel
14:38:10 <pbokoc> what do you mean by distro-sync?
14:38:15 <yruseva> manual upgrade? what's that?
14:38:36 <randomuser> umm.. what do you mean by manual upgrade?
14:39:08 <yruseva> pbokoc, ^ ?
14:39:29 <pbokoc> by manual upgrade I mean you have e.g. F19 installed, you grab F20 boot media (live image or netinst iso), boot from that, run Anaconda on that system and install F20 into the same root... basically
14:39:52 <randomuser> i'm picturing someone sitting down to a term on an F20 system and doing `yum distro-sync --releasever 21`
14:40:00 <pbokoc> while keeping your partitioning setup
14:40:13 <randomuser> oh, that, yeah pbokoc that should be covered
14:40:26 <pbokoc> yeah, that's what I meant :)
14:40:33 <Southern_Gentlem> randomuser, you know it will happen
14:40:46 <randomuser> Southern_Gentlem, WE DON'T TALK ABOUT IT :P
14:40:56 <pbokoc> hahah
14:41:01 <Southern_Gentlem> thats the point we should
14:41:35 <bexelbie> so Fedora updates are like Fight Club?
14:41:36 <randomuser> Southern_Gentlem, If you feel strongly about it, RFE?
14:42:17 <Southern_Gentlem> bexelbie,  nope upgrades from one release to another can be
14:42:35 <pbokoc> anyway
14:42:41 * bexelbie nods
14:43:00 <randomuser> Southern_Gentlem, it can require many other specific actions for each release, and we might not have the cycles to document it suitably
14:43:10 <randomuser> other guides?
14:43:53 <Southern_Gentlem> randomuser,  clean install and keep directory structure with screenshots would go a long way
14:44:12 <Southern_Gentlem> showing how not toreformat /home
14:44:28 <pbokoc> Southern_Gentlem, yeah, that's what I was planning to do
14:44:55 <Southern_Gentlem> +9000
14:44:59 <randomuser> jhradilek, is there a task list for the sysadmin guide?
14:45:07 <pbokoc> it should also be fairly easy to test in a VM and fairly short to write, so if anyone wants a quick task, ping me
14:45:11 <randomuser> or a task list for the Networking Guide, Capesteve ?
14:45:59 <pbokoc> #info task list for the Install Guide is at http://red.ht/1s2GmSK - if a bug is NEW and you want to work on it, assign it to yourself and switch the status to ASSIGNED
14:46:18 <jhradilek> randomuser: Ask Capesteve. :)
14:46:35 <randomuser> heh
14:47:05 <randomuser> i know there's a wiki page around somewhere...
14:47:08 <Capesteve> ?
14:47:38 <pbokoc> randomuser, by the way, do you know if Chris Roberts is still active? He has a bug assigned but it was last touched over a year ago... https://bugzilla.redhat.com/show_bug.cgi?id=986370
14:47:58 <randomuser> He is active but not so much in docs
14:48:16 <pbokoc> ok, I'll contact him
14:48:17 * randomuser reassigns
14:48:22 <pbokoc> ...or that
14:48:26 <jhradilek> We might want to revive this page: https://fedoraproject.org/wiki/Docs_Project_Review_Table
14:48:43 <jhradilek> Or at least come up with something similar.
14:49:43 <pbokoc> I dunno, in my experience keeping track of anything in the wiki means it's going to become outdated in a week
14:49:49 <randomuser> jhradilek, what to you think about a wiki page explaining QA/Review techniques, that sends off to a bz query?
14:50:27 <jhradilek> pbokoc: I agree, but this was created because people didn't want to mess with Bugzilla.
14:50:34 * randomuser really dislikes process status pages in the wiki
14:50:51 * jhradilek would like to automate everything.
14:51:04 <pbokoc> what randomuser says might be a good idea too - a page describing how to review wouldn't need to be maintained nearly as much
14:51:14 <randomuser> +1 to automation
14:51:29 <bexelbie> +1 to automation or a specific status app
14:51:30 <jhradilek> randomuser: Which reminds me that I would like to talk to you after the meeting. :)
14:51:40 <Capesteve> randomuser:  Bugs were created as a result of a similar page for the Networking Guide , and I did update them, but not touched that Sysadmin Guide page before
14:51:54 <pbokoc> still, our biggest issue is that not many people have time to review stuff
14:51:58 <randomuser> I'd rather have something that's accurate and less preferred than something that can change to be abandoned differently
14:52:14 <pbokoc> which reminds me I need to take a look at randomuser's commits in the IG :)
14:52:30 * randomuser groans
14:52:41 <randomuser> we talked about it, you had me fooled pbokoc
14:52:54 <pbokoc> what? You asked me to take a look yesterday!
14:53:06 <pbokoc> I was just busy playing Kerbal Space Program to do it
14:53:14 <randomuser> no, i just told you I had pushed
14:53:34 <pbokoc> really? alright
14:53:39 <randomuser> Capesteve, np, just digging for a link to put in the minutes
14:53:41 <pbokoc> more KSP time for me
14:54:37 <randomuser> #info bugzilla seems to be working as a method for tracking guide maintenance tasks
14:55:06 <Capesteve> I add that page top my ToDo list, but I have as a priority to get package owners to help review
14:55:12 <randomuser> #info vague consensus is that we should do that more and less task lists on the wiki - possibly with wiki pages autogenerated from bz
14:55:49 <randomuser> five minutes, let's open the floor
14:55:56 <randomuser> #topic open floor discussion
14:56:55 <randomuser> #info Sparks will be bringing doughnuts to the next meeting since he missed the one today
14:58:17 <randomuser> Toledo|sat6bomga, we were talking about docs bugs earlier and your name came up - would you look over your assignments and decide if you want to keep them, please?
14:58:58 <randomuser> #iinfo Docs office hours coming up, thurs at 1800 https://apps.fedoraproject.org/calendar/meeting/315/
14:59:06 <randomuser> #info Docs office hours coming up, thurs at 1800 https://apps.fedoraproject.org/calendar/meeting/315/
14:59:35 <randomuser> #info last office hours we talked about starting a firewall guide - this time we just might do it!
15:00:25 <lnovich> randomuser should i change my office hours to another time - i don't get any responses?
15:00:49 <randomuser> sure, lnovich, you can have it whenever you like
15:01:25 <randomuser> #endmeeting