15:00:30 <pknirsch> #startmeeting Fedora Base Design Working Group (2014-09-12)
15:00:30 <zodbot> Meeting started Fri Sep 12 15:00:30 2014 UTC.  The chair is pknirsch. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:43 <vpavlin> Good afternoon:)
15:00:43 <pknirsch> #meetingname  Fedora Base Design Working Group
15:00:43 <zodbot> The meeting name has been set to 'fedora_base_design_working_group'
15:00:49 <pknirsch> heya vpavlin !
15:01:10 <pknirsch> #chair vpavlin dgilmore masta msekleta
15:01:10 <zodbot> Current chairs: dgilmore masta msekleta pknirsch vpavlin
15:01:26 <pknirsch> So who else we got today?
15:01:38 <msekleta> hello everyone!
15:01:42 <pknirsch> Harald already informed me that he couldn't make it today as he's going on PTO
15:01:50 <pknirsch> heya msekleta
15:02:09 <masta> hello
15:02:34 * vpavlin is leaving to Wesford tonight and needs to pack so would appreciate to make the meeting short(er) this week:)
15:02:47 <pknirsch> And i didn't have a big agenda for today, so in case we've pushed out other stuff lately due other stuff we can touch those at the open floor
15:02:50 <pknirsch> yar
15:02:52 <pknirsch> :)
15:03:00 * pknirsch is all for short and spot on meetings
15:03:01 <pknirsch> :)
15:03:12 <pknirsch> with that
15:03:23 <pknirsch> #topic  Update on draft for /etc changes (Harald & Vaclav)
15:03:29 * masta 2nds the short meeting - is actually having quasi sick day today (fever)
15:03:55 <pknirsch> Harald already said he didn't have time to work on it yet due to tons of stuff that needed tp be done prior to his PTO
15:04:06 <pknirsch> vpavlin, did you have some time to work on it yet?
15:04:28 <pknirsch> ugh, get better masta !
15:04:55 <vpavlin> pknirsch: No, sorry - my apology is I needed to prepare for my trip to Westford (and of course do a lot of other stuff) so I haven't chance to touch it yet
15:04:57 <vpavlin> But..
15:05:25 <vpavlin> I have the logs downloaded and will try to write something up during the weekend
15:05:29 <vpavlin> :)
15:05:45 <pknirsch> ha! :)
15:05:48 <dgilmore> hola
15:05:53 <pknirsch> heya dgilmore !
15:06:11 <pknirsch> Alright, sounds good vpavlin
15:06:29 <pknirsch> #info vpavlin and harald stuck to other stuff this week, vpavlin to write up draft over the weekend
15:06:40 <pknirsch> Alright, next topic then
15:06:49 <dgilmore> vpavlin: FYI http://dl.fedoraproject.org/pub/alt/stage/21_Alpha_TC7/Docker/x86_64/
15:07:09 <pknirsch> #topic buildrequires cleanup quick update
15:07:12 <vpavlin> dgilmore: Cool, thanks
15:07:15 <pknirsch> nice!
15:08:44 <pknirsch> Thats just a quick update that as moben has gone back to university i've been looking for someone to take over his activities and i found someone! I totally forgot to invite him today, but will do so for next week. It's David Sommerseth, some of the Red Hatter should know him (he used to be in QA but moved to my team recently)
15:09:15 <pknirsch> I'll bring him up to speed next week in more detail and we'll see where it goes from there
15:10:08 <vpavlin> pknirsch: Awesome
15:10:13 <pknirsch> yar
15:10:30 <pknirsch> and david is a smart cookie, so really glad he (got) volunteered to work on it ;)
15:10:40 <pknirsch> (he actually did volunteer ;))
15:11:27 <pknirsch> He's ofc doing other stuff too, but i think there should be enough cycles left to do some nice progress on the work initiated by moben
15:12:07 <pknirsch> Alright, but thats it from me this week.
15:12:13 <pknirsch> #topic Open Floor
15:12:24 <pknirsch> Anyone got any other topics today we should cover?
15:12:31 <pknirsch> e.g. Docker docker docker! ;)
15:12:43 <vpavlin> Yeah, I have an update;)
15:12:46 <msekleta> I wanted to speak about docker image with systemd inside
15:12:49 <sgallagh> pknirsch: I just raised a topic on devel@ that might be worth discussing
15:13:28 <pknirsch> ok, vpavlin first. :) so whats your update?
15:13:46 <vpavlin> We've blocked fakesystemd for now - it broke too many things so untill I figure out how to fix it, we will stick with systemd in base image
15:14:54 <pknirsch> Ok, thats good to hear.
15:15:49 <pknirsch> msekleta: was that what you wanted to talk about, too?
15:16:26 <msekleta> I just wanted to do quick update on systemd in docker images
15:16:56 <msekleta> So 215 from 21 and 216 in rawhide are working just fine with couple of patches
15:17:18 <msekleta> I will posting them to systemd-devel sometime next week
15:17:21 <pknirsch> nice!
15:17:32 <msekleta> not sure who will do the review because lennart is on PTO
15:17:35 <pknirsch> Is that the regular version of systemd ?
15:17:39 <msekleta> yes
15:17:44 <pknirsch> yea, haraldh is on PTO as well
15:17:47 <pknirsch> ok, nice
15:18:18 <msekleta> Other than fixing systemd itself we have add conditions to some unit files we ship
15:18:40 * vpavlin would recommend to ask Zbyszek
15:18:54 <msekleta> So they will not run when inside the container
15:19:11 <pknirsch> ah, good
15:19:14 <msekleta> yeah, I also hope Zbyszek will look at them
15:19:49 <vpavlin> msekleta: What about the dbus problem,
15:19:51 <vpavlin> ?
15:20:22 <msekleta> Problem I have right now is that dbus crashes inside unprivileged container after the while
15:21:04 <msekleta> And I didn't have yet time to figure out why
15:21:46 <msekleta> That's pretty much it
15:22:47 <pknirsch> Ok, cool, thanks msekleta
15:24:23 <msekleta> sgallagh, your turn :)
15:25:16 <sgallagh> I just wanted to draw Base WG's attention to the offline updates topic I sent to devel@
15:25:31 <sgallagh> No action required this week, just please chime in on it on the list :)
15:25:38 * pknirsch nods
15:25:44 <pknirsch> thanks for the heads up sgallagh
15:26:46 <vpavlin> dgilmore: We need to get rid of grub2, dracut and maybe some other packages in the image:/
15:27:11 * vpavlin feels like filing more bugs for Anaconda guys...
15:29:07 <vpavlin> dgilmore: This change https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/fedora-docker-base.ks?id=8180b563f16b9e01af52ab935f40e0b8dbee0440 - why that can't be bootloader --disable?
15:29:18 <dgilmore> vpavlin: thats not something we can do much about I do not think
15:29:48 <dgilmore> vpavlin: I forget why. I think that something went wrong
15:30:45 <vpavlin> dgilmore: Could you please figure out what? I really think anaconda shouldn't install bootloader and dracut to the image - there is no need for it
15:32:08 <vpavlin> msekleta: btw..will your changes remove hwdb from systemd?
15:33:32 <msekleta> vpavlin, well that is something I will have to do downstream. I mean splitting the subpackage
15:34:06 <vpavlin> msekleta: I know..just asking if you are going to do that:)
15:34:43 <msekleta> vpavlin, sure will do that
15:35:51 <vpavlin> msekleta: Great, thanks
15:36:11 <dgilmore> vpavlin: I think it was that ksflatten puked on the kickstart. but I had to update ksflatten for something else
15:36:11 <msekleta> vpavlin, not sure how we will make sure it is not pulled inside the container, I mean subpackage
15:36:52 <msekleta> vpavlin, because systemd package will have to require same version of hwdb subpackage
15:37:23 <vpavlin> msekleta: ah..right...that's not very helpful then
15:38:37 <vpavlin> Damn you systemd:)
15:38:44 <vpavlin> bash-4.3# rpm -q --whatrequires "libqrencode.so.3()(64bit)"
15:38:44 <vpavlin> systemd-215-11.fc21.x86_64
15:39:19 <pknirsch> heh
15:39:22 <vpavlin> Not that it would matter much, but still - it makes me sad how much needs to be pulled in for no reason:)
15:39:46 <pknirsch> Wasn't that brought up on f-d ML already?
15:39:57 <msekleta> vpavlin, yep that's because journal sealing feature
15:39:58 * pknirsch remembers seeing something about it
15:40:05 <vpavlin> msekleta: I know:)
15:41:13 <pknirsch> Alright, anything else for today?
15:41:14 <vpavlin> pknirsch: It was - but I think the result was that systemd packaging is ok (from Lennart's point of view)
15:41:25 <pknirsch> :/
15:43:32 <vpavlin> msekleta: We should probably talk once more about "systemd-container" and how to automate it's creation (and how to make sure it won't break buildroots:/ ) - and possibly present some proof of concept to Lennart
15:43:48 * pknirsch nods
15:43:54 <pknirsch> code shows more than words :)
15:44:24 <vpavlin> Buildroot breakage will be the toughest here
15:44:42 <vpavlin> As we don't have separate "channels" in Fedora
15:46:09 <vpavlin> dgilmore: Thanks for the image - it look good:) I'd just like to get rid of bootloader and dracut and I am ok with that
15:46:18 <vpavlin> s/look/looks
15:46:39 * msekleta nods
15:47:51 <vpavlin> #action vpavlin and msekleta to look once more at "systemd-container", how to automate it's creation and assure it won't break anything (and convince Lennart it's good idea)
15:48:21 <vpavlin> I think that's all from me Today
15:49:17 <pknirsch> Okidokie
15:49:30 <msekleta> yes, I don't have anything else as well
15:49:44 <pknirsch> the lets wrap up for today vpavlin can pack for his trip to the US! Have fun there!
15:49:51 <pknirsch> Btw, will you be around next Friday then vpavlin ?
15:50:21 <dgilmore> vpavlin: http://koji.fedoraproject.org/koji/taskinfo?taskID=7572381
15:50:29 <dgilmore> that has bootloader --disabled
15:50:50 <vpavlin> pknirsch: Depends on whether I'll be able to find WiFi on the Prague Airport:)
15:50:56 <pknirsch> vpavlin: heh :)
15:51:33 <vpavlin> I should be back in Prague around 16:20 on Friday and leave for my PTO in Paris at 21:20..soo..:D
15:51:48 <vpavlin> But yeah, I'll try to join
15:52:32 <pknirsch> hehe
15:52:36 <pknirsch> Mr Travel :)
15:52:50 <pknirsch> But save travel and have fun in Westford vpavlin !
15:52:53 <vpavlin> Fingers crossed it will all click:)
15:53:05 <pknirsch> :)
15:53:05 <vpavlin> Thanks pknirsch:)
15:53:07 <pknirsch> End of Meeting
15:53:09 <pknirsch> #endmeeting