17:03:09 <roshi> #startmeeting
17:03:09 <zodbot> Meeting started Fri Sep 26 17:03:09 2014 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:03:16 <roshi> #meetingname Cloud SIG
17:03:16 <zodbot> The meeting name has been set to 'cloud_sig'
17:03:29 <roshi> #topic Roll Call
17:03:38 <imcleod> .hellomynameis imcleod
17:03:39 <roshi> who's around for some cloudy goodness?
17:03:40 <zodbot> imcleod: imcleod 'Ian McLeod' <imcleod@redhat.com>
17:03:49 <jzb> .hellomynameis jzb
17:03:50 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
17:04:09 <number80> .hellomynameis hguemar
17:04:11 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
17:04:19 <roshi> .hellomynameis roshi
17:04:20 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:05:10 <roshi> alright then, let's get to stuff
17:05:18 <roshi> #topic Previous Meeting followup
17:05:47 <roshi> I see mattdm emailed the list about composition
17:05:53 <roshi> where was that left?
17:06:22 <lalatenduM> .hellomynameis lalatendu
17:06:23 <zodbot> lalatenduM: lalatendu 'Lalatendu Mohanty' <lmohanty@redhat.com>
17:06:31 <mattdm> with no follow-up at all from me
17:06:38 <mattdm> that's where
17:06:55 <mattdm> I had intended to post a proposed new slate
17:07:06 <mattdm> but.. stuff this week
17:07:22 <jzb> roshi: ah, I thought you meant composing images or something :-)
17:07:32 <roshi> dude - go get lunch :p
17:07:36 <mattdm> basically was going to draw from everyone active here, on the mailing list, or tickets
17:07:45 <number80> roshi: not yet, mattdm was busy with shellshock and the board :)
17:07:55 <number80> at least, he did his board homework !
17:08:00 <roshi> oh yeah, jzb - #communication fail ;)
17:08:10 <mattdm> really anyone can make that list
17:08:11 <roshi> oh, carry on then :)
17:08:15 * number80 grade mattdm homework with A-
17:08:25 <mattdm> so I'd anyone wants to go ahead
17:08:25 <roshi> .beefy mattdm
17:08:25 <zodbot> Have a Beefy Miracle, mattdm
17:08:28 * number80 minus because he didn't bring cake
17:08:38 <jzb> number80: +1
17:08:40 <roshi> alright then
17:08:48 <mattdm> otherwise I will
17:08:55 <roshi> #action mattdm to follow up on list or tickets for WG Composition
17:08:56 <jzb> Yeah, I think mattdm gets a pass on any missing homework this week due to Shellshocked
17:09:16 * jzb notes - security vulnerabilities are no longer allowed without catchy names.
17:09:16 <number80> yup
17:09:19 <roshi> that's a fair point
17:09:29 <roshi> and logo's, oddly enough
17:09:57 <roshi> anything else on this?
17:10:30 <oddshocks> if you help fix the bash bug, make sure you're on the list for this badge ;) https://fedorahosted.org/fedora-badges/ticket/308
17:10:47 <roshi> define help fix?
17:11:00 * roshi tested and gave karma if that counts
17:11:25 <jzb> oh, I wish I could clame that
17:11:28 <jzb> er claim
17:11:28 <oddshocks> roshi: it does.
17:11:32 * lalatenduM also tested and gave karma for f19 n f20 :)
17:11:53 <jzb> All I did was tweet Ryan and Matt's stuff about it :-)
17:12:08 <jzb> roshi: what's next?
17:12:33 <roshi> looking for stuff that isn't in tickets already
17:12:49 <roshi> you got feedback for the magazine article
17:12:56 <roshi> did you get enough feedback jzb ?
17:13:22 <jzb> roshi: I did. I also was out of time this week + bash bug
17:13:26 <roshi> Stuff to review: * jzb start change page for F22 on cloud-init
17:13:26 <roshi> * jzb move discussion on cloud-init to mailing list.
17:13:27 <roshi> * mattdm connect with base wg, lsm5, docker, rel-eng about docker base image upload to registry
17:13:29 <roshi> * jzb file RFE for zodbot on actions during meeting
17:13:31 <roshi> yeah
17:13:40 <roshi> I had some time updating and testing my systems
17:13:40 <jzb> roshi: so I'll post it Monday, barring any further horrible vulnerabilities.
17:13:51 <roshi> found all the systems I forgot I had running too (I think)
17:13:57 <roshi> for sure
17:14:00 <jzb> I have not gotten to cloud-init, either.
17:14:02 <jzb> #shme
17:14:07 <jzb> er, #shame
17:14:18 <roshi> zodbot RFE?
17:15:02 * number80 thinks he should resume working on min-metadata-service
17:15:10 <roshi> anybody else have a machine in the house they can't find, but still responds to ping?
17:15:15 <jzb> roshi: I had that?
17:15:22 * jzb goes to look at minutes
17:15:23 <jzb> oh, right
17:15:27 <jzb> I'll do that now
17:15:30 <roshi> i pasted them in here :)
17:15:47 <roshi> mattdm, if you're still around: did you talk to base about the docker image upload?
17:16:07 <imcleod> roshi: The legend - http://www.theregister.co.uk/2001/04/12/missing_novell_server_discovered_after/ - netware server sealed behind drywall.
17:16:21 <roshi> haha
17:16:43 <jzb> it'd be nice if my FAS login persisted across Trac instances.
17:16:58 <jzb> instead of logging into cloud, fedora-infrastructure, rel-eng separately
17:17:08 <roshi> yeah
17:18:33 <roshi> ok, onto the tickets
17:18:39 <roshi> #topic Smoketests
17:18:44 <roshi> #link https://fedorahosted.org/cloud/ticket/38
17:18:46 * jsmith shows up late for the meeting -- sorry
17:18:58 <number80> #addchair jsmith
17:19:16 <roshi> #chair jzb jsmith number80 imcleod mattdm
17:19:16 <zodbot> Current chairs: imcleod jsmith jzb mattdm number80 roshi
17:19:34 <roshi> didn't really get a chance to mess with this this week
17:19:54 <roshi> I did however get access to some openstack, so once I figure out how to use the access I can start on some testing
17:20:09 <roshi> agrimm: you have anything for this?
17:20:15 <number80> I noticed no unusual issues this week on openstack
17:20:37 * number80 dogfooding alpha at $DAYJOB on openstack
17:20:42 <roshi> nice
17:21:01 <number80> I'll probably spend more time on atomic later
17:21:38 <jzb> number80: rock
17:22:20 <number80> :)
17:22:31 <roshi> I think we can move to the next ticket
17:22:38 <number80> ok
17:22:47 <roshi> we already discussed #75
17:22:57 <roshi> #topic Magazine article
17:23:25 * jsmith didn't do his homework and provide feedback
17:23:29 <roshi> #info jzb to publish on Monday (2014-09-29)
17:23:38 <jzb> roshi: will update ticket, thx
17:23:46 <jzb> roshi: and I'll set it to closed Monday
17:23:47 <roshi> sweet
17:24:01 <roshi> #topic Atomic Testdays
17:24:12 <roshi> #link https://fedorahosted.org/cloud/ticket/74
17:24:50 <jzb> we decided on next week, I still need to get the Wiki page finished + promote
17:24:53 <jzb> any help is welcome
17:25:09 <roshi> it appears the NetworkManager testday is the 2nd
17:25:15 <jzb> I am trying to get the image respun w/new bash
17:25:47 * number80 will take a look
17:25:56 <roshi> https://apps.fedoraproject.org/calendar/list/QA/?subject=Test+Day
17:26:04 <roshi> it seems we need to do some testday updating
17:26:10 <roshi> RDO isn't on the calendar
17:26:17 <jzb> ah, OK
17:26:28 <kushal> Sorry I am late (I am in a conference).
17:26:36 <roshi> but it seems we'll have a couple testdays all going on at the same time
17:26:44 <jzb> anybody want to take the action of updating the calendar?
17:26:45 <roshi> that's not ideal
17:26:49 <roshi> I will
17:26:51 <jzb> roshi: well, different groups
17:26:58 <roshi> #action roshi to update fedocal
17:27:05 <jzb> I think we agreed that 1 & 2 October overlap w/RDO was good?
17:27:16 <roshi> yeah, but in a perfect world we'd help them with their test days and vice versa
17:27:30 <jzb> do we want to skip a week forward?
17:27:36 <roshi> where is the docs for the RDO testday?
17:27:40 <jzb> I'm happy to have a few more days to prepare.
17:27:43 <jzb> roshi: just a sec
17:27:49 <roshi> I'm fine with moving it
17:28:50 <jzb> #info http://community.redhat.com/blog/2014/09/rdo-juno-test-day/
17:29:04 <jzb> #info https://openstack.redhat.com/RDO_test_day_Juno_milestone_3_test_cases
17:29:12 <jzb> let's do a quick show of hands?
17:29:24 <jzb> who's in favor of moving to the next week for Atomic test days?
17:29:41 <roshi> o/
17:30:01 <number80> \o
17:30:09 * number80 will be participating anyway to RDO test days
17:30:23 <roshi> who's coordinating with the RDO folks?
17:30:30 <imcleod> o/
17:30:34 <lalatenduM> jzb, I m in favor of moving it , not sure if that counts :)
17:30:53 <jzb> lalatenduM: this isn't a binding vote, just a check on opinion.
17:30:59 <jzb> roshi: I guess that'd be me.
17:31:24 <number80> well, we don't have quorum anyway and we're open by default ;)
17:31:32 <jzb> also dustymabe but dustymabe doesn't seem to be around today
17:31:46 <jzb> something something other obligations... :-)
17:32:48 <roshi> proposed #agreed - Move atomic test day to 2014-10-08 and 2014-10-09
17:32:48 * oddshocks steps out
17:33:12 <roshi> acks?
17:33:17 <jzb> +1
17:33:33 <lalatenduM> +1
17:33:45 <imcleod> +1
17:33:48 * roshi is used to blocker review meetings and it's rituals
17:33:56 <roshi> #agreed - Move atomic test day to 2014-10-08 and 2014-10-09
17:34:21 <roshi> alright, I'll update the calendar and work with jzb on wiki and whatnot
17:34:37 <roshi> should also probably write a magazine post for the atomic testday
17:34:41 <jzb> woohoo
17:34:47 <kushal> roshi, yup
17:34:49 <roshi> #action roshi to write brief writeup about atomic testday
17:35:05 <roshi> I think that's it for this ticket
17:35:07 <jzb> roshi: if you want Fedora Magazine, I'll cover Project Atomic + atomic mailing lists
17:35:16 <roshi> works for me :)
17:35:27 * roshi just has to get into the habit or writing more
17:35:35 <roshi> and this is a good kick in the rear to do it
17:35:42 <roshi> s/or/of
17:36:00 <roshi> #action jzb to email lists and update Project Atomic
17:36:21 <roshi> #topic .Next Website
17:36:25 <roshi> #link https://fedorahosted.org/cloud/ticket/36
17:36:45 <roshi> anything with this jzb ?
17:37:07 <jzb> roshi: we're good on it for now, only leaving it open for beta + final updates.
17:37:12 <roshi> staging instance is here: https://stg.fedoraproject.org/en/
17:37:16 <roshi> kk
17:37:32 <roshi> #info site is good to go atm, will update with later releases
17:37:58 <roshi> #topic Collaboration on cloud image updates
17:38:01 <roshi> #link https://fedorahosted.org/cloud/ticket/51
17:38:15 <roshi> I think this has been pretty much resolved
17:38:24 <roshi> it went to the list iirc with no issues
17:39:12 <number80> great
17:40:29 <roshi> can we close this?
17:40:35 <roshi> is there anything else outstanding for it?
17:40:50 <roshi> aiui, when we need a rebuild we just notify releng - right?
17:41:08 <number80> yup
17:41:14 <jzb> roshi: uh, about that
17:41:20 <roshi> uh oh
17:41:27 <jzb> so I got several very pointed comments that "notify"
17:41:32 <jzb> == opening a ticket
17:41:40 <jzb> and not == emailing infrastructure@
17:41:41 <roshi> that's what I figured
17:41:41 <jzb> apparently
17:41:43 <jzb> so ...
17:41:57 <jzb> let's have a process that details that w/what they want in said ticket?
17:42:10 <roshi> do you want to update the ticket with that info, or the wiki?
17:42:29 <roshi> I figure it's going to become a cloud sig process we should have documented somewhere
17:42:55 <jzb> roshi: I haven't filed the ticket yet, not sure exactly which info is needed - whether "hey, we need this" is sufficient or if there's more info wanted.
17:42:57 <roshi> which is exactly what you said :)
17:43:01 <jzb> roshi: I got the replies a few hours ago
17:43:06 <jzb> still have been buried in meetings
17:43:08 <jzb> :-)
17:43:12 <roshi> I know the feeling
17:43:30 <roshi> someone to coordinate with releng to see what they'd need and document it on the wiki?
17:44:00 <jzb> am I volunteering for this?
17:44:04 <jzb> I guess I am.
17:44:14 <number80> action me if you have too much work :)
17:44:21 <jzb> #action jzb coordinate with releng to see what they'd need and document it on the wiki?
17:44:28 <jzb> number80: I would, but I need to do this today anyway
17:44:41 <number80> no problem
17:44:53 <number80> I have a delayed reaction since it's dinner time here :)
17:44:54 <roshi> I was gonna say you or me jzb
17:44:58 <roshi> .moarwork jzb
17:44:58 <zodbot> jzb here, have some more work
17:46:02 <number80> well, if you can't, I'm at 30 minutes away from a releng guy :)
17:46:39 <roshi> sounds good
17:46:46 <roshi> anything else for this ticket?
17:47:00 <jzb> nope, I'll update it.
17:47:11 <roshi> jzb: ping me or number80 if you want/need some help
17:47:31 <roshi> #topic Test Plan
17:47:34 <roshi> #link https://fedorahosted.org/cloud/ticket/61
17:48:07 <roshi> I created a wiki space to discuss this almost 4 months ago to the day
17:48:38 <roshi> I don't have anything new for this
17:48:47 <roshi> but also don't know if anything else is needed
17:49:37 <jzb> roshi: I dimly recall we were going to solicit input from testing
17:49:44 <jzb> (QA)
17:49:50 <jzb> I don't recall if that happened.
17:51:42 <roshi> for what input though?
17:51:49 <roshi> that's the bit I don't recall
17:52:01 <roshi> I can always add it to the QA meeting on monday
17:52:06 <roshi> 1500 UTC iirc
17:52:13 <jzb> whether it matches expectations of QA?
17:52:28 <jzb> like whether it's a complete enough test plan, or if we're missing things?
17:52:59 <roshi> I can probably get adamw to take a look at it, but it's pretty much the same as the other WGs
17:53:14 <adamw> hmm?
17:53:41 <roshi> questions on whether my test plan and test overview meet the expectations of QA
17:53:47 <roshi> Overview here: https://fedoraproject.org/wiki/User:Roshi/QA/Cloud_Docs/Test_Overview
17:55:23 * roshi thinks they do, but he's bias
17:55:30 * number80 shivers every time he hears "SCL"
17:56:22 * adamw reads
17:58:46 <adamw> i don't have time the read the PRD right now, but basically, the test coverage should ensure that the cloud product as defined in it meets the overall quality expectations for fedora alpha/beta/final products
17:58:52 <adamw> which...aren't as well documented as i'd like, but hey.
17:59:00 <roshi> I can shore that up
17:59:17 <adamw> "All of the "featured" images will need to be tested to ensure they meet the "mandatory requirements" defined in the PRD. " basically covers it
17:59:29 <adamw> presuming this is a high-level 'statement of intent' not an actual test paln
17:59:46 <roshi> when I wrote it, I asked for comments in several meetings but never got feedback so thought it must be good enough
17:59:49 <adamw> which iirc it was (i know i invented the idea)
18:00:01 <roshi> it's meant to be high level as you intended adamw
18:00:24 <jzb> roshi: I have not given much input b/c it's so not my field of expertise
18:00:27 <roshi> #action roshi to shore up overview specifics
18:00:33 <jzb> I need to hop on a phone meeting now
18:00:43 <jzb> I'll keep an eye on channel but may be distracted
18:00:43 <roshi> #action everyone else to read his new version when he mails the list with it
18:00:46 <adamw> roshi: basically seems fine to me then
18:00:48 <roshi> np
18:00:52 <roshi> we're at our time then
18:01:00 <roshi> and I also have to depart
18:01:02 <jzb> roshi: if you feel good w/it and people have had plenty of time
18:01:05 <roshi> thanks adamw :)
18:01:08 <jzb> roshi: then I'd go ahead and close it
18:01:13 <jzb> adamw: thanks for the advice.
18:01:58 <roshi> last item was project atomic - but I think we've already covered that with the test day
18:02:02 <roshi> and jzb is out
18:02:04 <agrimm> sorry, all... had a lunch meeting today that ran late.
18:02:34 <roshi> np agrimm
18:02:45 <roshi> anybody have anything else, or can I endmeeting?
18:03:47 * roshi sets fuze
18:04:11 <roshi> thanks for coming folks!
18:04:16 <roshi> #endmeeting