17:00:47 <mattdm> #startmeeting Board (2014-09-29)
17:00:47 <zodbot> Meeting started Mon Sep 29 17:00:47 2014 UTC.  The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:49 <mattdm> #meetingname board
17:00:49 <zodbot> The meeting name has been set to 'board'
17:00:51 <mattdm> #chair mattdm gholms cwickert inode0 mjg59 Sparks jwb number80 yn1v
17:00:51 <zodbot> Current chairs: Sparks cwickert gholms inode0 jwb mattdm mjg59 number80 yn1v
17:00:57 <gholms> :D
17:01:00 <jwb> hi
17:01:07 * cwickert is here
17:01:08 <mattdm> #topic welcomes and stuff
17:01:13 <mattdm> hi all!
17:01:19 <mjg59> Morning
17:01:34 <mattdm> good morning! (or, corresponding whatever)
17:01:45 * number80 waves
17:02:03 <mattdm> whoo lookat that quorum :)
17:02:39 <mattdm> I'm going to wait another couple of minutes, switch topic to the agenda (as posted on the list) and then go from there...
17:02:43 <number80> well, now it only takes me to switch between terminal tabs between office and fedora :)
17:02:47 <inode0> hi everyone
17:02:55 <mattdm> The _overall_ topic, of course, is reorg plans
17:02:57 <mattdm> hi inode0!
17:03:15 * yn1v is here
17:03:52 <mattdm> okay so just waiting on Sparks
17:03:58 <mattdm> any non-board lurkers around?
17:04:12 * nirik is lurking in the back, but also in another meeting
17:04:27 <mattdm> :)
17:04:34 <mattdm> i sent a ping to Sparks
17:04:36 * stickster lurking
17:04:52 <number80> well, I'm lurking also at nirik meeting too so we're now even :)
17:04:58 <mattdm> hah
17:05:07 <mattdm> okay, so I guess we'll get started
17:05:12 <mattdm> #topic Agenda
17:05:28 <mattdm> 1. link goal-focused positions to Flock?
17:05:43 <mattdm> 2. concerns about overlap and workload
17:06:13 <mattdm> 3. (maybe partly related) encouraging/rewarding/allowing community participation
17:06:18 <mattdm> 4. size of board
17:06:25 <mattdm> anything else?
17:06:38 <number80> it pretty sums up everything
17:06:44 <mattdm> okay then I'll leave
17:06:47 <mattdm> 5. open discussion
17:06:47 <nirik> I have a suggestion that might help me (and possibly others)...
17:06:53 <mattdm> 6. next steps
17:06:56 <mattdm> nirik:  go!
17:07:37 <nirik> Would it be possible to make a draft wiki page or something that explains all the plan... it still seems kind of abstract on the list. Things like how people are chosen, what powers, how long they serve, basically the current Board page but for the council?
17:07:53 <mattdm> nirik: yes. you are jumping to #6 :)
17:08:28 <nirik> ok, fair.
17:08:35 * nirik goes back to the background.
17:08:44 <mattdm> also, an open question is whether we should use council for the new name or keep the name board. switching names makes a lot of work for _you_. :)
17:08:54 <mattdm> but let's leave that for later :)
17:09:05 <mattdm> #topic Link goal-focused positions to Flock?
17:09:24 <mattdm> was some discussion on list
17:09:29 <mattdm> number80: anything more on this?
17:10:19 <number80> mattdm: if we agree that goals will be discussed and reevaluated there (not exclusively there, I mean), I'm fine
17:10:25 * gholms is reluctant to lock this into specific, yearly events
17:10:38 * inode0 is against direct linkage but would expect regular annual Flock sessions on governance/leadership issues to evaluate progress
17:10:46 <jwb> inode0, yes, exactly
17:11:17 <mattdm> okay, yeah. so I think we all agree on that, and it's down to writing it up.
17:11:23 <mattdm> which I will do in nextsteps. :)
17:11:33 <number80> *nods*
17:12:02 <mattdm> #action mattdm to include language about evaluating goals (progress and issues) reguluarly at Flock and elsewhere
17:12:10 <mattdm> #topic concerns about overlap and workload
17:12:13 <mattdm> yn1v: ?
17:12:20 <mattdm> that summary isn't very good :)
17:12:22 * cwickert has problems to follow. What do you mean by linking positions to Flock and what do we (seem to) agree on?
17:12:30 <mattdm> #undo
17:12:31 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x51a149d0>
17:13:08 <jwb> cwickert, we seem to agree that using flock as a high-bandwidth forum to discuss current goals and seats is a good idea
17:13:18 <mattdm> cwickert: number80 had the initial suggestion of linking the goal-oriented positions I'd proposed to be selected at flock every year
17:13:30 <cwickert> I did read that
17:13:40 <cwickert> however I don't really agree :)
17:13:52 <mattdm> I had written 18 months in the proposal, but I didn't mean it to be a firm number
17:13:54 <number80> and from the start, I meant that it will be discussion, I'm perfectly in sync with no decision at flock
17:14:31 <mattdm> cwickert: okay can you explain the don't really agree part?
17:14:56 <cwickert> first of all, I don't think that Flock attendance should be a requirement to any position
17:15:10 <cwickert> at least as long as we cannot bring all the people there who like to attend
17:15:16 * gholms nods
17:15:36 <mattdm> Okay that sounds like agreeing with what we're saying above :)
17:15:49 <cwickert> we currently sponsor only speakers, so it is in fact: give a talk, be a potential candidate, get eleced eventually
17:15:50 <number80> oh, I understand, nobody wants to link positions to flock attendance :)
17:15:55 <cwickert> ok, sorry
17:16:10 <number80> but you're totally right
17:16:38 <gholms> Right, you just want to use it for high-bandwidth goal discussions when not everyone in those positions would be in attendance.
17:16:56 <mattdm> I think we *should* look at making sure board members are able to attend Flock. It's a reasonable use of our money.
17:17:04 <mattdm> At least, if we have a small, active board.
17:17:05 <gholms> If we can make absence from that not cripple things then that might be okay.
17:17:42 <gholms> Assuming people can actually take the time away from work to do it, mattdm.
17:17:44 <mattdm> but as we've discussed, flock is good for discussion and brainstorming but not for deciding.
17:18:09 <mattdm> gholms yes, absolutely a consideration
17:18:57 <mattdm> But I don't think anyone wants to make Flock attendence mandatory. cwickert, did you have a second thing to follow "first of all"? :)
17:19:11 <number80> it's just that afk discussions could help refining the discussion and coming up with proposals that can be discussed without dispersing too much
17:19:31 <number80> and without closing the discussion though
17:19:34 <cwickert> mattdm: not if we all disagree
17:19:49 <mattdm> or agree, depending on how you look at it :)
17:19:51 <cwickert> I mean, to the initial idea of making attendance mandatory
17:20:00 * mattdm nods cheerfully
17:20:04 <mattdm> #topic concerns about overlap and workload
17:20:22 <number80> I think that this should be the next board problem :)
17:20:31 <mattdm> yn1v had two concerns related to these things. I have not summarized them well. :)
17:20:45 <yn1v> okey
17:20:52 <yn1v> I only voice my concern about overlaping, I am not against that. Just think about something to keep an eye on.
17:21:25 <number80> I agree with yn1v proposal that the next board reevaluate regularly its efficiency and this particular issue
17:21:26 <yn1v> 1/4 people from rel eng, qa fesco
17:21:55 <yn1v> excatly, review later how actually works
17:22:28 <mattdm> yeah maybe there is something in general to formally say we'll review effectiveness overall and tweak as necessary after we've given it some time to work
17:22:28 <yn1v> the other concern is ... We have to figure out how to avoid burn out of very time intensive positions. People not being able to keep up with the role on the new_board and hies/her daily dutties.
17:23:04 <mattdm> new plan is to burn out 12 people instead of just one fpl!
17:23:31 <yn1v> :-)
17:23:33 <mattdm> orrrr, hopefully, spread out the heat to the degree that we have less burning _and_ more getting done.
17:23:34 <number80> I think that for positions tied to a group, the FPL could agree that another member from that group switches ;)
17:24:17 <cwickert> I don't think that burnout is a problem, because with the new 'goal' seats only Red Hatters will be able to fulfill this role anyway because they are the only ones who can spend that amount of time anyway. So I am more worried about community participation.
17:24:34 <mattdm> yeah, maybe we should move to that topic?
17:24:45 <number80> cwickert: this is why I want to keep few elected seats
17:24:51 <mattdm> #topic meaningful community participation?
17:24:54 <cwickert> number80: understood
17:25:12 <yn1v> yes, that's the other side of roles demanding too much time
17:25:20 <mattdm> ftr my proposal incorporates that with two elected seats
17:25:32 <number80> *nods*
17:25:40 <gholms> With how much time commitment attached to them?
17:26:07 <mattdm> gholms: variable. those are the seats with the least-predefined duties
17:26:14 <mattdm> so that may actually be _correct_
17:26:19 <number80> and I expect that the FPL keeps the implicit tradition to balance out the board between people with red fedora and white caps as much as possible
17:26:29 <cwickert> mattdm: how many 'goal' people would we usually have? would the number be constant or may it vary over time?
17:26:30 <gholms> Makes sense
17:26:51 <mattdm> I don't know if everyone had a chance to read the message I just posted to board-discuss about this -- I'm going to drop this link just in case
17:26:52 <mattdm> https://lists.fedoraproject.org/pipermail/board-discuss/2014-September/012875.html
17:27:06 <mattdm> cwickert variable. 2-4.
17:27:21 <mattdm> 4 seems like a lot, really, but it's a big project
17:27:32 <mattdm> with 1, we can definitely be doing more :)
17:27:38 <inode0> cwickert: just guessing I think much more than 4 would be too many big goals at once to juggle
17:28:02 <mattdm> inode0: yeah that's my intuition too
17:28:04 <jwb> inode0, agreed
17:28:29 * gholms nods
17:28:29 * cwickert wonders how this impacts decision making
17:28:41 <number80> one could think of small but effective goals (fixing our wiki organization)
17:29:03 <mattdm> cwickert: in my proposal, those positions only have binding votes in their own area, so, hopefully, not too much
17:29:15 <cwickert> number80: and that would give you a seat on the council?
17:29:19 <inode0> there will be lots of goals, just not at the level of needing a dedicated contributor on this body to get done
17:29:41 <number80> cwickert: only for their own area, that also means that you're in touch with *every* group in fedora
17:29:52 <number80> that's just an example
17:30:09 <mattdm> Fixing wiki, probably too small. But "fixing our information architecture" could easily be an 18 month goal.
17:30:31 <mattdm> This is why I put that number there -- it kind of gives a sense of the appropriate intended scope
17:31:31 <mattdm> anyway -- is there a connection to community participation here?
17:33:16 * mattdm hears crickets
17:33:30 <mattdm> possibly everyone is reading the mail I linked...
17:33:49 <mattdm> or possibly there's a netsplit and I am all alone here
17:33:56 * cwickert is still here
17:34:14 <jwb> i'm here.  i have nothing to add at the moment :)
17:34:16 <number80> I'm just confused
17:34:30 <yn1v> I get the weird feeling that at some extend people want to be on the luxury of being paid to work in fedora the full time, but at the same time does not want to fedora be full of red hats. Which makes some people going back and forth.
17:34:35 * MarkDude is also concerened that RH folks will be the ones that can attend FLOCK
17:34:37 <cwickert> mattdm: I don't get you last comment before it got quiet
17:35:06 <cwickert> "is there a connection to community participation here?" <-- where?
17:35:12 <MarkDude> +1
17:35:38 <number80> yn1v: my concern is to keep the initial social contract that started from the old times of fedora.us
17:35:53 <mattdm> cwickert: well the nominal topic is meaningful community involvement; that seemed to be a sidetrack on the goal-focused roles (or back to the earlier topic?)
17:35:57 <jwb> MarkDude, fwiw, speaker funding is normally given to non-RHT employees first
17:36:11 <jwb> MarkDude, and all RHT employees are asked to talk to their mgmt for travel funds to flock first
17:36:36 <MarkDude> If its a council/biard must attend, then it just seems easier local folks can attend. as well as RH
17:36:59 <mattdm> Funding speakers was definitely the priority this year, but -- we can decide to spend the money to get non-speaker participants there too
17:37:02 <cwickert> MarkDude: the "must attend" think is already off the table
17:37:26 <MarkDude> Thats good. that worried me
17:37:28 <MarkDude> eof
17:37:55 <jwb> mattdm, yes
17:38:00 <mattdm> The concern is more about spending money for people to just attend (and in some cases possibly with the goal of a free vacation really more than Fedora) — speaker made a simple threshold
17:38:01 <sgallagh> Can we guarantee subsidy for the Board for any non-RHT folks at least? I think there's real value in getting them all there if possible.
17:38:18 <number80> +1
17:38:18 <inode0> mattdm: so are you asking about community involvement in the project or in the council?
17:38:22 <inode0> :)
17:38:27 <jwb> sgallagh, i think we can possibly talk about that once we have the reorg done
17:38:51 <number80> sgallagh: but the matter is not only funding but being able to travel to Flock at that time too
17:38:54 <mattdm> inode0: good question. In the project, but in the sense of how council structure impacts that (not general brainstorming on the topic)
17:39:05 <MarkDude> sgallagh, +1
17:39:10 <jwb> guys, i don't want to derail good ideas, but you're still focused on Flock and not the overall reorg
17:39:11 <sgallagh> number80: Sure, but that's going to be an issue no matter what with this many people.
17:39:21 <jwb> Flock is a bonus.  it's a nicety where we eval stuff we can eval.  it's not a solution
17:39:22 <mattdm> ditto jwb
17:39:29 <MarkDude> +1
17:39:32 <cwickert> + jwb
17:39:39 <cwickert> lets move on
17:39:40 <sgallagh> It might be worth trying to push for earlier bids (as in having two year lead-times instead of 9-10 months)
17:39:47 <sgallagh> But I'm bikeshedding and will stop
17:39:48 <jwb> sgallagh, NO  MORE FLOCK
17:39:49 <mattdm> We can also do non-Flock board FADs, where we plan around the schedule of the board members
17:39:57 <jwb> mattdm, yes.
17:40:01 <mattdm> me gets the /kick ready
17:40:07 <mattdm> :)
17:40:10 <number80> mattdm: are we allowed to speak of FADs ?
17:40:17 <mattdm> not right now :)
17:40:20 <jwb> can we not pleasE?
17:40:45 <number80> jwb: it wasn't flock or alike related  but sure
17:41:20 <number80> well, I suggest that one of our first goal would be: community participation :)
17:41:24 <mattdm> The question is: how can we best structure the board/council to enable/empower community participation in the project, while also enabling and empowering the _board_ to a more active role?
17:41:29 <jwb> number80, i would love to talk about what we want to do at FADs or flock or wherever as a group, but we need to decide what that group is first
17:41:54 <number80> agreed
17:42:55 <MarkDude> I think the Community part- of almost all events- can be balanced- OSCONC and FOSSETCON, we had RH/Fedora folks- as well as plain old Fedora community people. A mix is great. Stating this a Project wide goal makes sense- as in attending events. The board is not yet formed- and I tend to trust it- as in people that care will be a part- no matter their paycheck surce
17:43:02 <MarkDude> :)
17:43:14 <cwickert> mattdm: I think with the mostly passive board was more it's role, not necessarily the time members can spend
17:43:34 <mattdm> One possibility would be to make one or both of the elected positions specifically tasked with representing individual contributors
17:44:00 <MarkDude> mattdm, +1
17:44:10 <mattdm> cwickert: can you expand?
17:44:12 <sgallagh> mattdm: I submitted a suggestion to the mailing list a few minutes ago recommending that the Diversity Coordinator should have that responsibility as well
17:44:43 <yn1v> or more generally elected seat can be tasked with specific goals that their skills be suited plus those goals that he/she brings to the board
17:44:59 <mattdm> I should note that it is also DEFINITELY an FPL responsibilty, in my mind.
17:45:23 <mattdm> whether or not I'm getting a paycheck for it
17:45:32 <cwickert> mattdm: I could, but now I completely lost you.
17:45:37 <number80> the more individual contributors we get on the board, the better even if it means that excellent contributors should cede their seats
17:45:48 <number80> (best effort though)
17:46:04 <number80> s/cede/relinquish/
17:46:05 <cwickert> mattdm: representing individual contributors? huh? Who else could represent say MarkDude but MarkDude himself?
17:46:18 <inode0> who isn't an individual contributor in this discussion?
17:46:21 <MarkDude> cwickert, I trsut you
17:46:31 <sgallagh> cwickert: Perhaps "special interests" would be a better term
17:46:48 <MarkDude> trust- to rep for my views- even if you disagree on it
17:47:03 <number80> cwickert: it's more about having more people with a different mindset. Though everyone is of good faith, you can't dismiss corporate bias
17:47:06 <mattdm> cwickert I can. MarkDude can talk to me, I can understand him, and I can advocate for him. For example.
17:47:14 <MarkDude> As well as many other fair people-
17:47:16 <MarkDude> +1
17:47:36 <mattdm> And unless we're going to direct democracy, there is really no other way.
17:47:44 <MarkDude> Many meetings- my peers have brought up my points- even if they are opposed to them- its egalitarian
17:47:51 <mattdm> We _definitely_ need people who are good at that in all of these roles.
17:48:00 <sgallagh> mattdm: So I guess you're talking a bit about a member-at-large whose job it is not to represent their own opinions, but those of groups that are less represented by other members.
17:48:04 <misc> number80: or group think, without even corporate being involved
17:48:28 <mattdm> misc: yes -- that's sgallagh's mailing list post about this being a diversity issue
17:48:30 * cwickert really has a hard time understanding
17:48:59 <number80> misc: that's what I expect from the next council, being inclusive and act as liaison between the head of the rest of the body :)
17:49:09 <sgallagh> cwickert: Maybe think of it sort of (very roughly) like a Human Resources representative. Their job is to take your concerns to the right people.
17:49:53 <cwickert> sgallagh: but that is not representing "individual contributors" at all but representing a certain group or having a certain role
17:49:56 <sgallagh> (Or maybe even better would be a faculty advisor at university, arguing on your behalf when needed)
17:50:10 <MarkDude> How many of use can be a diversity person? /me think its a small list of us
17:50:43 <MarkDude> Its a great goal- one I have done as long as I have been in FOSS
17:50:45 <cwickert> sgallagh: why would we represent certain people?
17:51:17 <sgallagh> cwickert: That may have been a language barrier issue. I didn't mean "specific" people, I meant "underrepresented people" in the abstract.
17:51:18 <mattdm> cwickert: can we go back a second to what you were saying about board role vs. time? Doesn't a more active board almost certainly imply a greater time commitment?
17:51:35 <MarkDude> But the thing is- I appear white- so nuance is needed. Im not just Italian, but Latino and Native American. Also active with Feminists
17:51:55 <MarkDude> unless we have some street cred on it- its a really dicey thing to do
17:52:29 <gholms> mattdm: It does, and that comes at a cost.
17:52:39 * inode0 feels we are drifting back and forth between about 4 topics and it is not easy to focus
17:52:47 <cwickert> mattdm: yes, we surely want a more active board and this requires active people, however if I look at the board and it's history, it was not the activeness of the individual members that made it become so passive
17:52:52 * mattdm agrees with inode0
17:52:58 * MarkDude respectfully is pointing out- that a very small group of people are capable of being Diversity person AND being looked at as a rep by outside community. eof
17:53:09 * number80 shuts up until the next topic to reduce signal noise
17:53:35 <MarkDude> Can we tak the diversity thing- and sorta brainsytorm it more - before its a rathole?
17:53:51 <mattdm> gholms: yes. So... a) is that cost okay with the current plan? b) can we mitigate it?
17:53:57 <MarkDude> take it off table- and really think it thru- focus on board?
17:53:59 <mattdm> MarkDude: can we save that for its own topic?
17:54:03 <MarkDude> +1
17:54:06 <yn1v> in "board role vs. time" I think that some roles will aling to what people is doing, and some will require start from scratch, some will require much hourly weeks than others
17:55:05 <gholms> mattdm: The cost is shutting out people who can't commit that much time.  From the sound of it we're pretty much in agreement that a more active board is worth that.
17:55:28 <yn1v> I agree with gholms
17:55:38 <inode0> gholms: not sure
17:55:50 <mattdm> gholms: I know this one kind of hits you directly
17:56:19 <cwickert> mattdm: sure, we all would need to be more active, but in your current proposal it sounds like a lot of people will not be able to be on the board if they cannot dedicate themselves 100% to Fedora
17:56:32 <cwickert> because of the role based approach
17:56:46 <gholms> mattdm: Hey, if it means progress...  ;)
17:57:36 <gholms> So, we have had trouble even filling the current board's seats at times.
17:57:37 * mattdm is thinking while typing
17:58:00 <jwb> i'm not sure that's true
17:58:05 <gholms> Will enough people still step up after this change?
17:58:06 <jwb> today the board doesn't have roles
17:58:14 <jwb> we don't have active goals or targets to hit
17:58:16 <mattdm> jwb what, that i'm thinking? i totally am
17:58:27 <yn1v> I think that cwickert is right for several proposed seats, some of those most likely are already full time fedora contrubutors
17:58:37 <jwb> so people have no incentive or interest in joining a body that apprears to do nothing
17:58:50 <mattdm> I agree with yn1v's assessment: some of the roles will require greater or lesser time.
17:59:17 <jwb> but if we have goals and targets, and we can rely on people to work on them and be accountable, i don't necessarily think that means 100%
17:59:26 <jwb> i think it means consistent effort over the defined timeframe
17:59:39 <mattdm> I also do think that a board-level position _needs_ to come with a commitment of time. It _should_ be a big deal.
17:59:43 <gholms> jwb: Do you believe that will be enough to get sufficient people to make that commitment?
18:00:12 <jwb> gholms, "enough"?  i don't know.  but it will go a long way towards helping people understand what they're expected to do
18:00:18 <mattdm> gholms: if it doesn't work, that'll be something we learn really quickly
18:00:21 * gholms nods
18:00:28 <jwb> and again, i don't think that expectation is necessarily 100% full-time effort
18:00:29 <inode0> gholms: who are you worried about?
18:00:49 <inode0> I mean which positions?
18:01:26 <inode0> 1/3 are automatic appointments of full time people, 1/3 are appointments of almost certain to be full time people.
18:01:30 <gholms> inode0: I'd like to stop having elections with barely enough candidates to fill all the positions.  So, the community members at large.
18:01:46 <mattdm> I think it's true that a lot of people will not be able to be on the board with the new structure. It's a cost. But, I think that we can find ways to make the contributions and input and ideas those people have be recognized _without_ giving board seats
18:02:17 <gholms> If there are only a couple, I suspect it won't be a huge issue.
18:02:28 <mattdm> inode0: I don't think that the goal-based ones are necessarily all full-time roles.
18:02:29 <gholms> mattdm: Yeah!
18:02:41 <cwickert> inode0: that is the point. whit this design, it looks like 2/3 of the seats will be filled by full-time people
18:02:44 <inode0> the two elected seats likely will be viewed as so marginalized that I don't expect much interest to be honest unless it is the novelty of a new organization
18:03:01 <MarkDude> inode0, +1
18:03:14 <jwb> marginalized in what way?
18:03:33 <mattdm> inode0: however, keep in mind that we're _also_ switching to a consensus decision model. unlike majority voting, marginalization is hard
18:03:49 <jwb> right
18:04:24 <mattdm> that's _really_ crucial to this proposal
18:04:47 <inode0> the board has used consensus in the past too ... I don't think that is a big differentiation
18:04:59 <jwb> not in the manner mattdm is suggesting
18:05:11 <jwb> or if it has, i don't recall it at all
18:05:20 <MarkDude> Differences between the two consensus models?
18:05:29 <inode0> maybe you could explain how decisions will be made in a bit more detail now then to help me understand
18:05:47 <sgallagh> mattdm: I missed the detail of the consensus model. Is this the "everyone has a full veto" model, or a "everyone but one" type, etc.?
18:06:09 <jwb> in short, if you have a -1 vote, the proposal doesn't pass initially at all.  the -1 vote needs to come with "these are the things i'm concerned about, or here is what would need to change to be acceptable"
18:06:38 <inode0> and then if we don't come to consensus?
18:06:55 <mattdm> We work at it. That's part of the time commitment.
18:07:10 <MarkDude> 1 person filibuster?
18:07:16 <inode0> does a single stubborn -1 with reasons block?
18:07:30 <jwb> yes, for some time anyway
18:07:42 <jwb> it's not a tally
18:08:00 <mattdm> Yeah, we can talk about formalizing a model where a single -1 can only block for a certain amount of time if no one else becomes convinced.
18:08:14 <jwb> e.g. 5 +1s and 4 -1s means "holy crap, this is really bad.  we need to reevaluate"
18:08:20 <jwb> not "measure passes"
18:08:25 <mattdm> jwb exactly
18:08:37 <inode0> ok, I'm open to changing my opinion about marginalization depending on the details here
18:09:12 * gholms notes that works better for people-y stuff like this than it does for software dev
18:09:14 <mattdm> I'll definitely put this in the next steps document.
18:09:28 <jwb> gholms, yes
18:09:29 <inode0> the odd community member could actually have more power rather than less
18:09:41 <sgallagh> IIRC, the way CentOS handles those -1 cases is that in the case of a stubborn -1 with reasons, the measure is blocked until the consensus is reached or a unanimous vote to remove the blocking person happens.
18:09:43 <jwb> inode0, certainly more "voice" than they've ever had
18:09:45 <mattdm> gholms yes I expect that fesco will stick to voting
18:09:47 <MarkDude> It still looks like 2/3 RH 1/3 community to me. Hash out details and its worth trying. it DOES have chance to balance this
18:09:52 <jwb> i kind of dislike phrasing things in terms of "power"
18:09:52 <sgallagh> Which means removing and replacing them on the Board.
18:10:09 <jwb> "power" sets up struggles.  "voice" sets up people to listen and discuss
18:10:10 <inode0> sgallagh: yeah, I strongly do not want that in Fedora
18:10:23 <mattdm> infinity freedom voice :)
18:10:23 <sgallagh> inode0: Sure, I don't think that's a good fit either.
18:10:29 <MarkDude> sgallagh, +1 that would freak many folks out
18:10:32 <inode0> jwb: fair, voice
18:10:41 <misc> sgallagh: isn't it a last measure , like FPL voting ?
18:10:48 <gholms> jwb: Does that mean we should pretend it doesn't exist, or is it just irrelevant?
18:10:59 <sgallagh> misc: To the best of my knowledge, it hasn't actually come up yet.
18:11:03 <mattdm> MarkDude: I'm not terribly excited about the RH vs. community distinction you are making there.
18:11:05 * stickster would think someone with a lone -1 would have respect for fellow group members and hold the -1 as long as was reasonable, and not beyond.  Otherwise we have different problems.
18:11:18 <MarkDude> not me- perceptions of FOSS community
18:11:19 <jwb> gholms, i said phrasing.  people can think whatever they want.  i'm just trying to stay positive (which is a new thing!)
18:11:21 <number80> Removing a dissonant voice is not a good thing, we don't want a homogenuous council
18:11:27 <gholms> jwb: Ah, got it.
18:11:38 * MarkDude is Community person- that trust RH and the Project
18:11:56 <jwb> stickster, agreed
18:11:58 <mattdm> stickster Yes! That is a key component of consensus. Everyone needs to feel strongly about working together for a common goal
18:12:09 <misc> number80: yet, people who block stuff may exist, it happened n a project i know
18:12:10 <sgallagh> number80: Well, the idea there is that this would only happen in cases of extreme need to get something through and it *would* carry a negative stigma
18:12:12 * yn1v needs to leave.
18:12:16 <number80> at the very least, if someone wants to keep disagreeing => -0
18:12:29 <sgallagh> But I am done defending it, because I don't like it either :)
18:12:39 <mattdm> and the flip side of what stickster is saying is that the rest of the group needs to respect a reasonable -1
18:12:53 <misc> number80: but exclusion didn't really solve the issue in the end
18:12:53 <stickster> mattdm++
18:12:53 <cwickert> mattdm: +1
18:12:54 <number80> misc: yup
18:13:00 <MarkDude> mattdm, +1
18:13:09 <gholms> Mhm
18:13:12 <number80> mattdm: +1
18:13:16 <misc> number80: now, without it, it could have stalled for much longer
18:13:38 <number80> misc: you should be able to override a single -1 after a certain amount of time
18:14:01 <mattdm> number80: let's work out the details separately.
18:14:06 <number80> *nods*
18:14:22 <sgallagh> We *should* have a way to address the worst case on the books.
18:14:22 <mattdm> mjg59: are you still around?
18:14:48 <sgallagh> I'd argue that it's not a terrible idea for it to be a bad situation for all involved, so that we're disinclined to allow it to reach that point.
18:14:56 <mjg59> I am
18:14:56 <mattdm> i'm curious to hear what you're thinking. so much quietness :)
18:15:15 <mjg59> (Sorry briefly distracted)
18:15:31 * gholms needs to go AFK in five minutes
18:16:00 <mjg59> Really if we have someone on the body who is -1 for poor reasons then the failure is in how we populated the board
18:16:21 <mjg59> We have to assume good faith
18:16:31 <number80> *nods*
18:16:40 <mjg59> And if people are earnestly disagreeing in good faith then that really does indicate that there's a problem we need to solve
18:16:59 <mjg59> Although I can see some cases where this might end up being problematic
18:17:29 <mjg59> eg, certain social issues are going to be difficult to solve in a way that will not result in someone feeling that the solution is actively harmful
18:17:29 <sgallagh> I think we minimize that if we require the "reasons" to always include "what would make me change this to +1"
18:18:18 <mattdm> I think we need to leave ourselves open to finding a way to a solution of we end up in a problem situation sometime in the future, but I don't think we need to optimize for it now.
18:18:18 <mjg59> I think that someone could earnestly believe that, for example, Fedora participation in OPW was something they fundamentally objected to
18:19:01 <mjg59> So I do think we need to figure out whether there are cases that the FPL should be empowered to override an otherwise deadlocked consensus process
18:19:48 <MarkDude> +1
18:20:07 <mjg59> Practically, I think the FPL should *always* be able to do that
18:20:30 <mjg59> And trust that we have FPLs who will choose not to exercise that power most of the time
18:20:45 <mattdm> mjg59: by asking the person blocking consensus to step down, or through some other means?
18:20:58 <mjg59> mattdm: By simply making the decision themselves
18:21:22 <gholms> Yup.  Same as we have now.
18:21:35 <gholms> (essentially)
18:22:05 <mattdm> can we do a straw poll of who on the board is in favor of that? +1 if so
18:22:10 <gholms> I need to go now, but I will read scrollback later.  Thanks for the discussion, everyone!
18:22:25 <sgallagh> BTW, what happens to the Board makeup when mattdm eventually steps down from FPL? Does the new FPL invest a new Board, or are they required to work with the existing Board, or <other>?
18:22:33 <mattdm> gholms: i'm counting your Yup as a +1
18:22:49 <jwb> +1
18:22:50 <mattdm> sgallagh: existing board, sucker.
18:23:19 <mjg59> +1, unsurprisingly
18:23:20 <inode0> mattdm: I really don't want to vote on that without thinking about it, if I have to vote two seconds after hearing it -1
18:23:29 <gholms> mattdm: The vote/tiebreak process we have now should be a last-resort deadlock breaker, yes.
18:23:40 <jwb> sgallagh, existing board.  mattdm didn't kick off this discussion, so it's not like he's the one changing the board because he was made FPL
18:23:54 <mattdm> number80, cwickert?
18:23:56 <mattdm> inode0: fair :)
18:24:07 <mattdm> this is a straw poll, not a binding vote
18:24:13 <cwickert> on whatß
18:24:15 <cwickert> ?
18:24:17 * inode0 could easily be persuaded in some form
18:24:36 <sgallagh> jwb: Sure, I was mostly looking for that to be unambiguous.
18:24:37 <mattdm> FPL as overriding stuck consensus as measure of last resort
18:24:42 <cwickert> ah
18:24:44 <cwickert> sure
18:24:49 <cwickert> that is a no-brainer
18:24:57 <number80> +0
18:24:59 <cwickert> I mean, didn't we always have that?
18:25:07 <mattdm> okay, so, looks like range is neutral to strongly in favor :)
18:25:13 <cwickert> or did we just have veto-powers for the FPL?
18:25:14 <inode0> not really, at least not codified
18:25:17 <sgallagh> mattdm: Suggestion: that power cannot be used without a minimum of 14 days of active discussion.
18:25:28 <inode0> veto power was codified
18:25:36 <mattdm> sgallagh: good call; something like that.
18:25:39 <sgallagh> (i.e. meaning not 14 days including the week between Christmas and New Year's etc.)
18:25:57 <number80> well, as long as the person is blocking decisions and refuse compromise :/
18:25:58 <mattdm> details :)
18:26:28 <mjg59> sgallagh: I'd extend that to "Or if the board accepts that they have reached deadlock and explicitly asks the FPL for a decision"
18:26:40 <mattdm> mjg59: also good.
18:26:40 <sgallagh> I think we can assume good faith that consensus is always the desired outcome for all participants
18:26:47 <sgallagh> mjg59: +1
18:28:14 * inode0 can easily agree to "If the board/council accepts that they have reached deadlock and explicitly asks the FPL for a decision"
18:28:20 <number80> Anyway, I have faith in our FPL soft powers :)
18:28:46 <mattdm> #info although nominally this was about individual community contributors, there's a lot of discussion in this part of the meeting about consensus process so if that's interesting to you see the full logs
18:28:59 <inode0> now what happens when the board/council is deadlocked and deciding that? :-)
18:29:11 <mattdm> inode0: ouch yes I was biting my tongue on that question :)
18:29:19 <number80> FPL take the decision and pwn them all
18:29:45 <number80> that's quite an incentive to encourage people to reach consensus
18:29:50 <mattdm> inode0: but we can find some wording that seems reasonable.
18:29:58 <sgallagh> In a consensus situation, that seems to me that it's the responsibility of both sides to try to write a more palatable proposal
18:30:02 <sgallagh> And find middle-ground.
18:30:04 * cwickert needs to leave
18:30:06 <mattdm> sgallagh: yes!
18:30:13 <inode0> How much longer are we planning to go today at this point? At least I am feeling better about this all now.
18:30:16 <sgallagh> If it's that split, it's *not* a good decision
18:30:27 <mattdm> inode0: in that case, we're probably done.
18:30:33 <mattdm> quick, quit now :)
18:30:40 * sgallagh snorts
18:30:45 <mattdm> in seriousness....
18:30:49 <mattdm> #topic next steps
18:31:03 <mattdm> I'm going to take my proposal into a wiki page
18:31:18 <mattdm> as nirik suggested, fleshing out something that would replace the current Board page
18:31:42 <mattdm> it would include both the structure part from my email _and_ the consensus method we've discussed here
18:32:00 <number80> personally, I think that we should accept that we can't solve every issue of the new governance and accept "good enough"
18:32:23 <number80> when reached, we should leave the new board/council address these issues
18:32:35 <sgallagh> "Changes to the consesnsus policy must be made by consensus of the Board" ;-)
18:32:50 <mattdm> then, this week, another round of "+1", or negatives or 0s with specific concerns
18:33:21 <mattdm> And let's aim to actually vote on something next monday?
18:33:42 <number80> +1
18:34:19 <mattdm> that is, final on monday -- I'll try to have the draft for first round MUCH before that, and hope y'all can provide feedback.
18:34:34 <mattdm> so that it is in fact an easy unanimous by monday
18:34:39 <mattdm> sound good?
18:34:54 <jwb> yes
18:35:09 <mattdm> okay then!
18:35:13 <inode0> yeah, I'd like to have time for further discussion - if that can happen before the weekend then Monday might work
18:35:49 <mattdm> yeah, if I don't hold up my end of the bargain and get further discussion going before monday, then I won't try to force a vote.
18:36:08 <inode0> I suspect at this point most concerns can be resolved, and would prefer to have them resolved if possible.
18:36:08 <mattdm> and conversely, if I do stay up all night writing, I hope feedback is fast and profuse :)
18:36:15 <mattdm> inode0: awesome.
18:36:29 <inode0> mattdm: depends on updates
18:36:47 <inode0> i.e., how many hours I need to spend doing them
18:37:06 <jwb> mattdm, fast and concise works too
18:37:17 <number80> I want git-formatted patches
18:37:21 <mattdm> jwb: true words!
18:37:34 <mattdm> in any case, I'm going to end this meeting in one minute
18:37:39 <mattdm> unless there are objections to that
18:37:51 <mattdm> and probably even if there are objections.
18:37:55 * inode0 expects this to be unanimous
18:38:04 * number80 is hungry
18:38:34 <mattdm> okay!
18:38:36 <inode0> Thanks everyone for the very helpful to me session today.
18:38:36 <mattdm> #endmeeting