15:01:57 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:01:57 <zodbot> Meeting started Tue Oct  7 15:01:57 2014 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:01 <Kevin_Kofler> #meetingname kde-sig
15:02:01 <zodbot> The meeting name has been set to 'kde-sig'
15:02:06 <Kevin_Kofler> #topic Roll call
15:02:18 * jgrulich is present
15:02:50 * Kevin_Kofler obviously is, too. :-)
15:02:54 <tosky> hi
15:03:14 <pino|work> me
15:03:25 * jreznik is around
15:03:53 <heliocastro> hello
15:04:45 <than> present
15:05:18 <rdieter> here
15:06:21 <dvratil> hi
15:06:24 <danofsatx-dt> here
15:06:39 <mbriza> hey
15:07:19 <Kevin_Kofler> #chair jgrulich tosky pino|work jreznik heliocastro than rdieter dvratil danofsatx-dt mbriza
15:07:19 <zodbot> Current chairs: Kevin_Kofler danofsatx-dt dvratil heliocastro jgrulich jreznik mbriza pino|work rdieter than tosky
15:07:38 <Kevin_Kofler> #info Kevin_Kofler, jgrulich, tosky, pino|work, jreznik, heliocastro, than, rdieter, dvratil, danofsatx-dt, mbriza present.
15:07:45 <Kevin_Kofler> #topic Agenda
15:08:02 <Kevin_Kofler> Topic #1 for this week's meeting needs to be approving the live image size increase, or coming up with a solution to make the old limit.
15:08:09 <Kevin_Kofler> Anything else to discuss this week?
15:09:06 <dvratil> I can give KF5/Plasma5 update
15:09:47 <Kevin_Kofler> OK.
15:09:57 <Kevin_Kofler> #topic live image size limit
15:10:06 <Kevin_Kofler> So, what do we do to the size limit of our live images?
15:10:42 <Kevin_Kofler> The current limit is 1 000 000 000 bytes, and we are exceeding that limit in some composes, probably soon in all (new SDDM dragging in Qt 5).
15:11:16 <heliocastro> live images will contain both kde 4 and kf 5 ?
15:11:20 <Kevin_Kofler> There was a proposal discussed to bump the limit to 1 400 000 000 bytes, which is the guaranteed size of a MiniDVD (some guarantee more, like 1 460 000 000, but probably not all, so 1 400 000 000 is safest).
15:11:30 <rdieter> +1 to bump to 1.4gb
15:11:38 <Kevin_Kofler> heliocastro: For F21, only the parts dragged in by SDDM.
15:11:41 <jgrulich> +1
15:11:51 <heliocastro> +1 bump
15:11:52 <pino|work> +1 what rdieter said
15:12:30 <Kevin_Kofler> So, what do the other voting members say?
15:13:02 <Kevin_Kofler> I'm not too happy about the size increase (yet another one!), but I also don't have a real alternative plan.
15:13:18 <Kevin_Kofler> So I'd tend towards abstaining (0 vote).
15:13:52 <than> +1 for 1.4gb
15:13:59 <dvratil> +1 for bump
15:14:19 <Kevin_Kofler> I think we need one more (heliocastro is not in the list of voting members, is he?).
15:15:11 <tosky> uhm, +1 from me too, I can vote for a reduction if some new solution comes out
15:15:22 <heliocastro> Can i be in the list ?
15:15:59 <ltinkl> +1 for 1.4
15:16:51 <Kevin_Kofler> heliocastro: We should probably kick out somebody else then. ;-) 11 voting members should be enough.
15:17:08 <Kevin_Kofler> Can we have that discussion another day?
15:17:24 <heliocastro> yep
15:17:45 <Kevin_Kofler> But yes, it makes sense to have you in the WG, noted. :-)
15:18:12 <Kevin_Kofler> For this one, I think we have an agreement.
15:18:19 <jreznik> +1 for 1.4 as commented in the bug
15:18:21 <Kevin_Kofler> (for this proposal)
15:19:07 <jreznik> Kevin_Kofler: you can kick me out, I'm really not very good member last few months :(
15:19:25 <Kevin_Kofler> #agreed The live image size limit for the KDE images is increased from 1 GB (1 000 000 000 bytes) to 1.4 GB (1 400 000 000 bytes). (+7, 1 abstention, 3 absent)
15:20:04 <Kevin_Kofler> #topic KF5/Plasma5 update
15:20:06 <danofsatx-dt> sorry, I'm +1 on that also
15:20:18 <jreznik> Kevin_Kofler: could you please update bug with this agreement?
15:20:21 <Kevin_Kofler> #undo
15:20:21 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x2c746a50>
15:20:22 <danofsatx-dt> (bosses walked in for an impromptu meeting)
15:20:23 <Kevin_Kofler> #undo
15:20:23 <zodbot> Removing item from minutes: AGREED by Kevin_Kofler at 15:19:25 : The live image size limit for the KDE images is increased from 1 GB (1 000 000 000 bytes) to 1.4 GB (1 400 000 000 bytes). (+7, 1 abstention, 3 absent)
15:20:30 <Kevin_Kofler> #agreed The live image size limit for the KDE images is increased from 1 GB (1 000 000 000 bytes) to 1.4 GB (1 400 000 000 bytes). (+8, 1 abstention, 2 absent)
15:20:33 <Kevin_Kofler> #topic KF5/Plasma5 update
15:20:44 <Kevin_Kofler> jreznik: Will do.
15:20:52 <Kevin_Kofler> dvratil: Your turn.
15:21:15 <dvratil> I'm building KF5 5.3.0 for rawhide as we speak (rdieter, I'll need f20-kde and f21-kde targets tomorrow pretty please :-)
15:21:36 <dvratil> we now have KF5 available in F20, F21 and rawhide, so I have removed the KF5 COPR
15:21:37 <rdieter> dvratil: I'll add 'em now
15:21:41 <rdieter> (so I don't forget)
15:21:44 <dvratil> thanks
15:22:17 * rdieter will clear f20-kde, f21-kde tags too
15:22:50 <dvratil> and Plasma 5.1 is coming next week (or the week after, so yay!)
15:23:44 <dvratil> and I also started working on plasma-5-unstable COPR (finally) that will contain packages with Plasma 5 apps that don't have yet stable releases - so mostly snapshots from "frameworks" branch in git - Dolphin, KMix, Gwenview, Konversation, Konqueror, Rekonq
15:24:05 <pino|work> (okular)
15:24:13 <dvratil> pino|work, yep, thanks
15:24:30 <jgrulich> dvratil: kate, kdevelop
15:24:38 <dvratil> Kate can be
15:24:45 <dvratil> not sure about kdevelop
15:25:01 <dvratil> kdevelop requires konsole and having konsole requires all apps that embed konsolepart to be KF5 too
15:25:09 <dvratil> and some of the might still be crashy
15:25:12 <Kevin_Kofler> #info KF5 now available in F20, F21 and Rawhide, KF5 Copr removed. KF5.3.0 building for Rawhide now.
15:25:17 <dvratil> even kdevelop from KF5 is rather crashy
15:25:32 <Kevin_Kofler> #info Plasma 5.1 is coming next week (or the week after, so yay!)
15:25:45 <Kevin_Kofler> #info dvratil also started working on plasma-5-unstable COPR (finally) that will contain packages with Plasma 5 apps that don't have yet stable releases - so mostly snapshots from "frameworks" branch in git - Dolphin, KMix, Gwenview, Konversation, Konqueror, Rekonq
15:25:47 <tosky> dvratil: but they are not "plasma" apps
15:26:01 <Kevin_Kofler> dvratil: That should summarize the essential stuff for the meeting summary. :-)
15:26:10 <dvratil> Kevin_Kofler: thanks
15:26:21 <jgrulich> dvratil: I can definitely help you with packaging that stuff
15:26:27 <Kevin_Kofler> dvratil: For the KonsolePart, we need to make the 4 and 5 ones coexist.
15:26:30 <dvratil> tosky:  true, it should be called kde-applications-5 or something, but blah - don't care for now
15:26:35 <Kevin_Kofler> In principle, it should work.
15:26:39 <Kevin_Kofler> The KParts install to all different paths.
15:26:50 <Kevin_Kofler> (at least for system-installed ones)
15:27:01 <Kevin_Kofler> If it's picking up the wrong ones, there's a bug somewhere that needs to be fixed.
15:27:16 <Kevin_Kofler> So we need a konsole4 compat package that installs only the KPart.
15:27:19 <dvratil> I need to test with current versions - I last tried a while ago, back then KF5 apps, when they did not find the KF5 build of KonsolePart tried to load KDE4 and boom
15:28:00 <Kevin_Kofler> The KParts will have to coexist for a long time to come.
15:28:22 <danofsatx-dt> Is there a how-to write up anywhere for converting to KF5?
15:28:24 <dvratil> depends
15:28:43 <dvratil> danofsatx-dt:  techbase.k.o and community.k.o
15:29:04 <danofsatx-dt> can we point to those in the fedwiki?
15:29:52 <dvratil> Kevin_Kofler: we need the KParts only if we ship any apps that depend on them, so "long time" might not be precise :)
15:29:54 <rdieter> danofsatx-dt: sure, where appropriate
15:31:02 <Kevin_Kofler> dvratil: We still have stuff that depends on the KDE 3 KatePart (at least Quanta).
15:31:12 <Kevin_Kofler> So it could be a VERY long time.
15:31:53 <heliocastro> Question, someone argued about linux-lsb ?
15:32:21 <dvratil> unfortunately KParts being run-time dependency, it's hard to check which packages actually depend on which KParts :(
15:33:05 <ltinkl> ye that's the whole point of plugin-based architecture :)
15:33:12 <heliocastro> dvratil: Maybe we can write a tool to do this ?
15:33:46 <dvratil> heliocastro:  of course we can :-) question is who has to time to do that :-P
15:34:19 <Kevin_Kofler> dvratil: The RPMs should have explicit runtime Requires on required KParts, if they don't → https://bugzilla.redhat.com/ :-)
15:34:40 <tosky> ehm, but then konqueror should depend on everything
15:34:41 <dvratil> Kevin_Kofler:  problem is that you have kparts in packages like kde-workspace or kde-runtime
15:34:46 * rdieter has several packages that Requires: konsole-part
15:34:52 <dvratil> which is not very conclusive
15:35:16 <rdieter> and, kate-part
15:35:42 <Kevin_Kofler> dvratil: Even those need runtime Requires.
15:35:47 <Kevin_Kofler> And what KParts are in workspace?
15:35:55 <Kevin_Kofler> I'd hope we don't need a kde-workspace4…
15:36:30 * dvratil does not have kde-workspace installed anymore
15:36:35 <rdieter> we'll find out
15:36:49 <ltinkl> rdieter: so what is another application also provides a terminal emulator part?
15:37:01 <heliocastro> yakuake ?
15:37:05 <ltinkl> this isn't a about konsole or kate specifically
15:37:06 <rdieter> -workspace has kfontviewpart , the only one I see
15:37:23 <rdieter> heliocastro: yakuake uses konsole-part
15:37:39 <rdieter> ltinkl: I'm not aware of any others
15:38:05 <rdieter> anyway, if anyone is curious, you can see for yourself:
15:38:06 <Kevin_Kofler> ltinkl: The apps request the KonsolePart by name.
15:38:19 <heliocastro> There's okularPart
15:38:22 <rdieter> repoquery --whatrequires kate-part     or   repoquery --whatrequires konsole-part
15:38:24 <Kevin_Kofler> It doesn't work on a document, so there isn't a way to request it by mimetype.
15:39:18 <rdieter> heliocastro: yep (we have a okular-part subpkg too)
15:39:52 <rdieter> it may be fun to track all the consumers of these various parts though (those that don't already have dependencies).  I'm sure we'll find out sooner or later
15:41:20 * rdieter has to go
15:41:22 * rdieter waves, bye
15:41:55 <heliocastro> o/
15:42:03 <rdieter> repoquery --whatprovides \*-part  , to see which various packages either have an explicit -part subpkg, or Provides: one
15:42:24 <rdieter> others include: ark, cantor, marble
15:42:29 <Kevin_Kofler> heliocastro: What about linux-lsb? Sorry, I haven't followed the discussion you refer to.
15:42:46 <heliocastro> redhat-lsb still requires qt3
15:42:53 <Kevin_Kofler> rdieter: Then of course it needs to be decided what needs a compat package and what not.
15:43:05 <heliocastro> Ans i don't know if we can do somethng on that part
15:43:09 <Kevin_Kofler> I don't think we need a cantor4-part, but maybe marble.
15:43:22 <Kevin_Kofler> heliocastro: That's the definition of the LSB.
15:43:39 <Kevin_Kofler> Nothing should require redhat-lsb in Fedora, if something does, the dependency bloat is there.
15:43:58 <heliocastro> at least i know one annoying guy, chrome
15:44:04 <heliocastro> But is external anyway
15:44:47 <Kevin_Kofler> (I've seen something from Fedora drag in redhat-lsb recently, I should probably file a bug. I think it was "ceph". In any case, it was something that used to be a dependency of qemu, but now only the libs are required. My old installation had the whole thing that dragged in the LSB stuff.)
15:45:03 <Kevin_Kofler> Chrome, we have no control over, sorry.
15:46:44 <heliocastro> But i mean from our side we can push to review this
15:47:09 <heliocastro> I know is a long process, but qt3 even is not supported
15:47:26 <Kevin_Kofler> qt3 is not going away anyway.
15:47:43 <Kevin_Kofler> I'm keeping it working, LSB or not.
15:47:51 <Kevin_Kofler> (Frankly, I don't give a darn about the LSB.)
15:48:36 <danofsatx-dt> for the uninitiated (or old farts like me with no memory), what's LSB again?
15:48:41 <drago01> fwiw gnome-software considers qt3 (and gtk1) "legacy toolkits" and don't show such apps
15:48:46 <heliocastro> Linux Standard Base
15:48:46 <Kevin_Kofler> Linux Standards Base
15:49:28 <danofsatx-dt> roger....thanks
15:49:45 <Kevin_Kofler> It's a set of libraries with fixed ABIs that binary (usually binary-only) packages can depend on.
15:50:25 <heliocastro> Ok,so nothing we can do
15:50:28 <Kevin_Kofler> Somebody decided to include Qt, but that was when Qt 3 was current.
15:50:54 <Kevin_Kofler> Now we have Qt 5, but the LSB moves really slowly, if it even still moves at all.
15:51:13 <Kevin_Kofler> Proprietary software developers don't want to upgrade to new libraries, ever.
15:51:33 <Kevin_Kofler> They'd still use Qt 1 if they could.
15:52:30 <Kevin_Kofler> The only thing we could do is try to get the LSB to release a new version of the LSB.
15:52:45 <Kevin_Kofler> But then we'd still have a lot of stuff targeting the old version that we'd have to deal with.
15:52:59 <Kevin_Kofler> (unless we decide that we just don't care)
15:53:36 <Kevin_Kofler> But that's really a Fedora-wide decision.
15:53:55 <Kevin_Kofler> And these days Workstation actually has compatibility with third-party binary-only stuff as a goal. :-(
15:54:10 * Kevin_Kofler thinks that should be a total non-goal for Fedora.
15:56:59 <Kevin_Kofler> #topic Open discussion
15:57:06 <Kevin_Kofler> So, anything else before I close the meeting?
15:57:49 <danofsatx-dt> nothing from the peanut gallery
16:00:17 <Kevin_Kofler> OK, thanks all for coming!
16:00:19 <Kevin_Kofler> #endmeeting