17:04:13 <roshi> #startmeeting Cloud WG
17:04:14 <zodbot> Meeting started Fri Oct 17 17:04:13 2014 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:04:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:04:24 <dustymabe> .hellomynameis dustymabe
17:04:25 <roshi> #meeting name Fedora Cloud WG
17:04:26 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@gmail.com>
17:04:34 <roshi> #topic Roll Call
17:04:43 <kushal> .hellomynameis kushal
17:04:44 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
17:04:54 <roshi> .hellomynameis roshi
17:04:55 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:05:00 <lalatenduM> .hellomyname is lalatendu
17:05:03 <agrimm> .hellomynameis arg
17:05:04 <zodbot> agrimm: arg 'Andy Grimm' <agrimm@redhat.com>
17:05:07 <lalatenduM> .hellomynameis lalatendu
17:05:08 <zodbot> lalatenduM: lalatendu 'Lalatendu Mohanty' <lmohanty@redhat.com>
17:05:36 <kushal> No one else?
17:05:54 <roshi> mattdm: you around for a cloud meeting?
17:06:08 <agrimm> sorry all, I have a conflict today, so I'm lurking, but probably not responsive
17:06:57 <roshi> no agrimm
17:06:58 <kushal> roshi, otherwise let us just go through the action items of the people who are present.
17:07:06 <roshi> yup, on it :)
17:07:17 <roshi> #topic Previous Meeting Follow-up
17:07:44 <roshi> Action Items
17:07:44 <roshi> ------------
17:07:44 <roshi> * mattdm to take jzb's proposed changes to ticket and then to fesco
17:07:44 <roshi> * roshi to link up with kushal and talk about smoketests
17:07:44 <roshi> * kushal to email roshi
17:07:46 <roshi> * roshi to coordinate with jzb for Atomic testday once we have a date
17:07:49 <roshi> * roshi and jsmith to poke jzb about cloud updates documentation
17:07:51 <roshi> * jsmith to coordinate with jzb about the feedback from the security team
17:07:54 <roshi> * roshi to update the wiki with the release criteria and close the ticket
17:07:57 <roshi> * dustymabe to work with mattdm on Digital Ocean account
17:08:06 <roshi> I'll go first I guess :)
17:08:27 <roshi> I'm in the process of writing Kushal back about smoketests
17:08:30 * dustymabe is ready to report when the floor is open
17:08:34 <roshi> no news on Atomic testday
17:08:54 <roshi> jsmith: did you poke jzb about the updates docs?
17:09:00 * kushal wrote a mail only one hour back to roshi. Still have to talk/catchup with him.
17:09:13 <roshi> :)
17:09:25 <roshi> and pretty sure I updated the release criteria
17:09:26 <oddshocks> .hellomynameis oddshocks
17:09:27 <zodbot> oddshocks: oddshocks 'David Gay' <dgay@redhat.com>
17:09:27 * roshi checks
17:09:43 * oddshocks apologizes, is in many chats at once
17:10:28 <dustymabe> floor open?
17:10:46 <dustymabe> roshi: I am working with mattdm and fedora legal regarding the DO account
17:11:03 <roshi> awesome
17:11:13 <roshi> also, I did update the release criteria :)
17:11:23 <roshi> https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria#Cloud_Product_requirements
17:11:37 <roshi> what's that process look like dustymabe ?
17:11:46 <roshi> how far along is it?
17:12:07 <dustymabe> roshi: I have sent some emails to legal@fedoraproject.org
17:12:28 <dustymabe> roshi: mattdm is meeting with a representative next week and will discuss this among other things with them
17:12:39 <roshi> sweet
17:12:42 <dustymabe> one other item I have is to try to get a FAS alias created for the account
17:12:53 <dustymabe> which I think is something for us to decide on here
17:13:12 <kushal> dustymabe, just digitalocean ?
17:13:15 <kushal> :)
17:13:26 <roshi> fedora-do
17:13:29 <roshi> do-fedora
17:13:30 <dustymabe> kushal: :) - yeah I'm new so I am starting small
17:13:48 <dustymabe> kushal: oh you mean the alias?
17:13:50 <roshi> do we have qourum for this meeting?
17:13:53 <kushal> dustymabe, yes
17:13:55 <roshi> number80: you around?
17:13:57 <dustymabe> kushal: got it
17:14:31 <dustymabe> kushal: roshi fedora-digitalocean or any combo that you guys have already mentioned woud suffice
17:14:41 <dustymabe> I don't know who I need to contact to get the alias made
17:14:48 <roshi> talk to infra
17:14:59 <roshi> nirik or dgilmore-bne would be my guesses
17:15:22 <dustymabe> roshi: got it.. releng != infra correct?
17:15:41 <roshi> that line is kinda fuzzy to me, tbh
17:15:50 <dustymabe> otherwise we could ask oddshocks
17:16:00 <roshi> #fedora-infra I think is the channel
17:16:31 <dustymabe> roshi: cool. I can try that avenue. Does anyone know how aliases are managed? like if an alias gets created, who has access?
17:16:32 <roshi> nvm - it's not the channel
17:16:53 <roshi> I think it might be managed by membership in some FAS group
17:17:09 <roshi> I can help you track an answer down after the meeting
17:17:18 <dustymabe> roshi: thanks. that would be great
17:17:23 <kushal> dustymabe, just ask nirik
17:17:36 <dustymabe> should we put in a info statement or something for the meeting notes about DO
17:18:28 <roshi> #info dustymabe to figure out FAS information for a Digital Ocean account
17:18:32 <roshi> oh, that reminds me
17:18:54 <roshi> #chair dustymabe kushal oddshocks lalatenduM
17:18:54 <zodbot> Current chairs: dustymabe kushal lalatenduM oddshocks roshi
17:18:55 <dustymabe> #info dustymabe working with mattdm and legal to get DO TOCs approved
17:19:13 <roshi> anything else before we move to agenda items?
17:19:15 <dustymabe> #undo
17:19:15 <zodbot> Removing item from minutes: INFO by dustymabe at 17:18:55 : dustymabe working with mattdm and legal to get DO TOCs approved
17:19:21 <dustymabe> #info dustymabe working with mattdm and legal to get DO TOS approved
17:20:05 <roshi> alright - first up
17:20:24 <roshi> #topic Releaseing Updated images (#43)
17:20:29 <roshi> #link https://fedorahosted.org/cloud/ticket/43
17:21:50 <roshi> this is directly related to #51
17:21:58 <roshi> looks like it's moving forward
17:22:35 <roshi> I don't see why we couldn't have this ready by F21 GA
17:22:45 <roshi> but I don't *really* know what all goes into it
17:23:27 <dustymabe> roshi: I think it would be good to add that to the ticket
17:23:36 <dustymabe> I can update the ticket with questions
17:24:05 <dustymabe> roshi: it does look related to 51.. are they the same thing?
17:24:22 <roshi> not quite - 51 I think can be closed
17:24:32 <roshi> it's about starting the communication to figure out what we need for updates
17:24:44 <roshi> jzb wrote it up and was going to put it on the wiki
17:24:54 <roshi> but I don't know where it is off the top of my head
17:24:58 <dustymabe> roshi: I remember his drafts he sent out
17:25:29 <dustymabe> we can just add that information to the ticket then.. it helps make progress
17:25:33 <nirik> FYI, for aliases it's an infrastructure ticket. Listing the alias and who should be on it. I'd say wait until all the legal stuff is done before requesting that however.
17:25:57 <dustymabe> nirik: thanks. will do that
17:26:00 <roshi> awesome - thanks nirik :)
17:26:28 <dustymabe> nirik: since I am fairly new I don't know if I have my Fedora account set up appropriately in order to be able to be included on such things
17:26:37 <dustymabe> nirik: can you check.. it should just be dustymabe
17:27:30 <nirik> dustymabe: you will need to be added to a group to get a @fedoraproject.org alias, but otherwise the account looks fine.
17:28:03 <dustymabe> nirik: thanks. I'll try to get added to a group before I open the ticket
17:29:10 <roshi> dustymabe: you can join the QA group since you'll be doing QA for at least cloud things
17:29:40 <dustymabe> roshi: thanks. does someone just add me or do I have to make a request?
17:29:52 <dustymabe> roshi: we can worry about this after the meeting.. lets move on
17:29:53 <roshi> I can just add you
17:30:04 <dustymabe> roshi: nirik thanks
17:30:28 <roshi> #action dustymabe to updateticket #43
17:30:47 <roshi> #topic Smoke Tests (#38)
17:31:01 <roshi> #link https://fedorahosted.org/cloud/ticket/38
17:31:21 <roshi> kushal and I will be talking about this more from here on out
17:31:36 <roshi> along with oddshocks and agrimm I suspect as time passes
17:32:24 * oddshocks nods
17:32:51 <kushal> :)
17:33:15 <roshi> I just emailed you back kushal
17:33:24 <roshi> we can move on with this one I think
17:33:32 <kushal> roshi, yup, thanks :)
17:33:51 <roshi> #topic Atomic Testday (#74)
17:33:56 <roshi> #link https://fedorahosted.org/cloud/ticket/74
17:34:12 <roshi> jzb has all the info on this one
17:34:38 <roshi> anybody have any other information on it?
17:34:47 <roshi> #info still waiting on a date to begin planning for
17:34:59 <roshi> #undo
17:35:00 <zodbot> Removing item from minutes: INFO by roshi at 17:34:47 : still waiting on a date to begin planning for
17:35:06 <roshi> #info still waiting on a date to begin planning for an Atomic Testday
17:35:37 <dustymabe> roshi: nothing here.. for now.
17:35:46 <dustymabe> roshi: i'm hoping to generate some test content soon
17:35:52 <roshi> that'd be great
17:36:00 <dustymabe> roshi: using walters new image he put out recently from alt
17:36:18 <dustymabe> you have created a page for me to put notes. I'm still planning to use that
17:36:30 <roshi> cool
17:36:37 <roshi> next topic then?
17:36:59 <kushal> roshi, yes
17:37:17 <kushal> I have few updates for open floor
17:37:28 <roshi> kk, should be there pretty quick
17:37:51 <roshi> #topic State of SIG article for magazine (#75)
17:37:55 <roshi> #link https://fedorahosted.org/cloud/ticket/75
17:38:11 <roshi> this is just here to remind us it's there for the beta release
17:38:36 <roshi> afaik the article is done and ready to go, just waiting on beta
17:40:03 <roshi> I propose we skip #51 (https://fedorahosted.org/cloud/ticket/51 )
17:40:12 <roshi> we already talked about it
17:40:18 <roshi> I think we can close this as well
17:40:26 <dustymabe> should I ask in the ticket if it can be closed?
17:40:35 <roshi> that's probably best
17:41:16 <roshi> #action dustymabe to ask in ticket #51 if it can be closed
17:41:40 <roshi> #topic Release Criteria (#77)
17:41:47 <roshi> #link https://fedorahosted.org/cloud/ticket/77
17:41:56 <roshi> this is my ticket and it needs closed
17:42:46 <roshi> there, closed :)
17:42:59 <roshi> alright, openfloor time
17:43:03 <roshi> #topic Open Floor
17:43:08 <roshi> kushal: you had stuff?
17:43:11 <kushal> https://fedoraproject.org/wiki/Changes/Convert_Fedora_Cloud_Image_to_Fedora_Server this is done
17:43:24 <kushal> It is in the testing repo
17:43:43 <kushal> Then I picked up https://fedorahosted.org/cloud/ticket/62
17:44:06 <kushal> Already submitted a patch for https://bugzilla.redhat.com/show_bug.cgi?id=995537 for dnf
17:44:32 <roshi> good work :)
17:44:34 <dustymabe> kushal: nice work
17:44:39 * number80 waves
17:45:22 <kushal> Along with the other treasures, I am going to inherit the ks files from mattdm :)
17:45:36 <kushal> Still working on the treasure list :p
17:46:01 <kushal> #info Kushal started working on https://fedorahosted.org/cloud/ticket/62
17:46:06 <kushal> #link https://fedorahosted.org/cloud/ticket/62
17:46:08 * roshi makes a note that kushal equates "work" with "treasure"
17:46:12 <roshi> :p
17:46:31 <roshi> be wary of going on treasure hunts with him :p
17:46:34 <kushal> roshi, :)
17:46:36 <kushal> haha
17:47:02 <number80> :)
17:48:01 <kushal> That is all from me.
17:48:13 <roshi> anyone have anything else?
17:48:15 <kushal> Actually one more thing.
17:48:17 <oddshocks> yes
17:48:24 <oddshocks> kushal: go ahead ;)
17:49:00 <kushal> #info kushal submitted patch(s) to rel-eng team so that nightly builds from masher script get build properly.
17:49:10 <lalatenduM> Can someone point me to some material/docs for start testing
17:49:12 <kushal> ^^ those patches are not tested yet though.
17:49:24 * kushal is finished, oddshocks stage is yours.
17:49:39 <roshi> I can help you out after the meeting lalatenduM
17:49:48 <lalatenduM> roshi, thanks
17:50:03 <roshi> np - it's what I'm here for :)
17:50:29 <lalatenduM> :)
17:51:28 <oddshocks> 1) ostree stuff is accellerating. I'm feeling good about developments the past couple of days, especially today, where I've been hashing things out with lmacken and walters with regards to ostree composes and eventual metalink hook ups to MM
17:51:51 <oddshocks> 2) has any progress been made on wiping AWS community creds and reissuing creds, or is there a timeline on that?
17:52:13 <oddshocks> and that's all from me
17:52:24 <roshi> awesome on 1 :)
17:52:38 * roshi is getting sped up on docker so he can then get to know atomic
17:52:57 <roshi> as for 2, who was handling that?
17:53:02 <roshi> agrimm: ^^ right?
17:53:02 <dustymabe> roshi: was it agrimm?
17:53:24 <agrimm> it was me
17:53:25 <dustymabe> he said he was lurking.. so he may or may not respond
17:53:30 <dustymabe> yay!
17:53:55 <oddshocks> not high priority but was just curious
17:53:57 <agrimm> I have not done that yet.   I will work on that this afternoon.
17:54:06 <oddshocks> agrimm: awesome :D
17:54:07 <oddshocks> thanks!
17:54:12 <roshi> thanks agrimm
17:54:22 <kushal> oddshocks, you will have to fill me with ostree info later on.
17:54:25 <dustymabe> roshi: is there an AI associated with that?
17:54:37 <roshi> I don't know
17:54:41 * lalatenduM is also interested in ostree
17:54:51 <dustymabe> not too hard to add one I guess
17:54:52 <roshi> #action agrimm to update credentials on AWS
17:54:56 <roshi> there is now!
17:54:57 <oddshocks> kushal: sure! there was an email thread i started last night on the cloud WG list that got 2 responses so far, and there'll be another email from me this evening probably regarding developments of the day
17:55:21 <kushal> oddshocks, Yup, read them.
17:55:38 <kushal> oddshocks, I will talk to you after meeting.
17:56:03 <oddshocks> kushal: cool
17:56:17 <roshi> anyone have anything else?
17:56:46 * roshi sets the fuse...
17:57:00 <dustymabe> nope.. +1 to close
17:57:50 <kushal> roshi, end it.
17:57:52 <kushal> :)
17:58:34 <roshi> you got it
17:58:38 <roshi> thanks for coming folks!
17:58:42 <roshi> #endmeeting