15:02:26 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:02:26 <zodbot> Meeting started Tue Oct 21 15:02:26 2014 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:30 <Kevin_Kofler> #meetingname kde-sig
15:02:30 <zodbot> The meeting name has been set to 'kde-sig'
15:02:38 <tosky> hi
15:02:41 * marcdeop is first time present
15:02:44 <dvratil> heya
15:02:47 <Kevin_Kofler> #topic Roll call
15:02:48 <jgrulich> present
15:02:52 <helio|lunch> present
15:03:09 <danofsatx> ahoy y'all
15:03:13 * Kevin_Kofler present and leading the meeting.
15:03:19 <mbriza> hey
15:03:25 * marcdeop just listening
15:03:31 <Kevin_Kofler> (Unfortunately, rdieter will not be able to attend today.)
15:03:37 <Kevin_Kofler> marcdeop: Can you introduce yourself?
15:05:42 <Kevin_Kofler> #chair tosky dvratil jgrulich heliocastro danofsatx mbriza
15:05:42 <zodbot> Current chairs: Kevin_Kofler danofsatx dvratil heliocastro jgrulich mbriza tosky
15:07:00 <Kevin_Kofler> #chair pino|work
15:07:00 <zodbot> Current chairs: Kevin_Kofler danofsatx dvratil heliocastro jgrulich mbriza pino|work tosky
15:07:22 <Kevin_Kofler> #chair ltinkl
15:07:22 <zodbot> Current chairs: Kevin_Kofler danofsatx dvratil heliocastro jgrulich ltinkl mbriza pino|work tosky
15:07:41 <marcdeop> sorry for the delay, should I go ahead an introduce myself?
15:07:59 <Kevin_Kofler> #info Kevin_Kofler, tosky, dvratil, jgrulich, heliocastro, danofsatx, mbriza, pino|work, ltinkl present, marcdeop listening.
15:08:04 <Kevin_Kofler> marcdeop: Go ahead!
15:08:43 <marcdeop> as my nick sugests, my name is Marc Deop. I work as a Sysadmin from Berlin where I moved a few months ago
15:09:02 <marcdeop> I have been using Fedora for quite a while and follow KDE development closely
15:09:24 <marcdeop> for now I would just like to learn how you guys work and see if I can help somehow in the furutre
15:09:41 <Kevin_Kofler> Great, welcome!
15:09:54 <Kevin_Kofler> #topic Agenda
15:10:16 <danofsatx> welcome abored marcdeop!
15:10:23 <Kevin_Kofler> So, what's up for discussion this week? I have at least 2 topics:
15:10:38 <Kevin_Kofler> * status update on PackageKit-hif comps support (needed for Apper)
15:11:12 <heliocastro> Ok, this is me
15:11:13 <Kevin_Kofler> * report (from me) about Calamares packaging efforts
15:11:46 <Kevin_Kofler> Anything else that needs discussion?
15:11:56 <Kevin_Kofler> Or shall we start with the comps stuff?
15:13:17 <Kevin_Kofler> OK, let's start then.
15:13:30 <Kevin_Kofler> #topic status update on PackageKit-hif comps support
15:13:34 <Kevin_Kofler> heliocastro: Any news?
15:16:27 <heliocastro> Kevin_Kofler: Ỳep ano no
15:16:39 <heliocastro> I know what to do, just will do it in the weekend
15:16:44 <heliocastro> Is in my timeline
15:16:51 <Kevin_Kofler> OK
15:16:58 <heliocastro> Time is ok, or need be sooner ?
15:17:35 <Kevin_Kofler> QA says it isn't a blocker for Beta, so I guess it'll be good enough.
15:17:58 <Kevin_Kofler> We'll just need to document that Beta users need to update PackageKit if they want to browse for new packages in Apper.
15:18:06 <Kevin_Kofler> (That's what CommonBugs is for.)
15:18:16 <Kevin_Kofler> #action heliocastro will work on this in the weekend.
15:19:23 <heliocastro> Is there an open bug for this ?
15:19:38 <heliocastro> If not i will open a new one
15:20:07 <Kevin_Kofler> There is an open bug, yes.
15:20:26 <Kevin_Kofler> .bug 1098735
15:20:29 <zodbot> Kevin_Kofler: Bug 1098735 apper: PackageKit-hif (hawkey) backend missing comps group support - https://bugzilla.redhat.com/1098735
15:22:32 <heliocastro> ok, getting the bug for me
15:22:39 <Kevin_Kofler> OK
15:22:46 <Kevin_Kofler> So, can we move on?
15:23:50 <heliocastro> ok for me
15:24:25 <Kevin_Kofler> #topic Calamares installer
15:24:41 <Kevin_Kofler> So, let's start with a report from me and then we can have some discussion if wanted.
15:25:18 <Kevin_Kofler> #info Kevin_Kofler has started work on packaging Calamares:
15:25:23 <Kevin_Kofler> #link https://github.com/calamares/calamares
15:26:17 <Kevin_Kofler> #info for Fedora or remixes. First working package is calamares-0-0.3.20141020git89fe455163c62.fc21:
15:26:24 <Kevin_Kofler> #link http://svn.calcforge.org/viewvc/kannolo/trunk/packages/calamares/
15:26:33 <Kevin_Kofler> #link https://copr.fedoraproject.org/coprs/kkofler/kannolo/build/54055/
15:27:04 <Kevin_Kofler> #info 6 issues have also been reported against upstream Calamares:
15:27:10 <Kevin_Kofler> #link https://github.com/calamares/calamares/issues
15:27:24 <Kevin_Kofler> So where we are at now:
15:27:45 <Kevin_Kofler> * installation of my Kannolo.iso completes
15:28:03 <Kevin_Kofler> * menu entry and/or desktop shortcut missing on the live image
15:28:46 <Kevin_Kofler> * branding still at default (because I don't want to put Fedora branding in the package given that all the official Fedora spins use Anaconda, and Kannolo branding is just generally not ready)
15:29:05 <Kevin_Kofler> (I'll be doing the branding on the kickstart, I think, not in the Calamares package.)
15:29:48 * than is present
15:30:01 <Kevin_Kofler> #info The package can complete an installation, no menu entry yet, only default branding.
15:30:44 <Kevin_Kofler> #info The idea is that Calamares can be an alternative to Anaconda's liveinst, and possibly replace Anaconda/liveinst on the KDE/Plasma spin/product eventually.
15:30:51 <Kevin_Kofler> #chair than
15:30:51 <zodbot> Current chairs: Kevin_Kofler danofsatx dvratil heliocastro jgrulich ltinkl mbriza pino|work than tosky
15:31:20 <Kevin_Kofler> So, that's pretty much the status, now we can have discussion: feedback, comments?
15:31:36 <Kevin_Kofler> Or even a proposal for a plan to move our spin to Calamares?
15:32:33 <ltinkl> Kevin_Kofler: have you tried it in your own spin? :)
15:32:41 <Kevin_Kofler> Do note that Calamares still needs quite some work also upstream. For example, the keyboard layout setting is only used during the installation and not persisted on the installed system, language setting is missing entirely, EFI support is being worked on this week etc.
15:32:46 <tosky> well, first it needs a working code; is Calamares used by other distributions, even in the current not-stable state? Also, is it live only?
15:32:58 <Kevin_Kofler> ltinkl: Yes.
15:33:06 <Kevin_Kofler> The main technical difference to the official KDE spin IS the installer.
15:33:18 <Kevin_Kofler> That said, I have SELinux off on my spin.
15:33:33 <Kevin_Kofler> So there might be extra work needed to get SELinux to work.
15:34:33 <Kevin_Kofler> If you want to test: http://svn.calcforge.org/viewvc/kannolo/trunk/kickstart/ – run build.sh to build the ISO, then test-hdd.sh to test it with a HDD image so you can test Calamares.
15:35:14 <Kevin_Kofler> Oh, and then run "kdesu -t calamares" in a Konsole, -t so you see the terminal output.
15:35:15 <heliocastro> what make calamares an better optoin than vlc ?
15:35:26 <Kevin_Kofler> VLC?!
15:35:35 <heliocastro> calamares is not a media player ?
15:35:39 <Kevin_Kofler> No.
15:35:42 <Kevin_Kofler> It's an installer.
15:35:48 <Kevin_Kofler> At least the Calamares I'm talking about.
15:35:56 <heliocastro> Ahh, ok, sorry
15:36:04 <Kevin_Kofler> It's a replacement for Anaconda liveinst.
15:36:22 <Kevin_Kofler> It's a cross-distro installation framework.
15:36:31 <ltinkl> it's plugin based, you could write a plugin to play a video during the installation *g*
15:36:41 <Kevin_Kofler> :-)
15:37:01 * ltinkl remembers some old SUSE installer having a game inside
15:37:12 <Kevin_Kofler> Yes, they embedded KSirtet.
15:37:18 <ltinkl> ah ye
15:37:20 <heliocastro> ltinkl: Yep ,tetris like
15:38:16 <Kevin_Kofler> The idea of the "framework" is, you just need to set some config files: http://svn.calcforge.org/viewvc/kannolo/trunk/packages/calamares/calamares-default-settings.patch?revision=37&view=markup (plus the branding that I didn't set yet) and you have a working installer for your distro.
15:38:23 <tosky> caldera too maybe (tetris)
15:39:09 <ltinkl> Kevin_Kofler: I see the benefits for post-install, I'm just a bit worried about the destructive actions being safe and well-tested (mainly partitioning and copying to disk)
15:39:26 <Kevin_Kofler> I also needed 2 simple patches for now: http://svn.calcforge.org/viewvc/kannolo/trunk/packages/calamares/calamares-grub2-tools.patch?revision=42&view=markup http://svn.calcforge.org/viewvc/kannolo/trunk/packages/calamares/calamares-device-source.patch?revision=41&view=markup – issues filed
15:40:06 <Kevin_Kofler> And if we need custom modules, they're very easy to write.
15:40:21 <Kevin_Kofler> Some modules are just a dozen lines of Python.
15:40:28 <Kevin_Kofler> C++ modules are also possible.
15:40:55 <Kevin_Kofler> ltinkl: The main benefit is that it doesn't require GTK+. :-)
15:41:10 * heliocastro dream on anaconda in Qt
15:41:15 <heliocastro> but is just me
15:41:36 <Kevin_Kofler> (Well, currently, there's a silly calamares → qt5-qtbase-gui → gtk2 depchain, but we're fixing the gtk2 dependency in qt5-qtbase-gui, we just need to filter the autoreqs from the platform plugin that does the GTK+ dialogs.)
15:41:58 <Kevin_Kofler> heliocastro: Well, Calamares basically IS "anaconda in Qt". :-)
15:42:21 <ltinkl> Kevin_Kofler: well the platform stuff is just really plugins, so no need for a hard-dep
15:42:57 <Kevin_Kofler> Right, but it needs an autoreq filter.
15:43:44 <Kevin_Kofler> heliocastro: The difference is that it's trimmed towards live images (installation from a package set is probably doable, but the module would have to be written by somebody, and chances are that any such module would only work on a small set of distros) and that it's cross-distro.
15:45:31 <Kevin_Kofler> Several distros are already using Calamares: Manjaro, KaOS, Netrunner, Maui, BBQLinux, and soon also Chakra.
15:48:57 <Kevin_Kofler> So, is there interest (other than from me) in having Calamares as the new official installer for the KDE spin in the future (like F22 or F23)?
15:50:37 <Kevin_Kofler> Or even… I have heard rumors that the Anaconda developers really want to drop liveinst. So maybe we could even move ALL Fedora live images to Calamares, and then Anaconda could go through with their plans.
15:51:17 <heliocastro> If calamares is qt5 and stable maintained, i don't see why not
15:51:22 <Kevin_Kofler> With Workstation wanting to ship some Qt libraries by default now, the use of Qt shouldn't be a blocker for them at least.
15:51:32 <Kevin_Kofler> Yes, it's Qt 5.
15:51:35 <heliocastro> But there's a whole complex discussion on this with more people than fedora-kde
15:53:33 <Kevin_Kofler> It's maintained very actively right now, but probably TOO actively to be considered "stable" yet.
15:53:58 <Kevin_Kofler> https://github.com/calamares/calamares/commits/master
15:55:44 <tosky> that's a good point to be considered (stabilization, at least of the core)
15:56:19 <Kevin_Kofler> For my remix "Kannolo", the whole thing is experimental at this time, so what's an experimental installer? :-)
15:56:36 <Kevin_Kofler> But of course I wouldn't ship it as the official Fedora KDE installer in F21.
15:56:46 <Kevin_Kofler> But F22 is still 7+ months ahead, isn't it?
15:56:57 <Kevin_Kofler> So it could already be a realistic target, if we really want it.
15:57:09 <Kevin_Kofler> Of course, it would mean sorting out all the politics, which can take ages.
16:00:14 <Kevin_Kofler> So, we're running out of time, anything else on Calamares?
16:01:01 <Kevin_Kofler> #topic Open discussion
16:01:06 <Kevin_Kofler> Or anything else in general?
16:01:17 <Kevin_Kofler> Otherwise I'll close the meeting in 60 seconds.
16:02:24 <Kevin_Kofler> OK, thank you all for coming!
16:02:26 <Kevin_Kofler> #endmeeting