19:03:26 <roshi> #startmeeting Cloud WG
19:03:26 <zodbot> Meeting started Wed Oct 29 19:03:26 2014 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:03:33 <roshi> #topic Roll Call
19:03:36 <kushal> .hellomynameis kushal
19:03:37 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
19:03:43 <roshi> .hellomynameis roshi
19:03:44 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
19:03:52 <dustymabe> .hellomynameis dustymabe
19:03:53 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
19:04:59 <roshi> is jzb around?
19:05:03 <kushal> No one else?
19:05:09 * roshi can't remember if this is an off week for him
19:05:29 <mattdm> i am here
19:06:26 <roshi> well, we've got 6 meeting items to go through
19:06:52 <roshi> #topic (#43) Process for releasing updated images
19:07:01 <roshi> #link https://fedorahosted.org/cloud/ticket/43
19:07:46 <jzb> I'm here
19:07:53 <roshi> hey jzb :)
19:08:43 <kushal> roshi, So, any update on that?
19:09:03 <roshi> not that I'm aware of
19:09:04 * jzb needs to put this meeting in his calendar.
19:09:15 <roshi> jzb: was going to document things on the wiki, iirc
19:09:38 <kushal> I am okay to move it after release.
19:09:46 <roshi> mattdm and dustymabe would have more details
19:10:03 <jzb> roshi: that's correct. I am behind.
19:10:04 * roshi is more of a moderator for cloud meetings than a source of information (most of the time)
19:10:35 <roshi> what? I can't believe that you'd be busy - that makes you the exception, not the rule :p
19:11:20 <dustymabe> so I added a comment to the ticket.. didn't get a response
19:11:42 <kushal> dustymabe, Let me reply :)
19:11:47 <roshi> for this ticket, I think the process is: call for a compose, run the update process on the various registries
19:12:33 <roshi> is this supposed to be the automatic parts of releasing updated images?
19:13:04 <kushal> roshi, We will have to test also, correct?
19:13:12 <roshi> for sure
19:13:53 <dustymabe> looks like this is something we can worry about after GA of F21
19:14:06 <roshi> jzb: dustymabe anything else spring to mind for this ticket aside from dealing with it after release?
19:14:07 <dustymabe> is there a state we can put the ticket in that denotes that
19:14:37 <roshi> we can just take it off the meeting list
19:14:56 <dustymabe> Sounds good.. should I?
19:14:59 * roshi needs to be better about pruning the list and knowing what all tickets we have
19:15:06 <roshi> go for it, I say
19:15:06 <kushal> dustymabe, go ahead.
19:15:20 <kushal> roshi, I will also do that before meetings from now on.
19:15:39 <roshi> sgtm
19:16:03 <roshi> #topic (#38) Automatic Smoketests on Image Build
19:16:13 <roshi> #link https://fedorahosted.org/cloud/ticket/38
19:16:54 * roshi has nothing for this - been busy with general release stuff and there's been no cloud images to test so far for beta
19:17:08 <roshi> and RC3 is baking now
19:17:16 <roshi> agrimm: you have anything for this?
19:17:24 <jzb> sorry, also otp
19:17:41 <roshi> otp?
19:18:08 <kushal> :)
19:18:49 <roshi> I'm +1 for moving this to F22, since we already have a ton to do between now and release
19:18:56 <mattdm> +1
19:18:59 <roshi> (and removing the meeting keyword)
19:19:01 <kushal> +1
19:19:12 <kushal> roshi, i am removing the keyword.
19:19:13 <dustymabe> +1
19:19:20 <number80> +1
19:19:21 <roshi> thanks kushal :)
19:19:27 <roshi> hey number80
19:19:29 <roshi> o/
19:19:38 <number80> \o
19:19:46 * number80 was around since the beginning ;)
19:19:52 <roshi> #topic (#74) Atomic Testday
19:20:03 <roshi> #link https://fedorahosted.org/cloud/ticket/74
19:20:16 <roshi> I think it's safe to assume we'll be doing this after the beta release
19:20:36 <roshi> sorry, didn't see you in roll call :p
19:20:52 <number80> jzb posted a status on the atomic list
19:21:20 <number80> (about the beta latest compose)
19:21:20 <roshi> yeah, but not regarding the test day itself
19:21:26 * roshi is looking at the email now
19:21:52 <roshi> jzb: anything for this ticket?
19:22:21 <jzb> roshi: waiting on a beta :-)
19:22:22 <mattdm> hold on a sec much typign
19:22:46 <mattdm> I think that with docker-storage-setup and possibly k8s and cockpit landing after beta...
19:22:54 <roshi> quick lets move on before he's don't typing!
19:23:02 <roshi> s/don't/done/
19:23:03 <mattdm> we should request a post-beta test compose with those things in
19:23:09 <mattdm> and do the test day on that.
19:23:16 <number80> +1
19:23:18 <roshi> k8s?
19:23:20 <kushal> #link https://bugzilla.redhat.com/show_bug.cgi?id=1158645
19:23:29 <jzb> mattdm: +1
19:23:32 <mattdm> as per http://fedoraproject.org/wiki/QA:SOP_compose_request test composes are done before the milestone freeze at the discretion of qa
19:23:42 <mattdm> k8s = kubernetes, an orchestration tool
19:23:52 <roshi> ah
19:24:15 <roshi> that works for me
19:24:17 * agrimm reads k8 as "kate"
19:24:25 <agrimm> which is much easier to pronounce
19:24:32 <roshi> just need someone to track that for the testday
19:25:50 <mattdm> roshi someone to track that those things are ready and ask for the test candidate?
19:25:57 <mattdm> er, test compose
19:26:00 <roshi> yeah
19:26:10 <roshi> get an image with those packages for the testday
19:26:27 * mattdm looks at jzb, maybe?
19:26:27 <jzb> #action jzb request post-beta test compose with k8s + Cockpit
19:26:39 <roshi> if it were a live image I could make it with the required packages, but I'm not sure how to generate a cloud image locally
19:26:49 <roshi> wfm
19:26:52 <dustymabe> should we create a ticket for the atomic test day and capture this information somehwere?
19:26:58 <dustymabe> oopes nvm
19:27:05 <dustymabe> we have https://fedorahosted.org/cloud/ticket/74
19:27:08 <roshi> lol
19:27:09 <dustymabe> :)
19:27:13 <roshi> yep :)
19:27:32 <mattdm> #info jzb also docker-storage-setup
19:27:39 * mattdm is reviewing docker-storage-setup package right now
19:27:44 <roshi> next ticket...
19:27:48 <jzb> mattdm: not quite in Fedora yet?
19:28:00 <roshi> #topic (#75) State of Cloud Article
19:28:04 <jzb> mattdm: is docker-storage-setup a sub-package for Docker, or?
19:28:09 <kushal> roshi, I am creating notes on how to make cloud images locally. Will talk about it in the open space
19:28:09 <roshi> #link https://fedorahosted.org/cloud/ticket/75
19:28:16 <roshi> sweet
19:28:24 <mattdm> jzb nope new package
19:28:25 * roshi hasn't had time to look into it at all :)
19:28:30 <mattdm> https://bugzilla.redhat.com/show_bug.cgi?id=1158645
19:28:33 <jzb> OK - #75
19:28:35 <mattdm> #info review request https://bugzilla.redhat.com/show_bug.cgi?id=1158645
19:28:37 <jzb> that's also pending beta
19:28:55 <roshi> yeah, 75 didn't need much :)
19:28:57 <jzb> basically I need to update the original text a bit and post once we actually have a beta.
19:29:09 <dustymabe> kushal: what are using to create cloud images locally?
19:29:14 <roshi> sweet, sounds good to me
19:29:16 <roshi> so we can move to the next two I added...
19:29:31 <kushal> dustymabe, Imagefactory
19:29:40 <roshi> let's knock out these two tickets, then we can have kushal show us what's up during open floor :)
19:30:03 <roshi> #topic (#79) FAS Cloud Group
19:30:04 <dustymabe> roshi: ok
19:30:11 <roshi> #link https://fedorahosted.org/cloud/ticket/79
19:30:44 <dustymabe> I think I am too new to have an opinion on this one.
19:30:55 <roshi> well, for things like the calendar
19:31:09 <roshi> QA has a group, qa-admin and we can all edit the calendar
19:31:18 <roshi> and the QA FAS group and some other bits and stuff
19:31:46 <roshi> I just didn't know if others thought it would be useful or not
19:31:56 <roshi> figured I'd get some feedback
19:32:15 <dustymabe> roshi: I like the idea to have a group. I would like some feedback from members with more wisdom though
19:32:15 <roshi> could also provide a list of people who can get cloud access, and so on and so forth
19:32:24 <roshi> you and me both :)
19:32:58 <kushal> roshi, FAS group can be useful in future, I am +1 in this.
19:32:59 <jzb> hang on a sec
19:33:22 <roshi> np jzb
19:34:07 <jzb> weird
19:34:08 <jzb> I thought I saw a cloud group earlier today when I logged in.
19:34:21 <roshi> I didn't see one when I looked
19:34:23 <kushal> jzb, sysadmin-cloud one?
19:34:24 <dustymabe> jzb: prophetic dream?
19:34:31 <jzb> dustymabe: perhaps
19:34:39 <jzb> oh
19:34:41 <jzb> Atomic
19:34:44 <agrimm> roshi, so I think that have a group that maps to cloud (like AWS or GCE) account access is a bit different from the group of people who can edit our calendar
19:34:57 <agrimm> be clear about the use cases in that ticket, please
19:35:07 <roshi> I was thinking the cloud group would be the WG slate
19:35:13 <agrimm> may need multiple groups for what you are hoping to achieve
19:35:14 <roshi> or have a cloud-admin group if we needed two
19:35:21 <kushal> agrimm, yes.
19:35:23 <agrimm> ok
19:35:34 <roshi> right now it's the calendar - but that was a use case I could see wanting in the future
19:35:42 <roshi> or possibly wanting
19:36:29 <roshi> so, to be clear - right now what I'm asking about: do we want a basic cloud group in fas for calendar access?
19:36:57 <number80> roshi: pingou told me that you only need a FAS group for fedocal if you want to restrain access
19:37:18 <number80> for meeting editing rights, you have to add as many people as possible in the meeting
19:37:23 <kushal> roshi, and number80 I guess you both are saying the same thing.
19:38:06 <roshi> oh
19:38:10 <number80> kushal: no, I'm saying we don't need a group for the calendar ;)
19:38:15 <roshi> I didn't know that's how it worked
19:38:27 <kushal> number80, Okay :)
19:38:34 <roshi> .fire roshi for not figuring out how things work
19:38:34 <zodbot> adamw fires roshi for not figuring out how things work
19:38:55 <roshi> so, for any other reason would we want one?
19:39:01 <mattdm> badges!
19:39:05 <roshi> doesn't seem like there's much point now :)
19:39:09 <dustymabe> mattdm++
19:39:14 <roshi> that's true I guess
19:39:22 <jzb> woo! badgers
19:39:23 <kushal> :) +1 from me too
19:39:26 <jzb> er, badges.
19:39:32 <mattdm> there are other ways to do badges, though
19:39:36 <roshi> badgers are mean...
19:40:12 <jzb> roshi: that's OK, so am I https://twitter.com/mattdm/status/527170217102032896
19:40:15 <kushal> roshi, hehe , why?
19:40:16 * roshi isn't in favor of making a group just for a badge
19:40:39 <roshi> lol jzb
19:40:54 <kushal> haha
19:41:04 <roshi> they're pretty territorial kushal :) you don't want to get on the wrong end of one in the woods
19:41:30 <roshi> well, we can go to the next ticket then. I'll close that one out
19:41:34 <kushal> we can get badges in other ways also.
19:41:47 <kushal> roshi, yes please.
19:42:07 <roshi> #topic (#80) Image Criteria
19:42:11 <roshi> #link https://fedorahosted.org/cloud/ticket/80
19:42:51 <kushal> I am totally plus one for this.
19:44:21 <dustymabe> Sounds good to me. I guess we can decide which hosting services we want to be in that list
19:44:35 <roshi> yeah, that's something we'd have to keep up to date
19:44:53 <kushal> digitalocean will also get in that list in future :)
19:45:06 <mattdm> and hopefully hp
19:45:07 <roshi> yeah, I imagine it'll keep growing
19:45:09 <jzb> +1
19:45:09 <dustymabe> kushal: right.
19:45:32 <dustymabe> i'm working with them.. once we have beta I am going to start the process of trying to get our image in their infra
19:45:43 <roshi> sweet
19:45:48 <kushal> mattdm, +1
19:45:57 <roshi> so, a general agreement on this criteria?
19:46:27 <roshi> I'll put an email together and send it to test sometime this week
19:46:42 <roshi> #action roshi to send email regarding new criteria
19:47:08 <roshi> it'll probably only get added for F22 - which is fine since we'll be blocking on this under the criteria cited in the bug
19:47:22 <roshi> so it's not time sensitive I don't think
19:47:26 <jzb> roshi: on the docker image part
19:47:30 <jzb> isn't that base WG?
19:47:34 <jzb> not that I disagree we need that.
19:47:40 <roshi> yeah, it is
19:48:00 <roshi> would have to talk to them about it - but I think it should be easy for us to handle the docker registry pull
19:48:51 <kushal> roshi, I was asking mattdm in #fedora-cloud and as I understood releng is taking care of that (and may be lsm5)
19:49:17 <roshi> or whoever, this was more of a "should this be a criteria" question, not who's going to do it
19:49:34 <roshi> QA is the gatekeepers of the criteria aiui
19:49:37 <jzb> fair enough
19:49:40 <kushal> Okay.
19:49:52 <jzb> I'm +1000 to make sure there's a docker image no matter whence it came.
19:50:01 <roshi> but I'd send the email to base as well as qa and cloud
19:50:18 <roshi> cool - if no one has anything else for this ticket...
19:50:27 <roshi> #topic Open Floor!
19:50:41 <roshi> floor is you're kushal :)
19:50:43 <kushal> I have something.
19:50:51 <roshi> wow, can't type today
19:50:57 <roshi> s/you're/yours/
19:51:24 <kushal> I am asking around too many questions about the processes and the tools related to the Fedora cloud activities.
19:52:03 <kushal> I am going to maintain a working note set for the same, I started today http://worknotes.rtfd.org
19:52:19 <kushal> Right now I managed to create working/bootable Fedora Cloud image.
19:53:06 <kushal> I will have a FAQ section also in it, this document is also for me to keep things in one place but I am sure others will also be able to use it.
19:53:29 <jzb> kushal: silly q - why not keep the notes on the wiki under the cloud space?
19:53:59 <roshi> that's what I was going to ask
19:53:59 <kushal> jzb, I prefer to write in restructuredtext, easier to maintain.
19:54:28 <kushal> jzb, roshi and I can use vim :)
19:55:15 <jzb> kushal: OK. I also prefer Vim, I've just tried to stick with the standard wiki.
19:55:17 <kushal> I found that my frequency of updating wiki pages is much lower than this kind of sphinx doc.
19:55:20 <jzb> kushal: I'm easy.
19:55:30 <kushal> jzb, :)
19:55:45 <roshi> yeah, same here jzb for official-ish tutorials and whatnot I try to stick to the wiki
19:55:58 * roshi dreams of our wiki rivaling that of arch someday...
19:56:02 <kushal> roshi, this is not official tutorial.
19:56:15 <kushal> roshi, just notes which can help others too.
19:56:28 <jzb> OK
19:56:29 <roshi> we should for sure put the tutorial on the wiki
19:56:42 <jzb> kushal: maybe just a link *to* these from the Cloud space on the wiki?
19:56:54 <kushal> jzb, I will add that.
19:56:58 <jzb> kushal: groovy
19:57:20 <kushal> jzb, http://fedoraproject.org/wiki/Cloud page ?
19:57:21 * jzb makes a note to check out readthedocs.org
19:57:43 <kushal> #link http://worknotes.readthedocs.org/en/latest/index.html
19:57:45 <jzb> kushal: yeah, maybe under "Runbooks"
19:57:57 <jzb> http://fedoraproject.org/wiki/Cloud/Atomic_Runbooks
19:58:20 <jzb> looks like oddshocks has been busy there
19:59:07 <kushal> jzb, Okay. Though these much more general notes to the whole cloud thingy than atomic.
19:59:14 <kushal> * these are
19:59:21 <jzb> yeah
20:00:05 <dustymabe> thingy.. a technical term
20:00:23 <roshi> lol
20:00:26 <kushal> EOF from my side.
20:00:52 <sesivany_> guys, do you still have a lot to discuss? we have a meeting scheduled here at 21:00pm. Not sure if to move it somewhere else or wait.
20:01:07 <dustymabe> sesivany_: i think we are pretty much done
20:01:08 <roshi> nope, I was about to set the fuze
20:01:20 <roshi> for sure wouldn't take up an hour :)
20:01:31 <roshi> anything else?
20:01:37 * roshi sets the fuse
20:01:41 <roshi> 3...
20:02:21 <roshi> 2...
20:02:37 <roshi> 1...
20:02:44 <roshi> thanks for coming folks!
20:02:50 <roshi> #endmeeting