19:02:50 <kushal> #startmeeting Cloud WG
19:02:50 <zodbot> Meeting started Wed Nov  5 19:02:50 2014 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:50 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:03:04 <kushal> #topic Roll Call
19:03:16 <jzb> .hellomynameis jzb
19:03:17 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
19:03:21 <kushal> roshi, I know you are in the blocker meeting
19:03:21 <dustymabe> .hellomyname is dustymabe
19:03:28 <roshi> I'm here-ish
19:03:34 <roshi> .hello roshi
19:03:35 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
19:03:39 <kushal> .hellomynameis kushal
19:03:41 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
19:03:42 <dustymabe> .hellomynameis dustymabe
19:03:44 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
19:04:00 <kushal> .chair jzb dustymabe
19:04:00 <zodbot> jzb dustymabe is seated in a chair with a nice view of a placid lake, unsuspecting that another chair is about to be slammed into them.
19:04:11 <kushal> eh
19:04:14 <kushal> .chair jzb
19:04:14 <zodbot> jzb is seated in a chair with a nice view of a placid lake, unsuspecting that another chair is about to be slammed into them.
19:04:22 <kushal> wrong command :(
19:04:23 <roshi> #chair jzb :)
19:04:28 <dustymabe> zodbot: what did I ever do to you
19:04:28 <zodbot> dustymabe: No such package exists.
19:04:39 <kushal> #chair jzb
19:04:40 <zodbot> Current chairs: jzb kushal
19:04:44 <oddshocks> .hellomynameis oddshocks
19:04:44 <kushal> #chair dustymabe
19:04:44 <zodbot> Current chairs: dustymabe jzb kushal
19:04:44 <zodbot> oddshocks: oddshocks 'David Gay' <dgay@redhat.com>
19:04:54 <kushal> #chair oddshocks roshi
19:04:54 <zodbot> Current chairs: dustymabe jzb kushal oddshocks roshi
19:05:04 <kushal> Okay, anyone else ?
19:05:38 <jzb> kushal: is mattdm about?
19:06:03 <kushal> jzb, Not sure
19:06:48 <kushal> I think we can start
19:06:55 <kushal> #topic Previous Meeting Follow-up
19:07:06 <mattdm> i'm here, sorry
19:07:28 <mattdm> dealing with A Thing :)
19:07:49 <kushal> and I missing all links :(
19:09:06 <kushal> Anyone has the list of action items?
19:09:17 <kushal> sorry, can not find the right tabs
19:09:27 <roshi> https://fedorahosted.org/cloud/report/9
19:09:49 <kushal> * jzb request post-beta test compose with k8s + Cockpit
19:09:49 <kushal> * roshi to send email regarding new criteria
19:10:11 <roshi> I didn't get to that yet
19:10:17 <roshi> will try to do today
19:10:32 <jzb> kushal: I need to do that today, have been buried.
19:10:34 <mattdm> roshi: see also https://bugzilla.redhat.com/show_bug.cgi?id=1160833
19:10:41 <mattdm> apparently _docker_ isn't in there?
19:10:46 * mattdm did not test the atomic image
19:11:34 <kushal> mattdm, ouch
19:11:36 * roshi didn't see that bug
19:11:40 <jzb> hmmm
19:11:46 <jzb> that doesn't seem right
19:12:09 <dustymabe> agreed. I haven't touched beta yet
19:12:15 <roshi> I haven't looked at atomic yet at all
19:12:16 <mattdm> roshi: it was filed against docker
19:12:19 <dustymabe> but the builds I pulled from koji last week were fine
19:12:43 <kushal> dustymabe, those were the beta release, correct>
19:12:44 <kushal> ?
19:12:59 <dustymabe> kushal: I believe so.
19:13:07 <scollier> dustymabe, sorry i'm late
19:13:13 <dustymabe> scollier: no worries
19:13:34 <jzb> I'm getting 404s trying to get the Atomic image
19:13:41 <jzb> http://fedoraproject.org/get-prerelease#cloud
19:13:52 <dustymabe> jzb: yeah he mentioned that in the bug report.. that the links are broken
19:14:18 <mattdm> oh! it's the wrong filename
19:14:22 <jzb> I've been testing about 8 billion different Atomic things so things are hazy in my mind, but, ISTR that the last TC worked
19:14:24 <oddshocks> As far as the atomic image goes that I've added to EC2, I have confirmed that it at least boots, you can ssh in, and run /bin/true and whatnot
19:14:25 <jzb> had Docker, etc.
19:14:39 <kushal> jzb, nirik was telling that they are in master mirror iirc
19:14:45 <mattdm> wait no, they're just missing
19:14:47 <mattdm> hmm.
19:15:08 <mattdm> they aren't included in https://dl.fedoraproject.org/pub/alt/stage/21_Beta_RC4/Cloud/Images/x86_64/
19:15:14 <mattdm> that's... not right.
19:15:18 <mattdm> we should have caught that.
19:15:23 <mattdm> *sigh*
19:15:31 <jzb> mattdm: who gets the ticket?
19:15:32 <kushal> mattdm, <maxamillion> informed the same few hours back.
19:15:56 <kushal> jzb, rel-eng?
19:16:56 <jzb> OK
19:16:57 <mattdm> yeah that's something for releng but someone here should also have ownership
19:17:44 <jzb> mattdm: ownership as in verifying or as in actually being able to do something about it...
19:17:45 <kushal> mattdm, should I add it to my todo/check list?
19:17:45 <dustymabe> ok. so where can I download it? I guess I'll start one up and try to confirm whether docker works or not for me
19:18:16 <kushal> dustymabe, https://kojipkgs.fedoraproject.org//work/tasks/4506/7974506/Fedora-Cloud-Atomic-20141028-21_Beta.x86_64.raw.xz is the one iirc
19:18:17 <mattdm> kushal: sounds good, yes :)
19:18:31 <jzb> so
19:18:46 <jzb> the one Ed found is 20141029-21
19:18:56 <jzb> that one is 20141028-21
19:19:05 <kushal> #action kushal will keep an eye to verify actual release images on the mirrors
19:19:48 <kushal> dustymabe, jzb then https://kojipkgs.fedoraproject.org//work/tasks/8938/7978938/Fedora-Docker-Base-20141029-21_Beta.x86_64.tar.gz
19:19:56 <kushal> oops that is docker :(
19:20:23 <jzb> Yeah, I'm not seeing a 29 here
19:20:29 <kushal> jzb, Strange, I can not find a 20141029 build
19:20:30 <jzb> what's up with that?
19:21:00 <dustymabe> so.. the one that kushal linked (had a 28 in it) is that the wrong one
19:21:13 <dustymabe> 20141028-21_Beta
19:21:19 <kushal> dustymabe, yes and we can not find any 29 build
19:21:21 <jzb> I'm wondering where the hell the 29 came from
19:21:34 <oddshocks> the one I was told to do for atomic was https://kojipkgs.fedoraproject.org//work/tasks/4506/7974506/Fedora-Cloud-Atomic-20141028-21_Beta.x86_64.raw.xz
19:21:47 <oddshocks> and that is the one on EC2 right now
19:21:49 * jsmith shows up late, sorry
19:22:21 <jzb> kushal: I'm about to file a releng ticket or do you want to?
19:22:35 <kushal> jzb, please go ahead on that.
19:22:53 <kushal> Found the issue
19:22:58 <kushal> At least I think so
19:23:04 * mattdm is afk for a few minutes
19:23:16 <dustymabe> kushal: what issue?
19:23:20 <kushal> mattdm, jzb He mentioned that he downloaded the image from http://mirror.pnl.gov/fedora/linux/releases/test/21-Beta/Cloud/Images/x86_64/
19:23:28 <kushal> There are only cloud base images
19:23:37 <kushal> Of course no docker in inside of them
19:23:45 <jzb> Yeah
19:24:39 <kushal> Means this is not a bug, he is supposed to use the atomic image, instead he used base cloud image
19:24:50 <kushal> I guess because of broken links to the mirrors.
19:25:08 <jzb> kushal: there's some valid complaints regardless.
19:25:16 <jzb> kushal: so let's leave it open because we need to fix the docs issues.
19:25:17 <kushal> jzb, True,
19:25:24 <kushal> jzb, Okay.
19:25:58 <dustymabe> kushal: it is worth updating the ticket though :)
19:26:07 <kushal> dustymabe, I will do that after the meeting.
19:26:27 <kushal> dustymabe, https://bugzilla.redhat.com/show_bug.cgi?id=1160833 this one, correct?
19:26:27 * lalatenduM forgot abt the cloud sig meeting :/
19:26:49 <jzb> dustymabe: already done
19:26:51 * kushal always get confused between bugs and tickets as we use both bugzilla and track
19:27:18 <kushal> jzb, thanks :)
19:27:24 <dustymabe> kushal: correct
19:28:03 <jzb> kushal: we do not lack for variety in tracking systems.
19:28:10 <kushal> jzb, hehe :)
19:28:57 <kushal> #action jzb to file rel-eng ticket for missing images
19:28:58 <dustymabe> just spun up the image.. docker run -it busybox worked fine
19:29:13 <kushal> Moving to action itesms
19:29:17 <kushal> * items
19:29:22 <kushal> oops
19:29:25 <kushal> agenda items
19:29:56 <kushal> #topic Plan test days for Atomic image (#74)
19:29:57 <jzb> kushal: https://fedorahosted.org/rel-eng/ticket/6032
19:30:14 <kushal> #link https://fedorahosted.org/rel-eng/ticket/6032
19:30:31 <roshi> I think meetbot automatically #links any url
19:31:26 <jzb> (It would be *awesome* if I was automatically logged into all Trac instances on Fedorahosted when I log into one...)
19:31:48 <jzb> kushal: this is pending the test compose with k8s and cockpit
19:32:22 <jzb> I pinged walters last week + he added those to the json files, and we *thought* they would get pulled automatically before TC4 for beta.
19:32:33 <jzb> why that didn't work I do not know.
19:32:53 <jzb> #action jzb follow up on tc for Atomic test days image
19:33:04 <mattdm> lmacken is working on the automatic compose stuff -- maybe he knows?
19:33:05 <jzb> #link https://fedorahosted.org/cloud/ticket/74
19:33:26 <mattdm> we also need the URL for f21
19:33:31 <jzb> mattdm: IIRC you said we need to work with QA to request the TC?
19:33:39 <jzb> mattdm: sorry?
19:33:59 <mattdm> jzb I was refering to the json file bit
19:34:09 <mattdm> or are you asking about what I said about a URL? :)
19:34:26 <mattdm> sorry, I'm task-swapping between things here
19:36:01 <jzb> mattdm: URL
19:36:55 <mattdm> right now, --url=http://dl.fedoraproject.org/pub/alt/fedora-atomic/repo is only rawhide, as i understand it
19:37:41 <mattdm> yeah http://dl.fedoraproject.org/pub/alt/fedora-atomic/repo/refs/heads/fedora-atomic/
19:37:46 <mattdm> so what's the public url for f21?
19:38:01 <jzb> ah, OK
19:38:11 <mattdm> this also needs to be in the spin kickstart before we have a tc
19:39:30 <jzb> OK
19:39:59 <jzb> Not sure how quickly this will happen
19:40:05 <jzb> when do we want to set the test days?
19:40:20 <mattdm> jzb: it's possibly that it's already 90% of the way there. I think only lmacken knows
19:40:42 <jzb> OK
19:40:58 <jzb> is next Thursday too soon for a test day?
19:41:50 <dustymabe> jzb: a better question might be: when is the latest day we can do?
19:41:51 <jzb> I'll be in EU the week after that, and the week after that is US holiday...
19:41:55 <dustymabe> and work from there
19:42:06 <kushal> Sorry my network went down, now using the mobile network
19:42:21 <kushal> jzb, It is good.
19:42:40 <dustymabe> jzb: I'll do my best to take off but I can't make any promises
19:42:45 <dustymabe> I really want to be involved though
19:43:10 <jzb> let's go w/next Thursday as a target then.
19:43:34 <kushal> jzb, There are few people from RH bangalore office who wants to attend atomic test day iirc
19:44:02 <dustymabe> jzb: ok. is this something we should publicize ?
19:44:17 <lalatenduM> kushal, I am one of them :)
19:44:31 <kushal> lalatenduM, yup :)
19:44:34 <dustymabe> lalatenduM: we really appreciate it
19:44:38 <jzb> dustymabe: once I get a thumbs up from lmacken and such that we'll have an image...
19:44:45 <lalatenduM> dustymabe, :)
19:44:50 <dustymabe> lalatenduM: do you think thursday works for you al?
19:45:24 <dustymabe> jzb: send out an email to the cloud list once it is official.. the more people we can get the better it will be
19:45:27 <kushal> Okay, going to the next item then
19:45:29 <dustymabe> i'll put out word too
19:45:32 <lalatenduM> dustymabe, should be ok, have we decided which thursday?
19:45:45 <dustymabe> jzb: is pushing for next thursday?
19:45:50 <dustymabe> I believe
19:45:53 <lalatenduM> ok
19:45:57 <kushal> dustymabe, Yes
19:46:07 <jzb> Yeah
19:46:09 <kushal> #topic Article for Fedora Magazine on "state of cloud SIG/product" for beta release (75)
19:46:23 <kushal> #link https://fedorahosted.org/cloud/la/75
19:47:03 <kushal> I am still having 5-10 seconds lag
19:47:06 <jzb> kushal: I think the right link is https://fedorahosted.org/cloud/ticket/75
19:47:23 <kushal> oops
19:47:27 <jzb> looks like something got elided there
19:47:46 <kushal> No clue where that la came from :(
19:47:56 <jzb> no worries
19:48:11 <jzb> anyway - I'll pub this next Tuesday assuming 1) we find the missing images, and 2) are ready for Thursday
19:48:18 <jzb> I'll add a note to this about the test day
19:48:49 <dustymabe> jzb: how soon will we know if next thursday is a go
19:48:59 <jzb> dustymabe: dude, I don't know.
19:49:43 <dustymabe> ok.
19:49:53 <kushal> We will just wait for the announcement.
19:50:26 <kushal> Moving to the next ticket then.
19:50:36 <dustymabe> the reason I ask is because it makes it difficult for people who volunteer to participate if we don't announce it until a few days in advance
19:50:46 <dustymabe> kushal: ok moving on
19:50:53 <jzb> dustymabe: I'm aware of that.
19:51:10 <kushal> #topic Public Uploaded Images Criteria (#80)
19:51:18 <kushal> #link https://fedorahosted.org/cloud/ticket/80
19:51:51 <oddshocks> I updated that ticket with a note that the beta AMIs are all set
19:51:51 <kushal> I was talking with lsm5 about the docker release.
19:51:55 <oddshocks> as per that comment I link to
19:53:54 <jzb> kushal: I feel like there was more coming after that sentence.
19:54:47 <kushal> He was doing it manually, dgilmore confirmed that automated builds out of koji to docker registry is not working yet, too many things are not in place in docker's side.
19:54:48 <kushal> Any other comments on this?
19:55:11 <kushal> My network is going down again and again.
19:55:21 <jzb> kushal: so, where does that leave us?
19:55:35 <jzb> kushal: are we getting images to Docker at all, or...?
19:55:38 <kushal> jzb, manual uploads from lsm5 as of now.
19:55:51 <jzb> kushal: are those going to be "official"?
19:56:19 <kushal> jzb, Those are the formal fedora images as of now, but not official ones.
19:56:28 <kushal> means if you do docker pull fedora
19:56:32 <mattdm> I think manual uploads of things w_which are produced in koji_ should be able to be official
19:56:43 <jzb> +1
19:56:46 <mattdm> as long as users can clearly trace the path to koji
19:57:01 <kushal> mattdm, lsm5 maintains separate repo altogether, not from koji
19:57:05 <mattdm> it's unfortunate that docker doesn't have tooling to do it, but...
19:57:16 <jzb> I guess it's a matter of semantics, if you look on Docker Hub it says "official repo"
19:57:18 <mattdm> yeah but lsm _can_ pull the image from koji, right?
19:57:27 <mattdm> jzb: that's docker official, not fedora official
19:57:28 <kushal> mattdm, Yes, he can.
19:57:41 <jzb> mattdm: I wonder how many users make / get the distinction.
19:58:04 <kushal> jzb, almost no one, that is why we have to fix it soon.
19:59:18 <kushal> Moving to next topic then.
19:59:21 <kushal> #topic participation in OpenShift Commons (#83)
19:59:29 <kushal> #link https://fedorahosted.org/cloud/ticket/83
19:59:32 <kushal> This is new.
19:59:45 <kushal> mattdm, Can you tell us a bit more on this?
20:02:34 <kushal> Time is already over :(
20:02:52 <kushal> Is there anything else for open spaces?
20:03:03 <kushal> We can discuss those till mattdm comes back.
20:04:17 <dustymabe> kushal: I have one
20:04:29 <dustymabe> https://lists.projectatomic.io/projectatomic-archives/atomic-devel/2014-September/msg00036.html
20:04:40 <dustymabe> looks like this is still an issue in Beta
20:05:53 <kushal> mattdm_, Can you please tell us about " participation in OpenShift Commons" ?
20:06:32 <jzb> dustymabe: looks like walters responded and asked a follow-up or at least seems aware of the possible issue.
20:06:35 <mattdm> hi sorry back online
20:06:51 <jzb> dustymabe: maybe ping him about it and see if it's likely to be taken care of soon?
20:07:11 <dustymabe> jzb: ok I will.. this is something we probably want fixed though
20:07:17 <mattdm> kushal openshift commons seems like a good opportunity for us...
20:07:35 <mattdm> we can work on what would be needed to get origin v3 back in the distro
20:07:50 <jzb> dustymabe: pardon my ignorance, but couldn't this be corrected with cloud-init as well?
20:08:05 <mattdm> and coordinate on efforts related to docker and atomic
20:08:11 <jzb> e.g. provide a cloud-init setup that people could load and get the right groups, etc.?
20:08:17 <kushal> mattdm, Okay.
20:08:28 <dustymabe> jzb: sure.. but that's not really a great answer
20:08:43 <kushal> mattdm, iirc there is already a board ticket on the same, correct?
20:09:07 <jzb> dustymabe: yeah, but IIRC we have to use cloud-init with all the images right now anyway
20:09:23 <mattdm> kushal yeah, and josh reasonably asks if we have the interest to make it really mean something
20:09:25 <jzb> dustymabe: so, failing Colin getting the bug fixed before final, we at least might be able to address it.
20:09:47 <dustymabe> jzb: true
20:10:09 <jzb> getting the bug/configuration fixed seems better, of course.
20:10:27 <jzb> mattdm: I have a fair amount of interest, FWIW
20:10:30 <dustymabe> jzb: although I don't think cloud-init is a requirement..
20:10:36 <jzb> mattdm: whether I have the *time* or whatever is another story
20:10:46 <dustymabe> jzb: ^^ me too
20:10:55 <dustymabe> no time.. lots of interest
20:10:58 <kushal> mattdm, So what should be the next step for us?
20:11:14 <jzb> I need to head out in a minute, have to get my eyes examined.
20:11:28 <jzb> time for the yearly game of "how blind am I now?"
20:12:49 <kushal> I am going to close the meeting now, we can carry on this discussion over the mailing list.
20:12:52 <mattdm> kushal if we _do_  have sufficient interest and a little time, telling the board officially that we do :)
20:13:19 <kushal> mattdm, which I think we do :)
20:13:37 <kushal> mattdm, Should I update in the board ticket?
20:15:16 * roshi has something for Open Floor when we get there
20:15:22 <roshi> (didn't want to forget)
20:15:29 <kushal> #link http://origin.openshift.com/commons
20:15:36 <kushal> Moving to open floor then
20:15:51 <kushal> #topic Open Floor
20:15:59 <kushal> roshi, stage is yours.
20:16:05 <roshi> :)
20:16:22 <roshi> are we going to keep the 1900 UTC time for meetings with DST changes?
20:16:30 <dustymabe> :)
20:16:50 <roshi> because right now we butt right up to the end of the fesco meeting
20:16:53 <dustymabe> roshi: once F21 is done will blocker meetings still be an issue?
20:17:07 <kushal> roshi, 1900 UTC is already 12:30AM for me :)
20:17:27 <roshi> and QA is looking at what time the blocker meeting is, if it sticks to US local time or to UTC
20:17:58 <roshi> I just didn't know if we were changing anything due to the DST time
20:18:22 <dustymabe> I'd like not to have to go through the whole process again of finding a new meeting time
20:18:35 <dustymabe> but if we have enough people who can't make it then we will of course do that
20:18:53 <oddshocks> I'm good with either time.
20:19:04 <kushal> 1900 is better for me :)
20:20:09 <roshi> I just have blocker meetings during this
20:20:31 <oddshocks> I also go to those but it's less of a big deal for me since roshi runs those things
20:20:58 <roshi> yeah :)
20:20:59 <dustymabe> roshi: did your blocker meeting move with DST or not?
20:21:16 <roshi> it's still up the air
20:21:26 <kushal> This is why the world should get only UTC :)
20:21:26 <roshi> figured I'd see what we were doing here
20:21:33 <roshi> so I knew how to lobby :p
20:22:22 <kushal> roshi, please keep it on 1900 :)
20:22:55 <roshi> I have to talk to adam about it and ping the list
20:22:59 <roshi> but that's all I had
20:23:14 <dustymabe> roshi: ok. let us know.. we might be able to switch the day or something
20:23:20 <dustymabe> thanks
20:23:29 <dustymabe> one last open floor thing
20:23:50 <dustymabe> does it bug you guys that in atomic the root prompt looks like:
20:23:53 <dustymabe> -bash-4.3#
20:24:08 <dustymabe> instead of a normal looking root prompt in F21
20:24:15 <oddshocks> hm I didn't notice
20:24:28 <kushal> dustymabe, It should look the same.
20:24:37 <oddshocks> I `chsh oddshocks -s /bin/zsh` first thing on a new install ;)
20:24:58 <dustymabe> I invite you guys to prove me wrong but I believe they don't behave the same
20:26:52 <dustymabe> do we agree that if it is differeing behavior then we should get it fixed or at least filed?
20:27:47 <kushal> dustymabe, We should
20:27:53 <kushal> dustymabe, Please file a bug.
20:28:06 <dustymabe> kushal: will do
20:28:14 <dustymabe> ok endmeeting?
20:28:33 <kushal> #endmeeting