#fedora-meeting: Env and Stacks (2014-11-26)

Meeting started by vpavlin at 12:01:05 UTC (full logs).

Meeting summary

  1. init process (vpavlin, 12:01:38)
  2. Follow-ups (vpavlin, 12:02:21)
    1. https://fedoraproject.org/wiki/User:Ncoghlan/User_level_package_management (vpavlin, 12:09:30)
    2. ncoghlan started with a draft for a "User Level Package Management" topic (vpavlin, 12:12:19)
    3. bkabrda plans to deploy devpi (vpavlin, 12:12:19)
    4. devpi instance wil be here: 209.132.184.166 (nothing is there ATM) (vpavlin, 12:16:35)

  3. Language specific repositories (vpavlin, 12:16:54)
    1. ACTION: ncoghlan to describe the devpi pilot and what we'd like to get out of it (vpavlin, 12:19:09)
    2. Koji devels are looking into building non-RPM content (Java jars in the first place) (vpavlin, 12:23:32)
    3. WRT vondruch'a opinion, Ruby might not be good candidate for "Language specific repositories" project (vpavlin, 12:36:37)
    4. Python's PEP 440 versioning scheme explicitly introduced redistributor support, any ecosystems without that feature may be ill-suited (ncoghlan, 12:38:58)
    5. pip and conda both came out of the Python community - the origins of that split reflects a real difference in the way application developers and data analysts approach their tools (vpavlin, 12:45:23)
    6. ACTION: everybody should look at conda/NixOS and continue to discuss Language specific repositories on ML. (hhorak, 12:53:14)

  4. Election planning (vpavlin, 12:54:17)
    1. Every voting member should state if he wants continue his participation as a voting member in the Env & Stacks WG by 10th Dec 2014, no response counts as negative answer (vpavlin, 12:56:31)
    2. Env&Stacks WG elections should be aligned with FESCo elections as it would be easier for us and users (vpavlin, 12:57:43)
    3. Decision to be made if we want Townhall, Interviews (or nothing?) (vpavlin, 13:04:48)

  5. Chairman for next meeting (vpavlin, 13:06:09)
    1. hhorak to chair meeting on 2014-12-03 (vpavlin, 13:08:40)

  6. Open floor (vpavlin, 13:08:48)


Meeting ended at 13:22:52 UTC (full logs).

Action items

  1. ncoghlan to describe the devpi pilot and what we'd like to get out of it
  2. everybody should look at conda/NixOS and continue to discuss Language specific repositories on ML.


Action items, by person

  1. ncoghlan
    1. ncoghlan to describe the devpi pilot and what we'd like to get out of it


People present (lines said)

  1. ncoghlan (91)
  2. vpavlin (57)
  3. hhorak (30)
  4. vondruch (26)
  5. bkabrda (7)
  6. zodbot (4)
  7. jreznik (3)
  8. mclasen (2)
  9. nphilipp (1)
  10. samkottler (0)
  11. sicampbell (0)
  12. tjanez (0)
  13. juhp (0)
  14. pkovar (0)


Generated by MeetBot 0.1.4.