14:01:56 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:01:56 <zodbot> Meeting started Mon Dec  1 14:01:56 2014 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:56 <randomuser> #meetingname Fedora Docs
14:01:56 <zodbot> The meeting name has been set to 'fedora_docs'
14:01:56 <randomuser> #topic Roll Call
14:02:21 * pbokoc 
14:02:48 * sclark is here
14:03:12 <randomuser> hey sclark, glad you could make it
14:04:00 <sclark> It's nice to be able to be here.
14:05:49 <randomuser> #chair sclark
14:05:49 <zodbot> Current chairs: randomuser sclark
14:06:22 <randomuser> #topic Follow up on last week's action items
14:07:27 <randomuser> three action items volunteered for; I was going to talk about media types in the RNs and IG, talk about fedora-release packages, in RNs, and forward an email
14:07:51 <randomuser> I need to do better with the media types one, but the others are done.
14:08:07 <randomuser> #action randomuser to update RNs, IG with media type guidance
14:09:05 <randomuser> #topic Publican/Publishing
14:09:35 <randomuser> I spend a few hours reading buildbot sources, but otherwise nothing to report
14:10:15 <randomuser> we're going into f21 with the existing platform, obviously
14:11:10 <sclark> Does that mean you still need to use an old version of Publican to publish?
14:11:51 <randomuser> sclark, it does, but I made a copr with that version of publican that can be installed in parallel and should work
14:12:02 <pbokoc> http://copr.fedoraproject.org/coprs/immanetize/publican2/
14:12:16 <pbokoc> randomuser, did you get around to testing it yet, btw? :)
14:12:48 <randomuser> eh... no, I didn't, sadly
14:13:30 <randomuser> any other questions and concerns in this area?
14:14:42 <randomuser> #topic Guide Status
14:14:54 <randomuser> I have nothing to report here - anyone else?
14:15:44 <sclark> I'm making a start on the firewall guide.
14:15:45 <pbokoc> yeah, me neither. Still need the intro section for the IG, but you mentioned that already
14:16:27 <randomuser> sclark, awesome!
14:17:16 <sclark> randomuser: I'm reading through the logs of the Office Hours sessions and working out what needs to go in.
14:17:41 <randomuser> sclark, that repo is awfully bare - should we set aside some time to talk strategy, or would you prefer to just take a run at it?
14:18:33 <sclark> randomuser: I wouold like to get my head around what is already out there but then it would be good to talk about it.
14:19:18 <randomuser> sclark, okay, speak up whenever then.
14:19:33 <sclark> randomuser: Will do. Thanks.
14:21:02 <randomuser> Okay, looks like we're tapped out on guides
14:21:26 <randomuser> #topic Outstanding BZ Tickets
14:21:58 <randomuser> #link http://tinyurl.com/lbrq84
14:22:35 <randomuser> so, we have bugs
14:22:57 <randomuser> #info bugzilla tickets are a place you can find things to do
14:23:59 <randomuser> enough! nobody likes bugs.
14:24:06 <randomuser> #topic Open Floor Discussion
14:25:04 <Sparks_too> GM
14:25:23 <randomuser> Morning, Sparks_too
14:25:59 <fweimer> I see that the old/duplicate version of the Defensive Coding guidelines were recently depublished.
14:26:29 <fweimer> This is good (thanks), but there are no redirects to the current version.  Can such redirects be added?
14:27:12 <randomuser> fweimer, sure, what kind of redirects would you like?
14:29:19 <fweimer> randomuser: docs.fedoraproject.org/en-US/Fedora_Security_Team/html/Defensive_Coding/ to docs.fedoraproject.org/en-US/Fedora_Security_Team/1/html/Defensive_Coding/
14:29:25 <fweimer> (I think.)
14:29:51 <randomuser> not docs.fp.o/defensive-coding to $long-url ?
14:32:42 <fweimer> randomuser: No, we have incoming links for the old URL.
14:33:44 <randomuser> fweimer, ah, ok
14:35:04 <randomuser> #action randomuser to provide redirect for defensive coding guide
14:35:14 <randomuser> Anything else for today?
14:35:54 <smccann> hey folks. I missed the newbie intro section
14:36:13 <smccann> But I'm new :-)
14:36:18 <smccann> (Sandra McCann
14:36:23 <randomuser> oh, my mistake, smccann - I skipped that topic
14:36:28 <randomuser> welcome!
14:36:33 <pbokoc> hey, welcome :)
14:36:42 <smccann> no worries. I was late. Nothing says stellar start like showing up late.
14:37:12 <smccann> Anyway, if there's pointer to where a rank beginner can start helping you out, let me know
14:37:43 <randomuser> smccann, have you read over any wiki pages or the documentation guide yet?
14:38:05 <smccann> Bits here and there. I'm also a fedora newbie so I've been haunting QA for the quick install tests etc
14:38:16 <pbokoc> https://fedoraproject.org/wiki/Joining_the_Docs_Project_checklist is a start
14:38:22 <smccann> my background is techwriting
14:38:31 <smccann> thanks pbokoc!
14:38:52 <pbokoc> smccann, do you have any experience with version control (we use Git) and DocBook?
14:39:12 <smccann> version control yes, Git and DocBook no.
14:39:45 <smccann> but if there's directions somewhere, I can play and come back to the doc channel w/ questions
14:39:50 <randomuser> there's a github tutorial on git that's decent
14:40:13 <smccann> cool, thanks!
14:40:33 <pbokoc> yeah, the tutorial is here: https://try.github.io/levels/1/challenges/1
14:40:47 <smccann> got it thanks!
14:40:56 <randomuser> smccann, I suggest you clone https://git.fedorahosted.org/cgit//docs/documentation-guide.git , build it, read through, and ask questions when they arise
14:41:09 <pbokoc> smccann, the tutorial is very... practical, so you might want to start with some theory first and read http://git-scm.com/book/en/v2
14:41:13 <smccann> ok sounds like a good start
14:41:13 <pbokoc> also an excellent resource
14:41:17 <randomuser> if you find places that need to change, then change them
14:41:27 <smccann> ok
14:42:13 <randomuser> and there are usually people in #fedora-docs or the list if you have questions
14:42:26 <pbokoc> for DocBook, there's this reference: http://www.docbook.org/tdg/en/html/docbook.html
14:42:51 <pbokoc> don't be intimidated, there's a few hundred elements but typically you won't use more than 2 dozen
14:43:40 <smccann> sounds like a great set of options to start out. Thanks folks!
14:43:43 <pbokoc> also, when you clone a book from git.fedorahosted.org, use the "https://" address, not the ssh one
14:43:56 <pbokoc> you need access rights for the latter
14:45:20 <sclark> smccann: There was also an introduction to documentation with publican talk at the recent Flock Conference.  The video is on YouTube http://youtu.be/4eDs74AbLnw?list=UUQIXiF6fxPCtHw_XwHFq6nA
14:45:53 <smccann> thanks sclark
14:47:10 <randomuser> okay, let's adjourn to #fedora-docs
14:47:19 <randomuser> thanks for coming, everyone
14:47:23 <randomuser> #endmeeting