#fedora-meeting: Env and Stacks (2014-12-03)

Meeting started by hhorak at 12:02:01 UTC (full logs).

Meeting summary

  1. init process (hhorak, 12:02:39)
  2. Follow-ups (hhorak, 12:04:26)
    1. https://fedoraproject.org/wiki/Env_and_Stacks/Projects/LanguageSpecificRepositories (ncoghlan, 12:06:03)
    2. https://github.com/pulp/pulp_python (ncoghlan, 12:10:50)
    3. the Java guys has reached a conclusion that downstream maven repository wouldn't have significant benefit, so I'd say that Python is alone as a pilot right now (hhorak, 12:14:20)
    4. Python wheel's currently have a problem where all prebuild Linux binaries get tagged "linux_<arch" (hhorak, 12:14:20)
    5. https://mail.python.org/pipermail/distutils-sig/2014-November/025297.html (hhorak, 12:24:08)
    6. https://mail.python.org/pipermail/distutils-sig/2014-December/025337.html (hhorak, 12:24:15)
    7. we should make some marketing for the 'upstream repository' ideas, so we get feedback from broader community, but not sooner than the devpi instance is out and we have an example of using that in a Dockerfile to install a Python app (hhorak, 12:31:13)
    8. https://fedoraproject.org/wiki/Env_and_Stacks/Projects/UserLevelPackageManagement (ncoghlan, 12:33:38)
    9. ACTION: ncoghlan: add the "trusted curator" rationale to LanguageSpecificRepositories page (ncoghlan, 12:51:52)
    10. ACTION: bkabrda will ask java guys to create a wiki page summarizing the approaches we thought of and why we think it's not worth the effort + post the link to WG ML once it's ready (hhorak, 12:56:37)

  3. SCLs and CentOS (hhorak, 12:59:43)
    1. Software collections development is now slowly moving to CentOS, since that is nice open platform where software collections make much more sense. (hhorak, 13:01:22)
    2. So, what is happening is that CentOS SIG was established that would help to develop some better ecosystem around SCLs where more people can actively participate. (hhorak, 13:01:49)
    3. http://wiki.centos.org/SpecialInterestGroup/SCLo (hhorak, 13:01:53)
    4. better said centos seems to like scls more than fedora (hhorak, 13:07:29)
    5. there are still valid use cases for SCLs in Fedora (hhorak, 13:23:08)
    6. SCLs as a technology should be implemented in Fedora first, irrelevant of its consumption of the content (hhorak, 13:27:41)

  4. Chairman for next meeting (hhorak, 13:39:01)


Meeting ended at 13:44:03 UTC (full logs).

Action items

  1. ncoghlan: add the "trusted curator" rationale to LanguageSpecificRepositories page
  2. bkabrda will ask java guys to create a wiki page summarizing the approaches we thought of and why we think it's not worth the effort + post the link to WG ML once it's ready


Action items, by person

  1. bkabrda
    1. bkabrda will ask java guys to create a wiki page summarizing the approaches we thought of and why we think it's not worth the effort + post the link to WG ML once it's ready
  2. ncoghlan
    1. ncoghlan: add the "trusted curator" rationale to LanguageSpecificRepositories page


People present (lines said)

  1. bkabrda (62)
  2. hhorak (62)
  3. ncoghlan (61)
  4. langdon (43)
  5. juhp (15)
  6. bochecha (14)
  7. Southern_Gentlem (5)
  8. zodbot (4)
  9. RemiFedora (2)


Generated by MeetBot 0.1.4.