#fedora-meeting: Server Working Group Weekly Meeting (2014-12-16)

Meeting started by sgallagh at 16:02:57 UTC (full logs).

Meeting summary

  1. roll call (sgallagh, 16:02:57)
  2. Agenda (sgallagh, 16:07:53)
    1. Agenda Item: Database Server Role Design (sgallagh, 16:08:04)
    2. adamw will work on a proposal for defining/documenting server role capabilities and requirements outside of the release criteria (sgallagh, 16:10:46)

  3. Database Server Role Design (sgallagh, 16:15:19)
    1. https://lists.fedoraproject.org/pipermail/server/2014-December/001694.html (sgallagh, 16:15:57)
    2. rolekit should support creating an admin account when creating the DB, but stay out of user management otherwise (sgallagh, 16:32:09)
    3. AGREED: The Database Server Role will be built with a single local process, with rolekit instances maintaining the databases within it. (lazy consensus) (sgallagh, 16:37:28)
    4. If we select a graphical tool for managing PostgreSQL, it must be able to manage user rights, replication and other system-level tasks (sgallagh, 16:43:54)
    5. A UI for SQL queries is a non-requirement (sgallagh, 16:44:04)
    6. Any UI we employ for the Database Server Role must be integrated with Cockpit in some reasonable way (sgallagh, 16:47:07)

  4. Cantas (sgallagh, 16:54:36)
    1. http://cantas-fedoraserver.rhcloud.com/ (danofsatx-work, 16:55:26)
    2. https://github.com/xychu/cantas ? (adamw, 16:56:15)
    3. https://github.com/onepiecejs/nodejs-cantas (sgallagh, 16:56:24)
    4. Cantas authentication does not integrate with fedoauth (yet) (danofsatx-work, 16:57:55)
    5. Current authentication is only through Google or Kerberos. (danofsatx-work, 16:59:04)
    6. Fedora Infrastructure does not support Kerberos (sgallagh, 16:59:21)


Meeting ended at 17:09:01 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. sgallagh (117)
  2. simo (69)
  3. danofsatx-work (27)
  4. adamw (17)
  5. zodbot (12)
  6. hanthana (8)
  7. mclasen (4)
  8. kushal (3)
  9. mizmo (1)
  10. nirik (0)
  11. mitr (0)
  12. stefw (0)
  13. danofsatx (0)
  14. tuanta (0)


Generated by MeetBot 0.1.4.