15:02:43 <rdieter> #startmeeting kde-sig
15:02:43 <zodbot> Meeting started Tue Dec 16 15:02:43 2014 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:46 <rdieter> #meetingname kde-sig
15:02:46 <zodbot> The meeting name has been set to 'kde-sig'
15:02:48 <rdieter> #topic roll call
15:02:59 <rdieter> hi all, who's present for today's friendly kde-sig meeting?
15:03:06 * danofsatx-work is heah
15:03:11 * heliocastro here
15:03:16 <jgrulich> hello
15:03:26 * donnie is here.
15:03:50 <Kevin_Kofler> Present.
15:06:03 * jreznik is here but will move to smartphone soon
15:06:17 * jwb listens in
15:07:28 <rdieter> #info rdieter danofsatx-work heliocastro jgrulich donnie Kevin_Kofler jreznik jwb present
15:07:39 <rdieter> #chair danofsatx-work heliocastro jgrulich Kevin_Kofler jreznik
15:07:39 <zodbot> Current chairs: Kevin_Kofler danofsatx-work heliocastro jgrulich jreznik rdieter
15:08:02 <rdieter> #topic agenda
15:08:39 <rdieter> ok, agenda... what to discuss today?  my query earlier in #fedora-kde was not productive...
15:08:54 <rdieter> though if there's nothing better, then can discuss plans to rollout plasma5 to rawhide
15:09:00 <Kevin_Kofler> Yeah.
15:09:03 <heliocastro> plasma-5 only ?
15:09:12 <Kevin_Kofler> The sooner, the better. That's what Rawhide is for.
15:09:23 <Kevin_Kofler> We have 6 months to polish it there.
15:09:30 <heliocastro> I agree, even considering current status
15:09:33 <Kevin_Kofler> If we import it late, of course the release will be buggy.
15:09:52 <rdieter> .bug 1135103
15:09:54 <zodbot> rdieter: Bug 1135103 Plasma 5 Tracker - https://bugzilla.redhat.com/1135103
15:09:55 <danofsatx-work> Is there a tracking bug for plasma5?
15:09:56 <rdieter> we have this ^^ tracking bug
15:09:57 <jreznik> Kevin_Kofler: not 6 months
15:09:59 <danofsatx-work> duh....
15:10:17 <jreznik> 5.1.95 is Tue 2015-01-13
15:10:34 <rdieter> https://fedoraproject.org/wiki/Releases/22/Schedule  dpesn
15:10:40 <rdieter> doesn't look solid yet
15:11:01 <rdieter> though Feb-24 is approx feature freeze
15:11:03 <jreznik> would be nice to take a look on it in copr, do some initial testing and start in Rawhide with 5.2.0 if it shows to be in a good state
15:11:10 <jreznik> https://techbase.kde.org/Schedules/Plasma_5
15:12:05 <danofsatx-work> the bugs in that tracker are all review requests or RFEs - should we tie actual bugs to it?
15:12:15 <rdieter> yep
15:12:30 <rdieter> it's there to track all plasma5-related issues
15:12:36 <danofsatx-work> roger ball
15:12:47 <rdieter> obviously, blocker0 is getting plasma5 package reviews done
15:13:22 <Kevin_Kofler> jreznik: So we have at least 5 months, with only "no earlier than" dates.
15:13:59 <jwb> so would plasma5-only be an f22 Change?
15:14:04 <rdieter> oh, and fyi, I created a kde-sig pkgdb group, so theoretically all these new packages could be owned by that, instead of listing all kde-sig'ers individually
15:14:11 <rdieter> jwb: yes
15:14:16 <jwb> ok
15:14:50 <rdieter> (though you can continue to be comaintainers listed separately too if you choose)
15:15:20 <jreznik> well, pls, create f22 change - let's risk it :)
15:15:35 <rdieter> so, while we're on the topic of plasma5 blockers, are we missing any obvious ones?
15:15:38 <jreznik> but still I'd like to have at least the first step - importing to rawhide more cautious
15:15:58 <rdieter> and to make jreznik feel better, have a good contingency plan
15:16:04 <jreznik> thanks :)
15:16:28 <jreznik> usually plasma 5 + 4/5 app mix works pretty well with breeze theming
15:16:30 <argonel> wasn't there something about libinput?
15:17:26 <jreznik> some kcms as far as I know are old systemsettings only
15:17:51 <heliocastro> i'm using plasma5 daily as my production system, and so far so good is good enough to meç but there are few quirks
15:17:51 <jreznik> so would be nice to have list of stuff, that can't be 4 and has to be ported to 5 before release (aka not shipping too systemsettings...)
15:18:08 <Kevin_Kofler> argonel: That's another Change that's not directly related to the Plasma 5 Change.
15:18:17 <jreznik> heliocastro: I spend half hour everyday to get it working next day but let's hope it will be better in time :)
15:18:46 <heliocastro> jreznik: I'm using self compiled with clang
15:19:07 <Kevin_Kofler> The only relation is that kcm_touchpad needs to get ported both to KF5 (not sure what the upstream status is there) and to libinput.
15:19:50 * rdieter adds that to the tracker
15:21:00 <danofsatx-work> I've been running Plasma5 for, oh, 3 weeks now. It has.....issues.
15:21:18 <heliocastro> There's a bug i'm tracking on the notification + screen energy saving
15:21:26 <rdieter> .bug 1174839
15:21:28 <zodbot> rdieter: Bug 1174839 kcm_touchpad kf5 port - https://bugzilla.redhat.com/1174839
15:21:51 <jreznik> but on the other hand, plasma 5 is the first DE that at least somehow supports HiDPI
15:21:55 <heliocastro> If you receive a notification during screen off on nergy saving, plasmashell frezes
15:22:00 <jreznik> it could be good selling point
15:22:07 <heliocastro> indeed
15:23:04 <rdieter> oh, can't forget sddm-kcm
15:23:21 <jreznik> rdieter: yep, we need list of kcms
15:23:34 <jreznik> all list of all stuff that does not make sense in 4/5 combo
15:23:37 <danofsatx-work> yeah, sddm is rather important ;)
15:24:09 <jreznik> (and still needs some polishing)
15:24:28 <jgrulich> actually it's not possible to mix 4/5 kcms
15:24:33 <rdieter> is there any kf5 equivalent to kcm-gtk yet?
15:24:54 <Kevin_Kofler> Speaking of sddm-kcm, that thing urgently needs updating for the config file changes in SDDM 0.10.
15:25:03 <Kevin_Kofler> Right now, what we ship in F21 mostly doesn't work!
15:25:12 <rdieter> there's https://projects.kde.org/projects/kde/workspace/kde-gtk-config
15:25:19 <donniezazen> upstream hasn't released kcm-gtk yet. there is a thread in plasma-devel
15:25:22 <rdieter> but that one has design issues (imo)
15:25:35 <rdieter> doesn't integrate with xsetting-kde (afaik)
15:26:11 <rdieter> not that our kcm-gtk is great in that regard either, but it mostly works
15:27:06 <Kevin_Kofler> I guess I'll have to have a look at the GTK+ stuff (including xsettings-kde), to see what I can do to make it just work also in Plasma 5.
15:27:44 <donniezazen> the one that we currently use is much better and less buggy.
15:28:22 <Kevin_Kofler> For sddm-kcm, there's this one that needs fixing NOW:
15:28:25 <Kevin_Kofler> .bug 1173825
15:28:28 <rdieter> .bug 1174848
15:28:28 <zodbot> Kevin_Kofler: Bug 1173825 sddm-kcm writes obsolete sddm.conf syntax that sddm does not understand anymore - https://bugzilla.redhat.com/1173825
15:28:34 <zodbot> rdieter: Bug 1174848 kf5 kde-gtk-config - https://bugzilla.redhat.com/1174848
15:28:52 <Kevin_Kofler> and this in the KF5 port tracking bug:
15:28:53 <rdieter> #topic plasma5 plan/blockers
15:28:55 <Kevin_Kofler> .bug 1174843
15:28:57 <zodbot> Kevin_Kofler: Bug 1174843 sddm-kcm kf5 port - https://bugzilla.redhat.com/1174843
15:28:59 <rdieter> forgot to update topic
15:29:23 <rdieter> ok, I think I just filed bugs for all the essential kcm's
15:29:28 <Kevin_Kofler> donniezazen: I agree.
15:29:40 <Kevin_Kofler> The problem is that upstream decided to "officialize" the other one.
15:30:18 <donniezazen> I was trying out the other one last week in Kubuntu. There are options that are there but they don't seem to get applied.
15:30:18 <Kevin_Kofler> (which I think makes sense in an environment without xsettings-kde, but with xsettings-kde, we will have to hide/remove most of the settings it offers because they'll be ignored in favor of KDE settings)
15:30:21 <donniezazen> so there is that.
15:30:34 <donniezazen> the one we use at least works as advertised.
15:30:48 <Kevin_Kofler> That said, xsettings-kde also needs to be adapted to new KF5 settings locations.
15:30:50 <rdieter> iirc, all the reviews referenced in the plasma5 blocker are done, not sure of import status (I'll check some now)
15:31:24 <rdieter> yeah, many still have no scm requests submitted, I can help with that post-meeting
15:31:59 <jgrulich> rdieter: I think dvratil wanted to wait until the rest of packages are reviewed
15:32:07 <rdieter> jgrulich: what's left?
15:32:26 <rdieter> are there more that need to be submitted and reviewed besides what is already on the tracker?
15:32:28 <jgrulich> rdieter: I haven't seen packages like plasma-workspace, plasma-desktop
15:32:47 <rdieter> ok, looks like we're still missing a lot
15:33:16 <rdieter> when we get a chance, can ask dvratil if he wants or needs any help getting those all submitted for review
15:34:56 * heliocastro raise hand to help
15:35:22 <rdieter> then the rest of the team pitching in to help with review tasks, of course.
15:35:43 <jgrulich> rdieter: dvratil is on vacation since last friday and will be until the end of this year
15:36:23 <rdieter> jgrulich: yeah, thanks.  otoh, the holidays for some is a good time to help work on this stuff
15:36:50 <rdieter> I wonder if you would mind if we just snatched what was latest in the plasma5 copr, and submitted it for him
15:37:50 <jgrulich> rdieter: I'm fine with that, but I can't speak instead of dvratil :)
15:38:27 <jgrulich> but he is usually available on IRC so we can ask him later
15:38:32 <rdieter> anyone interested in that task?  (I think I've volunteered do to 2-3 things after the meeting already)
15:38:46 <jgrulich> I can do that
15:38:56 <rdieter> jgrulich: great thanks
15:39:09 <jgrulich> I'll ping him and ask him if I can submit some packages instead of him to speedup the process
15:39:34 <rdieter> #action jgrulich will work with dvratil to get remaining plasma5-related packages submitted for review asap
15:40:36 <rdieter> anything else plasma5-related to discuss for now?
15:44:43 <rdieter> I'll take that as a no
15:44:47 <rdieter> #topic open discussion
15:45:08 <rdieter> anything else?  heliocastro, any PK/apper or lxqt news worth mentioning?
15:45:18 <heliocastro> rdieter: lxqt
15:45:34 <heliocastro> There's at least three persons start to using and report issues
15:45:56 <heliocastro> Is good, because i ḿ fine tuning the install. I need now do theme packaging
15:46:12 <heliocastro> and need itroduce group on comps
15:46:24 <heliocastro> No PK/apper news now
15:47:17 <Kevin_Kofler> PK/Apper, I am looking after heliocastro's pull request, making sure all the objections from hughsie get addressed.
15:47:31 <Kevin_Kofler> Last I checked (yesterday), there are still some open ones.
15:48:01 <Kevin_Kofler> Once everything's addressed, I hope hughsie will have another look, or if not, I'll try to nag him.
15:48:25 <Kevin_Kofler> https://github.com/hughsie/PackageKit/pull/20
15:49:15 <Kevin_Kofler> I can give an update on Calamares.
15:49:33 <Kevin_Kofler> A snapshot is now in updates-testing for F21, will reach updates soon.
15:50:50 <Kevin_Kofler> Not sure whether I already mentioned this in a logged meeting, but there is one packaging change that I plan, dropping the NoDisplay=true; from the .desktop file (that the live kickstarts are expected to sed away, a hack copied from Anaconda liveinst packaging), and instead remove the calamares package after installation (which Calamares can easily do).
15:51:21 <Kevin_Kofler> So then you'll get a menu entry if you yum install Calamares on a live image that doesn't ship with it.
15:51:26 <Kevin_Kofler> But that will be for the next update.
15:52:26 <Kevin_Kofler> I'm also working on packaging ufw-kde, I have an initial package of ufw now (not yet submitted for review, I want to have ufw-kde first), but not the KDE part.
15:52:44 <Kevin_Kofler> I also don't know what the KF5 port status of ufw-kde is (it's a KCM).
15:53:30 <Kevin_Kofler> That'll be a nice KDE alternative to the GTK+ firewall-config then, but it needs ufw instead of firewalld.
15:56:51 <rdieter> thanks for the updates, if there's nothing else, I'll end the meeting shortly
16:00:21 <rdieter> k, thanks everyone!
16:00:23 <rdieter> #endmeeting