15:01:09 <pknirsch> #startmeeting Fedora Base Design Working Group (2014-12-19)
15:01:09 <zodbot> Meeting started Fri Dec 19 15:01:09 2014 UTC.  The chair is pknirsch. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:17 <pknirsch> #meetingname  Fedora Base Design Working Group
15:01:18 <zodbot> The meeting name has been set to 'fedora_base_design_working_group'
15:01:47 <pknirsch> #chair haraldh masta dgilmore jreznik ffesti vpavlin msekleta
15:01:47 <zodbot> Current chairs: dgilmore ffesti haraldh jreznik masta msekleta pknirsch vpavlin
15:01:51 <pknirsch> hey everyone!
15:01:57 <jreznik> hi pknirsch!
15:02:00 <nphilipp> hey
15:02:00 <pknirsch> welcome to the last meeting this year for the Base WG
15:02:06 <msekleta> pknirsch, hi
15:02:45 <pknirsch> so lets go into it quickly as we got a lot of stuff today
15:03:12 <pknirsch> #topic Status buildrequires cleanup work (davids & nils!)
15:03:37 <pknirsch> so nphilipp, dazo, any news?
15:04:29 <nphilipp> pknirsch: not much of a new status I'm afraid. I cleaned up some stuff (ongoing), found that there are some bugs regarding timestamps in the XMLRPC interface.
15:04:32 <nphilipp> ...
15:05:03 <pknirsch> nphilipp: alright, no worries
15:05:19 <nphilipp> Then I told myself "do it bottom up as you'd usually do", i.e. just a shell script which goes through the list of packages to test and records results in text files, to fill the DB later.
15:05:46 <nphilipp> Unfortunately mock doesn't want to build F21 packages on the ppc64 machine I have for building, that's where I'm at.
15:06:44 <pknirsch> lets directly move on then as we have ffesti here today
15:06:51 <pknirsch> thanks nphilipp
15:06:59 <nphilipp> yw, it wasn't much :)
15:07:08 <pknirsch> next year!
15:08:22 <pknirsch> #topic Docker update / Rocket container check
15:08:39 <pknirsch> so vpavlin or msekleta any news there?
15:09:10 <msekleta> quiet on the Docker front AFAICT
15:09:35 <msekleta> meaning they still didn't merge the most important pull request
15:09:58 <haraldh> in case, you haven't seen it yet, systemd git HEAD can now download and start docker containers :) https://plus.google.com/115547683951727699051/posts/SkKuBF1XaNF
15:10:05 <haraldh> just a side note :)
15:11:32 <pknirsch> O.o
15:11:34 <pknirsch> sweet
15:11:47 <pknirsch> so systemd running docker instead of docker running systemd
15:11:50 <pknirsch> nice touch :P
15:12:19 <msekleta> as for rocket, vpavlin been playing with it a week or so back. I was giving it a test run two days ago and didn't get far with latest git (still too many rough edges)
15:12:45 <pknirsch> mhm
15:12:52 <pknirsch> so much of it is still vaporware
15:12:54 <pknirsch> not surprising
15:13:44 <pknirsch> anything else msekleta, vpavlin, haraldh ?
15:14:12 <msekleta> but in any case, I don't think that rocket is really something we (Fedora community) should be much concerned about. The valuable bit is Container Image spec and only future will tell if that gets wider adoption
15:14:23 <haraldh> msekleta, true
15:14:38 * pknirsch nods
15:14:58 <haraldh> anybody looked closer on canonical's snappy?
15:15:11 <msekleta> I didn't
15:15:11 <jreznik> nope
15:15:20 <haraldh> http://www.ubuntu.com/cloud/tools/snappy
15:15:23 <haraldh> for the reference
15:16:16 <pknirsch> maybe something to look at next year then?
15:16:59 <pknirsch> lets keep that for next year then and put it on the agenda for review
15:17:01 <haraldh> nothing new on the idea front, I think :)
15:17:08 <pknirsch> kek
15:17:13 <haraldh> pknirsch, :)
15:17:26 <msekleta> also there is proposal for coreos to move away from btrfs to ext4 and overlayfs
15:17:28 <msekleta> https://groups.google.com/forum/#!topic/coreos-dev/NDEOXchAbuU
15:17:34 <pknirsch> interesting
15:17:55 <haraldh> we need more btrfs devs ironing out the bugs! :)
15:19:10 <pknirsch> ok, but lets move on to the rpm stuff
15:19:15 <pknirsch> #topic Status rpm mechanisms for multiple config subpackages
15:19:18 <ffesti> or more devs ironing out btrfs...
15:19:26 <pknirsch> so haraldh and ffesti, anything there yet?
15:19:52 <ffesti> well, we now have some docs of the plugin interface on rpm.org
15:19:53 <haraldh> ffesti, or that, by extending the other FS
15:20:31 <ffesti> otherwise the rpm team lost one member, so time for side projects as this has become a bit more sparse
15:20:55 * pknirsch nods
15:21:34 <haraldh> well, plugin interface was not for rpmbuild... right?
15:21:46 <ffesti> no, it is for rpm itself
15:22:02 <ffesti> which has the benefit of not requireing changes to packages
15:22:20 <haraldh> topic Status rpm mechanisms for multiple config subpackages
15:22:23 <ffesti> you can just register/copy /hwhatever files at install time
15:22:53 <ffesti> well, that's basically done. I just need to find the time to do some more testing to get it upstream
15:23:13 <ffesti> if someone is interested I can hand out the patch
15:23:14 <pknirsch> #info ffesti: that's basically done. I just need to find the time to do some more testing to get it upstream
15:23:24 <ffesti> so you have something to play with over the holidays
15:23:53 <ffesti> and check if this is what you actually want
15:25:32 <pknirsch> haraldh, sounds good to you?
15:26:29 <haraldh> sure
15:26:34 <pknirsch> oki :)
15:26:45 <haraldh> not my feature, but msekleta's
15:26:48 <haraldh> but yeah
15:26:54 <pknirsch> so msekleta :)
15:26:58 <msekleta> ffesti, can you email me the patch?
15:27:07 <ffesti> sure
15:27:12 <msekleta> ffesti, thanks
15:27:23 <pknirsch> cool, thanks guys!
15:27:46 <pknirsch> lets move to the other rpm topic then:
15:28:00 <pknirsch> #topic Status rpm mechanisms for factory reset files
15:28:15 <pknirsch> so again ffesti and haraldh i think, any news there?
15:28:28 <haraldh> patch for me also plz!
15:28:37 <msekleta> I think that can be also implemented with plugin rights?
15:29:00 <haraldh> can be.. but I would like to see it in rpmbuild
15:29:04 <ffesti> oh, the lines above was actually more pointed as this topic
15:29:11 <haraldh> also for "rpm -qf"
15:29:15 <dgilmore> hey all
15:29:17 <haraldh> ah... so patch is for me :)
15:30:09 <ffesti> Last thing I remember was to not do it in rpmbuild
15:30:22 <pknirsch> hm
15:31:14 <pknirsch> maybe there was a confusion then ffesti and haraldh ?
15:31:30 <ffesti> I have a hard time remembering anything else
15:33:17 <pknirsch> haraldh, maybe that needs to be revisited and clarified then again?
15:33:41 <haraldh> yeah, let's see the patch
15:34:04 <pknirsch> oki, lets go with that first
15:34:07 <pknirsch> thanks guys!
15:34:17 <ffesti> ehm, what patch?
15:34:28 <ffesti> the line I was referining to were:
15:34:43 <msekleta> fwiw, here is log from mtg where this was discussed http://meetbot.fedoraproject.org/fedora-meeting/2014-10-24/fedora_base_design_working_group.2014-10-24-15.02.log.txt
15:35:08 <ffesti> <ffesti> well, we now have some docs of the plugin interface on rpm.org
15:35:15 <ffesti> <ffesti> otherwise the rpm team lost one member, so time for side projects as this has become a bit more sparse
15:35:33 <ffesti> <haraldh> well, plugin interface was not for rpmbuild... right?
15:35:33 <ffesti> <ffesti> no, it is for rpm itself
15:35:33 <ffesti> <ffesti> which has the benefit of not requireing changes to packages
15:35:42 <ffesti> <ffesti> you can just register/copy /hwhatever files at install time
15:35:52 <ffesti> the line with the patch is for the previous topic
15:37:13 <ffesti> From the last meeting:
15:37:16 <ffesti> 15:13:58 <ffesti> or if doing some runtime solution is more practical
15:37:16 <ffesti> 15:14:14 <ffesti> especially in the light of 3rd party packages
15:37:16 <ffesti> 15:14:40 <haraldh> I am fine with either thing
15:37:46 <haraldh> 2014-10-24
15:37:50 <haraldh> 15:36:57 <ffesti> ok, as we have a set of patches that implement file triggers we'll just uses this feature as one of the test cases
15:37:51 <haraldh> 15:37:18 <ffesti> that should backup the files without the need of altering all the packages
15:37:56 <haraldh> ..
15:38:01 <haraldh> you mean these patches?
15:39:37 <ffesti> No, I have not yet mentioned them today. But they do exist.
15:40:13 <pknirsch> so maybe letting haraldh and msekleta have a look at those might be beneficial too, ffesti
15:40:20 <ffesti> The issue with them is that in their curretn state the file triggers are executed as part of the scruptlet
15:40:36 <ffesti> which mean they are not executed *before* the scriptlets
15:40:46 <ffesti> which might be a problem for your use case
15:41:13 <ffesti> although I would prefer a solution with file triggers over a solution with plugins
15:41:22 <ffesti> nevertheless they are both runtime solutions
15:42:09 <ffesti> if we are back to discussing build time solutions the whole both solutions are pretty pointless
15:42:28 <haraldh> show me the bits :)
15:42:31 <pknirsch> :)
15:42:55 <ffesti> haraldh, you have been warned!
15:43:13 <haraldh> I think I have seen a lot of code in my life :)
15:43:23 <haraldh> including some really bad one
15:43:25 <haraldh> and my own
15:43:45 <pknirsch> and a combination of both?
15:43:46 <pknirsch> ;)
15:43:48 * pknirsch runs
15:43:56 <haraldh> yep :)
15:43:59 <pknirsch> hehehh
15:44:20 <msekleta> ffesti, how do you opt-in/out for this in case of implementation using file triggers?
15:45:21 <ffesti> you don't. You Register a path prefix and get called with a list of files. It is your job to the the right things with them.
15:46:02 <ffesti> haraldh, patches sent
15:46:15 <haraldh> thx
15:46:17 <ffesti> they should apply cleanly to rpm HEAD
15:46:21 <pknirsch> coolio
15:46:30 <pknirsch> thanks ffesti, haraldh and msekleta
15:47:51 <pknirsch> alright, then last real topic for today which was just a final acceptance check with everyone:
15:47:55 <pknirsch> #topic Base WG ownership of generic network install images
15:48:03 <pknirsch> and thanks ffesti for being here again today!
15:48:29 <ffesti> my pleasure
15:49:11 <pknirsch> think me, haraldh and msekleta already said that it looks fine.
15:49:34 <pknirsch> so jreznik, vpavlin, masta, dgilmore, any objections to accepting this?
15:50:13 <dgilmore> pknirsch: none.
15:50:17 <jreznik> no objections
15:50:27 <haraldh> vpavlin, masta: ping?
15:51:03 <masta> none
15:51:14 <pknirsch> thanks dgilmore and jreznik, i think we can check this off and move on
15:51:18 <pknirsch> and masta :)
15:52:24 <dgilmore> pknirsch: can you please file a releng ticket for it. so we work out the best way to make and deliver it
15:52:39 <pknirsch> dgilmore: will do
15:53:03 <pknirsch> #accept Base WG ownership of generic network install images
15:53:21 <pknirsch> #info pknirsch to open a ticker for releng to track and deliver this
15:53:35 <pknirsch> i got one last topic then for today:
15:53:39 <pknirsch> #topic Happy holidays!
15:53:51 <jreznik> Happy Holidays!
15:53:56 <pknirsch> and topic says it all, thanks everyone for all you've done in the past year
15:54:22 <pknirsch> it's been a lot of change over the last 12 months and lots of effort went into making Fedora move into the future
15:54:48 <pknirsch> So take the next few weeks to reflect on that and enjoy your time off
15:55:25 <pknirsch> I'll be back on January 7th, so i'd propose to do our next meeting on January 9th
15:55:57 * jreznik is back on 5th
15:56:18 <haraldh> 5th
15:56:32 <haraldh> 9th is ok for me
15:56:38 <pknirsch> alright
15:56:44 <masta> happy holidays
15:56:50 <haraldh> happy holidays!
15:57:18 <msekleta> jreznik, if I am not mistaken on 9th there is a new year party in brno office (actually outside of office) so not sure we (brno folks) will attend
15:57:47 <jreznik> msekleta: ah, you're right
15:58:08 <pknirsch> hm, so maybe move it to Jan 16th then?
15:58:30 <pknirsch> And if anything else important comes up we can always discuss it on fedora-devel
15:58:35 <jreznik> yep
15:58:53 * msekleta nods
16:00:02 <pknirsch> ok, lets move it to January 16
16:00:10 <pknirsch> thanks everyone, i need to stop here
16:00:15 <pknirsch> #topic Open Floor
16:00:17 <pknirsch> any other things?
16:01:08 * jreznik is ok
16:01:09 <pknirsch> if not, again thanks everyone for showing up today, and see you all next year!
16:01:14 <pknirsch> o/
16:01:15 <jreznik> see you!
16:01:24 <haraldh> o/
16:02:06 <msekleta> happy holidays to everyone! :)
16:03:19 <pknirsch> #endmeeting