17:00:15 <mattdm> #startmeeting Council (2015-03-09)
17:00:15 <zodbot> Meeting started Mon Mar  9 17:00:15 2015 UTC.  The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:16 <mattdm> #chair mattdm jreznik jwb cwickert rdieter langdon sgallagh decause
17:00:17 <zodbot> Current chairs: cwickert decause jreznik jwb langdon mattdm rdieter sgallagh
17:00:19 <mattdm> #topic introductions, welcome
17:00:27 <mattdm> Good $TIMEOFDAY, everyone!
17:00:32 <rdieter> hola
17:00:33 <jreznik> hello mattdm!
17:00:36 <mattdm> .hello mattdm
17:00:37 <sgallagh> Ciao
17:00:38 <zodbot> mattdm: mattdm 'Matthew Miller' <mattdm@mattdm.org>
17:00:40 <leanderthal> hallo mattdm
17:00:46 <langdon> hola mattdm
17:00:49 <kushal> .hellomynameis kushal
17:00:50 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
17:01:16 <mattdm> So, in the past, we've had a system of hand-raising (!, ?, etc) for board meetings...
17:01:19 <langdon> .hellomynameis langdon
17:01:20 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
17:01:22 <rdieter> .hello rdieter
17:01:23 <zodbot> rdieter: rdieter 'Rex Dieter' <rdieter@math.unl.edu>
17:01:35 <mattdm> I don't think we necessarily need to be formal for this meeting unless attendance is especially high
17:01:39 <jwb> hi
17:01:43 <mattdm> we can change that if need be.
17:01:46 <kushal> mattdm, Okay.
17:01:47 <rdieter> agreed
17:01:48 <jreznik> mattdm: I was looking on what we want for Council meetings compared to Board... not sure it is what we want
17:01:54 <mattdm> also hello everone
17:02:19 <mattdm> jreznik: elaborate, please?
17:02:51 <jreznik> mattdm: as you said - Board meetings were probably too formal...
17:02:58 <mattdm> for this meeting... we have basically four suggested agenda items, so my thought was to give about ten minutes to each of those, plus ten minutes for open floor if we manange to keep to the schedule
17:02:59 * cwickert is here
17:03:10 <mattdm> plus 5 minutes on each end for administrivia
17:03:11 * randomuser pops in
17:03:15 <cwickert> .fas cwickert
17:03:16 <zodbot> cwickert: cwickert 'Christoph Wickert' <christoph.wickert@gmail.com>
17:03:30 <mattdm> do we have remy?
17:03:44 <jreznik> mattdm: agreed, not sure I'll stay till the end, I'm not feeling very well today...
17:04:03 <mattdm> i think i saw the rest of the council
17:04:48 <mattdm> hmmm. in any case...
17:04:55 <mattdm> #topic agenda
17:04:57 <mattdm> -  5 minutes: intros and welcomes and agenda and stuff
17:04:58 <mattdm> - 10 minutes: outreach steering committee
17:05:00 <mattdm> - 10 minutes: objectives update
17:05:03 <mattdm> - 10 minutes: diversity advisor search
17:05:04 <mattdm> - 10 minutes: third-party repos
17:05:06 <mattdm> - 10 minutes: open floor, time permitting
17:05:08 <mattdm> -  5 minutes: next meeting, action plans
17:05:21 <sgallagh> ... ambitious
17:05:42 <mattdm> I pinged remy, and hopefully he'll be able to join in. I know he's getting adjusted to a new schedule and stuff
17:05:43 <langdon> sgallagh very
17:05:51 <mattdm> okay so let's get started :)
17:05:57 <mattdm> #topic outreach steering committee
17:06:30 <sgallagh> Do we have a bug tracker to keep track of agenda items and history?
17:06:36 <sgallagh> (and decisions)
17:06:39 <mattdm> So, this is the idea from a while ago (flock, maybe?) that it'd be nice to have a parallel to fesco
17:06:49 <jwb> sgallagh, aside from the council trac instance?
17:06:52 <jwb> what more do we need?
17:07:00 <mattdm> sgallagh: https://fedorahosted.org/council/
17:07:05 <mattdm> #link https://fedorahosted.org/council/
17:07:11 <mattdm> we can put things there if need be.
17:07:16 <sgallagh> jwb: I didn't know if one had been put up or if we were using the old Board trac, etc.
17:07:33 <mattdm> old one was migrated.
17:07:33 <jwb> it is, in fact, the old Board trac renamed
17:07:39 <jwb> anyway, towards the topic
17:07:50 <mattdm> There has been some discussion on the mailing list recently.
17:07:51 <randomuser> mattdm, fyi, meetbot gives you #link for free
17:08:07 <jreznik> generally, I like the idea to make all outreach teams to talk together and work together
17:08:10 <mattdm> cwickert, do you have any comments on that from the famsco perspective?
17:08:14 <cwickert> sure
17:08:22 <cwickert> so, we are facing two major problems
17:08:27 <jwb> mattdm, cwickert: it seems some in ambassadors either didn't understand or didn't like the idea
17:08:41 <cwickert> one is regional representation
17:09:00 <cwickert> we have been working hard on giving the local communities more power e.g. when it comes to budget
17:09:10 * mattdm nods
17:09:13 <cwickert> and we want to make sure it stays the same
17:09:20 <jwb> i don't see a problem with that
17:09:26 <cwickert> so we would have to find a way to represent all regions
17:09:40 <cwickert> and in the past, this was a problem, especially for NA
17:09:52 <mattdm> so, idea of region-based seats rather than all general-election as fesco?
17:10:02 <cwickert> even though they had an active community, they had nobody in FAMSCO for some time
17:10:06 <jwb> in my head, outreach isn't about money.  at all.  it's about messaging and positioning of the same consisten message about Fedora and it's community
17:10:16 <jwb> sorry, the outreach committee
17:10:18 <jreznik> jwb: but money are part of it
17:10:22 <kushal> jwb, +1
17:10:27 <cwickert> so we would have some reginal seats I thinl
17:10:33 <cwickert> think*
17:10:40 <cwickert> ppl agree?
17:10:43 <jwb> jreznik, how much money one has or doesn't have is secondary to whether people are talking about the same thing in the same terms...
17:10:47 <jreznik> outreach costs money... as it means events, travelling, marketing materials, swag
17:11:01 <sgallagh> cwickert: Like, one per continent (disregarding Antarctica)?
17:11:11 <jreznik> so it's going to be big part of fosco... has to be...
17:11:12 <jwb> jreznik, sure.  but until we get consistency in messaging why would we even be talking about spending money?
17:11:18 <cwickert> sgallagh: per regain (NA, EMEA, LATAM, APAC)
17:11:18 <jzb> one thing is we seem to be fixating on ambassadors here
17:11:23 <jzb> and not the other components.
17:11:24 <rdieter> remind me again the purpose of outreach steering committee, why it's needed, and possibly compare/contrast to FAMSCo/Abassadors?
17:11:32 <jwb> jzb, i'm trying not to.  that's kind of my point
17:11:32 <kushal> cwickert, I personally think having people involved who wants to work on outreach is more important than choosing one per continent.
17:11:39 <mattdm> (i think regional seats can make sense. maybe other ways to address problem, but if that's the main one people want okay)
17:11:48 <jreznik> jwb: it's not that easy part, ambassadors already spent a lot of time on it (and it was worth spending the time to do it correctly)
17:11:54 <jwb> rdieter, in my head, to get the ambassadors, the marketing people, the websites people, etc all takling together more than they do
17:12:08 <jzb> jwb: +1
17:12:11 <rdieter> jwb: ah, excellent, thx
17:12:26 <jzb> we have a serious disconnect right now and the right and left hands don't know what each other are doing.
17:12:31 <jwb> yes, that
17:12:33 <cwickert> and the next thing from my perspective is size
17:12:35 <jzb> moreover, I think it's very confusing for people who are new to Fedora
17:12:37 <jreznik> the question is - is it really needed all ambassadors for all regions has to be on famsco?
17:12:50 <rdieter> so I don't "regional representation" being important here
17:12:51 <jzb> to figure out where to jump in on an idea and carry it to conclusion.
17:12:59 <rdieter> I don't see... that is
17:13:05 <mattdm> (before we solve that problem, can we hear cwickert's other major area of concern?)
17:13:05 * cwickert things we are having two different conversations at the same time
17:13:15 <cwickert> thanks mattdm
17:13:25 <jreznik> or one representative from each team not to make it big... as there are local ambassadors groups... so I don't see any need to have more than one ambassador representative in fosco
17:13:33 <jwb> well, i think we're trying to solve two different problems with the same "outreach committee"
17:13:39 <jwb> and it's confusing
17:13:55 <rdieter> let cwickert finish, then we can discuss more
17:14:05 <jreznik> go on cwickert, sorry for shouting here :)
17:14:46 <cwickert> so, the ambassadors are just way bigger than marketing or design. we need to find a way to fairly represent everybody, but on the other hand we need to make sure the ambassadors cannot just overpower everybody else
17:14:54 <cwickert> we have seen this with board elections before
17:15:08 <jzb> +1
17:15:09 <cwickert> usually the candidates with an ambassadors background have good chances of making it
17:15:20 <cwickert> just because the group of ambassadors is huge
17:15:39 <rdieter> assuming membership is done via elections, not sure that is a given (yet)
17:15:39 <cwickert> currently we are collecting ideas, if anybody has one, I am open for it
17:16:01 <cwickert> rdieter: I think we want a mixed approach, some appointed seats e.g. for the regions and some elected
17:16:10 <rdieter> I don'
17:16:13 <jwb> wait, what?
17:16:14 <cwickert> similar to the council
17:16:19 <jreznik> but ambassadors are well structured into local region teams... so I still do believe it should be one representative for each area (ambassadors, marketing, websites, design) and then delegate to teams
17:16:28 <rdieter> sorry, I don't see regional representation or elections being important here at all
17:17:00 <jwb> famsco is the fesco of ambassadors, correct?
17:17:04 <rdieter> what *I* think, pull in representatives from those already-existing groups (ambassadors, marketing, design, etc...)
17:17:07 <jreznik> jwb: yep, it is
17:17:08 <kushal> jwb, yes.
17:17:16 <jreznik> rdieter: exactly
17:17:21 * mattdm notes clock and ambitious keep-meeting-short goal :)
17:17:28 <jwb> so why wouldn't we have a seat for famsco, one for marketing, one for design, one for docs, and one for the council and/or engineering?
17:17:43 <jwb> outreach != ambassadors
17:17:45 <rdieter> jwb: +1
17:17:45 <jreznik> jwb: that's what I and rdieter said above
17:17:51 <MarkDude> wait
17:17:55 <leanderthal> jwb, +1
17:18:01 <kushal> jwb, +1
17:18:09 <kraulain> jwb +1
17:18:19 <cwickert> I don't think that flies
17:18:32 <kushal> cwickert, which one?
17:18:44 <cwickert> kushal: the "one for every team"
17:18:49 <jreznik> cwickert: why not? ambassadors has a great structure bellow, other teams are smaller but there are still teams
17:19:32 <rdieter> if the purpose is to get various related teams all on the same page, that approach seems reasonable to me.  Is my perception of the purpose/objective wrong?
17:19:39 <kushal> jreznik, may be because finding that one person from each team who wants to work on outreach is difficult.
17:19:50 <cwickert> jreznik: because FOSCO will replace FAmSCO. We still need a place to coordinate the ambassadors activities, which are highly regional
17:19:51 <randomuser> cwickert, I think the ambassadors have done such a good job of handling their business internally that it's hard to see (for me, at least) what they need from the outreach committee, or even what they're doing outside of general terms
17:19:56 <jwb> what?
17:20:02 <jwb> nobody said FOSCO is replacing FAMSCO
17:20:18 <jreznik> jwb: well, one idea was to replace famsco
17:20:19 <mattdm> jwb: that has certainly been said
17:20:20 * rdieter doesn't see any replacement of FAMSCo either
17:20:23 <cwickert> jwb: that was the assumption in all previous discussions
17:20:26 <mattdm> it's not the _only_ possibility
17:20:26 <jreznik> that's why we didn't have elections last time
17:20:27 <jzb> jwb: that seems to be my understanding
17:20:39 <jzb> that the plan was to replace FAMSCO
17:20:42 <mattdm> I think the main idea there was to avoid introducing yet more committees
17:20:46 <langdon> minor side note: i think it is important to the proposal that eng and council be separate seats
17:20:52 <cwickert> mattdm: +1
17:20:59 <jzb> with a larger body that coordinated outreach altogether, ambassadors being a piece of that.
17:21:11 <rdieter> ah, found https://lists.fedoraproject.org/pipermail/marketing/2014-October/016636.html
17:21:16 <kushal> mattdm, +1
17:21:20 <rdieter> Proposal: consider tranforming FAmSCo into "FOSCo" — Fedora	Outreach Steering Committee
17:21:21 <jwb> i don't even care if we have an outreach committee.  the problem that needs to be solved is to have consistency about the messaging around Fedora, it's Editions, and it's community
17:21:28 <rdieter> that's precisely what it said
17:21:31 <jreznik> but in the end, I don't have a big problem with having four ambassadors in FAMSCo
17:21:31 * mattdm seems to have written that :)
17:21:49 <jwb> which means we need to have people that produce the messaging and people that deliver the messaging using the SAME messaging
17:21:51 <jreznik> sorry FOSCo
17:21:51 <kushal> jreznik, FAMSCo or FOSCo?
17:22:34 <cwickert> jwb: "ppl to produce the message" seems like a misconception of the ambassadors
17:22:36 <rdieter> so, again, I think we need to get more specific about exactly what we're talking about here
17:22:45 <jreznik> yep
17:22:47 <jwb> cwickert, no, ambassadors DELIVER
17:22:58 <jwb> marketing, websites, etc PRODUCE
17:23:10 <mattdm> okay, so: there is action on the Outreach mailing list
17:23:10 <cwickert> jwb: tell that to the ambassadors and most of them will resign
17:23:12 <mattdm> https://lists.fedoraproject.org/pipermail/outreach/
17:23:18 <MarkDude> Question: this is mostly effort by white folks?
17:23:25 <langdon> jwb the humans may wear multiple hats but the ambasadors hat is deliver
17:23:25 <FranciscoD|Uni> cwickert: really? I don't think so.
17:23:30 <MarkDude> We still need other voices for this appeal
17:23:48 <jwb> langdon, right.  and why cwickert says they'll resign is lost on me
17:23:50 <jwb> cwickert, ?
17:23:55 * MarkDude will follow up with email- sorry for interu[pting
17:23:56 <rdieter> MarkDude: I fail to see how that is relevant
17:24:09 <jzb> that's a big derail
17:24:12 <mattdm> in addition to the mailing list, there are plans to set up a meeting specifically for interested people to discuss this in full
17:24:13 <MarkDude> And therein lies the perceptionm issue
17:24:18 <MarkDude> Trust me
17:24:23 <randomuser> if the model says marketing produces strategies, and ambassadors implement them, and the ambassadors are encouraged to participate in other groups anyway... they can jump in on marketing efforts
17:24:31 <FranciscoD|Uni> randomuser: ++
17:24:35 <mattdm> randomuser +1
17:24:42 <inode0> The message that ambassadors deliver someone else's message diminishes what they have been doing for years. It likely would leave a lot of ambassadors feeling insulted.
17:24:43 <cwickert> FranciscoD|Uni, jwb: if ambassadors just deliver what somebody else produces, and have no say in it, this is not interesting at all
17:24:45 <langdon> randomuser +1
17:25:00 <jwb> cwickert, HENCE THE NEED FOR DISCUSSION BETWEEN THE GROUPS
17:25:00 <kushal> randomuser, we used to ask all ambassadors to become part of marketing team.
17:25:00 <FranciscoD|Uni> cwickert: that's not what anyone said - that ambassadors have no say in it :)
17:25:18 <rdieter> I think we can agree we all want a shared message
17:25:24 <cwickert> no need for shouting, jwb
17:25:25 <kushal> rdieter, +1
17:25:37 <FranciscoD|Uni> role wise, ambassadors deliver what the community produces and passes down, and the ambassadors are mostly part of quite a few teams in the community.
17:25:38 <rdieter> it's just a matter of find the best way to achieve that
17:25:40 <jzb> not just a shared message but some collaboration in creating the message
17:25:56 <jreznik> jzb, yep
17:26:14 <FranciscoD|Uni> like a common pipleline that everyone can send and receive from - at least that's what I understood from the outreach initiative
17:26:37 <jreznik> I still think about outreach committee as high level bodies and there still be needed that internal communication within the team
17:26:43 <mattdm> okay, so, 15 minutes on this so far -- do we want to continue with this topic, or should we go back to the list and specific meeting and then come back with some of these questions better answered?
17:26:58 <jreznik> so it's not going to replace internal communication of ambassadors, not design, not websites
17:27:02 <rdieter> though, saying that out loud now... is that precisely what 'marketing' is?
17:27:17 <cwickert> let's not forget the ambassadors are also a channel for feedback. They are the ones to go out and meet real users. yes, users, the kind of people many developers and marketing people rarely meet
17:27:19 <rdieter> and we already have that
17:27:27 <cwickert> anyway
17:27:32 <jwb> nobody is forgetting that
17:27:34 <mattdm> cwickert, yes, that part is often lost too
17:27:40 <jreznik> because I'd say half of what FAMSCo does now would be not interesting for design guys, half of what design would be boring for marketing...
17:27:45 <jwb> in fact, we're trying to encourage more of that feedback here
17:27:45 <mattdm> so that's part of the connection
17:27:48 <jreznik> so it's still requires some structure
17:28:01 <cwickert> jreznik: good point
17:28:03 <jzb> cwickert: er... I'm pretty sure that our devs and marketing people do meet "real users" ;-)
17:28:14 <jzb> cwickert: let's not forget that a lot of folks do double or triple duty
17:28:20 <cwickert> jzb: I often doubt that :)
17:28:36 * jwb hangs head
17:28:54 <jreznik> so maybe it's not going to replace famsco, but reduce it? yes, some part of it will be still needed
17:29:01 <FranciscoD|Uni> outreach is meant to keep stuff flowing between the teams, isn't that the basic point?
17:29:06 <jwb> yes
17:29:12 <cwickert> yes
17:29:22 <mattdm> okay good we have at least that agreement :)
17:29:24 <langdon> i would propose that a FAMSCo rep presents to the council meeting on current feedback on some regular basis.. as a complete aside to this convo
17:29:27 <jwb> increase the flow, the amount of interaction, and the EQUITY all of the parties have in it
17:29:54 <FranciscoD|Uni> jreznik: i wouldn't want to replace famsco - i think the top level work that they do is quite important for ambassadors - lots of coordination there
17:29:56 * jreznik thinks there's nothing better than arguing over internetz while struggling with terrible migraine :)
17:30:03 <mattdm> i'm gonna bang the gavel at this point, though.... clearly a lot of interest, so let's keep it going on the lists
17:30:11 * mattdm bangs gavel
17:30:12 <cwickert> langdon: that is why I am here
17:30:14 <FranciscoD|Uni> and I know we don't want another body, but that's sort of what it points at :/
17:30:57 <jzb> mattdm: may I make a suggestion?
17:31:00 <mattdm> jzb: sure
17:31:04 <langdon> cwickert, i guess i read it more as participation.. rather than "reporting feedback" ..
17:31:16 <mattdm> I don't want to kill good conversation but I did want to get to the other things too
17:31:18 <jzb> mattdm: It seems to me the council planning went pretty well and swiftly b/c it came to the lists pretty well formed.
17:31:34 <jzb> mattdm: it'd probably go better if we came at this with a better defined plan.
17:31:40 <jwb> jzb, it took over a year.  we don't have a yar.
17:31:42 <jwb> year
17:31:56 <jwb> jzb, but i do agree in principle
17:31:56 <jzb> no we don't.
17:31:57 * FranciscoD|Uni wonders if the answer could be a tool rather than a body of people?
17:32:13 <jreznik> jwb: and outreach is already like half year in the process?
17:32:19 <FranciscoD|Uni> but people will have to use the tool, so, yeah, back to people
17:32:21 <jreznik> FranciscoD|Uni: good idea
17:32:23 <gamemanj> FransciscoD|Uni: A "tool"?
17:32:28 <jwb> jreznik, mmm... i'd politely disagree
17:32:42 <MarkDude> 2011 https://fedoraproject.org/wiki/User:Markdude/Dont_Exclude_Yourself
17:32:47 <FranciscoD|Uni> well, the entire issue is that the bodies don't speak to each other
17:32:59 <MarkDude> Women, and minority folks created that
17:33:10 <MarkDude> And me
17:33:13 <jreznik> jwb: the first time folks really start talking about it was half year ago... and actually started planning bits...
17:33:19 <FranciscoD|Uni> and the one way is to have liasons - like we were supposed to have in the WGs - ambassadors in the WGs, marketing folks in the WGs and so on.
17:33:34 * jreznik is going to move on phone and goes home, his head is about to explode...
17:33:45 <jwb> jreznik, calendar time i guess, yes
17:33:53 <FranciscoD|Uni> so people in different teams each pick one other team that they will laison with - that could be one way, which is what the outreach committee would do?
17:34:05 <jwb> mattdm, did you break your gavel?
17:34:17 <FranciscoD|Uni> the other is to set up yet another app - one team drops something in, it gets circulated to the others, kinda?
17:34:20 <mattdm> So, cwickert, others -- can we have a more concrete plan -- can we work on the outreach mailing list to have a more concrete plan and come back?
17:35:12 <cwickert> mattdm: I was about to suggest the same. how about I start with a summary of the current discussion in FAMSCo and the other teams sent to the outreach list?
17:35:25 <mattdm> cwickert: sounds good.
17:35:44 <mattdm> #action cwickert to summarize current discussion, and we will come back with a more concrete plan
17:35:54 <mattdm> and next :)
17:35:55 <mattdm> #topic objectives update
17:36:08 <mattdm> this is actually a two-parter :)
17:36:09 <cwickert> for the record, this is the ticket in FAmSCo's trac: https://fedorahosted.org/famsco/ticket/373
17:36:16 <mattdm> cwickert: thanks
17:36:21 <cwickert> not sure if all of you can read it though
17:36:35 <mattdm> I think people can read it if they're logged in -- non anon, but not private
17:36:49 <kushal> mattdm, +1
17:36:55 <mattdm> part 1; sgallagh, can you give a brief update on your objective?
17:37:04 <mattdm> part 2; other potential objectives: how to get them.
17:37:16 <sgallagh> Hmm, ok
17:37:31 <sgallagh> (Formulating thoughts)
17:37:34 <mattdm> sgallagh sorry if that's putting you on the spot :)
17:37:53 * mattdm makes note to suggest this in the pre-sent-out-agenda next time
17:38:03 <sgallagh> Yeah, it's a difficult thing to state exactly where we are.
17:38:18 <sgallagh> Obviously, we had three distinct editions in F21, so that much at least is public.
17:38:38 <sgallagh> We've done a lot of work in F22 in the Alpha timeframe to reduce some of the major pain points of splitting the media
17:39:28 <sgallagh> One thing we really need to address going forward is how we present non-Edition media. This is largely a marketing and websites issue, but probably needs direction from the Council in general.
17:39:44 <jwb> aka Spins?
17:39:55 <mattdm> Spins and secondary architectures
17:39:55 <sgallagh> jwb: Yes, Spins.
17:40:07 <sgallagh> and secondary arches, as mattdm says
17:40:25 <mattdm> and even primary architectures where the Editions don't put that arch in a visible spot
17:40:25 <randomuser> sgallagh, +1, I encounter waaay too many questions about "I installed this edition but I really wanted something else"
17:40:58 <sgallagh> Right, so we need to iterate on that. Maintain our focus while not "hiding" our other offerings.
17:41:16 <jreznik_pp> And sometimes you even don't have a way how to install correct edition, as not everything is on the main site
17:41:20 <sgallagh> Some other things I'm working on for the editions:
17:41:29 <sgallagh> Clearly, the per-product config approach has not worked.
17:41:47 <mattdm> sgallagh: you mean technically or politically?
17:41:49 <sgallagh> Fortunately, thus far only firewalld has implemented it, so I'm planning to back that misfeature out by Beta.
17:41:52 <sgallagh> technically
17:42:02 <mattdm> just clarifying :)
17:42:12 <sgallagh> It has introduced too many issues that cannot be fixed without significant work at the RPM layet
17:42:13 <jreznik_pp> Why it has not worked?
17:42:15 <sgallagh> *layer
17:42:20 <jreznik_pp> Ah that way
17:42:29 <cwickert> sgallagh: how about we do this work instead of backing out?
17:42:42 * cwickert notes opensuse does it
17:42:43 <sgallagh> cwickert: We're going to do this work
17:43:01 <sgallagh> But I've been told that it's probably a 2016 target in RPM
17:43:09 <gamemanj> ...Is it a yes, a no, or a "We'll do the work and then decide"?
17:43:21 <cwickert> sgallagh: ah, I thought you meant in packaging, not rpm itself
17:43:23 <sgallagh> And for a feature we're not even using fully yet, I'm okay with backing out the poor implementation for now
17:44:06 <sgallagh> cwickert: Sorry, I wasn't clear above. Basically, for it to work properly, we need a dep _language_ "If A then install B", etc.
17:44:31 <sgallagh> The mechanism we were using *almost* worked with yum because we were abusing some low-level knowledge about the depsolver.
17:44:50 <sgallagh> But it still had holes that we discovered (like the environment groups not being installable in a live system)
17:44:56 * mattdm is okay with not getting too deep in the details here :)
17:44:59 <sgallagh> Right
17:45:04 * mattdm tapes gavel back together
17:45:13 <sgallagh> Suffice to say, my recommendation here is to back it out for now and solve it correctly before trying again.
17:45:22 <jwb> wait, i have one question
17:45:26 <sgallagh> In the one project that we're doing this, we'll approach it another way.
17:45:32 <sgallagh> jwb: Shoot
17:45:43 <jwb> this objective includes the rings approach, yes?
17:46:08 <mattdm> jwb: possibly some parts of it, but mostly, _no_
17:46:08 <sgallagh> Yes
17:46:11 <sgallagh> No?
17:46:14 <jwb> LOL
17:46:17 <mattdm> hah
17:46:28 <sgallagh> /me feels the boulder get lighter
17:46:28 <mattdm> well, it can to some degree, but that's a big thing in itself
17:46:34 <mattdm> right :)
17:46:42 <kushal> 14 minutes left.
17:46:55 <mattdm> #action mattdm to put the write-up for this objective in the wiki like he said he would
17:47:10 <jwb> that would be nice.  thanks.
17:47:34 <mattdm> I have a several drafts of ring-approach objectives (from different directions) that I need to kick out of my drafts folder, too
17:47:39 <sgallagh> jwb: What was your follow-up question anyway?
17:48:11 <langdon> mattdm, should you just send those over to envs&stacks and ask them to run with them?
17:48:34 <mattdm> langdon: that was one, but initial message got crickets. i'll try again :)
17:49:04 <langdon> mattdm, i meant the "several drafts" bit above
17:49:12 <mattdm> so, this partly answers the issue of other objectives. I was kind of expecting more to show up, but I guess we kind of have to prove the concept first
17:49:12 <jwb> sgallagh, just curious if you were making progress on the feedback you received on your latest rings proposal
17:49:35 <sgallagh> I've let it sit unattended while I was helping wrangle the Alpha release
17:49:43 <sgallagh> It's one of many things on my catch-up list right now
17:49:46 <jwb> ok
17:49:56 * mattdm notes kushal's clock warning :)
17:50:26 <mattdm> Anyone have other quick thoughts on potential other objectives that are more than just brainstorming?
17:50:59 <sgallagh> May I?
17:51:04 <mattdm> sgallagh: yes :)
17:51:16 <randomuser> sgallagh, where can I watch what's happening with the firewalld config package thing?
17:51:28 <sgallagh> One question: should we consider a non-technical objective such as attacking a potential market segment?
17:51:42 <sgallagh> randomuser: #fedora-server
17:51:48 <randomuser> ack
17:52:18 <mattdm> sgallagh: yes. one that's been suggested to me by a number of people is network switch/router / software-defined-networking
17:52:39 <sgallagh> Interesting.
17:52:56 <mattdm> I will do the things I said I would, which will keep some momentum going on this topic in general....
17:53:01 <mattdm> let's go to the next topic
17:53:01 <sgallagh> I was thinking more along the lines of my favorite unicorn: University Computer Lab presence.
17:53:14 <mattdm> sgallagh: oh, that's interesting too. yes, write that up :)
17:53:21 <sgallagh> "Get 'em while they're young"
17:53:31 <mattdm> sgallagh talk to remy about that too
17:53:35 <sgallagh> I have been
17:53:38 <sgallagh> spot also
17:53:39 <mattdm> cool
17:53:44 <mattdm> double cool
17:53:46 <mattdm> #topic diversity advisor search
17:53:47 <kushal> sgallagh, +1, getting new contributors from colleges is very important.
17:54:05 <mattdm> Okay so in the interest of time, I don't think we need a long conversation here.
17:54:08 <mattdm> see
17:54:09 <mattdm> https://lists.fedoraproject.org/pipermail/council-discuss/2015-March/013192.html
17:54:16 <mattdm> and please give feedback on the list (or privately)
17:54:38 <mattdm> and unless anyone objects in the next thirty seconds, going to next item
17:55:02 <langdon> mattdm, isn't this where MarkDude's points come in?
17:55:09 <langdon> or is that post "hiring"
17:55:11 <mattdm> langdon: yes, absolutely.
17:55:42 <mattdm> it's the starting point on beyond "hiring", I think.
17:56:04 <langdon> mattdm, righto
17:56:05 <mattdm> scare quotes necessary because there is not money or actual hiring involved
17:56:12 <mattdm> #topic third-party repos
17:56:29 <jwb> i propose we defer on the grounds that we only have 4 min
17:56:40 <sgallagh> seconded
17:56:45 <kushal> :)
17:56:49 <mattdm> yep, that seems resonable. big topic.
17:56:49 <jwb> but i'd note that we do need to discuss this
17:57:12 <mattdm> jwb yeah.
17:57:13 <sgallagh> And in the immediate future, I think. I expect that Workstation is going to want some part of this at least for F22 Beta
17:57:40 <jwb> hm
17:57:49 <jwb> reminds me someone needs to open that fesco ticket that was requested
17:57:57 <jwb> i thought sgallagh was going to do that :)
17:57:58 <sgallagh> s/someone/sgallagh/
17:58:08 <sgallagh> Yeah, I dropped the ball there
17:58:24 * cwickert has to run...
17:59:04 <mattdm> cwickert: okay, bye! I think we should schedule another of these soon.
17:59:28 * MarkDude will make points, in concrete and timely manner. Has learned from Fedora, can promise this will be easier and help in long run. As well as AVOID folks we DONT want to recruit
17:59:30 <MarkDude> :)
17:59:42 <mattdm> #info sgallagh is filing fesco ticket re workstation wg requests for third-party repos for f22
18:00:00 * MarkDude is Team player here, not the ass I have been over years. Ty for listening. eof
18:00:02 <mattdm> #topic next meeting, action plans
18:00:10 <mattdm> MarkDude heh
18:00:23 <mattdm> I think in the interest of time, skip open floor.... because we are at 2pm
18:00:38 <mattdm> #info no open floor -- please bring agenda items before meeting next time
18:01:11 <mattdm> do we want to do another meeting like this in two weeks?
18:01:19 <leanderthal> yes, please
18:01:30 <cwickert> +1
18:01:34 <langdon> +1
18:01:42 <rdieter> yes, I think we even have enough to not wait 2, but either is fine
18:01:50 <mattdm> does anyone want to do it next week?
18:02:02 <mattdm> I'm okay with that if it's going to be the most productive.
18:02:03 <sgallagh> I'd be in favor of next week
18:02:06 <langdon> would also like to propose that a portion of the meeting be "reporting on status" from the other groups e.g. famsco, marketing, etc
18:02:13 <sgallagh> Particularly with the repo question open
18:02:15 <leanderthal> there are some points that were going to solidify over the lists - these may need the two weeks
18:02:34 <mattdm> leanderthal: yep makes sense
18:02:37 <mattdm> let
18:02:49 <sgallagh> langdon: I'd actually suggest that this maybe wasted time. Maybe ask for a status email every Friday or something and flag certain things for follow-up?
18:02:59 <sgallagh> or every other Friday.
18:03:02 <leanderthal> that said, i'm open to weekly meetings as well
18:03:43 <mattdm> status emails feel like homework, but if people are up for doing that, it would be nice
18:03:54 <langdon> sgallagh, i think it may be an alternating meeting.. e.g. tickets meeting every 2 weeks/1 month and status every 1 month or something.. but I think it is important to 1) be able to ask questions 2) make it "formal" ..
18:04:10 <sgallagh> /me nods
18:04:21 <langdon> sgallagh, to me or mattdm ? :)
18:04:29 <mattdm> langdon: that seems like a good format
18:04:31 <sgallagh> yes ;-)
18:04:35 <langdon> sgallagh, lol
18:04:49 <sgallagh> langdon: I'm a programmer. You should have said XOR
18:04:51 <mattdm> as a taste of doing what I'm suggesting...
18:05:18 <mattdm> #action mattdm to write plan for future meetings to alternate between working on tickets vs. interactive status reports, send to list
18:05:33 <gamemanj> sgallagh: That would leave open the possibility of "nothing".
18:05:34 <langdon> sgallagh, but i meant OR :)
18:05:46 <mattdm> and I'll send these meeting minutes out promptly, including the action items
18:06:02 <mattdm> and I'll follow up with people before next meeting
18:06:04 <kushal> -6 minutes.
18:06:07 <mattdm> kushal: lol
18:06:10 <mattdm> okay then
18:06:15 <mattdm> #endmeeting