14:00:23 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings #meetingname Fedora Docs #topic Roll Call
14:00:23 <zodbot> Meeting started Mon Mar 16 14:00:23 2015 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:45 <randomuser> :/
14:00:53 <grundblom> hello!
14:00:58 <randomuser> #topic Roll Call
14:01:07 <randomuser> #chair pkovar
14:01:07 <zodbot> Current chairs: pkovar randomuser
14:01:26 <pkovar> /me is here
14:01:51 <randomuser> pkovar: I need to attend to a problem here in the office for a bit, can you handle this please?
14:02:08 <pkovar> randomuser: sure thing
14:02:13 <randomuser> thanks
14:02:21 <pkovar> np
14:02:26 * smccann is here
14:04:29 <pkovar> #topic New Writers
14:04:42 <pkovar> do we have new writers around?
14:04:45 * decause waves
14:04:52 <pkovar> decause: hi
14:04:56 <decause> pkovar: hi there
14:05:11 <smccann> still in the newbie status
14:05:42 <pkovar> let us know if you have any questions, issues or comments, decause, smccann
14:06:35 <decause> pkovar: I do, but for now, I'll be here mostly listening
14:07:03 <grundblom> I am here and new
14:07:04 <pkovar> decause: ok, we can chat later in fedora-docs
14:07:15 <smccann> I'd like to take the virt-guide discussions to email since we haven't met up in irc. is that okay?
14:07:53 <grundblom> Sure,
14:08:01 <grundblom> fine with me
14:08:38 <smccann> grundblom - is your email listed on the fedora wiki?  I can see lnovich is there so I can start an email thread
14:08:52 <decause> pkovar: thanks
14:10:08 <grundblom> sure is,
14:10:22 <grundblom> I think I have it under myuser page in the wiki
14:10:25 * rkratky comes late
14:12:31 <smccann> grundblom - yep, got it.  confusingly enuf, I'm mccann2 on the wiki...and I'll add my email addy there too
14:13:03 <randomuser> smccann, for email, please CC the docs list
14:13:07 * randomuser is slightly more here than before
14:13:55 <smccann> randomuser - okay
14:18:00 <pkovar> ok, i think we can move on
14:18:14 <pkovar> #topic Publishing
14:18:28 <pkovar> #link https://fedoraproject.org/wiki/Docs_Project_Focus
14:18:35 <pkovar> #link https://lists.fedoraproject.org/pipermail/outreach/2015-March/000036.html
14:18:47 <pkovar> waiting for your feedback
14:19:33 <pkovar> randomuser: do you have any updates wrt the tooling you've been looking into?
14:20:10 <randomuser> pkovar, somewhat
14:20:27 <randomuser> I put it at https://github.com/immanetize/anerist
14:21:22 <randomuser> it's still very crude, and it will probably grow into a bunch of buildbot-extending python modules with proper setuptools packaging, but right now it's just some .py files and an ansible config to bring up a buildbot cluster from minimal instances
14:22:09 <randomuser> it builds, it can almost to translations, for publican docs only
14:22:13 <decause> randomuser: I like the repo name
14:22:20 <randomuser> decause, :)
14:22:30 <randomuser> At this point, I need consensus on two things
14:23:00 <randomuser> a metadata format, both in terms of what type (yaml,xml,etc) and the content
14:23:24 * decause is partial to .yaml, but also very very new here
14:23:57 <randomuser> I am also leaning towards yaml, because there is reusable code for generating a site from it
14:24:39 <randomuser> for the content, I'm thinking Title, Summary, Description, tags, [uniform, pre-agreed] categories, other?
14:24:46 <pkovar> randomuser: ok, i we can reuse code, i say go for it
14:25:23 <pkovar> release? or would that be a tag?
14:26:25 <randomuser> pkovar, ah, yeah, that would be a good one to know :)
14:26:25 <pkovar> can it read Book_Info.xml to get the info?
14:26:47 <randomuser> pkovar, I expect that I will be able to learn how to read *_Info.xml for this info
14:27:03 <pkovar> or publican configs even
14:27:31 <pkovar> some books overwrite values in xml with cfg files
14:27:36 <randomuser> we should pick one or the other imo, or we'll forget to maintain both and I will have to accomodate them being different
14:28:53 <randomuser> pkovar, hrm... ok
14:30:07 <pkovar> randomuser: i would strongly prefer not having to manually maintain a separate file
14:30:29 <randomuser> pkovar, yes, that's the plan for publican guides
14:30:36 <pkovar> then again, for alternative formats, separate configs might be needed
14:30:50 <pkovar> depends on the formats we want to support
14:30:52 <randomuser> for say, a RST article, it could have a yaml header
14:30:57 <pkovar> right
14:31:39 <randomuser> I'll start a wiki page for this metadata question, people with experience with more markup languages should participate
14:32:06 <randomuser> which leads to the second thing I'd like consensus on: the second/next markup format we should target
14:33:08 <randomuser> This is where I think we should be polling the Fedora community
14:33:30 * decause listens intently
14:33:48 <randomuser> instead of "here is your other option" say "what other option would enable you to contribute"
14:34:32 * lnovich1 is here
14:35:13 <randomuser> from a pure vague, anecdotal recollection, I would say markdown or ReStructuredText
14:36:58 <randomuser> #action randomuser to draft wiki page on doc metadata and mail list about it
14:37:20 <lnovich1> smcann - we can talk later today if you want I will be on IRC for a few more hours today
14:38:02 <lnovich1> randomuser - sorry to jump on the bandwagon so late but what are we talking about with ReST?
14:39:29 <randomuser> ...there has to be something actionable for this second point
14:39:29 <randomuser> lnovich1, It's time we should decide what other format we want to offer contributors, because I am writing tools
14:39:57 <randomuser> i suppose I could send out a mass email, or ask -apps about setting up a survey and announce it
14:40:14 <randomuser> ...opinions welcome
14:40:41 <pkovar> randomuser: publican can already do markdown, btw
14:40:49 <lnovich> should we first of all decide what we will use for publishing and take it from there?
14:41:00 <pkovar> so with P4, we support two formats pretty much
14:41:37 <randomuser> lnovich, no, thar be circular reasoning
14:41:40 <decause> randomuser: please cc me on the ticket if you file one for doing surveys
14:41:55 <randomuser> pkovar, that's easy, then :)
14:42:18 <randomuser> decause, ack - are you subscribed to the docs list yet?
14:42:33 <pkovar> randomuser: right, there should be no additional work needed for markdown
14:42:44 <decause> randomuser: I believe I just subscribed on Friday but I'll double check
14:42:57 <pkovar> there's nothing preventing us from supporting other formats in the future, though
14:42:57 <lnovich> is it possible to have content in both formats used in the same book?
14:43:12 <pkovar> if the tooling is reasonably modular
14:43:44 <randomuser> lnovich, I don't see that happening, in the short term, unless publican already supports it
14:44:16 <lnovich> it can when you have mutiple contributors writing for the same book (a dream I know) but a possibility
14:45:11 <lnovich> also - is it possible that legacy docbook material have new chapters added in markdown?
14:45:15 <randomuser> I don't think `publican build` cares who wrote what :)
14:45:36 <lnovich> or new parts to an old chapter?
14:46:11 <lnovich> not who wrote what but who wrote with what
14:46:26 <randomuser> lnovich, that's a good question; I would guess not, but haven't tried.  There is an argument for the include tag to tell it the source format - maybe ask Jeff?
14:47:33 <lnovich> i think before we ask for opinions on what to use we need to make sure our current doc set works with content in other formats
14:47:56 <lnovich> and then only ask in a survey about what we know will work
14:47:57 <pkovar> lnovich: mixing multiple formats in one book doesn't seem to be a good idea, really. i'd convert the docbook sources to markdown with pandoc and then work with the output
14:48:54 <randomuser> lnovich, I'm really trying to abstract the original source format and build the site from prebuilt content using parsed or specifically written metadata
14:48:57 <lnovich> it didn't seem like a good idea to me either
14:49:27 <randomuser> publican not doing mix-and-match isn't a blocker for using some other tool to build html from markdown, for example
14:50:07 <lnovich> and if i am writing in docbook on a guide and some other author converts it to markdown then I need to convert it back again to docbook? - this would not make any sense and would make the contribution process more difficult
14:50:24 <randomuser> lnovich, yes, that would be a bad idea
14:50:47 <lnovich> that is the scenario i can see in the future unless we are careful about the choices we make
14:52:30 <randomuser> lnovich, I would hope that any contributors are courteous enough to not do that.  I want to support *new* articles with different formats; if a guide maintainer wants to convert to a supported format, fine; converting back and forth for editing is not something I see us wanting to do
14:53:07 <lnovich> ok so then we need to list on the wiki the format the document is in so that contributors know before downloading the repo
14:53:52 <randomuser> sure
14:54:28 <pkovar> or they can use our new git web viewer to preview the contents :)
14:55:04 <randomuser> I can think of a few ways to communicate that information
14:55:15 <randomuser> five minutes - I want to get a point in on something else
14:55:37 <randomuser> #topic Release Notes
14:55:46 <randomuser> #link https://fedoraproject.org/wiki/Category:Documentation_beats?rd=Docs/Beats
14:56:17 <randomuser> #link https://fedoraproject.org/wiki/Releases/22/ChangeSet
14:56:24 * randomuser digs for the chedule
14:56:50 <randomuser> https://fedorapeople.org/groups/schedule/f-22/f-22-docs-tasks.html
14:57:26 <randomuser> according to the schedule, we should be mostly ready for Beta right now
14:58:00 <randomuser> and in the real world, we have barely touched the content required to cover the Change set, and a lot of those are done for us
14:58:21 <randomuser> everyone, please find some time to work on RNs
14:59:05 <grundblom> RNs?
14:59:11 <grundblom> what does that mean?
14:59:48 <roshi> release notes
14:59:58 <grundblom> oh! thank you
15:00:22 <roshi> np :)
15:01:27 <randomuser> anyway, thanks for coming, all, and for chairing, pkovar
15:01:32 <randomuser> #endmeeting