17:00:16 <mattdm> #startmeeting Council (2015-03-16)
17:00:16 <zodbot> Meeting started Mon Mar 16 17:00:16 2015 UTC.  The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:19 <mattdm> #chair mattdm jreznik jwb cwickert rdieter langdon sgallagh decause
17:00:19 <zodbot> Current chairs: cwickert decause jreznik jwb langdon mattdm rdieter sgallagh
17:00:21 <mattdm> #topic introductions, welcome
17:00:24 <mattdm> hello everyone!
17:00:24 <jwb> YESSSSSSSSSSSSSSSs
17:00:28 <mattdm> who do we have today?
17:00:39 <mattdm> a very excited josh!
17:00:39 <sgallagh> Hello
17:00:47 * cwickert thought we only had meetings every other week?
17:00:51 <jwb> i am excited that we have a follow up meeting, on time, with an agenda.  SUCCESS
17:00:52 <rdieter> hola
17:01:15 <mattdm> jwb: heh.
17:01:21 <jreznik> jwb: +1!
17:01:31 * jreznik is here too, trying to multitask a bit but here
17:01:31 * decause waves
17:01:40 <mattdm> cwickert: usually, but last week everyone was excited to do another
17:01:41 <rdieter> cwickert: usually, had a bunch of stuff we weren't able to cover 100% last week, so here we are
17:01:54 <mattdm> hello decause!
17:02:04 <decause> :)
17:02:12 <decause> glad to finally be here
17:02:16 <mattdm> okay so, let's get right to it!
17:02:20 <mattdm> #topic agenda
17:02:27 <mattdm> #topic agenda
17:02:29 <mattdm> -  5 minutes: intros and welcomes and agenda and stuff
17:02:31 <mattdm> - 10 minutes: outreach steering committee
17:02:33 <mattdm> - 10 minutes: third-party repos
17:02:35 <mattdm> - 10 minutes: university involvement objective
17:02:37 <mattdm> - 10 minutes: contributor survey
17:02:39 <mattdm> - 10 minutes: open floor, time permitting
17:02:41 <mattdm> -  5 minutes: next meeting, action plans
17:02:43 <mattdm> ^ above is from the mail I sent this morning....
17:02:52 <mattdm> anyone have anything to add (or remove)?
17:03:05 <jwb> i'd remove contributor survey
17:03:11 <sgallagh> I have not seen this email...
17:03:14 <jwb> because we're going to run long on at least 2 of those topics
17:03:26 * decause has not seen this email either :/
17:03:28 <mattdm> jwb: yeah that's why I put it last
17:03:36 <jreznik> yep, it's probably too much for one meeting
17:03:41 <mattdm> sent email to council-discuss
17:03:46 <jwb> i got it
17:03:51 <jreznik> and we don't have to sort out everything Board did not do in a few meetings
17:03:54 * jreznik got it too
17:03:56 * decause adds to taskwarrior
17:04:27 <mattdm> so skip that and add 5 minutes to the first two topics?
17:04:33 <jwb> yes
17:04:39 <mattdm> works for me.
17:04:40 <decause> +1
17:04:49 <mattdm> #topic outreach steering committee
17:05:01 * decause has created a trac: http://fedorahosted.org/fosco
17:05:04 <mattdm> cwickert, did you have a chance to move further on this?
17:05:52 <decause> it is very much just a shell at the moment, but should help direct tickets and action and collect knowlege
17:06:02 <langdon> .hello langdon
17:06:05 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
17:06:11 <cwickert> mattdm: no, still working on the summary of the previous discussions as I thought I had one more week
17:06:16 <mattdm> hi langdon! current topic is outreach steering committee
17:06:37 <langdon> mattdm, yeah.. sorry .. lost track of time
17:06:48 <mattdm> cwickert: yup no problem. can decause help in any way?
17:07:14 <cwickert> mattdm: I'll finish the summary later tonight and then ask for ideas.
17:07:25 <jreznik> in such case, we can skip it too today, it doesn't make sense to go over it without having more details
17:07:31 <mattdm> cwickert: awesome thanks
17:07:46 <mattdm> #action cwickert to finish outreach summary later today, ask for input
17:07:58 <mattdm> jreznik: yeah, I agree.
17:08:07 <mattdm> cwickert: anything else you can use from anyone to help?
17:08:30 * decause also created #fedora-outreach on Freenode
17:09:04 <cwickert> mattdm: not at the moment. I think we need to agree on some very basic questions first, e.g. whether or not FOSCo is going to replace FAmSCo or not and so on
17:09:26 * mattdm nods
17:09:44 <mattdm> okay... let's move on and come back to this next week, with that hopefully posted + some input on it as well
17:09:55 <mattdm> #topic third-party repos
17:10:17 <mattdm> jwb, do you want to introduce your thoughts here?
17:10:28 <jwb> sort of
17:10:39 <jwb> i'll start with a recap from FESCo last week
17:10:45 <mattdm> k
17:11:10 <jwb> the Software installer in Workstation gained support for disabled repository metadata searching (i'm paraphrasing)
17:11:23 <jreznik> #link https://fedoraproject.org/wiki/Changes/DisabledRepoSupport
17:11:48 <jwb> the Workstation WG wanted to know if it was feasible to install COPR repository files that were disabled by default.  they took that request to FESCo, and FESCo agreed
17:11:51 <jwb> thanks jreznik
17:12:32 <jwb> now, that gets Fedora into a place were people can search for things that are permissible in COPRs but no in the main Fedora repositories for whatever reason
17:12:32 <jreznik> btw. we wanted something similar with Playground repo, that would somehow allowed similar thing
17:12:52 <jreznik> FESCo rejected it that time but now as we have implementation ready...
17:12:53 <jwb> jreznik, right, i was also going to mention that
17:12:55 <sgallagh> jreznik: Yes, I think we need to have the Env/Stacks group collaborate on the curation process
17:12:59 <mattdm> outcome is update to this policy:
17:13:01 <mattdm> #link https://fedoraproject.org/wiki/Third_Party_Repository_Policy
17:13:09 <jwb> mattdm, correct, thanks
17:13:43 <jwb> now.  beyond that specific request, the Board weighed in on that policy when it was originally created and didn't offer very specific guidelines on Policy
17:14:48 <jwb> we have had requests in the past for various third party repositories outside of COPRs to be searchable
17:15:04 <jwb> specific, approved, and currated repositories.  not something like rpmfusion
17:15:54 <jwb> i am going to go out on a limb and suggest that with the new mechanism in place, it might not be a bad idea to sit down and figure out exactly what we want to allow and disallow outside of COPRs
17:15:57 <mattdm> and not to dance around it: the change page specifically mentions "non-libre but licit" software Steam and Chrome
17:16:45 <jwb> mattdm, yes, correct.  i had forgotten those were used as examples
17:17:13 <jreznik> the question is, what "(or possibly sanctioned)" means in the change page - is it rpm fusion too? as it's currently sanctioned
17:17:20 <sgallagh> So a valid question to ask here is whether the Council thinks that the benefits to Fedora outweigh the possible negative implication of supporting the installation of non-libre software.
17:17:25 <jwb> no, i just said not rpmfusion
17:17:34 <sgallagh> jreznik: RPMFusion is not sanctioned and never has been
17:17:39 <stickster> jreznik: I drafted that page, I can answer that
17:17:45 <sgallagh> It's "tolerated" by necessity :)
17:17:50 <mattdm> jreznik: "sanctioned" is one of those awesome english words which can also mean its own opposite
17:18:09 <jwb> yeah, english is terrible
17:18:12 <jreznik> mattdm: ok, I'll take a lesson here :)
17:18:21 <sgallagh> Yeah, that word should be considered inflammable...
17:18:27 <jwb> let's say "approved" and "disapproved"
17:18:29 <stickster> sgallagh: :-P
17:18:54 <mattdm> in _this_ sense, "sanctioned" means basically "explictly allowed"
17:19:22 <jwb> one second please
17:19:27 <jreznik> mattdm: I don't think so as it's next to not officially included...
17:19:35 <jwb> to be clear, the Board weighed in with two specific statements:
17:19:41 <jwb> "The board believes that shipping repository metadata that points at
17:19:42 <jwb> non-free software is incompatible with Fedora's foundations"
17:19:43 <jreznik> "needs to be clearly identified as not officially included (or possibly sanctioned) by that distribution"
17:19:47 <jwb> "The board believes that reducing technical barriers to explicit user
17:19:48 <jwb> choice to install third-party software (non-free or otherwise) is
17:19:48 <jwb> compatible with Fedora's foundations."
17:20:22 <sgallagh> This topic is likely to get into a debate about the "Freedom" foundation, but I'd like to make sure we accommodate the possibility that advancing Freedom may mean permitting small exceptions in order to expand to wider influence.
17:20:35 <mattdm> jwb thanks for finding those -- was looking for exact statements but couldn't find em
17:20:40 <jwb> so.  the new technical implementation in Software does not ship repository metadata, and it eases explict user choice
17:21:04 <jreznik> maybe the question is one level above - are our project's core values still valid when our top subprojects thinks, it hits theirs mission?
17:21:20 <sgallagh> jreznik: Sorry, could you rephrase that?
17:22:47 <jreznik> sgallagh: I'll try - workstation is our major edition, seems like they think it makes harder to reach theirs (and in this case also our) goals because proprietary software is needed for the target audience
17:22:53 <mattdm> The projects core values are just that -- they're fundamental. However, they're _values_, not strict legal code.
17:23:35 <jwb> sgallagh, so your take is that any such proposals on other third party repos should include statements as to who else will be reached and why that will be good for Fedora?
17:23:36 <sgallagh> jreznik: Thank you, that's a much clearer question
17:23:49 <mattdm> jwb: I certainly think so.
17:23:53 <sgallagh> jwb: Yes, I think that would go a long way towards justifying the request
17:24:02 <sgallagh> And reducing unnecessary religious warfare
17:24:23 <stickster> !
17:24:28 <jwb> go ahead stickster
17:24:58 <jreznik> btw. I still stand behind my opinion during that Board discussion - I'm ok with it but with user's consent on making repository searchable *before* searching for it... I'm not happy about having proprietary stuff but I'm also pragmatic and I understand why we need it
17:25:21 <stickster> First, jreznik++ for summarizing an important point, although I think s/proprietary software/software not included in Fedora *such as* proprietary software/ ...
17:25:30 <mattdm> (note that we're now 15 minutes on this topic, but as we shortened the last one, we still have time)
17:26:26 <sgallagh> mattdm: I would be okay with postponing the University Involvement topic if we get to that point. This is pretty important and more urgent.
17:26:41 <stickster> Second, I wanted to clarify how a statement should be detailed to help the Council here. For instance, one way to explain the case for something like Chrome would be to show market penetration, and workflows that developers use with that tool.
17:27:25 <sgallagh> stickster: Yeah, that's a more verbose way of saying what I was trying to above: that any exemption should come with a carefully-researched justification.
17:27:48 <stickster> Then one might reasonably say that our goal is to attract developers to discover the many benefits of our free software platform while easing their migration -- they can get access to tools with which they're already comfortable with minimal friction.
17:27:48 <mattdm> I notice that the current change proposal has the installation of the "non-libre but licit software" listed as a benefit in itself. Given our mission to advance free and open source software, I don't think that that's sufficiently explanatory.
17:27:59 <mattdm> stickster: yes, like that.
17:28:19 <sgallagh> stickster: Yeah, please include that phrasing in the Change page :)
17:28:25 <langdon> as, potentially, an aside.. can we work in a way that FOSS alternatives might be presented when choosing non-foss software?
17:28:30 <jwb> mattdm, the Change uses it as an example of the possible.  not what is actually changing
17:28:37 <mattdm> langdon +1
17:28:52 <sgallagh> langdon: IIRC, there's some effort underway to display "similar applications" which may help that
17:28:55 <mattdm> jwb: yes, but it's in the "benefits to fedora" section
17:29:02 <sgallagh> But I'd have to double-check with Richard
17:29:11 <jwb> mattdm, then i'd simply say strike that line
17:29:16 <stickster> jwb: That's correct, because at the time it wasn't clear what if any .repo definitions would be shipped
17:29:23 <stickster> So the page is largely theoretical
17:29:42 <jwb> stickster, then until we get to a concrete proposal for a non-COPR repo, i suggest striking that line
17:29:50 <mattdm> agreed
17:30:00 <stickster> langdon: Yes, the function is already built in so if you enable a disabled repo, we can display specific Fedora-related text to the user (including presumably a link to more info)
17:30:14 <stickster> langdon: I believe that is on a per-repo basis.
17:30:21 <stickster> jwb: I can do that.
17:30:35 <stickster> Where should the reasoning stuff go?
17:30:50 <jwb> stickster, in a separate request to enable a specific repo?
17:30:58 <langdon> stickster, meh.. works for "chrome" but not for "rpmfusion" (just two examples off the top of my head)
17:31:13 <jwb> s/enable/ship a disabled repo file for
17:31:13 <decause> to langdon's point: is there a "FOSS alternatives" resource page somewhere we point people at already?
17:31:21 <jwb> decause, no
17:31:26 <stickster> langdon: I specifically am not interested in anything that means risk. Forget about rpmfusion, it's not part of this discussion at all
17:31:42 <decause> #action decause start sourcing a "FOSS Alternatives" resource page
17:31:46 <jreznik> stickster: I'm happy to see that text, that explains it to users but I'd still prefer having this dialog available even before this software *is* searchable
17:31:54 <langdon> stickster, hence the "example" remark.. i just mean a "repo that has more than 1 piece of software in it"
17:32:00 <sgallagh> proposal: The Council is amenable to allowing a limited set of third-party repositories be searched in Fedora software stores, however each such example should be brought to the Council with a justification of how it would benefit Fedora's mission to include the software contained in that repo.
17:32:05 <jwb> if it would please the counci, we can simply state officially that rpmfusion repo files cannot be included in any Fedora package or COPR
17:32:13 <jreznik> decause: awesome! something we're looking for in our openalt group!
17:32:13 <jwb> that way we stop talking about it.
17:32:16 <sgallagh> (just to see if we have an agreement on that point at least)
17:32:50 <jwb> sgallagh, i think that might be slightly overstating it
17:33:04 <sgallagh> jwb: In what way?
17:33:09 <stickster> sgallagh: You need an editor. ;-)
17:33:17 <sgallagh> stickster: I've got vi!
17:33:20 <jwb> i don't think we've said we're amenable to allowing.  i think we've all said we're amenable to discussion of specific repos
17:33:22 <jreznik> sgallagh: I'm still not confortable with that searchable by default without opt-in or opt-out before searching... that's the only problem I have with the whole thing
17:33:36 <langdon> decause, there is an outstanding web page the tells you how to shift from non-free->foss (mostly about privacy concerns) produced by someone at gnu? or libre-planet or something.. must dig..
17:33:40 <sgallagh> jwb: Well, that was what I was trying to determine: a vote on whether we are amenable as a whole
17:34:01 <jwb> sgallagh, yes but amenable to allowing is phrasing that is suggestive towards permission
17:34:12 <sgallagh> jreznik: If it's not searchable by default, the discussion is moot because nothing will be discoverable
17:34:12 <jwb> nobody has said they're leaning that way
17:34:17 <sgallagh> jwb: OK
17:34:57 <stickster> sgallagh: Correct on discoverability. Otherwise the barrier for users hasn't changed and the feature's worthless.
17:35:03 <stickster> Well, worth less.
17:35:29 <langdon> so.. just because I am confused.. does "3rd-party repo" == "repo that only provides one piece of software" (and maybe its deps) in this conversation?
17:35:41 <jwb> langdon, most likely yes
17:35:55 <jreznik> stickster: exactly
17:36:08 <jwb> however, i'd like us to take one step back
17:36:13 <stickster> langdon: Yes. At this point I don't think anyone's comfortable with "repo full of software" other than COPRs where there is at least reliably just FOSS
17:36:22 <mattdm> langdon: From the earlier conversation, I think the idea was that we would stick to that, in order to reduce burden on legal agreements
17:36:39 <jreznik> stickster: but fot COPR, I'm definitely +1
17:36:42 <jwb> because we're talking about "repos" in the traditional RPM sense of things.  yet App containers can be just as much third party
17:36:49 <jreznik> so maybe, can we switch it to more phases?
17:37:07 <jreznik> like phase 1 COPR - that's what I understand they are asking for now
17:37:10 <jwb> jreznik, i'd not be supportive of that
17:37:13 * stickster EOF until someone calls him
17:37:14 <jreznik> and deal with other phases later?
17:37:24 <jwb> jreznik, COPRs is already approved
17:37:37 * langdon thinks he must have missed the first bullet..
17:37:57 <jwb> langdon, you didn't miss the bullet.  you missed being on the board where the original proposal was submitted
17:38:04 <sgallagh> langdon: COPR was approved by the old Board and recently revised for functionality by FESCo
17:38:07 <jwb> there's a bit of tribal knowledge here
17:38:09 <sgallagh> It's covered.
17:38:12 <jreznik> jwb: and for COPR, I'm definitely +1 but any other repos may need different way how to deal with it
17:38:22 <jwb> jreznik, which is exactly what we're discussing
17:38:35 * jwb thinks people missed his Container statement
17:38:57 <sgallagh> jwb: I saw it, but I was concerned that it would confuse the topic further
17:39:03 * mattdm did not miss the container statement
17:39:08 <jreznik> jwb: it's not that clear as it was repeated several times, that for now, we talk about COPR for now
17:39:17 <jreznik> but I got it now
17:39:45 <jwb> sgallagh, if we're going to craft a process or policy on how to deal with thrid party things, then it should be general enough to cover third party things, not just RPM repositories
17:39:59 <jwb> sgallagh, otherwise this topic will come up again in a year and we'll fight all the same battles
17:40:00 <mattdm> I agree that anywhere we are saying 'repo' we should keep 'app delivery by whatever mechnism' in mind.
17:40:08 <jreznik> jwb: I agree
17:40:56 <mattdm> okay, so, what immediate outcomes are we looking for here?
17:41:00 <decause> so for today, phase 1 = copr repos with only libre software, yes?
17:41:04 <jwb> decause, no
17:41:08 <jwb> that's already approved
17:41:11 <decause> kk
17:41:12 <decause> thanks
17:41:13 <mattdm> a clarified preemptive statement of some sort?
17:41:26 <jwb> mattdm, yes.  along the lines of what sgallagh was getting at with his proposal
17:41:51 <sgallagh> Proposal: The Council does not approve a blanket exemption for searching any third-party repository. Individual repositories can be assessed based on a case-by-case basis with a justification provided on how it will benefit the Fedora Project to include it.
17:42:21 <jwb> yes, something quite like that
17:42:36 <inode0> !
17:42:54 <mattdm> I'm roughly for that, but I would like to s/benefit Fedora Project/advance the Fedora Project's mission/
17:43:06 <sgallagh> inode0: go ahead
17:43:23 <inode0> Has the council already rejected that shipping 3rd-party metadata is inconsistent with Fedora's foundations or is it a given that it is going to do that?
17:43:34 <inode0> Seems to be implicit in the discussion?
17:43:36 <stickster> (Have to jump in as editor.) To state it more succinctly: The Council must individually approve search enablement for any third party repository on a case-by-case basis. The justification must include how the content will benefit the Fedora Project.
17:43:44 <inode0> EOF
17:43:52 <jwb> inode0, the Board rejected that outright.  the Council has not overruled that decision
17:44:10 <jreznik> stickster: I like it this way
17:44:14 <inode0> How can any of this be done without doing that?
17:44:18 <sgallagh> inode0: Implicit in the discussion is that we are potentially open to the idea of including certain repositories if doing so would result in a significant net gain.
17:44:33 <sgallagh> net gain to Fedora's overall mission
17:44:42 <jwb> inode0, because the metadata is not being shipped with the new Software mechanism
17:44:43 <langdon> what is the "burden" on approval of the repo? council decision? wkstn wg? fesco? something else?
17:45:01 <sgallagh> langdon: I'd say the burden has to be on the Council
17:45:19 <rdieter> all nuanced with the newer statement of course: "The board believes that reducing technical barriers to explicit user choice to install third-party software (non-free or otherwise) is compatible with Fedora's foundations."
17:45:22 <inode0> Either it is conveniently shipped with Fedora or it isn't helping any.
17:45:32 <mattdm> inode0: "third party" doesn't necessarily mean proprietary. that's a separate axis.
17:45:33 <langdon> sgallagh, don't have a strong opinion (and that seems right to me).. but, I think it should be in the phrasing
17:45:52 <jwb> stickster, care to edit in langdon's point?
17:45:52 <jreznik> stickster: maybe I'd patch it - not only approve but also "Council reserves right to ask for other technical means of enabling these repositories" aka consent with searchability before it's turned on/off (aka opt-in, opt-out)
17:45:58 <langdon> or.. we need the "how" somewhere
17:45:59 <inode0> mattdm: I didn't say proprietary did I?
17:46:00 <sgallagh> langdon: I think stickster's phrasing covers it
17:46:18 <mattdm> inode0: okay, but I don't see how "third party" is necessarily incompatible with our foundations
17:46:43 <mattdm> too broad. some third party could be completely aligned in every way.
17:46:50 <langdon> sgallagh, ok.. re-reading.. hmm.. sure.. not sure what i think was missing
17:46:52 <sgallagh> inode0: Right, "third-party" could conceivably be CPAN or Rubygems.org (in theory)
17:46:54 <inode0> yes,
17:47:05 <stickster> Or "LAMP-in-a-container"
17:47:29 <stickster> er, LAMP+app (which makes more sense) :-P
17:47:34 <jreznik> mattdm: yep, there are more 3rd parties and each can be decided separately... this way, we will unblock it for clear good 3rd parties
17:47:38 <sgallagh> Do we want to vote on stickster's phrasing?
17:47:58 <sgallagh> Proposal: "The Council must individually approve search enablement for any third party repository on a case-by-case basis. The justification must include how the content will benefit the Fedora Project."
17:47:59 <mattdm> are people opposed to my amendment?
17:48:07 <langdon> might need to be careful on containers (e.g. docker hub).. (or rubygems.org)... they have lots-o-software ... so neither would pass the 3rd-party rule right as proposed
17:48:07 <inode0> so non-free is more what I meant, sorry
17:48:10 <jreznik> sgallagh: I'd like to patch it with my appendix (or some other way for opt-in/opt-out for users)
17:48:11 <sgallagh> /me missed it
17:48:25 <mattdm> s/benefit Fedora Project/advance the Fedora Project's mission/
17:48:47 <decause> mattdm: +1 to that last edit
17:48:50 <stickster> mattdm: I'm for your change of phrase.
17:48:56 <jwb> mattdm, not opposed
17:48:59 <sgallagh> Proposal: "The Council must individually approve search enablement for any third party repository on a case-by-case basis. The justification must include how the content will advance the Fedora project's mission."
17:49:17 <sgallagh> jreznik: The council always reserves all rights to change its mind. I think that addendum is redundant :)
17:49:31 <mattdm> +1 to that
17:49:35 <jwb> +1
17:49:39 <stickster> In fact, that's a reasonable level someone could meet, whereas the way I phrased it first was probably an impossible bar :-)
17:49:41 <sgallagh> +1
17:49:53 * langdon wonders if he hasn't had enough coffee..
17:50:00 <rdieter> +1
17:50:06 <jwb> langdon, because?
17:50:16 <jreznik> +1, even I'd like to have it stated there :)
17:50:19 <mattdm> but, I want to make sure we don't get into another "what does metadata mean"? argument with "search enablement". Is what Software does now "search enablement"?
17:50:35 <langdon> so .. is the proposal from ~13:48 (est) by sgallagh the one to vote on? or is there an appendix?
17:50:45 <jwb> langdon, 13:48
17:51:05 <stickster> mattdm: We could be more exacting, "approve including a disabled repo definition"
17:51:06 <sgallagh> langdon: 13:48; if you want the appendix, vote -1
17:51:26 <langdon> 2.. any comments on my concern that rubygems.org and docker hub wouldn't be "allowed" in the current definition of "3rd party"?
17:51:40 <jwb> stickster, i dislike that.  it is too technically specific
17:51:43 <mattdm> stickster: _too_ exacting; I want general but clear
17:51:44 <sgallagh> stickster: We were trying to avoid specifying an implementation
17:52:05 <mattdm> langdon: right, that's a really good concern. the current docker client _does_ search a third party repository
17:52:08 <sgallagh> langdon: I missed that.
17:52:20 <stickster> Then I think the original is probably specific enough
17:52:24 <jwb> langdon, they already aren't "allowed"
17:52:36 <sgallagh> langdon: In my head, that's covered, but if the language is implying otherwise, maybe it needs to be tweaked
17:52:52 <langdon> jwb, i am just clarifying that they are "lots-o-software" repos vs "single-app" repos
17:53:10 * mattdm notes clock since kushal isn't here today to do so :)
17:53:33 <jwb> langdon, oh i see
17:53:46 <jwb> mattdm, i propose we just continue
17:53:48 <jreznik> we are back to that some software already does it - aka firefox...
17:54:07 <stickster> jreznik: Or curl.
17:54:22 <stickster> Or $LONG_LIST_OF_SOFTWARE_WITH_WHICH_YOU_CAN_DOWNLOAD_THINGS
17:54:24 * mattdm is okay with continuing
17:54:37 <langdon> however, I am +1 one on this language ""The Council must individually approve search enablement for any third party repository on a case-by-case basis. The justification must include how the content will advance the Fedora project's mission." but am still confused about where the appendix remark came fron.. and I think we need to address "lots o software" repos another time..
17:54:50 <jwb> langdon, i think this propoal is mostly along the lines of the default software installation tools.  not ... tool-specific items like rubygems
17:55:09 <jwb> i don't even know what the appendix is supposed to be
17:55:11 <sgallagh> langdon: The appendix was jreznik asking for the council to reserve the right to demand that the tool provide an opt-in or opt-out for this
17:55:12 <mattdm> jwb +1. should we work that in there?
17:55:28 <langdon> jwb, ha.. i wish it was that simple .. you can (well, technically, "used to be") get vagrant from rg.o :)
17:55:36 <jreznik> maybe we should add it to the proposal it is for the default software installation tools
17:55:41 <sgallagh> langdon: I argued that the council always reserves all rights and that this was redundant
17:55:43 <jwb> mattdm, no
17:56:01 <jwb> i mean, there is only so much language lawyering we can do if we aren't going to blanket approve or disapprove things
17:56:10 <mattdm> jwb: maybe into the quesiton we are answering, not the answer itself. :)
17:56:12 <jwb> so there will naturally be some things we need to review
17:56:22 <langdon> sgallagh, ahh.. got it now.. ok.. im +1 on the proposal by sgallagh.. I think the council will attempt to not be wishy-washy but makes no promises :)
17:56:46 <mattdm> right on wishywashy :)
17:57:09 <sgallagh> I'm still unclear why "all cases must be approved individually" is apparently controversial
17:57:22 <jwb> sgallagh, i don't think it is?
17:57:30 <sgallagh> jwb: Then why are we still arguing?
17:57:40 <jwb> because people are confused as to what exactly we're voting on
17:57:54 <langdon> jwb, i prefer to think "just me" :)
17:57:57 <sgallagh> Shall I re-propose it?
17:58:03 <jwb> langdon, no, i didn't know what "Appendix" meant either
17:58:06 <sgallagh> Proposal: "The Council must individually approve search enablement for any third party repository on a case-by-case basis. The justification must include how the content will advance the Fedora project's mission."
17:58:14 <jwb> +1\
17:58:23 <langdon> +1
17:58:27 <mattdm> +1
17:58:27 <decause> I'm +1 on the proposal, and perhaps we need a subcommittee and/or separate meetings on these 3rd Party questions/approval for the future?
17:58:33 <rdieter> +1
17:58:40 <sgallagh> +1
17:58:44 <decause> it is 2 mins til </councilmeeting>
17:58:46 <mattdm> cwickert still around?
17:59:13 <jreznik> +1
17:59:13 <rdieter> decause: ideally most discussion would happen onlist (and not in the meeting).  crazy?
17:59:24 <mattdm> rdieter: yeah :)
18:00:24 * cwickert is busy at work and had no chance to follow the discussion, sorry
18:01:06 <mattdm> cwickert: *nod*. did you see the proposal a few lines up from sgallagh? if you're good with that (and that's all we've really gotten to) we can call it approved
18:01:21 <jwb> langdon, if it makes you feel better, i think docker hub is a great example to start from.
18:01:58 <langdon> jwb, certainly more obvious.. but, technically, pypi or rubygems.o has the same problems.. lots of "software" not just libraries
18:02:16 <langdon> although.. i suppose.. most of pypi and rb.o is foss, right?
18:02:18 <cwickert> mattdm: +1
18:02:24 <mattdm> cwickert: okay cool
18:02:30 <jwb> langdon, yes.  docker hub is frankly worse than rpmfusion in that regard
18:02:58 <mattdm> #agreed "The Council must individually approve search enablement for any third party repository on a case-by-case basis. The justification must include how the content will advance the Fedora project's mission."
18:03:41 <mattdm> Is there a further proposal for now, or should we go back to lists to figure out some of these issues with things like docker?
18:03:53 <jwb> mattdm, i don't believe there is a further proposal
18:04:26 <mattdm> ok. anything in specific we want to discuss now or on lists?
18:04:44 * jreznik has to leave now, so nothing to discuss here today
18:04:58 <jwb> mattdm, i might bring up docker hub.  i make no promises
18:05:09 <mattdm> jwb fair enough
18:05:29 <mattdm> okay, so... meeting time +5.
18:05:41 <mattdm> #topic wrap-up
18:06:01 <mattdm> Unless there's anything particularly urgent, let's discuss the other things on list and in their respective tickets.
18:06:08 <sgallagh> decause: Do you have 30 minutes to spare this afternoon?
18:06:34 <sgallagh> I want to pick your brain about the University stuff
18:06:43 <decause> sgallagh: perhaps if we can do a conf call (I've got about 15 mins of driving time in the near future)
18:06:56 <mattdm> #action sgallagh and decause to get together about the university objective proposal
18:07:12 <sgallagh> decause: It can wait until tomorrow if you're booked.
18:07:26 <decause> sgallagh: I can handle it on my drive, or later tonight
18:07:37 <jwb> sgallagh, and spot, right?
18:07:47 <decause> sgallagh: we'll coordinate after </meeting>
18:07:56 <sgallagh> ok
18:08:13 <mattdm> thanks everyone!
18:08:16 <mattdm> #endmeeting