18:00:09 <nirik> #startmeeting Infrastructure (2015-07-09)
18:00:09 <zodbot> Meeting started Thu Jul  9 18:00:09 2015 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:09 <nirik> #meetingname infrastructure
18:00:09 <zodbot> The meeting name has been set to 'infrastructure'
18:00:09 <nirik> #topic aloha
18:00:09 <nirik> #chair smooge relrod nirik abadger1999 lmacken dgilmore mdomsch threebean pingou puiterwijk pbrobinson
18:00:09 <zodbot> Current chairs: abadger1999 dgilmore lmacken mdomsch nirik pbrobinson pingou puiterwijk relrod smooge threebean
18:00:10 <nirik> #topic New folks introductions / Apprentice feedback
18:00:29 <nirik> Any new folks like to introduce themselves ?
18:00:34 <nirik> or apprentices with questions ?
18:00:57 <AadityaNair> Hi
18:01:03 <AadityaNair> I am aadityanair
18:01:10 <AadityaNair> from India
18:01:39 <AadityaNair> I was wondering how to get SSH access onto the machines
18:01:39 <nyazdani> welcome, AadityaNair!
18:01:42 <nirik> welcome AadityaNair.
18:01:59 <nirik> are you more interested in sysadmin work or application development, or both?
18:02:27 <jcvicelli> Question: do we also provide support for apps inside infra?
18:02:27 <AadityaNair> sysadmin work is my prefernece
18:02:35 * threebean is here
18:02:40 * relrod is here
18:02:49 * rahulrrixe_ is here
18:02:52 * lmacken 
18:03:18 * puiterwijk is here but checking something
18:03:22 <nirik> jcvicelli: yes? you have an example?
18:03:26 <rahulrrixe_> Hi AdityaNair :)
18:03:30 * pcreech|work is here, but at nginx training
18:03:35 * prth is here
18:03:47 <nirik> AadityaNair: great. see me in #fedora-admin after the meeting and I can get you added to our apprentice group to look around.
18:03:51 * ardian is here
18:04:41 <AadityaNair> nirik: ok, thanks. I will just sit back during the meeting.
18:04:52 <jcvicelli> Like koji for example
18:04:54 <nirik> any other new folks with introductions or apprentices with questions?
18:05:00 <nirik> jcvicelli: yes. We support koji.
18:05:31 <jcvicelli> And also develop?
18:05:31 <ardian> nirik, yes
18:05:37 <threebean> jcvicelli: mostly, yes :)
18:05:46 <jcvicelli> Cool, thx
18:05:55 <nirik> jcvicelli: we are actively involved yeah... there is an upstream project tho seperate from us
18:05:59 <threebean> jcvicelli: we play less of a role in koji development than in other things.  it varies from service to service how much we're involved.
18:06:03 <ardian> The list for easyfix https://fedorahosted.org/fedora-infrastructure/report/14 has some old tickets are they still relevant
18:06:24 <nirik> ardian: likely yes. :)
18:06:49 <nirik> I can try and go through them, but if they were not closed, they should be handled.
18:07:00 <nirik> often someone starts working on one and wanders off.
18:07:06 <ardian> I see
18:07:29 <jcvicelli> Looks like they are done but it's not clear what is missing
18:07:55 <nirik> feel free to ask questions in the ticket. I get copies of every email to every ticket and can try and update status.
18:08:08 <ardian> one more thing if the ticket says that it's owned by sysadmin-members
18:08:20 <ardian> does that mean that you have to be in that group ?
18:08:31 <nirik> no, thats just the default generic group that gets email about it.
18:08:38 <nirik> some types of tickets go to specific groups.
18:08:44 <nirik> thats just the generic one
18:09:16 <ardian> ah ok, I am new and looking to find my way through the tickets
18:09:16 <ardian> thanks
18:09:42 <nirik> cool. I keep meaning to try and file some more easyfixes, but it's hard to come up with things that are really easy
18:09:59 <nirik> but do ask questions and we can try and get you working on something you like. ;)
18:10:07 <nirik> #topic GSoC student update - kushal
18:10:23 <nirik> I don't see kushal around, but any GSoC folks want to update us on their projects?
18:11:17 <sonalkr132> On glittergallery, I am working on implementation of git ssh protocol. It is crucial for sparkleshare
18:11:25 <AnuradhaW> Hi, I have figured out how to integrate the styles I have coded into askbot with the help of TheMonster which has given me trouble during the past weeks.
18:12:10 <rahulrrixe_> This week I have worked on mainly adding review process in fresque. I have made a simple commenting system and would be integerating with app. Also I have fixed some bugs on the git integeration.
18:12:27 <AnuradhaW> So, during the next few days I will be working on integrating the styles into the test instance set up in openshift.
18:12:32 <prth> I implemented delete overlay. Last week after bug reports from pingou, I've been testing the app with high resolution wallpapers & fixed the bugs. I'm working on cropping wallpapers server side now as browser crashes for wallpapers > 3000*3000 with segments > 1000*1000
18:13:14 <nirik> cool. Sounds like great progress all around.
18:14:04 <nirik> #topic announcements and information
18:14:04 <nirik> #info July apprentice email is out. Please reply by next monday - kevin
18:14:04 <nirik> #info Some cloud instances moved from old -> new cloud - kevin
18:14:04 <nirik> #info Fedora22 Jenkins builder setup in new cloud - kevin
18:14:04 <nirik> #info people03 migrated to people01 - kevin, patrick
18:14:05 <nirik> #info Ipsilon to prod scheduled for upcoming wednesday. Please test - Patrick
18:14:06 <nirik> #info Making progress with the bodhi2 staging deployment https://admin.stg.fedoraproject.org/updates/ - lmacken
18:14:09 <nirik> #info fun but slow progress on fedora-hubs design and implementation https://pagure.io/fedora-hubs/raw/develop/f/docs/diagram.png - mrichard / ralph / nyazdani
18:14:15 <nirik> lots of info / status as usual. ;)
18:14:35 <nirik> I had one discussion item:
18:14:35 <nirik> #topic Outage announcements - kevin
18:14:37 <threebean> lmacken++ on bodhi2.  rad to see it up in staging.
18:14:49 <puiterwijk> I do want to point out the Ipsilon one if possible. Please test thoroughly this week :)
18:14:57 <nirik> puiterwijk: can do
18:14:59 <lmacken> threebean: been working behind the scenes on the client/cli stuff yesterday... getting close ;)
18:15:05 <nyazdani> nirik: real quick, how did you turn that ascii chart into a png?
18:15:06 <nirik> lmacken++ indeed. bodhi2 goodness
18:15:08 <zodbot> nirik: Karma for lmacken changed to 7:  https://badges.fedoraproject.org/tags/cookie/any
18:15:08 <threebean> super
18:15:27 <nirik> nyazdani: which chart?
18:15:38 <threebean> nyazdani: ah, this tool -> https://apps.fedoraproject.org/packages/ditaa
18:15:54 <nyazdani> nirik: sweet, thank you
18:16:19 <threebean> this is in reference to this two files -> https://pagure.io/fedora-hubs/blob/develop/f/docs
18:16:25 <threebean> s/this/these/
18:17:02 <nirik> cool. Looks nice. ;)
18:17:45 <nirik> ok, on outage tickets. Right now we have a template in trac with a somewhat incomplete list of our services in it, and we fill it out for an outage with 'affected services' and 'unaffected services' lists.
18:17:57 <nirik> we can somewhat get a more up to date list from apps.fedoraproject.org
18:18:13 <nirik> but personally I wonder how much people care about 'unaffected services'
18:18:41 <nirik> anyone have thoughts on how we best should handle them?
18:19:16 <threebean> hm.  not sure on the second part yet..
18:19:55 <threebean> but pulling the list of services dynamically from apps.fp.o/js/data.js could be cool.
18:20:28 <threebean> hm.  the list of unaffected services goes on-and-on at the end of the template.  perhaps if it was just one comma-separated line..
18:20:32 <nirik> thing is, it might also not be complete... or some of them might not have urls.
18:20:39 <threebean> then people who care about one service or another could search for the text of it and see that it's there..
18:21:23 <nirik> yeah, but if we only include affected services they could look and not see it there and know it's ok?
18:21:50 <nirik> I guess the danger is that we might not think of everything affected and forgot to list something.
18:22:40 <nirik> I guess I will look at how other places do things and see if we can come up with something clever.
18:22:50 <nirik> #action nirik to check other projects for ideas
18:23:03 <nirik> any other discussion items today?
18:23:33 <nirik> #topic Learn about: fedorapeople.org - kevin
18:23:48 <nirik> ok, I thought I would do a quick learn about on fedorapeople.org since we have been working on it.
18:24:38 <nirik> fedorapeople.org is a server we have setup to allow any contributors to login and upload/distribute content from.
18:24:53 <nirik> We just migrated it the other day from a rhel6/puppet managed host to a new rhel7/ansible managed one.
18:25:29 <nirik> https://fedoraproject.org/wiki/Fedorapeople_Repos https://fedoraproject.org/wiki/Infrastructure/fedorapeople.org
18:25:57 <nirik> contributors can login with their ssh key.
18:26:08 <nirik> They can use a public_html directory to serve files out
18:26:29 <jcvicelli> Is it all done or you have still work to do?
18:26:30 <nirik> They can use repos.fedorapeople.org / /srv/repos/<username>/ to serve yum/dnf repos
18:26:47 <nirik> They can use public_git to serve out git repos
18:27:00 <nirik> jcvicelli: it's pretty much all done aside from fixing any issues people report. ;)
18:27:07 <kinokoio_> *is late
18:27:37 <nirik> Also, fedorapeople.org gathers rss feeds from contributors and serves them out as planet.fedoraproject.org (soon to change to fedoraplanet.org)
18:27:57 * kinokoio_ is on a windows computer slow as hell
18:28:11 <nirik> welcome kinokoio_
18:28:42 <nirik> We have quite a lot of data on fedorapeople, as it's one of the earliest services we offered.
18:29:08 <nirik> There's about 460GB of content (most of it rpms) on there.
18:29:34 <nirik> The server it's on is hosted at ibiblio.
18:29:48 <nirik> Thats the high points I think. Any questions on the setup?
18:31:02 <nirik> Alrightly then. ;)
18:31:05 <nirik> #topic Open Floor
18:31:15 <nirik> any questions, comments, announcements, puzzles?
18:31:25 <sonalkr132> Hi. I have something I would like to ask/request
18:31:33 <nirik> sonalkr132: fire away
18:31:54 <sonalkr132> Until now glittergallery was using openshift for hosting
18:32:28 <sonalkr132> but now I need to implement ssh access for git. I will need some sudo access to limit ssh access
18:32:55 <sonalkr132> I also need access to .ssh/authorized_keys file. Which openshift doesn't provide
18:33:08 <sonalkr132> Which would mean that we move to VPS
18:33:25 <nirik> per user keys? or ?
18:34:07 <sonalkr132> nirik: Point is I need a VPS, which we don't have.
18:34:26 <nirik> well, we can set you up with a development instance in our cloud pretty easily.
18:34:50 <sonalkr132> that would be great. Whom should I talk to about this?
18:35:10 <nirik> please file a ticket on it? there's a cloud instance request type
18:35:23 <nirik> and say what os/size you need...
18:35:42 <sonalkr132> ohkay! Would that be all?
18:36:19 <nirik> yep. we can get it setup...
18:36:31 <sonalkr132> thank you. I more thing
18:36:51 <sonalkr132> In our team we don
18:37:27 <sonalkr132> we don't have any one experienced with git server and stuff, so I was kinda having hard time.
18:38:08 <nirik> do feel free to ask in #fedora-apps / #fedora-admin and we can help if we are able...
18:38:13 <sonalkr132> Our project is very similar to that of gitlab. So, does anyone know who can talk me up to a gitlab developer?
18:38:42 * nirik doesn't know any of them off hand. ;(
18:39:41 <threebean> sonalkr132: pingou and bochecha are probably your best bet for advice on that, but they're likely off for the night now due to timezones.  you may catch them tomorrow?
18:39:42 <sonalkr132> Thank you. I guess I can handle it.
18:40:18 <kinokoio_> nirik, was ticket https://fedorahosted.org/fedora-infrastructure/ticket/4779 already discussed?
18:40:47 <sonalkr132> threebean: thank you. I will talk to them
18:40:56 <nirik> lmacken: so, f23 branching is next tuesday. I guess we won't have bodhi2 in production before then. :) Can we shoot for before alpha freeze? (28th?)
18:41:08 <nirik> kinokoio_: yeah. we did.
18:41:38 <nirik> kinokoio_: going to try and gather more data on with other projects do/best practices. If you would like to look for that info and add it to the ticket that would be great.
18:42:01 <lmacken> nirik: yeah, the alpha freeze is probably more realistic, since I'm moving apartments next week
18:42:28 <nirik> lmacken: yeah. Please let me know if I can do anything to help it along (make instances, help out with ansible side, etc).
18:42:44 <lmacken> nirik: cool, will do.
18:42:45 <nirik> I really want to get it in. :) Now also because I want to kill releng04/relepel01 from puppet.
18:42:56 <kinokoio_> nirik: I'll look for the info, maybe other distros or sysadmin channels would be a good place too ask
18:43:02 * lmacken nods
18:43:14 <nirik> kinokoio_: yeah, I'd check debian/suse/other mailing list archives, etc.
18:43:26 <nirik> we are getting down to the wire on puppet migrations. ;)
18:43:39 <nirik> I hope to have them all done by flock one way or another.
18:43:54 <kinokoio_> nirik: need any help with the migrations?
18:44:51 <nirik> kinokoio_: sure, but we are down to some very hard machines. ;) There's one ticket out there for migrating darkserver.
18:45:28 <nirik> https://fedoraproject.org/wiki/Infrastructure/PuppetToAnsibleMigration and we should get 3 more in the next few days
18:45:54 <nirik> ok, anything else for open floor?
18:45:58 <nirik> or shall we call it a meeting?
18:46:07 <kinokoio_> i'll get into both when i'm on my pc
18:46:08 <adrianr_> one thing
18:46:26 <threebean> I should probably mention that I'm going to be afk july 13th-24th.
18:46:46 <adrianr_> I wanted to mention that I was talking with pingou about moving the crawlers closer to the mirrors
18:47:08 <nirik> threebean: have a great time away. :) Hope you are going somewhere fun...
18:47:09 <adrianr_> so that if we have machines somewhere that we use them to crawl the local mirrors
18:47:15 <nirik> adrianr_: I am not sure thats practical
18:47:52 <nirik> many of the sites we have proxies don't have lots of resources
18:48:00 <nirik> I doubt any of them have 48GB or whatever.
18:48:21 <adrianr_> nirik: ok, good to know, was just thinking about what can be improved
18:48:42 <nirik> so, you were looking for non NA/usa?
18:49:27 <adrianr_> I know that the proxies are in different locations, but not exactly where,
18:49:48 <adrianr_> to reduce long crawl times it might help to crawl closer to the mirrors
18:49:50 <nirik> yeah, I don't think we really have any good remote sites for a crawler. Unless it could use a lot less memory
18:50:40 <adrianr_> ok
18:50:50 <nirik> there's one host in germany with some memory, but it's low on cpus.
18:51:16 <nirik> good idea tho. ;)
18:51:22 <adrianr_> we could try to crawl european mirrors from there, not so much in parallel, more serial
18:51:51 <adrianr_> maybe instead of 30 at a time, only 8 and then we might can make this work with 8GB
18:52:16 <nirik> we could give it up to 16GB, but not sure how many cpus. All are currently commited there.
18:52:24 <nirik> we can discuss out of meeting I guess. ;)
18:52:34 <adrianr_> sure, just wanted to mention it here
18:52:40 * nirik nods.
18:52:56 <nirik> ok, if nothing else will close out in a minute. .
18:53:30 <nirik> thanks for coming everyone!
18:53:32 <nirik> #endmeeting