15:05:03 <rdieter> #startmeeting kde-sig
15:05:03 <zodbot> Meeting started Tue Aug 11 15:05:03 2015 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:05:06 <rdieter> #meetingname kde-sig
15:05:06 <zodbot> The meeting name has been set to 'kde-sig'
15:05:10 <rdieter> #topic roll call
15:05:15 <Kevin_Kofler> Present.
15:05:19 <rdieter> hi all, friendly kde-sig meeting time, who's present today?
15:05:20 <than> present
15:05:46 * jreznik is here
15:05:58 <heliocastro> here
15:06:29 <mustafam> Not KDE SIG member, but present :)
15:06:35 <dvratil> hello
15:06:37 <rdieter> all are welcome
15:07:00 <rdieter> jgrulich sent regards onlist, I think
15:07:20 <rdieter> feel free to poke anyone else you think should be here
15:07:22 <rdieter> :)
15:07:32 <rdieter> #info rdieter Kevin_Kofler than jreznik heliocastro mustafam dvratil present
15:07:39 <rdieter> #chair Kevin_Kofler than jreznik heliocastro mustafam dvratil
15:07:39 <zodbot> Current chairs: Kevin_Kofler dvratil heliocastro jreznik mustafam rdieter than
15:07:52 <rdieter> let's hit topic 1
15:07:59 <rdieter> #topic Qt-5.5 for f22/f21
15:08:39 <rdieter> i've a tracking bug opened recently for 5.5 related issues, I think all the blockers are cleared, any opinions on when to push 5.5 to f22 ?
15:08:44 * satellit listening
15:08:59 <rdieter> .bug 1229922
15:09:02 <zodbot> rdieter: Bug 1229922 upgrade qt to 5.5 - https://bugzilla.redhat.com/1229922
15:09:33 <rdieter> still have nice-to-have...
15:09:36 <rdieter> .bug 1233829
15:09:40 <zodbot> rdieter: Bug 1233829 Qt5: private headers/interfaces - https://bugzilla.redhat.com/1233829
15:09:50 <rdieter> to implement, heliocastro said he'd look at it, not sure if it's worth blocking on though
15:10:04 <rdieter> (probably not, imo)
15:10:05 <heliocastro> Is not blocker
15:10:18 <dvratil> I don't think anything needs it right now (not even GammaRay)
15:11:09 <rdieter> heliocastro: I recall you mentioning some odd transmission-qt crashes ?
15:11:09 <Kevin_Kofler> Well, it does need the private headers, but they're all in the public package right now.
15:11:15 <dvratil> I'd say ship when ready, the bugfixes are worth it :) I've been using it since release and I haven't run into any problems
15:11:32 <heliocastro> rdieter: Transmission and cutegra
15:11:34 <Kevin_Kofler> I'd also say ship 5.5 NOW.
15:11:52 <heliocastro> rdieter: Agreed, ship NOW
15:12:08 <heliocastro> This crashes is very specific to user + machine
15:12:13 <rdieter> i've been using the qt5 copr for a few weeks happily
15:12:23 <rdieter> so +1 here too, any objections ?
15:12:30 <than> +1 for 5.5
15:12:33 <jreznik> I'm on F23 with 5.5 and I don't see any issues +1
15:12:39 <dvratil> +1
15:13:23 <mustafam> I use Rawhide and have no issues with Qt
15:13:31 <rdieter> close to consensus then, any volunteers to work on builds, submitting updates?  (else I can)
15:13:38 <Kevin_Kofler> +1, just to be clear. (It was implied in my previous message, but let's be explicit.)
15:14:05 <rdieter> #agreed Qt-5.5 ready for f22/f21 updates
15:14:16 <than> rdieter: i will take care
15:14:31 * pino|work is here
15:14:33 <rdieter> #action than will work on builds, submitting bodhi updates
15:14:36 <rdieter> than: thanks!
15:14:44 <rdieter> #info pino|work here too
15:14:45 <than> rdieter: np :)
15:14:57 <rdieter> anything else qt-5.5 related ?
15:15:10 <heliocastro> webengine
15:15:20 <heliocastro> Take Kevin approach and cripple ffmpeg
15:15:23 <heliocastro> And release ?
15:15:33 <heliocastro> Or put on hold
15:15:40 <heliocastro> and wait all the bits together
15:16:03 <rdieter> oh, if folks hadn't watched qt5-qttools commits recently, I split out qt5-designer, qt5-linguist, qt5-qhelpgenerator recently, the latter 2 should help a lot with future bootstrapping
15:16:15 <dvratil> rdieter: \o/
15:16:31 <heliocastro> goooddd
15:16:42 <Kevin_Kofler> I think the "cripple FFmpeg" is only a quick way to get something that can be legally built in Copr.
15:16:49 <Kevin_Kofler> There is more work to be done.
15:16:49 <rdieter> though we're still getting wierd crashes with qdoc, though Kevin_Kofler's hack of running it through valgrind works (for now)
15:17:10 <Kevin_Kofler> We need to go through each subdirectory of third_party to see what it is and whether it can be unbundled.
15:17:44 <rdieter> yeah, a lot of work, I guess if anyone *wants* to work on that sooner rather than later, you're welcome to do it
15:17:50 <Kevin_Kofler> We should also try to solve the SQLite issue somehow, either get the patch into the sqlite package or get Chromium to work without it.
15:18:54 <Kevin_Kofler> I'd like to look into it, but the current Vienna temperatures aren't helping, really.
15:18:55 <rdieter> than: fyi, 3 new qt-5.5 modules just passed review, qtenginio, qt3d, qtcanvas3d, be sure to include those too
15:19:09 <Kevin_Kofler> And also the sheer size of that Chromium/QtWebEngine thing.
15:19:29 <heliocastro> Let me keep working on webengine as i already did that and i'll talk to Alan often
15:19:36 <Kevin_Kofler> Still, I'll see what I can do, but don't wait for me if you want to work on it.
15:19:43 <Kevin_Kofler> If I have something, I'll post it to the review and/or IRC anyway.
15:20:04 <rdieter> heliocastro: is the current qtwebengine .spec in SCM anywhere?
15:20:26 <heliocastro> rdieter: On the dvratil fedora-kde-frameworks
15:20:32 <rdieter> excellent
15:20:53 <rdieter> https://github.com/FedoraKDE/fedora-kde-frameworks
15:21:00 * dvratil should rename the git repo  :) it's far beyond just being kde-frameworks :)
15:21:13 <rdieter> meh
15:21:37 <heliocastro> dvratil: It works, is just a name
15:21:44 <heliocastro> not worth the trouble
15:22:28 <rdieter> ok, let's move on...
15:22:50 <Kevin_Kofler> heliocastro: Well, my point is that unbundling stuff probably needs to be done in spite of upstream (well, QtWebEngine upstream may be more helpful, but Google is just uncooperative there), not with upstream.
15:23:22 <rdieter> Kevin_Kofler: a healthy mix of both may be needed, true
15:23:52 <rdieter> #topic firefox-as-default-browser timetable
15:24:19 <Kevin_Kofler> IMHO, it is really too late to switch the default browser in F23.
15:24:22 <rdieter> Kevin_Kofler argued onlist that we should delay the implementation of adding firefox to kde spin until f24
15:24:24 <Kevin_Kofler> We are past feature freeze.
15:24:29 <Kevin_Kofler> And Alpha is already out with Konqueror as default.
15:25:06 <Kevin_Kofler> Even just adding Firefox can interfere with defaults and is thus a change that needs to respect the freeze timelines.
15:25:12 <rdieter> personally, (as mentioned onlist), this is a smallish configuration change, arguably not feature-worthy, so is safe to implement now in time for f23-beta (jgrulich +1'd onlist)
15:25:16 <rdieter> any other opinions ?
15:25:38 <Kevin_Kofler> -1 to implementing in F23, breaks freeze.
15:25:42 <pino|work> +1 on generally ok to change even now
15:26:53 <dvratil> +1 to change now
15:28:32 <rdieter> than, jreznik, heliocastro?  (I can guess what mustafam thinks)
15:28:36 <heliocastro> +1
15:28:57 <than> +1
15:29:08 <mustafam> Of course, but I can't vote :)
15:29:28 <jreznik> I'd like to take a look on the options of theming it to fit Breeze better
15:29:30 <rdieter> we're only solicitating informal opinion here so far
15:29:37 <jreznik> 5.4.0 should bring icons for Firefox
15:29:49 <rdieter> jreznik: +1, definite nice-to-have regardless
15:30:27 <Kevin_Kofler> Theming Firefox is possible? In what universe?
15:30:27 <jreznik> as it was agreed on, I think do it now, it's still Alpha and we can collect feedback (and revert it if feedback is bad in time)
15:30:57 <Kevin_Kofler> jreznik: What do we have feature freezes for then?
15:30:58 <rdieter> ok, that's probably as close to consensus as we can get
15:30:59 <jreznik> Kevin_Kofler: I know it's not that easy possible but at least, we might have a guidance how to make it less alien looking in Plasma
15:31:12 <pino|work> mozilla has always supported themes
15:31:15 <Kevin_Kofler> "a guidance" as in users will have to do it manually?
15:31:19 <Kevin_Kofler> That doesn't help at all.
15:31:28 <Kevin_Kofler> The browser needs to integrate into the desktop BY DEFAULT!
15:31:32 <jreznik> Kevin_Kofler: I agree with rdieter that this is not a big change (from implementation POV)
15:31:37 <Kevin_Kofler> And there the Firefox package maintainers won't help us.
15:31:47 <Kevin_Kofler> jreznik: It is from a user POV.
15:31:48 <jreznik> Kevin_Kofler: they can't :(
15:32:09 <Kevin_Kofler> Plus, some integration stuff actually requires a patched Firefox, not the one we'll ship.
15:32:18 <jreznik> well, seems like user really wants it, I'm not very fond of it but we do our spin for users...
15:32:19 <Kevin_Kofler> Which means Firefox basically will NOT be themed on the KDE Spin.
15:32:26 <rdieter> arguing about integration now, is no longer useful or constructive
15:32:29 <Kevin_Kofler> Which is why I'm saying it is a no go.
15:32:41 <Kevin_Kofler> If you want a themed browser, you need to withdraw your vote for Firefox.
15:32:53 <rdieter> arguing that non-integration be a blocker for inclusion, that is
15:32:54 <Kevin_Kofler> rdieter: It is, because jreznik brought it back up.
15:33:01 <rdieter> I clarified ^^ :)
15:33:12 <Kevin_Kofler> It is a blocker for inclusion and will always be.
15:33:15 <rdieter> adding integration is now a nice-to-have
15:33:26 <Kevin_Kofler> You are ignoring it and screwing our users.
15:33:41 <Kevin_Kofler> What we release will be a broken piece of shit.
15:33:42 <rdieter> Kevin_Kofler: in your opinion, we already discussed that part at length onlist, no need to rehash things yet again
15:33:51 <jreznik> Kevin_Kofler: that's the problem - our users prefers unintegrated firefox over integrated offering...
15:33:54 <Kevin_Kofler> The thing is, I cannot release anything with Firefox in it.
15:33:55 <heliocastro> Ok, did we all vote ?
15:33:59 <Kevin_Kofler> So I will have to leave the SIG.
15:34:14 <Kevin_Kofler> jreznik: Says who?
15:34:19 <Kevin_Kofler> The user feedback was mostly negative.
15:34:29 <Kevin_Kofler> There was mostly only mustafam arguing for it.
15:34:51 <jreznik> Kevin_Kofler: that long thread and I read it almost everywhere that Fedora KDE deserves better browser (and I'm not sure Firefox is solution but...)
15:34:54 <rdieter> #agreed (mostly) consensus to try pushing firefox-as-default-browser to f23 spin
15:35:00 <jreznik> it doesn't make sense now, move on
15:35:13 <rdieter> #action rdieter to work on adding ff as part of kde-settings/theming defaults work asap
15:35:29 <rdieter> yes, moving on
15:35:34 <Kevin_Kofler> By the way, is there no look&feel freeze in Fedora?
15:35:49 <Kevin_Kofler> If there were, that'd also be a strong reason not to change this this late in the F23 cycle.
15:36:07 <Kevin_Kofler> Really, we shouldn't rush this now, and look into a real replacement (QtWebEngine) for F24.
15:36:09 <rdieter> f23-backgrounds only exists for a couple of weeks
15:36:14 <Kevin_Kofler> And skip Firefox entirely.
15:36:21 <rdieter> speaking of looknfeel
15:36:33 <Kevin_Kofler> It has always been a no go and nothing changed at all.
15:36:35 <rdieter> #topic theming
15:36:45 <rdieter> jreznik: did you want to discuss theming still?
15:37:02 <Kevin_Kofler> The kde-settings changes also have a potential to screw users who don't even have Firefox installed.
15:37:12 <Kevin_Kofler> And break upgrades.
15:37:30 <rdieter> Kevin_Kofler: nothing will break, you're exagerating now
15:37:35 <heliocastro> Kevin_Kofler: Please, can you move on ?
15:37:44 <jreznik> well, there was discussion on fedora-qa regarding if new backgrounds should be blocker
15:37:49 <Kevin_Kofler> rdieter: Things can open in a random app instead of the installed browser.
15:37:53 <rdieter> there are small chances someones default browser (e.g. default realted mimetypes may change)
15:37:57 <rdieter> but that is all
15:38:01 <Kevin_Kofler> heliocastro: No. You will NEVER be able to move on until the decision gets reverted.
15:38:05 <jreznik> as it's always late for Alpha and KDE theming is even later (as it depends on backgrounds)
15:38:06 <rdieter> Kevin_Kofler: no, if it does, that's a bug
15:38:12 <rdieter> and we can easily fix mimetypes
15:38:16 <Kevin_Kofler> I can filibuster the meetings all I want.
15:38:26 <jreznik> adamw raised question, why we have to create new theming package for every release
15:38:32 <jreznik> that's the story
15:38:38 <rdieter> Kevin_Kofler: you can certainly do that, and we can start ignoring you too
15:39:25 <Kevin_Kofler> I also find it sad that several people who had voted against Firefox for F21 now voted for it.
15:39:32 <rdieter> jreznik: nod, afaik, the only/best way to set default theming is via a looknfeel package
15:40:07 <rdieter> and limitatations of looknfeel (like it cannot reliably use/refer-to resources via symlinks)
15:40:50 <rdieter> one smallish simplification of *-kde-theme, remove kdm theme from there, so one less item to worry about
15:41:04 <Kevin_Kofler> I was saying on the chan that we need to reintroduce something like that default-wallpaper patch.
15:41:11 <Kevin_Kofler> i.e., we just add our own setting
15:41:19 <dvratil> we could try to talk to upstream about making look-n-feel packages simpler (like inheritance or something)
15:41:38 <Kevin_Kofler> Now I just need to find the place where the wallpaper is set.
15:41:41 <Kevin_Kofler> (in the code)
15:41:58 <Kevin_Kofler> Adding a setting would be a patch of 1 to 3 lines.
15:43:06 <rdieter> dvratil: inheritance would solve things nicely (for the most part)
15:43:21 <rdieter> since all *we* are doing really is using breeze + fedora wallpaper
15:43:47 <rdieter> Kevin_Kofler's suggestion could work as well
15:44:01 <mustafa_> I even prefer upstream wallpaper, so I change to it.
15:44:30 <dvratil> yep - there will be Plasma people in the Randa sprint in couple weeks, we can try to come up with some solution there (for Plasma 5.5 obviously)
15:44:39 <Kevin_Kofler> I think it'd be something like:
15:44:45 <heliocastro> dvratil: You're going to Randa ?
15:44:46 <Kevin_Kofler> KConfig config("fedorakderc");
15:44:51 <dvratil> heliocastro:  yes
15:45:04 <heliocastro> dvratil: Good, so now you have a taks to do ( another one ) :-)
15:45:08 <Kevin_Kofler> KConfigGroup group = config.group("Wallpaper");
15:45:29 <Kevin_Kofler> defaultWallpaper = group.read("defaultWallpaper", the upstream default);
15:45:33 <dvratil> heliocastro: I'm going primarily for KDE PIM group, but of course it's whole week, so there will be time to talk to others :)
15:45:33 <Kevin_Kofler> inserted in the right place.
15:46:03 <heliocastro> kconfig already do inheritance
15:46:07 <heliocastro> Since my days, since ever
15:46:50 <heliocastro> So, is easy to add just the fedora changes without cause any post issue
15:47:17 <heliocastro> I did this lot of times on Mandriva and Conectiva, so if needed i can help with that
15:47:17 <Kevin_Kofler> heliocastro: The problem is not to do settings inheritance, it is to add a setting separate from the Plasma theme to begin with.
15:47:32 <heliocastro> We *don't* need everything
15:47:40 <heliocastro> We need just wallpaper and maybe the button
15:47:42 <heliocastro> And done
15:47:56 <heliocastro> This means two kiosk lines in two configsa maybe
15:48:03 <rdieter> Kevin_Kofler: wouldn't that potentially interfere with users wanting to change their wallpaper then (to something else)?
15:48:15 <heliocastro> rdieter: Nope
15:48:21 <rdieter> ok
15:48:27 <heliocastro> Only if we maked as a non-muttable
15:48:28 <rdieter> either is fine with me then
15:48:48 <heliocastro> It can be done with two files, three tops
15:48:55 <heliocastro> Non conflicting
15:49:17 <heliocastro> This is something that i know very well and run like hell for ages
15:51:10 <jreznik> :D
15:51:54 <heliocastro> kconfig is ancient, but works
15:53:19 <Kevin_Kofler> rdieter: We would just use our default before the theme default.
15:53:25 <Kevin_Kofler> User settings would still take preference.
15:53:55 <rdieter> ok, make a some testable implementation :)
15:54:29 <heliocastro> o>
15:55:21 <jreznik> ok, good to see we can improve :)
15:55:24 * jreznik has to leave now
15:56:46 <rdieter> ok, let's move on
15:56:49 <rdieter> #topic open discussion
15:57:01 <rdieter> anything else for today (in the last few minutes)
15:58:00 <Kevin_Kofler> I'm still trying to find where exactly the wallpaper is set.
15:58:55 <Kevin_Kofler> It's a mess: 3 different tarballs, a wallpaper plugin that loads images where then you set the actual wallpaper image as a parameter, and of course QML to complicate everything. :-(
16:00:39 <heliocastro> No needed
16:00:43 <heliocastro> Just add this:
16:01:04 <heliocastro> in -> plasma-org.kde.plasma.desktop-appletsrc
16:01:41 <heliocastro> [Containments][7][Wallpaper][General]
16:01:51 <Kevin_Kofler> That's the problem, we cannot prefill plasma-desktop-appletsrc.
16:01:51 <heliocastro> Image=file:///Somthing
16:01:58 <Kevin_Kofler> Plasma will overwrite it on initialization.
16:02:09 <Kevin_Kofler> Only JavaScript init scripts can initialize the settings.
16:02:09 <heliocastro> Yep, we can, i will show later when back from company meeting
16:02:16 <heliocastro> Actually no
16:02:37 <Kevin_Kofler> That was when we switched to the current approach in KDE 4 times.
16:02:56 <Kevin_Kofler> I wanted to just revert the "fix" that clears the plasma-desktop-appletrc entries, but it was vetoed.
16:03:03 <heliocastro> Ok, i did on javascript for precious company as well, on frameworks
16:03:19 <rdieter> I guess we can continue discussion after meeting in #fedora-kde, thanks everyone
16:03:20 <Kevin_Kofler> As for the JavaScript approach, we were unable to get it to work.
16:03:25 <rdieter> times up here (for now)
16:03:28 <heliocastro> Ok
16:03:36 <rdieter> #endmeeting