15:05:48 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:05:48 <zodbot> Meeting started Tue Sep  8 15:05:48 2015 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:05:57 <Kevin_Kofler> #meetingname kde-sig
15:05:57 <zodbot> The meeting name has been set to 'kde-sig'
15:06:00 <Kevin_Kofler> #topic Roll call
15:06:05 * Kevin_Kofler is present, who else?
15:06:07 * jgrulich is present
15:06:09 <pino|work> me
15:06:31 <rdieter> hi
15:07:21 <rdieter> Kevin_Kofler: thanks for leading the meeting
15:07:35 * jreznik is here
15:07:56 <tosky> hi
15:10:00 <Kevin_Kofler> #chair jgrulich pino|work rdieter jreznik tosky
15:10:00 <zodbot> Current chairs: Kevin_Kofler jgrulich jreznik pino|work rdieter tosky
15:13:30 <Kevin_Kofler> #info Kevin_Kofler, jgrulich, pino|work, rdieter, jreznik, tosky present.
15:13:32 <Kevin_Kofler> #topic Agenda
15:13:41 <Kevin_Kofler> So, what do we discuss?
15:14:12 <Kevin_Kofler> I'd like to take up dolphin4 packaging and how to proceed with kompare/libkomparediff2.
15:16:08 <Kevin_Kofler> Anything else?
15:17:55 <Kevin_Kofler> #topic Dolphin4 packaging
15:18:32 <Kevin_Kofler> So the thing is, we now have a dolphin4 and a dolphin4-libs package. And several users are confused by having the dolphin4 executable next to the new dolphin (5).
15:18:47 <Kevin_Kofler> The initial packaging had the executables removed, and I don't understand why we readded them.
15:18:53 * danofsatx has arrived
15:18:56 <Kevin_Kofler> It's clear that they are not needed. All Konqueror needs is the KPart.
15:18:59 <Kevin_Kofler> #chair danofsatx
15:18:59 <zodbot> Current chairs: Kevin_Kofler danofsatx jgrulich jreznik pino|work rdieter tosky
15:19:04 <Kevin_Kofler> #info danofsatx also present (late).
15:19:24 <danofsatx> sorry, $dayjob interefered
15:19:28 <tosky> in fact it shouldn't be there; the desktop file for dolphin4 was removed on purpose by dfaure when he readded the code
15:19:30 <Kevin_Kofler> No problem.
15:19:40 <Kevin_Kofler> So I think we should remove the dolphin4 binary (and the kdeinit lib) again.
15:19:47 <rdieter> Kevin_Kofler: "initial packaging had the exe removed" , I don't think that's accurate
15:19:49 <Kevin_Kofler> And IMHO there should not be a dolphin4 main package at all.
15:20:06 <rdieter> from looking at recent commits
15:20:08 <Kevin_Kofler> The KPart should be in -libs.
15:20:19 <Kevin_Kofler> rdieter: You had dvratil readd it before importing the package to history.
15:20:22 <Kevin_Kofler> Check your IRC logs. :-)
15:20:33 <rdieter> Kevin_Kofler: he removed it all
15:20:45 <rdieter> iirc
15:20:49 <rdieter> not just the bin
15:20:59 <Kevin_Kofler> Only dolphin4 and kdeinit_dolphin4.so were removed, and those can go away just fine.
15:21:10 <Kevin_Kofler> We need only the KPart.
15:21:16 <rdieter> but I personally don't have any problem keeping the binary
15:21:23 <Kevin_Kofler> Anyway, it doesn't matter what was there in the past.
15:21:29 <rdieter> so meh
15:22:04 <Kevin_Kofler> My point is, we should remove the main package and move the KPart to -libs, or rename the main package to -part and remove the binary.
15:22:10 <rdieter> I do agree the part should move to -libs
15:22:27 <tosky> what is the reason for keeping the binary?
15:22:46 <rdieter> I don't care about the binary , it can go I guess, but I don't see any harm in keeping it either
15:23:18 <rdieter> personally, I'd rather keep it in the short-term, in case there are any bad kf5-related regressions
15:23:18 <Kevin_Kofler> I guess it can stay in the main package, IF the KPart gets moved to -libs or a new -part and IF we stop requiring dolphin4 (main package).
15:23:39 <rdieter> <nod>, the main pkg dep could go
15:23:41 <tosky> rdieter: that's not a plan; dolphin is not like gwenview
15:23:44 <Kevin_Kofler> Then it will not be installed by default, and if people really want it (e.g. to use old kioslaves), they can install it.
15:23:59 <rdieter> tosky: it's not user-visible (ie, not in menus)
15:24:14 <tosky> rdieter: the KF5 porting was almost ready for 15.04 already, it was stopped because they were really late and it has been refined in the last 3 months
15:24:21 <rdieter> anyone looking in /usr/bin/, should know what they're doing
15:24:40 <rdieter> so I don't buy that it is confusing
15:24:42 <Kevin_Kofler> Dolphin is kinda like Konsole, we need only the KPart of the old version.
15:24:51 <tosky> ok, I guess this needs to be solved upstream
15:25:28 <pino|work> well, what actually requires/uses the dolphinpart?
15:25:30 <rdieter> I don't believe there's any problem to be solved (short of our packaging fixes)
15:25:37 <Kevin_Kofler> pino|work: Konqueror.
15:25:46 <pino|work> i see
15:25:51 <Kevin_Kofler> (The file management mode is based on the DolphinPart.)
15:26:09 <Kevin_Kofler> (That's why upstream provides it to begin with.)
15:26:12 <tosky> pino|work: dfaure restored the code just before 15.08 because dolphin was ported to KF5, but the rest of kde-baseapps was not
15:26:55 <tosky> with some tuning (different translation domain, etc)
15:28:23 <rdieter> so I see 3 changes here, 2 are not controversial (so far):  move part to -libs, make main pkg not depend on dolphin4
15:28:32 <rdieter> those changes can be made asap
15:28:40 <rdieter> (imo, yada yada)
15:29:03 <rdieter> 3.  drop/omit dolphin4 binary (and matching libkdeinit)
15:29:14 * linux-modder hangs out to learn some kde
15:29:48 <rdieter> as mentioned, I personally don't think 3 is needed, but won't object if others feel strongly otherwise
15:30:08 <Kevin_Kofler> #agreed We will move the DolphinPart 4 to dolphin4-libs and make kde-baseapps not depend on the main dolphin4.
15:30:57 <Kevin_Kofler> Well, I'm not sure what good the package will do, and it's also not compliant with the packaging guidelines (GUI app without a menu entry).
15:31:17 <Kevin_Kofler> (but adding the menu entry would suck, too)
15:32:25 <rdieter> Kevin_Kofler: it's an exception, hidden for good reason
15:32:54 <rdieter> though I would argue a .desktop should be provided, but marked as hidden instead, but meh
15:33:07 <tosky> no, please; the .desktop file is missing for a good reason
15:33:21 <tosky> but as I said, I will file a patch upstream to not install it at all, so that would solve the issue
15:33:23 <rdieter> tosky: ok, then upstream should drop the binary too.
15:33:30 <tosky> agreed
15:33:30 <rdieter> +1
15:33:56 <rdieter> if that's accepted, then we can drop it too then
15:34:11 <Kevin_Kofler> #action tosky will work with upstream to not install the binary in the first place.
15:34:23 <Kevin_Kofler> Makes sense.
15:34:38 <Kevin_Kofler> I think we reached consensus here, so let's move on.
15:34:47 <Kevin_Kofler> #topic Kompare and libkomparediff2
15:35:08 <Kevin_Kofler> So, Kompare is still stuck on the last kdelibs4 version.
15:35:27 <rdieter> and kdevelop
15:35:52 <Kevin_Kofler> Yeah, the main reason is the usage of libkomparediff2 by KDevelop. But does KDevelop 4 actually use the system libkomparediff2?
15:36:03 <rdieter> oh, I see not, nvm
15:36:10 <Kevin_Kofler> repoquery says no, at least here on F21.
15:36:32 <Kevin_Kofler> I was told the patches to use the system version never made it into KDevelop 4, only 5.
15:36:48 <rdieter> that's true
15:36:58 <Kevin_Kofler> So I think we'd actually help everyone by just updating Kompare and libkomparediff2 to the latest version, that'd also help people wanting to try out KDevelop 5.
15:37:27 <rdieter> I thought you said kompare hasn't been ported yet?
15:37:42 <Kevin_Kofler> I don't think it would make any sense in this case to backport the unbundling changes to KDevelop just to be stuck with maintaining a compat lib just for KDevelop. ;-)
15:37:49 <Kevin_Kofler> It has.
15:37:55 <rdieter> ok, then go ahead +1
15:37:58 <Kevin_Kofler> It's been there since 15.04!
15:38:08 <Kevin_Kofler> I thought we had already agreed to ship 15.04.
15:38:29 <Kevin_Kofler> Instead, I noticed only a few days ago that there's only one failed 15.04 Rawhide build and nothing since then.
15:38:53 <rdieter> more likely: we agreed it's a good idea, but no one has worked on updating the packaging yet
15:39:19 <rdieter> I think we still agree it's a good idea
15:39:41 <Kevin_Kofler> So IMHO, keep F21 at 14.12, update F23+ to 15.08, no strong opinion about F22.
15:40:24 <Kevin_Kofler> (On one hand, it'd be upgrading from a kdelibs4 version to a KF5 one, with possibly some regressions, on the other hand, Kompare is not a rewrite, it's basically a straight port, at most there are some bugs from the kdelibs4support removal Jeremy did.)
15:40:55 <Kevin_Kofler> (but he already fixed some of the regressions that were found)
15:41:29 <rdieter> I think f22 is worthy to consider at least
15:41:35 * rdieter has to go
15:41:39 * rdieter waves
15:41:49 <Kevin_Kofler> We'll need it if people want KDevelop 5, at least.
15:42:02 <Kevin_Kofler> (though that'd likely be only in a Copr for F22)
15:43:17 <Kevin_Kofler> #agreed Kompare and libkomparediff2 shall be upgraded to the latest version (15.08.x) for at least F23+, possibly F22. (No need to wait for KDevelop 5 because KDevelop 4 does not use libkomparediff2.)
15:44:00 <Kevin_Kofler> (Or are there any objections? I see only consensus from rdieter and me and silence from the audience. ;-) )
15:44:49 <Kevin_Kofler> #topic Open discussion
15:45:04 <Kevin_Kofler> Anything else to discuss this week? Otherwise, I'll close the meeting in a minute.
15:45:05 <tosky> well, it's really on "as long as you do it", I guess; as you said, kompare is a standalone application
15:45:49 <Kevin_Kofler> tosky: I can have a look at it, after all I'm technically the upstream maintainer, so theoretically I should know best how to package it. ;-)
15:47:12 <Kevin_Kofler> I think that's all for today then, thanks for coming!
15:47:16 <Kevin_Kofler> #endmeeting