14:06:01 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:06:01 <zodbot> Meeting started Mon Nov 23 14:06:01 2015 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:06:01 <zodbot> The meeting name has been set to 'docs_project_meeting_-_agenda:_https://fedoraproject.org/wiki/docs_project_meetings'
14:06:03 <randomuser> #meetingname Fedora Docs
14:06:03 <zodbot> The meeting name has been set to 'fedora_docs'
14:06:03 <randomuser> #topic Roll Call
14:06:16 * pbokoc 
14:06:44 <randomuser> #chair pbokoc
14:06:44 <zodbot> Current chairs: pbokoc randomuser
14:08:22 <bexelbie> .hello bex
14:08:23 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
14:08:39 * bexelbie is a bit lurky
14:09:51 <cprofitt> hello all
14:09:53 <randomuser> you should get an ointment for that, bexelbie
14:10:26 * bexelbie will get on that :P
14:11:35 <randomuser> okay, let's get on with it
14:11:43 <randomuser> #topic follow up on action items
14:11:58 <randomuser> #info randomuser and pbokoc did not work out windows checksum instructions, redo
14:12:13 <randomuser> #action pbokoc and randomuser to make better windows checksum instructions
14:12:36 <randomuser> #info randomuser still needs to publish things
14:12:52 <randomuser> #action randomuser to publish relnotes, others that need it
14:13:06 <randomuser> aaaand that's all I have noted
14:13:12 <randomuser> #topic New Writers
14:13:40 <randomuser> in this part of the show, we've reserved some time for new folks to introduce themselves and ask questions while they have a captive audience
14:14:45 <pkovar> /me is late
14:14:50 <randomuser> cprofitt, I guess that'd be you today - how is acquainting yourself with the Fedora Project coming along?
14:16:09 <cprofitt> sorry, work issue missed that.
14:16:31 <cprofitt> I am finding it fairly easy to get to know people.
14:16:53 * smccann sneaks in late, sits in the back
14:16:54 <cprofitt> The Wiki is organized a bit different than I am used too, but I am reading the docs on how things are setup.
14:17:53 <cprofitt> about me, I am migrating from using Ubuntu as my main OS to Fedora. I have been playing with Linux since 1993 and started using it as my primary OS in 2006.
14:18:16 <pbokoc> cool, a veteran!
14:18:36 <randomuser> Our wiki has a different use case that what you might be used to; there's some contributor facing stuff for groups, and some volunteered documentation, but the *majority* of content is scratch space or project tracking and such
14:18:53 * cprofitt nods
14:20:30 <randomuser> that said, it is almost universally a very approachable community.  You can jump into any of the Fedora IRC channels and get a friendly reception and answers to your questions
14:20:53 <randomuser> which is a good idea, whether or not the wiki is what it is :)
14:22:07 <cprofitt> I know there is a wiki gardening project going on and as I learn more about how things arae structured I will be able to better assist with that. I did a similar cleanup for the Ubuntu Community wiki.
14:22:18 * randomuser nods
14:23:00 <randomuser> it's an ongoing thing.  We had some discussions not too long ago about automated archiving, but it didn't take off yet.
14:23:13 * cprofitt nods
14:23:39 <randomuser> I'll dig up some references to that for you
14:23:47 <cprofitt> I appreciate that.
14:23:48 <randomuser> or bexelbie will
14:24:09 <randomuser> anyway, enough putting cprofitt on the spot... for today
14:24:15 <randomuser> @topic Publishing
14:24:16 <fedbot> randomuser: (topic [<channel>]) -- Returns the topic for <channel>. <channel> is only necessary if the message isn't sent in the channel itself.
14:24:19 <randomuser> bah
14:24:22 <randomuser> #topic Publishing
14:24:52 <randomuser> #info ryanlerch might be helping with code or design or something of his choice
14:25:05 <randomuser> I wrote some conceptual documentation up at....
14:25:22 <randomuser> https://github.com/immanetize/anerist/blob/docker/docs/operational_theory
14:26:34 <randomuser> ryan pointed out that Hubs is slated to have contributor facing stuff, so we might not have to, and developer.fp.o exists for developer facing stuff
14:27:11 <pbokoc> I'll take a look at it at some point
14:27:12 <randomuser> I've had a working goal of accomodating SIG/subgroup documentation from the wiki as well as our developer facing guides
14:27:34 <randomuser> and having three high level sections for each target audience
14:28:01 <randomuser> your thoughts?
14:28:10 <zephrax> _o_/
14:29:25 <randomuser> hello, zephrax
14:29:34 <pbokoc> randomuser, the three high level groups thing sounds reasonable, but I'm afraid one or two will end up being empty, or hopelessly outdated after the start
14:29:34 <cprofitt> I don't have enough background to really comment, but the document links looks good.
14:30:13 <randomuser> hm
14:30:20 <cprofitt> what is the target for the documentation here; the wiki or the docs.fp.o
14:30:33 <randomuser> cprofitt, this group does very little work in the wiki
14:30:41 * cprofitt nods
14:31:03 <randomuser> mostly because we've reached consensus that it's a mess, and we can't change the institutional practices that made it that way
14:31:36 <cprofitt> I agree with that. I was excited to see a migration to something other than a wiki. Out of date documentation is evil IMHO.
14:31:42 <randomuser> absolutely.
14:32:36 <cprofitt> so this is aimed at docs.fp.o and local to the installed computer?
14:33:02 <cprofitt> sorry that I am playing catch up and making you rehash some stuff everyone else likely knows.
14:33:29 <randomuser> cprofitt, the linked doc describes a system that, when completed, will live in fedora infrastructure and process content from git repos to create docs.fp.o
14:33:42 * cprofitt nods
14:33:51 <randomuser> there was not a thing that met the needs we (I?) had, so I'm writing it.  Participants welcome.
14:35:29 <randomuser> that's the news there, anyway, find me if you have questions
14:35:41 * cprofitt nods
14:35:47 <randomuser> #topic Guide Status
14:36:16 <randomuser> Capesteve gave me some notes on the firewall guide, which I still need to implement...
14:36:36 <randomuser> what other guide items do we have today?
14:39:55 <randomuser> hm. not much, apparently.
14:40:55 <d0nn1e> randomuser, should we touch on the thing we chatted about friday at all?
14:41:02 <d0nn1e> (sorry, late btw)
14:41:30 <d0nn1e> about the security guide seeming to have been split up, and how we should approach now?
14:41:38 <randomuser> I'm terrible at calendar-based recollection, d0nn1e, sorry.  What was the to... okay
14:42:56 <pbokoc> yeah, about the security guide - it was split on Red Hat's end (RHEL official docs), and the maintainer of the RHEL SELinux guide (bara) was keeping the Fedora version updated as well
14:42:56 <randomuser> hey Sparks.  It's been pointed out that we merged selinux content into the security guide, and recently have published a new security guide, so there's some redundancy.  What are your thoughts?
14:43:18 <pbokoc> problem is, now bara is working on something else and whoever maintains the RHEL book isn't active in Fedora
14:43:43 <Sparks> Here's what I can tell you...
14:44:18 <Sparks> The Security Guide didn't specifically come from what RHEL...
14:45:16 <randomuser> pbokoc, is there an opportunity for evangelism with the new maintainer?
14:45:32 <randomuser> do your work upstream, life is easier at release time, blah blah?
14:45:43 <Sparks> Back in the RHEL5 days the RHEL Security Guide was out there but was lacking.  What we had an encryption guide that wasn't in RHEL.
14:46:04 <Sparks> So we decided to try to combine all the information together and go forward.
14:46:37 <Sparks> And the security guide for RHEL 6 was what came from both Fedora and Red Hat.
14:46:57 <Sparks> Obviously we were publishing all along the same guide for Fedora
14:47:25 * randomuser ponders
14:47:33 <Sparks> The SELinux documentation (the many books) stopped getting updated in Fedora.
14:47:43 <Capesteve> and then the RHEL maintainer wanted it to make a different one for RHEL7
14:48:06 <cprofitt> Sparks: are you in need of a person to assist with that documentation - I may know a person who would be a good candidate (not me)
14:48:07 <pbokoc> randomuser, I'll have to find out who that actually is, first. It's not proving to be an easy task so far.
14:48:11 <Sparks> So I decided to try to pull all the information into the security guide (if only because some of the topics were duplicated) and start again.
14:48:16 <randomuser> I think the most pertinent point is to find maintainers for these things
14:48:51 <Sparks> But then I got too busy to maintain the thing and now it sits there.
14:49:20 <Capesteve> so keep guides smaller and more focused
14:49:21 <randomuser> cprofitt, we're always open to that kind of assistance (within reason, not all help is correct help, and other obvious caveats)
14:49:29 <cprofitt> I will ask the person I know... he used to write documentation for ubuntu, but moved to Fedora with Fedora 18
14:49:34 <randomuser> cool
14:49:48 <Sparks> The entire guide needs needs a good edit (like, a group of people meet in an office somewhere, prints the thing out, and then goes nuts with a highlighter and a black marker)
14:49:59 <cprofitt> https://fedoraproject.org/wiki/User:Bodhizazen
14:50:18 <randomuser> I believe a lot of these issues will go away once we have a platform that doesn't mandate publishing entire cohesive books :P
14:50:36 <randomuser> cprofitt, yeah, he's around
14:50:38 <Sparks> randomuser: Here's another thing...
14:50:39 <pbokoc> ooooh of course, it's rkratky... he was actually active in Fedora at one point, but recently he's been buried in work as far as I know
14:51:15 * randomuser misses rkratky
14:51:38 <Sparks> randomuser: I found a lot of overlaps with the admin guide, etc.  I never had time to read those other manuals but I think it would be great to have links between the different guides.  The wiki makes this easier..
14:53:40 <randomuser> yeah, a systematic solution is in order
14:53:51 <Sparks> randomuser: we should talk
14:54:09 <randomuser> yes.
14:54:19 * d0nn1e hears wheels in motion.
14:54:21 <randomuser> I have another meeting after this one, but I'll find you
14:54:58 <randomuser> we've probably burned up enough time on this topic.. good thoughts but they need to gel
14:55:23 <randomuser> #topic  Outstanding BZ Tickets'
14:55:28 <randomuser> #link http://tinyurl.com/lbrq84
14:56:03 <randomuser> thar be bugs
14:57:19 * pbokoc has to run
14:57:22 <d0nn1e> Indeed i'm hoping to put some time into them this week since I'm getting a break at work thanks to thanksgiving
14:58:30 <randomuser> thanks, d0nn1e
14:58:44 <randomuser> #topic Open Floor
15:00:46 <d0nn1e> I'm guessing most office hours for Thursday might be cancelled due to Turkey Day here in the U.S.?
15:01:13 <randomuser> I can probably manage an hour or so
15:01:37 <randomuser> for now, though, I have to take of for the next meeting
15:02:03 <randomuser> good meeting, all
15:02:07 <randomuser> #endmeeting