14:03:52 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:03:52 <zodbot> Meeting started Mon Feb  8 14:03:52 2016 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:03:52 <zodbot> The meeting name has been set to 'docs_project_meeting_-_agenda:_https://fedoraproject.org/wiki/docs_project_meetings'
14:03:52 <randomuser> #meetingname Fedora Docs
14:03:52 <zodbot> The meeting name has been set to 'fedora_docs'
14:03:54 <randomuser> #topic Roll Call
14:03:57 <randomuser> zodbot, ping
14:03:57 <zodbot> pong
14:04:03 * pbokoc 
14:04:03 <randomuser> #chair pbokoc zoglesby pkovar
14:04:03 <zodbot> Current chairs: pbokoc pkovar randomuser zoglesby
14:04:27 <pkovar> /me is here
14:06:19 <randomuser> /me wonders how many people are sleeping off devconf still
14:08:30 <randomuser> well, that's five minutes
14:09:13 * kirsti is here
14:09:13 <randomuser> #topic Follow up on action items
14:09:32 <randomuser> #info rescheduling the meeting still seems relevant, three people are here
14:09:47 <randomuser> #action randomuser to send out scheduling poll already
14:09:58 <randomuser> #topic New Writers
14:10:57 <randomuser> Anyone with news of new writers?
14:12:53 <pbokoc> yeah, I helped a few more Red Hatters from Brno set up recently... at least IRC, not sure if they made FAS accounts yet or anything
14:13:04 <pbokoc> last week was kinda busy
14:13:13 <pbokoc> there's one
14:13:15 <pkovar> i know that max did
14:13:28 <randomuser> cool
14:13:29 <pkovar> not sure if he has the right permissions though
14:13:57 <randomuser> I think you both are sponsors for the docs fas groups, right?
14:14:08 <pkovar> i am not actually
14:14:29 * randomuser was just checking
14:14:32 <pbokoc> I might be. In any case, jhradilek definitely can sponsor people so we can settle that at some point
14:15:46 <randomuser> crap, wrong button
14:16:03 <pkovar> heh, i got removed from docs :)
14:16:09 <pbokoc> oh noes, what did you do?!
14:16:12 <pbokoc> hahahaha
14:16:21 <pkovar> i don't know :)
14:16:31 <pkovar> just joined the docs meeting :)
14:17:04 <pbokoc> I meant what did randomuser do. I wasn't sure if the wrong button launched the nukes or something
14:17:06 <randomuser> there, you're both docs sponsors
14:17:15 <pkovar> randomuser: thank you :)
14:17:23 <randomuser> I accidentally kicked pkovar off the team :P
14:17:28 <pkovar> :)
14:17:39 <pbokoc> yeah, that's kinda similar
14:18:02 <randomuser> is a sponsor, has a sponsor, needs a sponsor; all mostly in the same area
14:18:42 <pkovar> are we using the docs-writers group?
14:18:50 <randomuser> cspicer1, we're doing the "new writers" part of the show; any comments, questions, observations?
14:18:59 <randomuser> pkovar, sure, we can do that one too
14:19:22 <pkovar> which one is the group that lets you push your commits?
14:19:28 <randomuser> docs-writers
14:19:31 <pkovar> aha
14:19:32 <pbokoc> in any case, there won't be any sponsoring till I read everyone's introduction mails on fedora-docs!
14:19:33 <pkovar> ty
14:19:35 <cspicer1> randomuser: nothing so far :)
14:20:12 <cspicer1> woops... *ahem* i'll send that today...
14:20:15 <pkovar> pbokoc: fair enough
14:20:25 <pbokoc> and I expect a similar level of entertainment to what I got out of GARY SKEETE
14:20:31 <pkovar> oh no
14:20:57 <randomuser> yes, initiates *must* show a strong interest in creative writing
14:21:02 <kirsti> O_o ... good thing jhradilek sent someone else my way
14:21:11 <pbokoc> multiple hours long rambling videos on youtube, that kind of thing
14:21:23 <pbokoc> oh, hi kirsti :-D
14:22:57 <randomuser> that covers new folks, then
14:23:05 <randomuser> #topic Publishing
14:23:26 <randomuser> some discussion around this on the list lately
14:23:27 <pkovar> publican 2 must be destroyed
14:23:51 <randomuser> to recap, people seem to think that publishing should be different
14:24:55 <pkovar> also, quite a few people discussed fedora docs at devconf
14:25:06 <randomuser> oh?
14:25:20 <pkovar> they were wondering what's the status of the publishing side of things, and what help is needed
14:25:33 * jsmith shows up late, sorry
14:25:58 <randomuser> pkovar, did they find answers?
14:26:22 <pkovar> randomuser: not yet :) but many recommended https://pagure.io/ as a good replacement for fedorahosted
14:26:32 * randomuser nods
14:26:53 <pkovar> other fedora teams are already using it
14:27:17 <pkovar> one of the killer features is live editing of the source document
14:27:29 <pkovar> with previews for asciidoc, markdown et al.
14:27:31 <randomuser> I think that it would work nicely too, giving us both the web-based PR workflow and some feature development tools
14:27:42 <pkovar> yes!
14:28:01 <randomuser> pkovar, we asked for that live editing, and pingou delivered!
14:28:04 <randomuser> pingou++
14:28:04 <zodbot> randomuser: Karma for pingou changed to 21 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:28:13 <pkovar> randomuser: excellent :)
14:28:20 <pkovar> pingou++
14:28:20 <zodbot> pkovar: Karma for pingou changed to 22 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:28:57 <randomuser> The other feature I'd really like - and it may be there - are ACLs by branch
14:29:03 <pkovar> oh yeah
14:29:21 <pingou> randomuser: using forks you could mitigate this no?
14:29:27 <pkovar> so that you have say maintainers allowed to push or merge stuff into master etc.
14:29:38 <randomuser> so we can have 'production' branches that only docs-writers can touch, and 'draft' branches that 'docs' can play with
14:30:10 <pkovar> i think that pagure can already support acls no? pingou
14:30:20 <pingou> no per branch
14:30:22 <pingou> not*
14:30:23 <pkovar> aha
14:31:02 <randomuser> pingou, yes, that would cover it for workflow; branch ACLs are a nice-to-have thing that would allow drafts to be built and previewed, without executing on arbitrary PR content
14:31:25 <randomuser> but that's extra sauce, not a requirement
14:32:51 <randomuser> so, what should we consider before a migration to pagure?
14:33:06 <randomuser> oh, I know
14:33:36 <randomuser> pingou, I have the impression that it will be available as a fedorapeople offering eventually?
14:34:06 <pingou> randomuser: not following your question
14:34:37 <randomuser> pingou, I haven't had much coffee yet :)
14:35:23 <randomuser> I'm wondering if using pagure will mean not using fedorapeople, or if fedorapeople will migrate to pagure from cgit/trac
14:35:48 <pingou> randomuser: fedorahosted you meant :)
14:35:54 <randomuser> pingou, fedorahosted, not fedorapeople
14:35:55 <randomuser> yeah
14:35:57 <pingou> randomuser: no we plan to keep both running atm
14:36:07 <pingou> in the future, if no-one uses fedorahosted anymore, we'll see
14:36:20 <randomuser> ok
14:38:21 <randomuser> pingou, pagure does know about FAS groups, right? that's really all we need
14:39:11 <pingou> randomuser: nope, but you can make your own groups in pagure
14:40:02 <randomuser> hm, ok
14:40:28 <randomuser> that would also be nice to have :)
14:41:05 <pingou> there is a ticket for this, but pagure is self-hostable which makes relying on FAS for groups harder
14:41:29 <randomuser> we're about 20 minutes in to the topic; anyone have action items ?
14:43:17 <randomuser> let's move on then
14:43:24 <randomuser> #topic Release Notes
14:43:48 <randomuser> #link https://fedoraproject.org/wiki/Releases/24/Schedule
14:44:05 <randomuser> #info f24 mass rebuild has been performed
14:44:43 <randomuser> it occurred to me that mass rebuild failures are probably a decent signal that a package has changed in a notable way
14:45:09 <randomuser> so I'll probably skim over the resulting bug list for clues
14:45:36 <pbokoc> hmm, I never thought of that
14:46:03 <randomuser> most packagers will not be introducing major version bumps after this point; if they do, it *should* be in a Change proposal
14:47:39 <pbokoc> there's tons of accepted changes already, too, but I'd hold off on trying to document them since they'll inevitably, well, change
14:49:59 * randomuser nods
14:50:32 <randomuser> it might not be too soon to start planning for them, assigning docs contacts to the changes, etc
14:51:34 <randomuser> #info F24 Change Proposals are happening, many accepted; you can start tracking your favorites now but they will probably change so don't do final documentation now
14:51:52 <randomuser> #action randomuser to send email to list re: changes, what we can do write now
14:52:05 <randomuser> ... unless someone else wants to send that mail?
14:52:33 <pbokoc> nnnnnnope :P
14:52:54 <randomuser> heh
14:53:34 <randomuser> I'm going to jump to open floor, then leave this for you folks to wrap up; there's another thing at the top of the hour I have to get set up for
14:53:42 <randomuser> #topic Open Floor
14:53:53 <randomuser> it's bcotton day, hooray!
14:54:27 <randomuser> okay, commute time, bye
14:54:38 <pbokoc> o/
14:54:44 <kirsti> cu
14:55:34 <kirsti> has anyone seen grundblom or smccann on line lately?
14:58:08 <pbokoc> I haven't, dunno about anyone else...
14:59:19 <pkovar> me neither
14:59:24 <pbokoc> anyway, I guess we can close this meeting
14:59:37 <pbokoc> #endmeeting