18:00:00 <mattdm> #startmeeting Council (2016-03-14)
18:00:00 <zodbot> Meeting started Mon Mar 14 18:00:00 2016 UTC.  The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:00 <zodbot> The meeting name has been set to 'council_(2016-03-14)'
18:00:02 <mattdm> #meetingname council
18:00:02 <zodbot> The meeting name has been set to 'council'
18:00:04 <mattdm> #chair mattdm jkurik jwb cwickert langdon decause robyduck
18:00:04 <zodbot> Current chairs: cwickert decause jkurik jwb langdon mattdm robyduck
18:00:12 <jkurik> .hello jkurik
18:00:13 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
18:00:14 <mattdm> #meetingtopic Fedora Objective Review
18:00:26 <mattdm> #topic Welcomes and hellos
18:00:30 <mattdm> jkurik: you are too fast :)
18:00:35 <jkurik> sorry
18:00:38 <mattdm> :)
18:00:41 <mattdm> .hello mattdm
18:00:42 <zodbot> mattdm: mattdm 'Matthew Miller' <mattdm@mattdm.org>
18:00:43 <robyduck> .hello robyduck
18:00:44 <zodbot> robyduck: robyduck 'Robert Mayr' <robyduck@gmail.com>
18:00:58 <bconoboy> .hello blc
18:00:59 <zodbot> bconoboy: blc 'Brendan Conoboy' <blc@redhat.com>
18:01:19 <mattdm> hey robyduck! welcome bconoboy!
18:01:29 <robyduck> hi all
18:01:32 <mattdm> langdon said he might be a few minutes late
18:01:57 <mattdm> jwb isn't in channel...
18:02:03 <mattdm> nor cwickert
18:02:16 <mattdm> decause is around somewhere :)
18:02:52 <jwb> hi, apologies for being late
18:03:11 <mattdm> jwb cool welcome
18:03:43 <mattdm> okay, so
18:03:46 <mattdm> #topic Agenda
18:04:00 <mattdm> 0. Intros, welcomes, agenda (in progress!)
18:04:11 <mattdm> 1. Review Modularity refresh
18:04:15 <decause> .hello decause
18:04:16 <zodbot> decause: decause 'Remy DeCausemaker' <decause@redhat.com>
18:04:17 <mattdm> 2. Review University Involvement
18:04:20 <mattdm> hi decause!
18:04:24 <sgallagh> /me lurks
18:04:26 * decause waves
18:04:35 <mattdm> 3. Discuss proposals for other new objectives
18:04:47 <mattdm> and then
18:04:54 <mattdm> 4. open floor if any time is left
18:05:26 <mattdm> I didn't spell it out, but for anyone who didn't catch the email last week, this meeting is meant to be a review of our 12-18month objectives
18:05:35 <langdon> .hello langdon
18:05:36 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
18:05:56 <mattdm> I don't expect that we'll have final vote on all of this since it needs community input that I don't think we're really gotten yet
18:06:04 <mattdm> but it seemed good to start somewhere
18:06:12 <mattdm> and hopefully close not too long from now.
18:06:24 <mattdm> (pause for any comments)
18:06:32 <mattdm> (or corrections or additions)
18:06:34 <mattdm> (or applause)
18:06:35 <jwb> close?
18:06:49 <sgallagh> /me claps politely
18:06:51 * langdon claps uproariously
18:06:54 <mattdm> "close" I mean "stop talking, have approved a new slate of objectives"
18:06:56 * bconoboy claps
18:07:02 <jwb> ah
18:07:20 * cwickert is sorry for being late
18:07:28 <mattdm> welcome cwickert!
18:07:42 <mattdm> cwickert: do you need the scrollback?
18:08:01 <cwickert> mattdm: would be nice, but in private please
18:08:05 * linuxmodder hangs in back
18:08:20 <cwickert> thanks mattdm
18:09:14 <cwickert> mattdm: carry on pls, no need to let the others wait while I read
18:09:23 * mattdm pastes
18:09:25 <mattdm> #topic Fedora Modularity Objective
18:09:27 <mattdm> #link https://fedoraproject.org/wiki/Objectives/Fedora_Modularization,_Requirements_Phase
18:09:29 <mattdm> #info that's the current/previous phase
18:09:50 <mattdm> and the proposed new phase is
18:09:53 <mattdm> https://fedoraproject.org/wiki/Objectives/Fedora_Modularization,_Prototype_Phase
18:09:56 <mattdm> #link https://fedoraproject.org/wiki/Objectives/Fedora_Modularization,_Prototype_Phase
18:10:17 <mattdm> langdon, this is your circus -- you want the floor?
18:10:20 * mattdm rests fingers
18:10:29 <langdon> uhh lol
18:11:00 <langdon> so.. i think the best bet is.. i sent out a modularity update last week to devel.. did everyone here read it? need link?
18:11:16 <mattdm> yeah link please :)
18:11:24 <jwb> link would be good
18:11:27 * langdon mutters.. one sec
18:11:34 <jkurik> langdon: I have it on my todo list to go through it
18:11:44 <langdon> #link https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/UTNLVDK6TPGWKZHANSFAPJQLZFYLSI3X/?sort=thread
18:11:48 <mattdm> Looking back at the previous phase, I would say: this didn't generate a lot of noise, but we did get around to figuring out what this more concrete phase would look like :)
18:11:48 <decause> and a nice use-case on the commblog too:
18:11:51 <decause> #link https://communityblog.fedoraproject.org/modularity-use-case-application-independence/
18:12:34 <mattdm> I was expecting a little more response on devel
18:12:35 <langdon> well.. suffice to say.. it is time to move to a prototype phase for modularity.. we have some dedicated resources from red hat, we have me (which is questionable), and we are starting to get some good user stories
18:13:00 <mattdm> I guess maybe you did the "slip it in on Friday and hope the news cycle doesn't notice" thing a little too well
18:13:06 <langdon> we want to use a agile-y / scrum-y approach to the work.. always shipping demos..
18:13:07 <mattdm> #nottheplan
18:13:14 <langdon> mattdm, lol
18:13:18 <jwb> mattdm: i think it's likely that status updates with no functional products that don't actually break or change anything people are using aren't going to generate a lot of discussion
18:13:20 * decause waves to tatica
18:13:47 <langdon> using taiga to load in stories.. right now the only work there is the content updates we have been doing.. the wiki page and the proposal for the objective
18:14:01 <decause> langdon: and the commblog post :)
18:14:13 <linuxmodder> mattdm,  post mtg  you think your'd have a few mins  to spin me up on the modularity  initiative?
18:14:31 <jkrieger> maybe we need a "how does agile-y/scrum-y approach actually work" wiki page langdon ?
18:14:33 <langdon> the objective asks for a "re-up" and to re-jigger the e&s and base working groups in to a modularity working group.. (depending on how you slice it...)
18:14:55 * langdon digs for discussion link about working groups between mattdm and ncoghlan
18:15:00 <mattdm> linuxmodder: possibly -- I have to take my kid to a doctor's appointment.
18:15:08 <langdon> jkrieger, ohh.. actually we have a stub of one..
18:15:11 <mattdm> jkrieger++
18:15:11 <zodbot> mattdm: Karma for jkrieger changed to 1 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:15:18 <linuxmodder> mattdm,  whenever didn't mean RIGHT after :)
18:15:30 <jkrieger> ok, langdon, when you can... show me and I will actually write it.
18:15:37 <decause> jkrieger++
18:15:38 <zodbot> decause: Karma for jkrieger changed to 2 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:15:46 <bconoboy> jkrieger++
18:15:51 <langdon> #link https://fedoraproject.org/wiki/Modularization/Planning
18:15:52 <mattdm> jwb I think that's a good point, so I think langdon (and jkrieger)'s agile-with-demos approach will be helpful
18:16:12 <mattdm> the basic goal of this phase is to generate something concrete people can talk about
18:16:16 * langdon reads a little scrollback
18:16:18 <mattdm> and, ideally, not panic about :)
18:16:26 <decause> when the 'with-demos' part happens, commops will be happy to help socialize on commblog with you folks
18:16:30 * langdon notes mattdm will provide towels
18:16:45 <mattdm> langdon: for space travel, you mean?
18:17:01 <langdon> mattdm, for "not panicking" of course
18:17:11 <mattdm> yes, of course. always handy.
18:17:40 <langdon> mattdm, where was the convo about the working-groups? devel? or e&s?
18:17:55 <mattdm> In any case, has everyone read this proposal? Since we have the full council here (awesome!), are there any immediate concerns?
18:18:02 <mattdm> langdon: env-and-stacks list, yeah
18:18:36 * langdon waits for the internet
18:18:53 <langdon> #link https://lists.fedoraproject.org/archives/list/env-and-stacks@lists.fedoraproject.org/thread/43UKYOPQKTLC2JVBLIODVAI4RQ3V334A/
18:18:57 <bconoboy> I have read the proposal and think it's great.  Having concrete a deliverable will be very helpful to keeping people on track.
18:19:21 <langdon> not great at meetbot'ing.. how do i say "this link is about blah"? #info?
18:19:31 <decause> nod nod
18:19:38 <cwickert> !
18:19:41 <mattdm> jwb Do you think waiting for feedback is going to be useful at all, or just a bureaucratic step?
18:19:46 <mattdm> cwickert go!
18:19:52 <cwickert> not a concern, but
18:19:58 <langdon> #info see that link for discussion about e&s working group "mothballing"
18:19:58 <cwickert> I totally want this
18:20:07 <mattdm> cwickert: :)
18:20:11 <langdon> cwickert, which part?
18:20:14 * jwb thinks
18:20:14 <cwickert> but how far are we on the technical end?
18:20:25 <cwickert> langdon: modularization, all of it ;)
18:20:29 * tatica jumping on/off due awful internet :(
18:20:29 <tatica> I miss home
18:20:47 <jwb> mattdm: i think it will be mostly bureaucratic
18:21:09 <mattdm> I think _after_ we have something to show here, the next phase will be a lot more... interesting. :)
18:21:14 <langdon> cwickert, ahh.. yes.. early days yet.. but have some bits and pieces going.. just to get the engineers working together.. i would like a first sprint/demo in the next 2-3 weeks.. but, it may not look like much.. more "infra"
18:21:24 <cwickert> and from the governance side: do we have commitment from say FESCo and the relevant SIGs?
18:21:36 <jwb> mattdm: though i do wonder if the current base WG members even saw any of this
18:21:45 <jwb> mattdm: since they have no list like E&S
18:21:58 <sgallagh> jwb: Their list is devel@, though
18:22:09 <jwb> sgallagh: yes.  but given the lack of response...
18:22:23 <jwb> cwickert: commitment to what exactly?
18:22:24 <sgallagh> cwickert: There was a proposal to the Server SIG last week that was well received. I'd tentatively call it commitment.
18:22:36 <sgallagh> At the very least, no one voiced objection
18:23:16 <cwickert> jwb: this will require a lot of changes and many people/groups involved. I expect QA to be the biggest opposition since nobody can test all the moduls and interdependencies. So we should start by making sure all relevant parties are with us.
18:23:26 <langdon> i have also gotten a number of queries like "how do i help" .. but not so much in a public response.. more like direct pms to say.. where do i start
18:23:39 <langdon> adamw, ping ^^
18:23:39 <zodbot> langdon: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
18:23:47 <mattdm> cwickert yeah, agreed.
18:24:18 <langdon> cwickert, mattdm i have talked to some of QA/E adamw (mostly) and a few others
18:24:19 <cwickert> how about a session on this issue with representatives from say QA and rel-eng, too?
18:24:27 <mattdm> I've spoken to release engineering, and they're onboard in theory although interested in specifics
18:24:31 <jwb> cwickert: i believe that testing of modules cannot be done to completion, particularly when they really start to proliferate.  however, getting QA and rel-eng on board is required, yes
18:24:32 <cwickert> cool
18:25:01 <mattdm> I've spoken to tflink a little bit about technical/tooling needs
18:25:01 <jwb> cwickert: from a FESCo point of view, i'm not sure there's much for them to commit to.  at least in the near term
18:25:08 <langdon> jwb, cwickert mattdm i actually want them to have "official" representation in the "modularity wg" .. but i am not sure how we structure that
18:25:19 <adamw> langdon: sorry, on a phone call
18:25:23 <cwickert> langdon: sounds good
18:25:23 <robyduck> I think cwickert got the point here, the proposal is great, but this will involve a lot of teams/sigs/groups
18:25:39 <langdon> in theory.. all of fedora at some point :)
18:25:43 <sgallagh> jwb: Well, it will end up being a significant change in how the distro is constructed and delivered, so I think a FESCo rubber-stamp is probably a good idea
18:25:49 <mattdm> checking my watch, I don't think we want to actually _have_ the discussion with QA/adamw right now :)
18:26:01 * decause agrees
18:26:02 <robyduck> right
18:26:12 <jwb> sgallagh: we have 0 actual technology and only words on wiki pages
18:26:19 <langdon> mattdm, i guess i was looking for them to say.. yeah, we have discussed it and we don't think it is a terrible idea ;)
18:26:22 <mattdm> So, proposal: let's give this a week with reaching out to those groups specifically for comment, and then open a ticket for council voting next week.
18:26:29 <cwickert> robyduck: right. I'm also afraid some SIGs will feel as 2nd class citizens again, even though this proposal brings more flexibility and freedom for them.
18:26:32 <langdon> jwb, hey.. BIG words though!
18:26:32 <jwb> so yeah, when we're at the point where we can even demo a module being created, then we can start pinging people for buy in
18:26:40 <jwb> doing it *now* buys us nothing
18:26:43 <sgallagh> jwb: So what you're saying is we're further along on this than on many things with Change Proposals? :)
18:26:48 <mattdm> jwb: that's not true. we also have a chart with *arrows*
18:26:54 <robyduck> cwickert: i fear that too
18:27:10 * cwickert looks at the KDE guys... :(
18:27:12 <jwb> sgallagh: and yet not far enough to claim the world is changing.  alas.
18:27:12 <langdon> and ascii art... ohh.. arrghh.. mattdm we forgot the ascii art
18:27:14 <decause> srsly tho, did you see all those arrows?
18:27:15 <decause> :)
18:27:24 <jwb> cwickert: wait, what?
18:27:36 <jwb> cwickert: how is this anything but a positive for groups like KDE?
18:27:55 <cwickert> jwb: I know, but do they know?
18:28:03 <sgallagh> (alternately, where did we screw up the conversation if it looks like it's not)
18:28:12 <mattdm> yeah, what sgallagh said :)
18:28:15 * langdon wonders if i need to do a tour of all the WGs/SIGs
18:28:47 <cwickert> jwb: I just want to make sure that nobody falls behind. If we start with a demo that involves say GNOME, the KDE SIG will be the first to complain I'm afraid
18:28:50 <sgallagh> langdon: Do you remember the diagram from Flock Prague of all the WGs/SIGs in Fedora? That could take months
18:29:02 <langdon> sgallagh, lol.. point
18:29:13 <jwb> cwickert: nobody is going to start a demo with an entire desktop environment stack
18:29:19 <sgallagh> cwickert: Well, the Server SIG basically volunteered to be the guinea pigs here.
18:29:20 <langdon> cwickert, the demo we have in the works involves a terminal :)
18:29:23 <sgallagh> Which is probably non-controversial
18:29:38 <cwickert> #link https://lh4.googleusercontent.com/-lifthhJ5HwY/U-YwWeD2fhI/AAAAAAAALtE/29YIEDNhmM03MgbNbNX5vgaePSs_ErXoA/w1111-h833-no/09.08.14%2B-%2B1
18:29:53 <sgallagh> cwickert: I love that you had that readily to hand
18:29:54 <mattdm> langdon: a tour seems like a good idea. is a week enough for that or do you need more?
18:30:06 <langdon> mattdm, uhh.. are you kidding?
18:30:18 <robyduck> :)
18:30:18 <jwb> a week is not going to cover it
18:30:23 <langdon> for the entire board? or should we pick some?
18:30:23 <jwb> a month is more realistic
18:30:36 <jwb> however, i don't think we should delay actual work
18:30:43 <cwickert> +1
18:30:51 <langdon> i wonder if we could use fedocal.. and offer to the peeps that have meetings?
18:31:51 <jkurik> langdon: my experience is that fedocal does not work. Just a few people is using it
18:32:17 <mattdm> So, should we give, like, tentative approval, and a go-ahead for investment of initial effort?
18:32:22 <decause> langdon: we can have a calendar, and then socialize it more tradtionally via lists/commblog.
18:32:34 <langdon> decause, ohh that's smart
18:32:43 <langdon> decause, maybe you could do the talks too ;)
18:32:47 <decause> langdon: I just created 2 new fedocals in the past week, def recommend
18:32:54 * robyduck is also for commblog
18:33:21 <jwb> mattdm: i think we approve fully, then get to work
18:33:22 <decause> we don't have as much visibility as magazine, but it can be a central platform at least
18:33:30 * decause is ready to approve
18:33:32 <jwb> i really fear the longer we spend talking, the more in the weeds we'll get
18:33:48 <jwb> if we have things to *show* when we talk, it should help us focus on concrete issues
18:33:49 <mattdm> jwb: with 'socialize this' as part of the 'getting to work', basically.
18:33:55 <langdon> ohh.. maybe i am confused.. i was thinking 3-6 meetings of "what modularization means to you" with like 3 focii, then people can come and attend?
18:34:00 <jzb> jwb: +1
18:34:03 <jwb> mattdm: no, with 'ACTUALLY START BUILDING THINGS'
18:34:19 <jwb> mattdm: socializing meetings is an additional activity
18:34:33 <langdon> jwb, how about just demos then?
18:34:39 <jwb> langdon: however we structure it, sure
18:34:40 <langdon> and people can ask qs?
18:34:40 <mattdm> jwb: like an activity I should draw on my chart? :)
18:34:53 <langdon> with arrows!
18:35:05 <jwb> mattdm: sure.  with arrows to each of the groups we need to reach out to
18:35:10 <jwb> langdon: jinx
18:35:27 <mattdm> ok, so, is anyone -1 to approving this _now_?
18:35:36 * decause nope
18:35:37 <jkurik> I am +1
18:35:40 <decause> +1
18:35:47 <langdon> i like the original proposal (where I put words in jwb's mouth).. how about we just start doing demos.. invite the whole world.. poke some people in individual groups.. and wait for bug reports?
18:36:30 <mattdm> Approving the objective doesn't mean that we're commiting to giant changes in Fedora, especially as this is explicitly an exploration/demo
18:36:41 <langdon> mattdm, +1
18:36:43 <mattdm> and given that I'm +1 for now too
18:36:47 <jkrieger> sounds like an agile demo. :D select a small starting chunk of work, demo a proof of concept, and ask for feedback
18:37:22 <mattdm> cwickert: what do you think?
18:38:11 <cwickert> +1
18:38:15 * robyduck is +1 for it
18:38:23 * langdon is obviously +1
18:38:25 <mattdm> cool, okay, that makes it easy
18:38:32 <mattdm> langdon: you can't be +1 _twice_
18:38:38 <mattdm> i mean, you can, but I'm only counting once
18:38:43 <langdon> mattdm, i was commenting on your ocmment above..
18:39:06 <langdon> but.. +1 +1 +1 +1
18:39:11 <langdon> :)
18:39:13 <decause> :)
18:39:18 <mattdm> #agreed Council approves Modularization Objective prototype phase. Demos will commence!
18:39:25 <decause> \o/
18:39:29 <jzb> woot
18:39:30 <mattdm> #info along with specific discussions with various WGs and SIGs
18:39:35 <mattdm> okay next!
18:39:36 * jzb is psyched to see this
18:39:37 <robyduck> cool
18:39:43 * langdon wonders how in (*&*&@ he is going to get videos using OSS
18:39:55 <mattdm> #topic University Involvement Objective
18:39:57 <decause> langdon: jitsi was good for sync, but doesn't do saving
18:39:58 <jwb> langdon: jitsi?
18:40:11 * decause clears his throat and shuffles papers
18:40:21 <decause> so
18:40:24 <mattdm> last time I used jitsi, everyone spoke like darth vader
18:40:27 <mattdm> #link https://fedoraproject.org/wiki/Objectives/University_Involvement_Initiative
18:40:46 <decause> this first item is, we developed a decent looking logic model
18:40:47 <decause> #link
18:40:47 <decause> 5 http://fedoraproject.org/wiki/Objectives/University_Involvement_Initiative#Overview
18:40:48 <jzb> mattdm: I told you, I always sound like that.
18:40:52 <langdon> mattdm, so that is a +1 for jitsi?
18:40:59 * decause tries that again
18:41:04 <decause> #link
18:41:05 <decause> http://fedoraproject.org/wiki/Objectives/University_Involvement_Initiative#Overview
18:41:14 <decause> ...
18:41:21 <decause> it should still show up in the minutes
18:41:38 <decause> shoutout to mizmo for the pixel ninja'ing skills
18:41:56 <mattdm> My concern with this picture is its lack of arrows :)
18:42:12 <decause> #action decause moar arrows in the EDU logic model
18:42:41 <decause> There were a number of aspects to the model, some more traditional, and some new
18:42:53 <mattdm> And I mean that in a haha-only-serious kind of way... this picture gives a nice overview but it's hard to see how inputs connect through
18:43:01 <decause> traditional includes things like installfests and events on campuses
18:43:09 <mattdm> or in reverse how all of the desired outcomes are supported
18:43:40 <decause> mattdm: yes, perhaps we can do a more column-ular approach like the modular objective
18:43:54 <decause> this was born of a spreadsheet afterall, and was already column-ular
18:44:20 <mattdm> spreadsheets are not the best tool either because they're also inherently... row-ular?
18:44:36 <mattdm> langdon said it's a "mindmap with swimlanes"
18:44:53 <decause> well put
18:45:07 * langdon has a hard time staying in swimlanes
18:45:10 <decause> I think that revisiting the graphics of it will be easier now that mizmo is back in the fold
18:45:24 <decause> #action decause revisit EDU logic model with Fedora Design team
18:45:43 <mattdm> So, I guess the question for us is, logic model aside for a minute...
18:45:53 * decause pauses
18:45:58 <mattdm> This didn't go very far in this school year
18:46:06 <mattdm> Do we want to renew it for the next one
18:46:08 <cwickert> ?
18:46:10 <mattdm> or are we on to other things?
18:46:25 <decause> mattdm: lemme grab some highlights
18:46:26 <decause> first
18:46:34 <decause> #info After Software Freedom Day 2015, we have a PoC model for future
18:46:34 <decause> Badge-a-thon contests and coverage:
18:46:39 <decause> #link https://fedoraproject.org/wiki/Softwarefreedomday/2015#Badge-a-thon
18:46:43 <decause> #link https://fedoramagazine.org/celebrating-software-freedom-day-2015/
18:46:52 <mattdm> cwickert: yes?
18:46:59 <decause> #info We are sponsoring participating in more University Level Hackathons in NA, such as brickhack, bitcamp, and HackRU:
18:47:00 <cwickert> my question is: what did we invest and what did we get in return? was it that we did not have enough people from our side are was the response the problem?
18:47:04 <decause> #link https://communityblog.fedoraproject.org/find-fedora-at-brickhack-2016/
18:47:10 <cwickert> s/are/or
18:47:11 <decause> #info Fedora Campus Ambassadors Initiative is showing renewed interest
18:47:17 <decause> #link https://fedoraproject.org/wiki/Campus_Ambassadors
18:47:34 <decause> those are the 'traditional' things we've usually done
18:47:49 <decause> as far as the 'newer'-ish things:
18:47:58 <decause> #info Fedora has participated in both rounds of Outreachy this year.
18:48:03 <decause> #link https://wiki.gnome.org/Outreachy/2016/MayAugust
18:48:07 <decause> #link https://fedoraproject.org/wiki/Outreachy/2016
18:48:11 <decause> #link https://fedoraproject.org/wiki/Outreachy/2015
18:48:17 <decause> and
18:48:21 <decause> #info Fedora/Project Atomic has been accepted this year to Google Summer of Code!
18:48:27 <decause> #link https://summerofcode.withgoogle.com/organizations/5630777857409024/
18:48:38 <decause> so
18:48:47 <mattdm> cwickert: that's a good question. decause, would you consider these things basically under that umbrella of investment in this area?
18:49:26 <decause> mattdm: yes, unless we want to include those into a new Diversity and Inclusion Objective (which i would be amenable to)
18:49:26 <cwickert> mattdm: mainly manpower, I don't care about money at this point
18:50:41 <decause> what we invested was me, mostly
18:50:52 <mattdm> :)
18:50:58 <decause> and the time that went into the oboarding programs def beared fruit
18:51:16 <mattdm> I'm lookin' at the clock again -- sorry, I haven't been keeping things moving as I should
18:51:29 <decause> folks like jflory7 and bee2502 have come directly from these initiatives, and have had massive project wide impact, IMHO
18:51:45 <mattdm> decause, could you put together a summary of how things have gone against the desired outcomes and impact, in as numerical terms as possible?
18:51:46 <decause> just to name two
18:51:58 <mattdm> for the mailing list
18:52:05 <mattdm> and then we'll pick up the conversation from there?
18:52:20 <decause> sure, do we have a preferred format or list of questions?
18:52:29 <decause> we are getting along in meeting time
18:52:34 <mattdm> decause: hasn't been done before so you get to make the format :)
18:52:49 <decause> #action decause report back to council-disucss on EDU Involvement Objective
18:52:52 <mattdm> yeah, I want to get to the "possible new objectives"
18:52:55 <mattdm> cool thanks decause
18:53:03 <mattdm> #topic Possible new objectives
18:53:33 <mattdm> okay, so, we set this up with 2-4 objectives in play at a given time
18:53:43 * decause has one when we're ready
18:53:51 <mattdm> decause: okay go!
18:54:01 <decause> #link https://fedoraproject.org/wiki/Objectives/Fedora_Marketing_Python
18:54:22 <decause> from the overview:
18:54:27 <decause> #info It has been suggested that Fedora take on on Marketing as a top-level objective this year to increase our exposure in the developer community. Rather than try to market to every developer everywhere, we want to focus on a specific community. This is similar to the Fedora.next strategy of separate editions — we can have bigger impact by really winning in individual areas and growing from there than we can in attempting to appeal to all peopl
18:54:31 <cwickert> somebody just switched off the lights in my office, I should probably go home
18:54:59 <decause> and that community we identified was the python community
18:55:07 <mattdm> cwickert: good thing they didn't cut the internet :)
18:55:12 <decause> which has lots in common with fedora, including major stakeholders
18:55:31 <jzb> you have a screen and Internet, right? That's plenty of light.
18:55:44 <decause> the first big milestone is coming fast, May 27th for PyCon NA
18:56:30 <decause> we want to have a set of materials for both "Premier Events" and "Local Events" that ambassadors can use to engage with pythonistas
18:57:01 <mattdm> I'm generally in favor of this. I like the focused approach, Python is a natural, and the developer focus fits perfectly with plans for both Fedora Workstation and Fedora Atomic
18:57:10 <decause> I think it'd also be a good idea to discuss official relationships at the project level between Fedora and PSF, and other supporting orgs in the python ecosystem eventually
18:57:19 <langdon> decause, i would like to see more "formal" component of impact/connection to 1) the uni objective 2) the workstation wg (specifically, would the python spin be the best dev workstation for python people?) ... and, perhaps, some objective line item about python.org recommending fedora for new python people
18:57:22 <mattdm> I assume Fedora Marketing is on board?
18:57:54 * langdon realizes psf would have been shorter than python.org but had been planning to write it out ;)
18:57:57 <jzb> mattdm: yes.
18:58:03 <decause> mattdm: Fedora Marketing has had 3 meetings this year so far, and is still coming back online, but yes, it has been a topic of discussion
18:58:29 <mattdm> jzb, decause cool.
18:58:54 <jzb> mattdm: to decause's point, "coming back online" is a good way to say that marketing is sort of under refresh
18:59:06 <mattdm> Okay, so, let's take this back to the mailing lists too. Maybe get marketing to help fill out hte proposal as part of the refresh?
18:59:15 <jzb> mattdm: and this objective gives us a good focal point instead of "boil the ocean" and "market all the things"
18:59:21 <mattdm> jzb++
18:59:23 <decause> agreed
18:59:23 <zodbot> mattdm: Karma for jzb changed to 6 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:59:25 <decause> jzb++
18:59:42 <decause> happy to take it back to the lists, but
18:59:47 <langdon> decause, did you see my comment(s)?
19:00:01 <decause> if it needs a lead, I should probably be on either EDU or this
19:00:05 <mattdm> okay, so, nominally 30 seconds left. I can go on for a bit, although my kids have showed up and are telling me aobut how to find the areas of parallelograms
19:00:31 <langdon> mattdm, tell em to go calc pi for pi day.. that should occupy them for a bit
19:00:36 <decause> langdon: I did see your comment, and it would be great to tie it into other objectives
19:00:36 <langdon> 22/7
19:01:04 <mattdm> decause: *nod* Yeah, we should not have the same person as lead on two things, because I think that's a recipie for both of them to half succeed :)
19:01:24 <decause> langdon: we should have a 'objectives' support group or something where we (leads) talk this out on the regular
19:01:26 <jzb> perhaps the discussion on both topics will help us decide on lead(s)
19:01:30 <mattdm> so, other possible proposals:
19:01:43 * langdon wonders how he could expense the beer
19:01:48 <mattdm> - I sugggested an OpenShift❤Fedora thing, but that didn't get many bites earlier
19:02:08 <jwb> decause: wait... what?
19:02:10 <langdon> mattdm, did you suggest that to the openshift people?
19:02:15 <decause> mattdm: that being said, even IF I were to reliquish EDU Lead, I would still be willing (and a good fit) for the GSoC Admin and Outreachy Coordinator activities
19:02:17 <mattdm> - Also, Fedora Hubs might be a good one -- but as I understand from Apps/Infra, that's probably the latter half of the year
19:02:35 <decause> mattdm: we've had like 10+ people express interest since our gsoc announce :)
19:02:42 <mattdm> langdon: I did to scott collier and to diane mueller, but did not get much more than polite nods
19:02:48 <mattdm> well, that's not quite fair
19:02:54 <decause> we're gaining community momentum, but yeah, after FLOCK I think would be a good time to propose as objective
19:03:11 <mattdm> scollier and infrastructure are working together to stand up an instance of openshift in fedora infro
19:03:12 <mattdm> a
19:03:15 <mattdm> which is AWESOME
19:03:20 * langdon thinks mattdm should approach openshift evangelists..
19:03:22 <mattdm> but the objective part wasn't so clear
19:03:32 <mattdm> langdon: if you want to hook me up with people, I totally will
19:03:41 <langdon> will do
19:03:48 <mattdm> thanks!
19:04:02 <decause> jwb: was suggesting regularish meetings for Objective leads to work together
19:04:04 <mattdm> #action langdon to connect mattdm with openshift evangelists
19:04:12 <jwb> decause: re: objective leads support group, just use the council-discuss list.  there is no reason NOT to spread that kind of knowledge
19:04:23 <mattdm> decause: you mean, beyound the Council?
19:04:33 <jwb> decause: and if it's done regularly, it could help encourage people to setup new Objectives since they then know how
19:04:37 * cwickert needs to leave
19:04:39 <cwickert> see you
19:04:51 <langdon> jwb, mkes a good point.. but does not solve the beer acquisition problem
19:05:33 * langdon belatedly waves to cwickert
19:05:35 <jwb> langdon: pfft.  you are not thinking.  just make 'beer' one of the outcomes (or input!) of your Objective and we'll be obligated to fund it
19:05:50 <decause> jwb: def def, not suggesting we don't communicate in public or keep council up to date, using council list as place to discuss, I just know that I do regular "hack sessions" with commops folks to tackle tickets and whatnot, and could do with a "power session" to tackle objective related tasks
19:05:57 <mattdm> connect it through with arrows, and I'll be sold.
19:06:05 <langdon> jwb, lol! at double or even triple the rate of $0 last year
19:06:17 <decause> jwb: brillant
19:06:40 <jwb> decause: sure.  power sessions are cool too.  just as long as they have a summary email to council-discuss at the end :)
19:06:47 <decause> jwb: agreed
19:06:55 * langdon had another objective idea in mind.. but it is gone now..
19:07:02 <decause> :P
19:07:22 * langdon intentionally vague pronoun just for mattdm
19:07:37 <mattdm> I definitely would like Council to stay the center of gravity around objectives -- otherwise, we're back to the org chart whiteboard mess
19:07:40 <langdon> ^ provided
19:08:05 <langdon> decause, we could have those "meetings"in fedora-council.. i should think
19:08:05 * mattdm thinks maybe map of fedora as http://i.kinja-img.com/gawker-media/image/upload/s--_5rk36gF--/18r7z4vs073ocjpg.jpg is in order
19:08:06 <decause> mattdm: didn't mean to imply a separate group, just a dedicated chunk of time to work on objective related materials
19:08:27 <mattdm> decause: yeah, sounds like a good idea
19:08:29 <langdon> where is cthulu?
19:08:39 <mattdm> langdon: _different_ verse
19:08:55 <langdon> or just under the turtles
19:09:04 <mattdm> also, different universe :
19:09:07 <jkurik> mattdm: reptilians are missing
19:09:12 <mattdm> okay I can see we are winding down now :)
19:09:25 <decause> nod nod
19:09:32 <mattdm> Good meeting, y'all
19:09:35 * langdon was just gonna say that but couldn't spell deteriorating..
19:09:46 <decause> so we approved modularization++, and we're going to talk about Fedora-marketing and EDU intiatives on the list, yes?
19:09:46 <mattdm> #action mattdm to update Objectives page with link to new Modularization phase
19:09:53 <mattdm> decause: yeah, exactly
19:10:00 <decause> kk, word
19:10:03 <langdon> uhhh...
19:10:06 <mattdm> and continue discussion of a possible 4th
19:10:10 <langdon> fedora-marketing = objective?
19:10:20 <langdon> or am i just reading that wrong?
19:10:21 <mattdm> fedora-python-marketing = proposed objective
19:10:25 <decause> fedora-marketing-python = objective
19:10:29 <decause> mattdm: jinx!
19:10:32 <langdon> mattdm, ahh gotcha.. sorry
19:10:33 <mattdm> :)
19:10:34 <decause> this wavelength thing
19:10:35 <decause> :)
19:11:26 <mattdm> okay, so, ending in 3...2...1...
19:11:28 <mattdm> 3...
19:11:33 <mattdm> 2...
19:11:35 <mattdm> 1...
19:11:39 <mattdm> #endmeeting