14:59:00 <rdieter> #startmeeting kde-sig
14:59:00 <zodbot> Meeting started Tue Mar 22 14:59:00 2016 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:59:00 <zodbot> The meeting name has been set to 'kde-sig'
14:59:07 <rdieter> #meetingname kde-sig
14:59:07 <zodbot> The meeting name has been set to 'kde-sig'
14:59:07 <dvratil> hello
14:59:09 <tosky> hi
14:59:11 <rdieter> #topic roll call
14:59:20 <rdieter> hi all, who's present for friendly kde-sig meeting today?
14:59:34 <pino|work> me, although come-and-go :/
14:59:43 * jreznik is friendly
14:59:46 * jgrulich is present
14:59:57 <lupinix> .hello lupinix
14:59:58 <zodbot> lupinix: lupinix 'Christian Dersch' <lupinix@mailbox.org>
14:59:58 * pino|work as above ^
15:00:32 <rdieter> #info rdieter pino|work dvratil tosky jreznik jgrulich lupinix present
15:00:41 <rdieter> #chair pino|work dvratil tosky jreznik jgrulich
15:00:41 <zodbot> Current chairs: dvratil jgrulich jreznik pino|work rdieter tosky
15:00:54 * rdieter waits another minute or 2
15:02:46 <rdieter> ok, let's go
15:03:18 <rdieter> #topic offer kde-sig/working-group seat to lupinix
15:03:22 <rdieter> per https://lists.fedoraproject.org/archives/list/kde@lists.fedoraproject.org/thread/EMA2AIQONXMT2RDEKCIIDR2O22BNDCYH/
15:03:41 <rdieter> I suggested to lupinix he post his interest in the vacant seat left by ltinkl
15:04:10 <rdieter> any comments or concerns (before we formally vote)?
15:04:18 <lupinix> i thought it was the seat left by kevin?
15:04:43 <rdieter> lupinix: one of the 2 :)  , the other seat was filled by heliocastro
15:05:00 <rdieter> either way, we have a vacancy
15:05:02 <lupinix> ok, i just wrote kevin in my mail
15:06:49 <jreznik> it really doens't matter whose seat :)
15:08:29 <rdieter> ok... let's go ahead and vote on it then.... PROPOSAL: kde-sig offer empty seat to lupinix
15:08:41 <rdieter> sig members, please vote for the record
15:08:44 <tosky> +1
15:09:22 <rdieter> +1
15:09:22 <jgrulich> +1
15:09:32 <than_> present
15:09:37 <dvratil> +1
15:09:39 <rdieter> #info than_ present
15:09:42 <rdieter> #chair than_
15:09:42 <zodbot> Current chairs: dvratil jgrulich jreznik pino|work rdieter than_ tosky
15:10:06 <jreznik> +1
15:10:42 <than_> +1
15:11:53 <rdieter> ok, I think that's everyone present, and enough to ratify things
15:12:12 <rdieter> #agreed kde-sig appoints lupinix to empty seat
15:12:19 <rdieter> lupinix: welcome aboard
15:12:26 <lupinix> thank you :)
15:12:26 <jreznik> welcome!
15:13:06 * rdieter will try to remember to add you to kde-sig group in FAS after meeting
15:13:34 <rdieter> moving on...
15:13:50 <rdieter> #topic recent updates status: Qt 5.6.0, KF5 5.20, Plasma 5.6
15:14:14 <rdieter> So, I banged out Qt 5.6.0 updates over the past week or so, got everything submitted to bodhi yesterday
15:14:29 <dvratil> KF5 5.20 in rawhide and bodhi as well
15:14:29 <rdieter> purposely left out F22 (for now), per my post onlist
15:14:59 * jreznik agrees with f233
15:15:03 <jreznik> f22 (sorry)
15:15:29 <dvratil> jreznik always planing for distant future :)
15:15:42 <than_> it seems  there's a regression in qt 5.6.0.
15:15:44 <rdieter> oh, and recent kde-apps-15.12.3 release, I think it's all in rawhide, will try to find time to submit f24/f23 updates soon
15:15:51 <jreznik> dvratil: as we say in czech - profesni deformace :)
15:16:06 <than_> kcalc doesn't start correctly
15:16:15 <rdieter> than_: there's an update submitted for that
15:16:34 <than_> kcalc update ?
15:16:35 <rdieter> rats, but only f24 so far
15:16:37 <jreznik> I expect with this megaupdate, we should keep it in -testing for longer period
15:16:53 <than_> rdieter: or qt?
15:17:10 <rdieter> than_: I added a workaround patch
15:17:21 <lupinix> jreznik: yes, although i'm using qt 5.6 @f23 for some while now (using the copr)
15:17:29 <rdieter> http://pkgs.fedoraproject.org/cgit/rpms/kcalc.git/tree/kcalc-15.12.3-qt56.patch
15:17:43 <rdieter> .bug 1315835
15:17:44 <zodbot> rdieter: Bug 1315835 kcalc Doesn't start (with Qt 5.6) - https://bugzilla.redhat.com/1315835
15:17:51 <lupinix> no issues yet except the mentioned kcalc issue h
15:17:51 <rdieter> http://bugs.kde.org/360105  upstream
15:17:54 <than_> rdieter: great
15:18:15 <rdieter> fyi, anyone finding qt-5.6 related issues, please block tracking bug
15:18:25 <rdieter> .bug 1291040
15:18:26 <zodbot> rdieter: Bug 1291040 qt-5.6.0 tracker - https://bugzilla.redhat.com/1291040
15:18:28 <rdieter> (alias qt-5.6)
15:18:47 <dvratil> for Plasma 5.6 I need to get a couple of new packages reviewed
15:19:02 <dvratil> .bug 1319519
15:19:03 <zodbot> dvratil: Bug 1319519 Review Request: plymouth-theme-breeze - Plymouth Breeze theme - https://bugzilla.redhat.com/1319519
15:19:04 <dvratil> .bug 1319520
15:19:06 <dvratil> .bug 1319521
15:19:06 <zodbot> dvratil: Bug 1319520 Review Request: grub2-breeze-theme - Breeze theme for GRUB2 - https://bugzilla.redhat.com/1319520
15:19:09 <zodbot> dvratil: Bug 1319521 Review Request: plasma-integration - Qt Platform Theme integration plugin for Plasma - https://bugzilla.redhat.com/1319521
15:19:10 <dvratil> .bug 1319522
15:19:12 <zodbot> dvratil: Bug 1319522 Review Request: kactivitymanagerd - Plasma service to manage user's activities - https://bugzilla.redhat.com/1319522
15:19:19 <rdieter> I'd mentioned it in #fedora-kde earlier, but to be on record, should definitely keep plasma-5.6 rawhide only until f24-alpha freeze is over
15:19:53 <rdieter> dvratil: thx
15:20:03 <dvratil> yep, and I'd like to get all three (Qt 5.6, KF5 5.20, Plasma 5.6) submitted for stable all together
15:20:46 <rdieter> right, since kf5-frameworkintegration (and soon plasma-integration) have hard dep on the Qt version used to build it
15:21:23 <tosky> what is the risk of (other) regressions with Qt 5.6.0?
15:21:53 <jreznik> tosky: I'd say we already saw enough regressions to expect even more...
15:22:03 <rdieter> good question, we've had a fair number of people using the Qt 5.6 copr for quite awhile
15:22:26 <jreznik> and hitting issues... at least, my case
15:22:37 <rdieter> and it was unfortunate that 5.6.0-rc introduces some qtdbus weirdness, but that should all be resolved now (hopefully)
15:23:08 <tosky> *if* there is a real risk of regressions with Qt 5.6.0, wouldn't it make sense to split the updates for now? (KDE updates vs Qt updates)
15:23:09 <jreznik> yeah, due to that issue I really didn't have much possibility to test
15:23:31 <rdieter> tosky: not possible, since kf5-frameworkintegration has a hard dep
15:23:45 <rdieter> well, we could theoretically do Qt + KF5 first, plasma later
15:23:57 <rdieter> dvratil: ^^ is that possible?
15:23:59 <tosky> rdieter: well, only if you compile it with that version of Qt
15:24:07 <tosky> frameworksintegration should work with Qt 5.3
15:24:09 <dvratil> honestly I'd like to avoid any potential issues that could  arise from mixing the versions
15:24:39 <dvratil> tosky: according to distibutions@k.o we should always recompile -integration plugins against current Qt (they might be using private API or something)
15:24:42 <rdieter> I *do* agree, doing Qt + Kf5 + Plasma all at once is bug and scary
15:24:52 <rdieter> heh s/is bug/is big/
15:25:13 <dvratil> there could also be the issue with KActivities
15:25:21 <dvratil> since 5.20 does not have kactivitymanagerd
15:25:24 <tosky> dvratil: yes, so my point was: do all against Qt 5.5; there are Frameworks every month, at some point it will be synchronized with Qt 5.6
15:25:30 <jreznik> but it can be properly tested together instead of fighting issues later with mix of versions as dvratil pointed out
15:25:34 <tosky> oh, kactvitymanagerd
15:25:41 <dvratil> we'd need to add kactivitymanagerd package to the Frameworks update
15:26:01 <dvratil> which is not a big problem once the package is reviewed
15:26:17 <rdieter> fwiw, I would've liked to get Qt 5.6.0 out by itself first, but I'd missed sufficiently warning dvratil, and he's already merged kf5-5.20 to f23/f24 branches
15:26:42 <tosky> by mix of version you mean Qt 5.5 (which is the one tested on KDE CI) with Frameworks 5.20 and Plasma 5.6?
15:27:13 <rdieter> but it does appear that KF5-5.20 + Plasma-5.6 kinda have to go out together, to minimize headaches (due to recent kactivities splits)
15:28:44 <rdieter> dvratil: ^^ is that accurate?
15:29:06 <dvratil> yes, but as I said, we could just add kactivitymanagerd to the Frameworks update
15:29:11 <dvratil> that should solve the problem
15:29:30 <rdieter> oh, if we could do KF5 5.20 by itself first, that would make me happier (and I think tosky too)
15:30:25 <dvratil> okay
15:30:26 <tosky> it's a basic risk assessment
15:30:29 <rdieter> dvratil: as long as it's feasible and not (too much) extra work?
15:31:01 <dvratil> not for me, just need to get review for kactivitymanagerd, build it and add it to the KF5 update in Bodhi
15:31:23 * lupinix could do the review now
15:31:30 <rdieter> fwiw, I have a few reviews waiting, that I'd like to get done in time for f24 too
15:31:56 <rdieter> .bug 1287201
15:31:57 <zodbot> rdieter: Bug 1287201 Review Request: kf5-kross-interpreters - Kross interpreters for KDE Frameworks 5 - https://bugzilla.redhat.com/1287201
15:32:20 <rdieter> .bug 1314974
15:32:21 <zodbot> rdieter: Bug 1314974 Review Request: kdepim4 - KDE4 PIM (Personal Information Manager) applications - https://bugzilla.redhat.com/1314974
15:32:31 <rdieter> ^^ for knode mostly
15:33:03 <rdieter> but I think dvratil's are more important, if you have to choose
15:33:49 * lupinix ← already running fedora-review @kactivitymanagerd
15:33:56 <rdieter> ok, anything else on these recent updates?  or can we move on?
15:34:11 <rdieter> lupinix++
15:35:10 <rdieter> moving on...
15:35:22 <rdieter> #topic f24, theming, etc...
15:36:05 <rdieter> so, in the short term (f24-alpha), I'd submitted updates for kde-spin to use upstream breeze looknfeel
15:36:22 <rdieter> https://bodhi.fedoraproject.org/updates/FEDORA-2016-c984441023
15:36:33 <rdieter> .bug 1319043
15:36:34 <zodbot> rdieter: Bug 1319043 Include F24 Alpha backgrounds in next RC - https://bugzilla.redhat.com/1319043
15:36:51 <rdieter> to address blocker bug ^^, blocker text is strictly that we need to not use fedora-1 theming
15:37:36 <rdieter> after alpha, we will switch things to use the standard f24-backgrounds-kde
15:38:24 <rdieter> one question I had, was how to implement that moving forward.  historically, we'd created a separate fxx-kde-theme pkg, containing a copy of breeze's looknfeel, but with wallpaper replaced
15:38:48 <rdieter> I was considering moving away from that, and use plasma scripting to set wallpaper instead
15:39:12 <rdieter> pro: avoids proliferation of fXX-kde-theme pkgs, (arguably) simpler
15:39:37 <rdieter> con: well, it's no longer a nice looknfeel theme, that users can (more) easily switch to/from
15:39:54 <rdieter> thoughts?
15:40:52 <rdieter> fwiw, http://pkgs.fedoraproject.org/cgit/rpms/kde-settings.git/tree/set_wallpaper.js that heliocastro had offered late last cycle (for plasma-5.4) no longer seems to work
15:41:05 <dvratil> I prefers having a proper look-n-feel package, but then I'm not doing any of the work....
15:41:25 <tosky> I don't know the plasma scripting mechanism too much, how does then user go back to the "standard" theme? Does the added js basically "transform" the base theme?
15:41:30 <rdieter> so, in the absense of working plasma scripting, look-n-feel is really our only option
15:42:01 <rdieter> tosky: all the script does is run once, and sets users' wallpaper as specified
15:42:09 <tosky> I see
15:42:26 <rdieter> thinking out loud, that means, folks upgrading to f24 will get their wallpaper changed (which may not be expected)
15:42:29 <dvratil> also isn't just copying the breeze package and replacing couple wallpapers files in spec file much easier than Plasma scripting? :)
15:42:45 <lupinix> so the current selection for fedora theme will vanish from settings?
15:42:45 <rdieter> dvratil: in the end, I guess it's about the same
15:43:04 <rdieter> lupinix: yes, there won't be a "f24" looknfeel, if we go with that approach
15:43:10 <tosky> mmhh...
15:43:16 <jreznik> dvratil: yeah, I believe it's easier
15:43:55 <rdieter> ok, I think I'm getting convinced that making a f24-kde-theme pkg for looknfeel is the way to go, I'll start working on that
15:44:13 <rdieter> next subtopic: gtk theming
15:44:23 * lupinix would prefer a proper look n feel package too
15:44:32 <rdieter> subtopic a:  I assume we want to use breeze-gtk ?
15:44:56 <dvratil> are there any alternatives?
15:45:02 <rdieter> subtopic b: implementation, xsettings-kde+kcm-gtk(kde4 kcm) vs kde-config-gtk
15:45:11 <rdieter> dvratil: continue using (default) adwaita
15:46:08 * dvratil prefers breeze-gtk
15:46:14 <rdieter> for b, while I (still) find the xsettings-kde implementation superior, the fact that it only integrates with (kde4) kcm-gtk is ... bad
15:46:46 <lupinix> i prefer breeze-gtk too
15:46:49 <rdieter> dvratil: how long have you used it (breeze-gtk)?
15:47:03 <rdieter> mind you all, it's pretty new, not well tested yet
15:47:21 <rdieter> I haven't looked, does breeze-gtk support both gtk2/gtk3 ?
15:47:27 <dvratil> 5.4/5.5? Basically since it was introduced
15:47:38 <rdieter> dvratil: oh right, i forgot
15:47:56 <rdieter> I think 5.5, I erroneously thought it was new in 5.6
15:48:21 <dvratil> and yes, it supports both gtk2 and gtk3
15:48:47 <heliocastro> late arrival /o\
15:48:55 <rdieter> #info heliocastro present
15:49:10 * heliocastro enters and someone says support gtk :-P
15:49:14 <rdieter> heliocastro: currently discussing f24 theming issues (gtk in particular right now, whether to use breeze-gtk or not)
15:49:19 <heliocastro> ( nice catch the thing on the middle )
15:49:38 * heliocastro listening
15:50:02 <rdieter> ok, I haven't seen anyone speak against breeze-gtk
15:50:07 <rdieter> let's go with that
15:50:25 <jreznik> anyone tried it already?
15:50:29 <rdieter> #agreed configure f24/plasma environment to default to using breeze-gtk
15:50:36 <heliocastro> Nope. but i can
15:50:42 <rdieter> jreznik: dvratil has
15:50:51 <lupinix> jreznik: i'm using it
15:51:14 <heliocastro> is there a ready kcm ?
15:51:30 <rdieter> though I vaguely recall someone mentioning #fedora-kde recently that firefox + breeze-gtk => a little ugly.
15:51:40 <rdieter> heliocastro: kde-config-gtk ?
15:51:51 <heliocastro> thanks.
15:51:59 <mbriza> just trying the breeze theme out
15:52:00 <heliocastro> I almosy gone to kcm-gtk
15:52:02 <mbriza> it looks pretty good
15:52:04 <rdieter> I think I got that pkg name wrong
15:52:20 <rdieter> kde-gtk-config
15:52:22 <rdieter> there
15:52:59 <rdieter> that brings us to topic b:  I guess we should start using it (kde-gtk-config), and eol/retire xsettings-kde/kcm-gtk ?
15:53:25 <rdieter> or I suppose we could theoretically skip eol'ing them, and keep them available in repos for another release (or 2)
15:53:33 <rdieter> (just no longer install them by default)
15:54:05 <lupinix> +1 @kde-gtk-config
15:54:07 <heliocastro> Agreed. +1 against duplication and misleading users on the proper one
15:54:31 <rdieter> would anyone be able/willing to work in implementing/testing the gtk theme/intergration bits we just talked about?
15:55:06 <rdieter> (I could help, not sure how much time I'll have in the short-term, my plate is already pretty full)
15:55:29 * lupinix is quite busy as he has to finish his thesis in ~3 weeks
15:57:08 <rdieter> #action kde-sig (any help appreciated) to work on spin using breeze-gtk by default, and using kde-gtk-config (instead of current xsettings-kde/kcm-gtk combo)
15:57:22 <rdieter> our hour's almost up...
15:57:27 <rdieter> #topic open discussion
15:57:31 <rdieter> anything else for today ?
15:57:42 <dvratil> just two short reports
15:58:07 <dvratil> we had a couple of packages that had no owner (because we filed group::kde-sig as owner which does not work), it should be all fixed now (https://fedorahosted.org/rel-eng/ticket/6376). Let me know if you find any more KDE packages without an owner
15:58:09 <jreznik> there's still that xorg plasma breakage so we should be careful to test all updates hitting updates-testing
15:58:26 <rdieter> dvratil: ah, I'd noticed one today... umm... ah.  libkface
15:58:41 <dvratil> and second: I requested EPEL7 branches on all Frameworks and they were created; I need to submit phonon5 package for review (because RHEL already has KDE4 phonon packages which we can't change to have the Qt5 version too) and once done I'll start building 5.20 (maybe 5.21?) into EPEL. After that we can hopefully start looking into getting Plasma build for EPEL in a Copr repo.
15:59:05 <rdieter> \o/
15:59:18 <lupinix> dvratil++
15:59:18 <zodbot> lupinix: Karma for dvratil changed to 3 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:59:28 <dvratil> libkface was on the list
16:00:00 <rdieter> fwiw, I recall a fellow in #kde recently working on kf5/plasma5 for centos7, which I've been giving advice recently, I think luminoso
16:00:14 <rdieter> I've invited them to #fedora-kde
16:00:21 <heliocastro> Yes, good thing
16:00:32 <dvratil> ok, I'll ping him after the meeting
16:00:43 <rdieter> (hopefully I'm remembering the nick right)
16:01:24 <rdieter> dvratil++
16:01:26 <rdieter> thax
16:01:28 <rdieter> thanks even
16:02:01 <rdieter> well, time's up, and good meeting, thanks everyone!
16:02:06 <rdieter> #endmeeting