18:00:15 <mattdm> #startmeeting Council (2016-04-11)
18:00:15 <zodbot> Meeting started Mon Apr 11 18:00:15 2016 UTC.  The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:15 <zodbot> The meeting name has been set to 'council_(2016-04-11)'
18:00:17 <mattdm> #meetingname council
18:00:17 <zodbot> The meeting name has been set to 'council'
18:00:19 <mattdm> #chair mattdm jkurik jwb cwickert langdon decause robyduck tatica
18:00:19 <zodbot> Current chairs: cwickert decause jkurik jwb langdon mattdm robyduck tatica
18:00:21 <mattdm> #topic Introductions, Welcomes
18:00:25 <langdon> .hello langdon
18:00:26 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
18:00:31 <jwb> hi
18:00:32 <jkurik> .hello jkurik
18:00:34 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
18:00:42 <mattdm> .hello mattdm
18:00:43 <zodbot> mattdm: mattdm 'Matthew Miller' <mattdm@mattdm.org>
18:00:44 <decause> .hello decause
18:00:44 <robyduck> .fas robyduck
18:00:45 <zodbot> decause: decause 'Remy DeCausemaker' <decause@redhat.com>
18:00:48 <cwickert> .hello cwickert
18:00:48 <zodbot> robyduck: robyduck 'Robert Mayr' <robyduck@gmail.com>
18:00:51 <zodbot> cwickert: cwickert 'Christoph Wickert' <christoph.wickert@gmail.com>
18:01:23 <mattdm> whoo, good crowd today :)
18:02:23 <mattdm> well, let's get right to it...
18:02:40 <mattdm> #topic Initial FY17 budget meeting
18:02:47 * decause drumrolls
18:03:12 <mattdm> ideally, this wouldn't be "initial" -- the initial meeting really should have been in September
18:03:18 <mattdm> but we're getting a new process started
18:03:20 <mattdm> see
18:03:24 <mattdm> #link https://budget.fedoraproject.org/
18:03:30 <mattdm> #info new budget process site
18:03:48 <mattdm> we're currently at the "adjustment/allocation" stage
18:04:01 <mattdm> having gotten the community budget numbers from our sponsor
18:04:16 <mattdm> decause, you wanna take this?
18:04:27 <decause> mattdm: the big number, yeah?
18:04:31 <mattdm> yeah
18:04:43 <decause> #topic The Big Number
18:04:52 <mattdm> #link http://lists.fedoraproject.org/archives/list/council-discuss@lists.fedoraproject.org/message/TML72C4572A6FVK6UJDFCMUN56T4PKJ4/
18:05:04 <decause> #info The Big Number this year, is the same as last year, at $195,000
18:05:05 <mattdm> #info email from mattdm summarizing things from this morning
18:05:34 <decause> the difference this year, is how we discuss and prioritize making that number stretch
18:06:01 <mattdm> #info That covers events, swag, Fedora conferences, activity days, and any other community spending
18:06:20 <decause> *everything*
18:06:24 <mattdm> #info Does not include infrastructure, hardware, etc
18:06:42 <decause> meant to put one * on that 'everything' ;)
18:07:23 <decause> we should just take a moment to make sure everyone here has read mattdm's email to the council list today
18:07:29 * mattdm quiets up and lets decause talk
18:07:45 <mattdm> (although if anything was unclear, I can help explain)
18:07:45 <decause> as it condenses all the history into one succinct place
18:08:22 <decause> I've spent the past few weeks shaking the trees to get our regional information into one place, which mattdm has done a great job of compiling
18:08:31 <decause> our new budget site
18:08:40 <decause> #link http://budget.fedoraproject.org
18:09:10 <decause> is where we'll announce the regional allocations
18:09:29 <decause> as well as the central budget for Fedora events
18:10:27 <decause> Regions are still responsible for crunching/reporting their own numbers, but they have additional support now via the Community Blog and CommOps team to help publicize and socialize their events
18:10:40 <decause> as well as help with gathering some impact metrics for such activity
18:11:24 <decause> a place where we're gathering all the budget information is the new fedora-budget repository hosted on pagure
18:11:32 <decause> #link http://pagure.io/fedora-budget
18:12:23 <decause> by treating the budget process the same way we treat other infrastructure within fedora, and use the same tools to wrangle it, we can make it much easier to distribute the load of reporting
18:13:08 <decause> right now, there are directories for each fiscal year, and each region, but the data we have from year's past has not been fully committed to the repository
18:13:40 <decause> which is a "nice-to-have" for historical reasons, but not entirely necessary for today's talks
18:14:57 <decause> I'm going to be working with the delegates from each region to standardize on a reporting mechanism (spreadsheet) that we use on a quarterly basis to report on action and impact
18:15:08 <decause> and then updating budget.fp.o accordingly with the numbers
18:16:01 <decause> I am accountable for getting the numbers into "production" but regions are accountable for delivering their numbers to the repository
18:16:07 <jwb> i have a question
18:16:15 <decause> yes, now is a good time for questions
18:16:31 <jwb> why would you use a spreadsheet and then manually transfer data to the repo, instead of just taking pull requests to the repo?
18:17:19 <decause> preferably, all the data would come in as pull-requests; the same way we collaborate on other kinds of infrastructure
18:17:33 <decause> currently, the most common way budget has been reported is via spreadsheet
18:17:35 <cwickert> ?
18:18:07 <decause> I'm more interested in having a central place where all the data can be seen, and working out the standard way it is reported across regions
18:18:10 <decause> which we haven't tried before
18:18:12 <decause> cwickert:
18:18:27 <MarkDude> Standardizing regional things whilst we have special rules for India seems dubious at best. It sets the region in a non parity state, IMO. It'1 2016, can we still have "special rules for the brown folks in India?" (This is in context of parity of regions, reporting, making budgets, etc.)
18:18:41 <jwb> a spreadsheet -> repo method seems like a lot of manual work that is error prone
18:18:51 <cwickert> I wonder why there is this strong focus on tooling because I don't think we had a tooling problem in the past. AFAICS the problem was always manpower and I'm afraid with the different roles this will get worse.
18:18:55 <mattdm> MarkDude: hold that for a second plase
18:18:58 <MarkDude> And fed msg bus could help with at least parts of this. It's untapped to fully help us do things smoothly
18:19:11 <cwickert> But this is just a side-question and has nothing to do with the actual numbers
18:19:23 <MarkDude> No prob FPL :)
18:19:44 <decause> cwickert: the problem before has been cycles, agreed
18:20:18 <decause> the roles make sure that we know who is responsible for what
18:20:35 <cwickert> decause: did you manage to fill all vacant roles?
18:20:40 <decause> rather than all the ambassadors unofficially picking somone to carry the load of reporting expenses, we officially pick a person,a nd support them
18:20:41 <mattdm> the main problem with tooling I saw was having everything in one place. even with the wiki before, it's really inconsistant
18:21:45 <decause> cwickert: I have not gotten responses from all regions yet, no, but in light of there being actual numbers at stake, I expect an elevated level of attention and interest
18:22:37 <cwickert> decause: ok, let's see. ignore my question and let's move on to crunching numbers then
18:22:51 <decause> designating roles and having accountability is how we do #action items in meetings, and it is something I think will improve follow-through. we'll see how the experiment ends up :)
18:23:06 <decause> cwickert: nod nod nod
18:23:23 <decause> any other questions on process before we go forward with numbers?
18:23:30 <mattdm> tools are the easy part; figuring out what to do with limited budget is much harder :-/
18:23:36 <decause> mattdm: agreed.
18:24:16 <MarkDude> mattdm: +1
18:24:54 <decause> briefly, to markdude's question: The is no special policy for India. India is part of APAC, and their regional budget is what the scope of this meeting is about.
18:25:13 <decause> other questions?
18:25:14 <decause> going once
18:25:16 <decause> going twice
18:25:17 <decause> going thrice
18:25:28 <decause> #topic Crunching the Numbers
18:25:49 <decause> So, I think mattdm has characterized the crunch nicely in the update to council list
18:26:02 <decause> and I would add some flavor
18:26:57 <decause> keeping the budget at historical levels has been due to our ability to report on what we've spent, and how that expenditure creates value for the project.
18:27:05 <decause> we want to grow
18:27:09 <MarkDude> Process is same to join all parts of Fedora, minus rules for India. By definition special rules, tho Im dropping it due to not the time. Shutting up :)
18:27:12 <decause> and growing means growing pains
18:27:36 <decause> this year, we've already seen an increased demand for Fedora Events (FADs) that is up from historical levels
18:27:50 <decause> so, we're probably not going to have enough budget to do all the thigns we want to do
18:28:04 <decause> the important part to remember, is that a budget cycle is a full year
18:28:14 <decause> and if we want to impact the budget, it takes months to do it
18:28:36 <mattdm> (although note on FADs: it's not necessarily up hugely from earlier, just up from what the flat budget is based on, which leads to a dissonance)
18:28:38 <decause> so this year, is going to be all about getting our metrics and numbers square, so that we can tell the story *next* year for increasing and growing our budget
18:29:14 <mattdm> decause++
18:29:22 <cwickert> !
18:29:29 <decause> cwickert: you can just chime in ;)
18:29:38 <cwickert> We've always had this problem and the only way to improve is with proper reporting
18:29:45 <decause> 100% agreed
18:29:46 <decause> yes
18:29:49 <cprofitt> +1
18:29:54 <cwickert> that also means: We (at least in EMEA) requested more then we got
18:30:08 <cwickert> and at that point we just had to do a haircut
18:30:17 <cwickert> trim all events by x percent
18:30:25 <cwickert> and even skip some small ones
18:30:26 <MarkDude> If we dont spend the money in a cycle, we may get less. This is partly responsible for "budget issues" we had in another region years ago. Funding needs change. Based on many things. I did NOT want to do release parties for a while, partly due to the Distro being not too usable. Following consistency model I should have had events, so I can do them now?
18:31:02 <cwickert> I don't think this should be a problem, we just need to pay a little attention. But I'm all for making the FAds happen, even if this means spending less on other events
18:31:20 <cprofitt> spending money to ensure the ability to spend it in the future is a bad way of running the ship.
18:31:28 <robyduck> cwickert: +1
18:32:10 <cprofitt> +1 cwickert
18:32:27 <MarkDude> RH has the money, we made the product. Some regions choose not to do extra events due to monies. Things vary.
18:32:30 <MarkDude> cprofitt: +1
18:32:31 <decause> cwickert: and it is my hope that by improving the connection between ambassadors and commops, we don't ahve to leave event owners to do the reporting entirely on their own
18:33:14 <decause> cprofitt: yes, budget is odd in this way, here or in other places. What we have not done before is keeping track of the "hair" that we left on the floor after trimming
18:33:42 <mattdm> cprofitt: Agreed. We need to be able to show the impact of money spent.
18:33:49 <decause> if there is an event/opportunity that we are *not* taking, we should record that opportunity cost somewhere so that next year, when we propose the budget, we can make the case for increase.
18:34:08 <mattdm> MarkDude: Well, keep in mind that this is far from all of the money spent on Fedora
18:34:29 <MarkDude> False choice, we can do FADs AND local events. We can do more, and more importantly not lower our high standards in process. Having a 20% reserve is a decent way to allow for extras, yet still gauge.
18:34:54 <cprofitt> decause: yes, if we can track those 'not done' this year items that may come back that would be good. Budget is always a bit difficult... one idea I like is having a small percentage of the budget that is allocated towards 'initiatives' - spefically trying new things.
18:35:02 <cwickert> I think it comes down to: How can we make sure we make the FADs happen? I see two options: 1) allocate a good chunk of the budget and cut the regional events on the other hand. 2) use the regional budgets to sponsor FAD attendees. While 2 is more flexible, 1 is cleaner and will (hopefully) help us getting more money for FADs next year.
18:35:05 <MarkDude> Yes FPL. Ty for letting me speak here to bring these points up. I'll lurk now, and let you folks do your awesomeness. :)
18:35:36 <cprofitt> mattdm: yes, we need to show the imapct.
18:35:56 <cprofitt> +1 decause on recording opportunities missed.
18:36:01 <decause> MarkDude: increasing/reserves anything that is dealing with increasing the "big number" is out of scope for today's discussion. It is important that we have those conversations some where, but the time for adjustment has passed. We have to spend the numbers we have.
18:36:38 <cprofitt> decause++ budget page looks good.
18:36:41 <decause> cwickert: this is helpful
18:37:32 <mattdm> So... what are our next steps here?
18:37:43 <decause> mattdm: right
18:37:57 <mattdm> I'd _really_ like to see something like https://pagure.io/fedora-budget/raw/master/f/FY17/proposedannualbudgets/emea/FedoraEMEABudgetFY2017.ods from LATAM, NA, and APAC
18:38:52 <jwb> perhaps we can take the overall budget, allocate money for flock, FUDCons, and FADs, and then divide the remaining amount among the regions once we have the budgets from the regional coordianators?
18:38:54 <decause> I have a very simple task ahead: update the budget numbers here: https://budget.fedoraproject.org/#budgetnumbers
18:38:59 <jwb> er, coordinators
18:39:39 <cprofitt> mattdm: would you want that spreadsheet to containe impact data or just expenses?
18:39:40 <decause> jwb: that sounds about right, yes
18:39:49 <mattdm> cprofitt: awesome question :)
18:40:01 <decause> cprofitt: the "impact" data is part of the event reportin that we're going to track going forward
18:40:09 <cprofitt> jwb +1 that sounds like a good way to do it.
18:40:11 <mattdm> I was thinking maybe each thing have a link to an event page, which would contain that?
18:40:26 <mattdm> cprofitt: but if you have a better idea I'd love to hear it
18:40:47 <decause> I don't think we can "ex post facto" reporting standards onto last year, but we can do some archeology to dig that up for some events
18:40:55 <decause> mattdm: +1
18:41:08 <cprofitt> mattdm: hmm... I know that the BrickHack event we had attendee badges...
18:41:13 <mattdm> FWIW, the breakdown in the previous regional budgets (considering regional budgets alone) is about: 16% APAC, 26% EMEA, 16% LATAM, 42% NA
18:41:30 <decause> and going forward, the event reports, even if they are hosted on personal blogs, will be aggregated on the commblug
18:41:33 <decause> commblog
18:41:39 <decause> so that we have them all in one place later
18:41:54 <decause> and there are some bullet points that get addressed in each post
18:41:59 * decause digs up link for impact metrics:
18:42:02 <mattdm> cprofitt: fedora-badges badges? that's definitely useful, since we can do analytics on that later.
18:42:11 <jwb> mattdm: i'm not sure that breakdown holds any longer to be honest
18:42:15 <cprofitt> the event page would help with 'expected attendance', 'actual attendance'... but measuring impact might need to have multiple inputs. Different events like converting to Python 3 might have better metrics based on commits.
18:42:20 <decause> #link https://fedoraproject.org/wiki/Budget.next#Reimbursement
18:42:33 <mattdm> jwb Yeah, that's just the historical allocations
18:42:43 <mattdm> (also not including FUDCons/Flock)
18:42:48 <cprofitt> we likely need to take a closer look at all the possible sources of metrics based on event types... and help organizers of future events be aware that those tools exist.
18:42:58 <jwb> mattdm: i mention it because i think people need to be aware that historical allocations are not likely to match to this year's allocations
18:43:23 <decause> cprofitt: yes, we have a script that is a PoC on tracking fedmsg data in the fedora-stats-tools repo
18:43:49 <cprofitt> decause: yes, going back might not be worth the effort. Looking forward we just have to make sure we take a look at how to measure an event... ensure we give as much support to the person coordinating the event as possible.
18:44:15 <mattdm> cprofitt++
18:44:15 <zodbot> mattdm: Karma for cprofitt changed to 9 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:44:17 <decause> cprofitt: these are great discussions to have, and I'm def into it from the commops side of things for sure
18:44:29 <decause> falls squarely within "metrics" areas
18:44:49 <decause> jwb: yes, I think this is good to point out as well
18:44:51 <cprofitt> decause: yeah, likley a side conversation as it is a little bit of a birdwalk for this conversations main topic...
18:45:19 <decause> so, as a warning, I mentioned on the ambassador list that if we didn't have a proposed budget reported, that it would impact our ability to allocate budget for a region
18:45:22 <mattdm> Council members: I want to highlight what jwb said a few minutes ago. I agree and want to make sure no one _disagrees_....
18:45:42 <mattdm> That is: we won't use historical percentage as the baseline for regional allocation
18:45:52 <mattdm> (It _might_ end up like that, but it might not.)
18:46:04 <mattdm> Does anyone disagree with that?
18:46:13 <decause> +1 history does not dictate future necesarily
18:46:18 <cprofitt> mattdm: so we want people to agree upfront to the 'norm' for determining budget?
18:46:32 <cprofitt> I do not disagree mattdm
18:46:37 <mattdm> cprofitt: I'm not sure I understand that question....
18:47:02 <decause> cprofitt: we just want to be clear that this year's numbers will not necessarily be the same as last year's numbers per region
18:47:02 <cwickert> -1
18:47:03 <cprofitt> we want peole to agree with the method of allocating funds -- ahead of allocation..
18:47:22 <decause> cprofitt: hang back for a sec, this is a big question
18:47:34 <decause> cwickert: ?
18:47:34 <cprofitt> k
18:47:36 <jwb> cwickert: you disagree that historical budget allocation is not how we're going to allocate this year's budget?
18:47:45 <cwickert> I think historical allocations are the only thing we can actually rely on
18:48:02 <decause> meh
18:48:14 <cwickert> and if we don't, we will punish the regions who did good reporting in the past
18:48:21 <langdon> this paticular year? or future years?
18:48:27 <jwb> cwickert: i think doing so is not responsible.  the 42% allocation to NA seems excessive given the growth of the contributor bases in the other regions
18:49:19 <cwickert> jwb: good point, but I don't see how an increase in user base translates into numbers
18:49:21 <jkurik> if we do not use the historical allocations what will be the way how the budget is distributed ?
18:49:32 <decause> cwickert: contributor, not user
18:49:33 <langdon> so.. i definitely agree that this year might be weird.. but why wouldn't we use historical in future years?
18:49:56 <jwb> jkurik: perhaps we can look at the submitted budget and attempt to gauge impact of the events and activites
18:50:19 <cprofitt> We want to, as a group, agree on a method for determining funding. Keeping in mind that this may, or may not, reflect historical spending. The method of allocation is meant to maximize impact and regional spending may flucuate based on multiple factors. What I am having issues grasping is what the other method is.
18:50:28 <robyduck> we shoud at least keep history in mind when it comes to decide whether cut one or another region. Not relying totally on it, but neither forget it
18:50:40 <mattdm> robyduck: yeah, well put
18:50:41 <decause> Question have we ever had a standard "percentage" for each region?
18:50:45 <jwb> robyduck: yes that is certainly fair
18:50:49 <decause> I don't think we have
18:50:50 <mattdm> also cprofitt, well put :)
18:50:56 <jwb> decause: mattdm listed them above
18:51:03 <langdon> also .. what does "historical" mean here? do you mean "na always gets 42%" or do you mean "na spent 42% last year and had xyz growth, we shoudl give them more"?
18:51:14 <decause> jwb: for every year?
18:51:19 <mattdm> I was *just* looking at the nominal allocations
18:51:25 <mattdm> not even actual-spent money
18:51:35 <cprofitt> perhaps having a two part system.... part of the budget is historical, with a portion being allocated based on potential impact.
18:51:44 <jwb> decause: yes?
18:52:04 <decause> ok, good to know.
18:52:18 <cwickert> ok, let me rephrase what I wrote earlier: we need to give all regions a chance. They are to submit a budget, that's the process we always followed. but when we need to decide on the submitted budgets, then we need to have history in mind to see how realistic a request is. We had this 3 or 4 years with the APAC regions: They were very enthusiastic and requested a lot of money, but did not spend much in the end.
18:52:28 <jwb> look, the fact is that we've had a flat budget for the past 5 years but we've been doing more.  if we cannot sufficiently explain why that budget needs to go up, through both accurate _planning_ and accurate _reporting_, it won't go up
18:52:50 <decause> jwb: this is def the reality
18:52:52 <decause> yes
18:53:03 <cprofitt> example: 70% is allocated by historical and 30% is allocated by potential impact. I agree with cwickert that we need to ensure all regions know we are doing this and have a chance to get their reporting in place.
18:53:32 <robyduck> jwb++
18:53:32 <mattdm> cwickert: I can agree with that.
18:53:34 <jwb> cwickert: yeah.  unfortunately, enthusiasm does not trump actually doing things.
18:53:41 <langdon> cprofitt, that proposal does not account for "poor planning" ... aka asked for 10 spent 5
18:54:04 <decause> cwickert: I think you're trying to future-proof against the right things, yes
18:54:38 <cprofitt> langdon: it was meant to be a rough proposal. I agree we need to adjust based on actually spent money not proposed, but unspent.
18:55:01 <mattdm> I'm definitely suffering from lack of standarization of process in the past
18:55:21 <decause> mattdm: agreed. aggregating this history has been challenging
18:55:37 <cwickert> cprofitt: not sure if we can do a percentage, but more something along the lines: Let them request money, look at the requests when they come in and then say: "Ok, region X has a tendency to under-spend, so we cut their budget by 20%, while region Z does very good reporting and therefor we cut their budget by only 5%. That's what we did in FAmSCo all the years.
18:55:54 <cprofitt> mattdm: agreed we need to standardize and let everyone know what the process will be.
18:56:05 <cprofitt> cwickert: that works for me.
18:56:06 <cwickert> s/reporting/reporting+budgeting
18:56:35 <cprofitt> we can also work with regions that have had inconsistent reporting / planning and help them improve.
18:56:38 <cwickert> decause: we don't have numbers from the regions yet, right?
18:56:57 <mattdm> cwickert: yeah, by not following history, I don't mean throwing all that out.
18:56:59 <jwb> cwickert: i can agree with that somewhat.  my main point is that past allocation does not ensure future allocation.  it has to be somewhat results driven, based on whatever we consider "results" to be (e.g. perceived or actual impact, accuracy, etc)
18:57:04 <dzho> one sees in federal research grant funding decisions the use of proposals vetted by peer review, the results of which are consulted by ultimate decision makers. It involves a lot of poorly rewarded work by those doing the review, but I wonder if there's anything useful from that model?
18:57:11 <decause> cwickert: we have EMEA numbers, and some LATAM numbers, some rought NA numbers, but I need APAC numbers most
18:57:20 <cprofitt> +1 jwb
18:57:39 <mattdm> as far as know only EMEA and APAC have planned/actual budget numbers for FY15 and FY14
18:57:39 <cwickert> jwb: sure, we totally agree and I'm all for enabling new contributors in other regions because this is where we can grow
18:57:56 <jwb> dzho: i think that is essentially what we are proposing here, yes.  the peers in this case are the council and the regions
18:58:10 <cwickert> decause: we have two FAmSCo members in APAC, let me talk to them on Wednesday
18:58:19 <decause> cwickert: awesome, thank you
18:58:45 <decause> dzho: yes, what jwb said
18:58:57 * dzho nods, continues lurking
18:59:43 <decause> so, from what it looks like, we want the future allocations to be *informed* by historical percentages, but adjusted by results and ahereance to the process
19:00:00 <langdon> decause, and actuals
19:00:10 <mattdm> okay, so, here we are an hour in. We should be looking at next steps :)
19:00:21 <mattdm> I definitely think we should continue next Monday....
19:00:27 <cprofitt> decause: yes.
19:00:35 <jwb> step 1 was suggested.  which is basically, put in the values for flock, FADs, and fudcons
19:00:35 <cprofitt> +1 mattdm
19:00:36 <decause> mattdm: I believe we allocated an extra hour today
19:00:37 <mattdm> but we should be looking at concerete decisions at that point.
19:00:42 <decause> I did at least on fedocal last time
19:01:02 <mattdm> jwb: I did that in a spreadsheet right before the meeting, which I then failed to save properly :)
19:01:08 <jwb> decause: if you've imported the ical from fedocal, it does not update
19:01:26 <mattdm> An open question is whether we're going to put the proposed $17k into the APAC FAD
19:01:34 <decause> jwb: I think I only added it statically last week, which we cancelled, and then didn't double-blcok this week
19:01:37 <decause> that is my bad
19:01:48 <jwb> decause: er, update in whatever calendar you imported it to.  so i'm not sure anyone noticed if you changed it even if you did
19:02:02 <jwb> mattdm: i mean in the budget.fp.org site
19:02:06 <decause> jwb: I'll post those types of updates to the council-discuss next time too, just in case
19:02:15 <mattdm> jwb: oh, good call.
19:02:19 <jwb> people really love spreadsheets when they are just extra manual steps..
19:02:31 <decause> jwb: the formulas are nice
19:02:40 <decause> I prefer csv myself, it is portable and human readable
19:02:55 <mattdm> spreadsheets suck. however, they're really convenient to hack on without knowing what you're really doing :)
19:03:08 <decause> aspirationally, I'd love ot paint a picture of what budget reporting could be like :P
19:03:18 <langdon> i heard jwb propose creating a taiga card for autouploading
19:03:54 <nb> 17k for a FAD?
19:03:56 <jwb> the council doesn't use taiga.  it could though, and i'd probably be way happier than using trac
19:04:02 * nb thought they were generally 5k
19:04:06 <mattdm> nb: er, sorry. FUDCon
19:04:06 <nb> or are you talking about fudcon?
19:04:08 <nb> oh ok
19:04:18 <mattdm> which is also quite high
19:04:18 <decause> If we get more information from the regions as we go forward, I'm ok with adjusting, but I've given notice on the lists, and reached out individually too (as cwickert will also do this week with apac)
19:04:28 <mattdm> but basically what we approved for LATAM
19:05:05 <cwickert> 17k for a FAD?
19:05:10 <cwickert> where does this come from?
19:05:22 <mattdm> cwickert: from me mistyping "FUDCon" :)
19:05:23 <cwickert> ah, sorry, FUDCon
19:05:31 <cwickert> sorry, slow reading the backlog
19:06:41 <mattdm> decause: you wanna #action yourself for putting up a proposal on the budget.fpo page?
19:07:28 <decause> #action decause post a proposed budget scenario to council list, and upload the document (spreadsheet or otherwise) to the pagure.io repo
19:07:46 <mattdm> decause++
19:07:55 <decause> mattdm: what I need to know from council is the preferred contours of the scenario
19:07:58 <decause> i will crunch a few of them
19:08:12 <mattdm> decause yeah, I was just gonna say a few possibilities would be nice
19:08:18 <decause> but mostly I have to make 7 numbers happen:
19:08:23 <decause> the first one is done:
19:08:28 <decause> Total: 195,000
19:08:56 <decause> I think cwickert original observation about rolling the FUDCon funding into 'council' instead of 'each region' was a keen one
19:09:20 <MarkDude> +1
19:09:28 <cwickert> decause: actually, premiere events have always been handled globally
19:09:28 <decause> so I will take the proposed FUDCon and FLock (and pending FAD requests) and roll those into council
19:09:38 <nb> cwickert++
19:09:38 <zodbot> nb: Karma for cwickert changed to 7 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:10:03 <decause> i will follow up with OSAS to find out if we got dedicated OSAS funding for Outreachy
19:10:11 <decause> #action decause follow up with OSAS to find out if we got dedicated OSAS funding for Outreachy
19:10:16 <cwickert> decause: I think the first step is premiere events vs. regional budget and then we can further distribute the regional budget.
19:10:26 <mattdm> cwickert: yeah, except for in the FY14 budget email, where they were divvyed up to the regions even though then later handled centrally
19:10:27 <decause> otherwise, I'd like to request that we allocate one slot per quarter as one scenario
19:10:39 <decause> ideally 2 (tech and non-tech)
19:10:44 <decause> that'll be one scenario
19:10:59 <decause> but the overarching scenario, of the regional percentages
19:11:23 <decause> those should hold as a "base-line" then, but will not be 100% the same as history
19:11:28 <cwickert> and we could as well say: premiere events = council, regional budget = FAmSCo. That's what we did in the past. It wasn't perfect (for technical events in a region such as FADs), but it worked.
19:11:50 <robyduck> yup
19:11:52 <mattdm> I'd like to see regional planning FADs budgeted in, and as line items for the regions
19:12:26 <decause> #info regional budget planning FADs for each region, as part of the region's budget
19:12:27 <cwickert> mattdm: if we fly the design team to the US for a FAD, how is that regional?
19:12:40 <mattdm> there's some disparity in the docs on FADs about whether or not they regional events in general
19:12:48 <decause> FAD is a centrally organized, not regionally organized event
19:12:50 <cwickert> decause: I disagree with the #info
19:12:53 <cwickert> right
19:13:08 <mattdm> cwickert: but in what I meant above, I meant specifically region-focused planning FADs
19:13:10 <nb> so we all should have a regional planning FAD now?
19:13:19 <decause> cwickert: mattdm is talking about budte planning FADs, like what EMEA has been doing for years
19:13:31 <decause> s/budte/budget
19:13:36 * nb not opposed
19:13:47 <mattdm> nb I think it's a good model. It makes sense to colocate it with other events (Flock, FUDCons) when possible
19:13:51 <cwickert> mattdm, decause: that should be one FAD for each region, so easy to budget.
19:14:00 <nb> mattdm, yeah
19:14:03 <cwickert> s/budget/project
19:14:03 <decause> nb: yes, we should, so that there are *always* numbers for the council to consider in the future, unlike today ;)
19:14:21 <mattdm> cwickert: yeah, and that's why I was suggesting putting them as line items in the regions
19:14:29 <nb> decause, mattdm good idea
19:14:32 <nb> we did that a few years ago in NA
19:14:34 <cwickert> mattdm: makes sense
19:14:52 <nb> Blacksburg maybe, we had the FAD the day before fudcon, then more people got to stay for fudcon also
19:15:01 <decause> mattdm: standard $5K FAD limit?
19:15:03 <mattdm> nb exactly, yeah.
19:15:10 <cwickert> mattdm: note we might not even need a planing FAD in some regions if they have FLOCK or a FUDCon
19:15:10 <mattdm> decause: up in the air, I think
19:15:19 <cwickert> decause: yes, 5k should be ok everywhere
19:15:20 * mattdm squints at that bottom line
19:15:26 <decause> mattdm: agreed. I can try to crunch a high and low scenario then
19:15:34 * decause signs up for more work
19:15:37 <decause> :P
19:15:38 <mattdm> decause++
19:15:39 <nb> cwickert, true, depending on how many people get funded for flock/fudcon otherwise
19:15:52 * nb sees it more as "paying for more people to go to Flock, given that there is a planning session at flock"
19:15:54 <mattdm> cwickert: I'd rather say "we have the planning FAD at Flock/FUDCon"
19:15:54 <nb> or something like that
19:15:59 <nb> mattdm++
19:15:59 <zodbot> nb: Karma for mattdm changed to 12 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:16:01 <decause> the good news is, Flock planning has given their number at $75K this year
19:16:09 <cwickert> mattdm: that's what I meant
19:16:09 <decause> same as last year
19:16:18 <mattdm> cwickert: cool
19:16:27 <decause> so, that is a nice 'not-dotted-line' item
19:16:52 <jwb> that's an interesting way to put it :)
19:17:10 <cwickert> decause: prices are highter are EMEA and NA, but travel is more expensive in APAC and LATAM. So 5k for a planning FAD should do everywhere and if it is co-located with another event, we just skip it in the budget.
19:17:29 <robyduck> to avoid confusion, why don't we put those planning FAD events in the reginal budget and handle the other FADs globally? This way every region also can manage their budget better, doing the planing with other events like fudcon or flock.
19:17:42 <robyduck> just a thought
19:17:48 <jwb> cwickert: no... we show the that 5k was allocated to bring more people to Flock/FUDCon
19:17:53 <jwb> we don't "skip" things any more
19:17:56 <mattdm> robyduck: I think that's what we're saying
19:18:08 <decause> robyduck: yeah, what mattdm said
19:18:10 <nb> jwb++
19:18:10 <zodbot> nb: Karma for jwboyer changed to 9 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:18:13 <robyduck> we can name them differently
19:18:30 <robyduck> but that's a detail
19:18:33 <cwickert> jwb: ok, if you put it that way.
19:19:02 <decause> we're going to be settling on a standard format for reporting these things (my vote is based off the very decent EMEA sheet)
19:19:06 <mattdm> I am all for finding more ways to get involved, active people on the ground at Flock that don't involve them needing to give a talk
19:19:22 <decause> #link https://docs.google.com/spreadsheets/d/11nWHrooCwoiWqGx4iEUnITQAWwQrQ6_2ito8GUtBk_g/edit#gid=0
19:19:30 <nb> mattdm, i agree.  I mainly only submitted a talk so that I could hopefully get funding
19:19:35 <robyduck> mattdm: would be nice
19:19:47 * nb wnats to go to plan stuff for next year in NA
19:19:54 <mattdm> that's probably a conversation for another time, though :)
19:19:59 <decause> agreed
19:20:13 <decause> I'm going to be pushing my updates to the pagure.io/fedora-budget repo
19:20:20 <decause> they'll likely be spreadsheets/csv
19:20:28 <decause> unless jwb, you have a better suggestion?
19:20:45 * decause is *def* open to better ideas
19:21:07 <jwb> i suggested just updating the website with pull requests, but whatever works for the people actually doing this is what will work best
19:21:18 <mattdm> I saw whatever works, is consistent, and puts 'em all in the same place for later
19:21:30 <decause> jwb: the website does not get granular down to the proposed budget levels (yet)
19:21:52 <decause> standing up the entire 'fedora-websites' repo is a bit much to just twiddle a number
19:21:55 <decause> imho
19:22:25 <decause> jwb: but yeah, the future /could/ look like a webhook that updates the production site based on data in fedora-budget repo
19:22:28 <decause> ideal bridge
19:22:31 <decause> +1 jwb
19:22:39 * cwickert needs to run now, it's already late here. I will read the log later, but so far I'm happy with decause's approach.
19:23:03 <decause> cwickert: thank you for your support, and I'll be sure to add council to the pagure.io members with push/pull access
19:23:17 <mattdm> thanks cwickert!
19:23:20 <decause> doing budget with PR's is going to be *much* better than emailing spreadsheets
19:23:31 <cwickert> #action cwickert to discuss the budget with FAMSCo, in particular from APAC and LATAM
19:23:58 <cwickert> ok, bye
19:25:13 <nb> decause, we could always make it a separate repo
19:25:25 <decause> nb: http://pagure.io/fedora-budget
19:25:30 <decause> ok
19:25:31 <decause> so
19:25:40 * mattdm isn't technically leaving but is starting to have wandering-brain syndrome....
19:25:55 <decause> what were those percentages again? I can dig for them in the logs, but it'd be nice to have some consensus on what they are
19:26:18 <nb> decause, oh ok
19:26:36 <decause> nb: which, btw, there is a NA folder that could *totally* use some input ;)
19:26:41 <mattdm> decause the historical fraction?
19:26:42 <decause> nb++
19:26:46 <decause> mattdm: yes
19:26:55 * decause didn't know there was one before today
19:27:15 <mattdm> decause: roughly: APAC 16% EMEA 26% LATAM 16% NA 42%
19:27:28 <decause> I'll have a few scenarios for everyone to discuss next week
19:27:33 <mattdm> it's not a rule -- it's an extrapolation from FY14, FY15, FY16
19:27:56 <decause> mattdm: acknowleged, I think we all agreed that it is more of a 'guideline' than a rule
19:28:02 <decause> +1
19:28:17 <decause> next week we should still do a double block though, yeah?
19:28:35 <mattdm> decause: well, I think we shouldn't even consider it a guideline -- more, another input into the process
19:28:44 <mattdm> decause: yeah, I think double-book is good
19:28:55 <decause> #action decause schedule double-block council meeting for budgeting on fedocal
19:29:06 <langdon> literally dbl? or 2h?
19:29:14 <mattdm> 2h = dbl
19:29:29 <mattdm> or I guess we could also get #fedora-meeting-1 :)
19:29:33 <decause> #help Ambassadors please submit your Budget Reports, Proposals, and Delegation Selections to decause ASAP
19:30:10 <mattdm> #info where ASAP really means "this week, because we want to decide things next week, so we can actually spend money without fear"
19:30:39 <langdon> probably should info those fy16 allocations too, no?
19:31:17 <mattdm> langdon: maybe?
19:31:32 <decause> langdon: I don't think they are supposed to be 'concrete'
19:31:50 <langdon> decause, well.. they were for fy16, right?
19:32:21 <mattdm> more info doesn't hurt
19:32:24 <decause> langdon: I thought mattdm said they were conglomerated from history,not just last year
19:32:25 * mattdm composes an info
19:32:32 <langdon> ok
19:32:39 <decause> yeah, since mattdm crunched, he knows best
19:33:36 <mattdm> #info Allocation of regional portion of budget over last three years roughly APAC 16%, EMEA 26%, LATAM 16%, NA 42%. This is nominal, not money actually spent. FY17 and future budgets not necessarily based on this number.
19:33:42 <decause> mattdm: since I'm going to be travelling on Thursday, and attending all-weekend events, the sooner the better. I'd like to have the scenarios posted by Wednesday in an ideal world
19:33:57 <decause> mattdm++
19:34:38 <mattdm> decause: hopefully that can happen :)
19:35:29 <decause> mattdm: :)
19:35:35 <decause> ok
19:35:45 <decause> I think we're all in a good place here?
19:36:00 <jwb> yes
19:36:04 <mattdm> Good enough. Planning to be in a great place this time next year.
19:36:09 <mattdm> Thanks, everyone!
19:36:27 <mattdm> (esp. decause who did the bulk of the typing!)
19:36:30 <mattdm> #endmeeting