14:01:17 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:01:17 <zodbot> Meeting started Mon Jun 13 14:01:17 2016 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:17 <zodbot> The meeting name has been set to 'docs_project_meeting_-_agenda:_https://fedoraproject.org/wiki/docs_project_meetings'
14:01:17 <randomuser> #meetingname Fedora Docs
14:01:17 <randomuser> #topic Roll Call
14:01:17 <zodbot> The meeting name has been set to 'fedora_docs'
14:01:47 <c0mrad3> .hello dhanvi
14:01:49 <zodbot> c0mrad3: dhanvi 'Tummala Dhanvi' <dhanvicse@gmail.com>
14:01:54 * c0mrad3 waves to randomuser
14:02:20 <randomuser> hey c0mrad3 !
14:02:54 <terminal__> hey :_
14:02:58 <terminal__> :)
14:03:26 <randomuser> hello terminal__
14:03:41 <c0mrad3> randomuser: the package is almost done except the tests are failing in f24 and rawhide !
14:03:48 <terminal__> how's it going Pete
14:03:50 <c0mrad3> hello terminal__
14:03:55 <randomuser> c0mrad3, cool, we'll check in with you on that momentarily
14:04:00 <terminal__> hey c0mrad3
14:04:11 <randomuser> it's monday, and i'm on the first cup of coffee... too soon to say, terminal__
14:04:32 <terminal__> haha
14:04:35 <terminal__> fair call
14:05:28 <bexelbie> .hello bex
14:05:29 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
14:05:48 <randomuser> #topic Follow up on last week's action items
14:06:01 <randomuser> #link https://meetbot.fedoraproject.org/teams/fedora_docs/fedora_docs.2016-06-06-14.05.html
14:06:12 <randomuser> we had one action item, creating a package.  I did that.
14:06:36 <randomuser> I learned to use `git archive`, because pagure doesn't create tarballs on the fly like cgit does
14:07:24 <randomuser> #topic Publishing
14:07:42 <randomuser> c0mrad3, this is your stuff, can you fill us in?
14:08:22 <c0mrad3> randomuser: you meant GSoC ?
14:08:32 <c0mrad3> or some one else ?
14:08:37 <randomuser> c0mrad3, yes, you are doing work on the Docs publishing tools as part of GSoC.
14:09:02 <randomuser> but that's not exclusively a GSoC effort, it is a thing our community is working on
14:09:05 <c0mrad3> yes randomuser cool
14:09:42 <c0mrad3> I was thinking you mistakenly mentioned my name, no worries
14:10:19 <randomuser> nope
14:10:58 <randomuser> ... you mentioned a package failing tests?
14:11:05 <randomuser> maybe we could start there
14:11:11 <c0mrad3> So basically the newer tools chain requires mainly 3 packages and a continuous integration to be in palace and later we will do other stuff like pulling new words to zanata
14:11:28 <c0mrad3> pintail is packaged by randomuser https://copr.fedorainfracloud.org/coprs/immanetize/pintail/
14:11:31 <c0mrad3> #link https://copr.fedorainfracloud.org/coprs/immanetize/pintail/
14:11:53 <randomuser> the link happens automatically, fwiw
14:12:06 <c0mrad3> I am working on packaging other two packages
14:12:13 <c0mrad3> #link https://copr.fedorainfracloud.org/coprs/dhanvi/pintail-asciidoc/
14:12:20 <c0mrad3> #link https://copr.fedorainfracloud.org/coprs/dhanvi/asciidoctor-mallard/
14:12:52 <c0mrad3> so I am stuck with some tests failing when packaging in f24 and rawhide
14:12:56 * randomuser looks
14:13:18 * c0mrad3 will keep the info about link in mind
14:13:19 <randomuser> c0mrad3, do you know how to fix them?
14:14:18 <c0mrad3> randomuser: not exactly I thought it was issue with copr and asked in #fedora-buildsys but they suggested to ask me in #fedora-devel
14:14:44 <randomuser> yeah, it looks like a build problem to me
14:14:56 <randomuser> did you get help in #fedora-devel?
14:15:26 <c0mrad3> no not exactly but I can say the issue is only with the test and remaining works fine
14:15:30 <c0mrad3> https://copr.fedorainfracloud.org/coprs/dhanvi/pintail-asciidoc/build/340350/
14:16:06 <c0mrad3> without the test the build is successful on wherever the pintail is packaged
14:16:21 <randomuser> https://copr.fedorainfracloud.org/coprs/immanetize/pintail/
14:16:54 <randomuser> I see a very direct correlation between the builds that succeeded and the chroots where one of your BuildRequires, pintail, is available
14:17:17 <c0mrad3> also I tried installing manually on rawhide and it works prefectly!
14:17:44 <c0mrad3> so need to figure out where I am going wrong
14:18:29 <c0mrad3> as soon as the build is sucessfully I will submit a request for review of package and get started with CI
14:18:39 <randomuser> https://copr-be.cloud.fedoraproject.org/results/dhanvi/pintail-asciidoc/fedora-23-i386/00340350-python-pintail-asciidoc/root.log.gz is complaining that the pintail repo that would provide it is not available
14:18:48 <randomuser> does this help, c0mrad3 ?
14:19:33 <randomuser> DEBUG util.py:417:  Error: No Package found for pintail
14:20:09 <c0mrad3> randomuser: that's because you didn't package pintail for i386
14:20:15 <randomuser> correct
14:20:21 <randomuser> do you think I should?
14:21:08 <c0mrad3> well ya even though no one uses i386 now a days but doing it won't harm us :)
14:21:29 <randomuser> ok then, i'll make a new build with i686
14:21:50 <randomuser> I am *not* going to build for EPEL at this time, or ppc
14:22:02 <randomuser> so you should remove those chroots from your copr project
14:22:37 <c0mrad3> well I have done that already https://copr.fedorainfracloud.org/coprs/dhanvi/pintail-asciidoc/
14:22:40 <randomuser> #info new packages are not currently being built for epel because it is more work, please say something if you need that
14:23:37 <randomuser> c0mrad3, feel free to reach out to me or #fedora-devel when you run into these things, it's usually easy to pick out the problem if one is versed in the topic
14:23:39 <c0mrad3> randomuser: I think we might need to package for epel7 in case we need server or we could ask infra team for a fedora server for ci
14:24:00 <c0mrad3> sure randomuser
14:24:32 <randomuser> c0mrad3, there's another GSoC student working on CI integration for pagure, can you find out what distribution it is running on?
14:25:08 <randomuser> #link https://farhaanbukhsh.wordpress.com/2016/06/02/pagure-ci/
14:25:31 <c0mrad3> #action c0mrad3 has to find out about other GSoC student work environment
14:25:59 <c0mrad3> randomuser: he is a friend of mine so it won't be a problem
14:26:46 <randomuser> cool.  That's most likely where we'll be running our CI functionality
14:27:22 <randomuser> any other thoughts on publishing topics?
14:28:06 <c0mrad3> randomuser: zach also told it's fine if we have it fedora server
14:28:31 <c0mrad3> randomuser: !
14:29:01 <randomuser> it's a process under heavy development, c0mrad3, don't get too attached to implementation details of work we haven't started or fully planned
14:29:55 <c0mrad3> randomuser: ack
14:29:59 <randomuser> implementing a CI system is different from building a CI system, and I'd rather only do one if we can save the work
14:30:54 <randomuser> #topic Release Notes
14:31:04 <randomuser> #info randomuser built relnotes rpm
14:31:44 <randomuser> we're getting some great feedback from translators, which drives home that I really should have started pushing POTs sooner
14:32:20 <randomuser> otherwise, we're mostly done
14:32:57 <randomuser> #action randomuser to build 'prerelease' fedora-release-notes rpm for f25
14:33:19 <randomuser> #action randomuser to clear master branch of release-notes repo
14:33:46 <randomuser> so we're down to last minute changes and additions, maybe not a lot to talk about
14:33:54 <randomuser> anyone have thoughts on release notes to share?
14:36:09 <randomuser> ok then
14:36:15 <randomuser> #topic Guide Status
14:37:19 <randomuser> so, anyone planning to work on a guide ?
14:37:42 <Capesteve> SysAdmin and Networking Guide can be published as is, I was planing to update some text references to guides with links using the redirects
14:37:59 <randomuser> oh right, I was going to fix your redirects
14:37:59 <Capesteve> can do that tonight if there is still time
14:38:09 <randomuser> the figurative 'your'
14:38:56 <randomuser> I have them prepared but slacked off when it came to sending an email for approval to break the infrastructure freeze, sorry Capesteve
14:39:02 <randomuser> I'll do that today probably
14:39:14 <randomuser> #action randomuser to update docs.fp.o redirects
14:40:07 <randomuser> and perhaps I'll gently bring up the idea of using a .htaccess
14:40:28 <Capesteve> what is current target date for publsing?
14:41:05 * randomuser shrugs
14:41:21 <Capesteve> Ok, so minor fixes can still carry on
14:41:33 <randomuser> soonest?  I don't know that we're deliberately holding back things for a certain date
14:41:53 <randomuser> yeah, and we can publish again if there are more minor fixes
14:42:11 <Capesteve> can you also republish f23?
14:42:25 * c0mrad3 brb
14:42:46 <Capesteve> not sure how mush work that is for you randomuser
14:43:17 <Capesteve> ................much
14:43:25 <randomuser> Capesteve, not a huge amount
14:43:53 <randomuser> i don't especially enjoy it, but that shouldn't hold anyone else up
14:44:08 <Capesteve> Ok, then I will see that you are suitably rewarded if you do f23 and f24
14:44:17 <randomuser> :)
14:45:15 <randomuser> Capesteve, refresh sysadmin and networking for f23, and publish both for f24 then?
14:46:35 <Capesteve> err, f23,  sysadmin and networking are ready for republishing, I will do the links for f24 tonight, then they are ready too
14:46:47 <randomuser> ok
14:47:00 <randomuser> #action randomuser to publish f23 sysadmin and networking guides
14:47:13 <Capesteve> ta
14:47:36 <randomuser> what's next, hm
14:47:56 <randomuser> #topic Outstanding BZ Tickets
14:48:04 <randomuser> #link http://tinyurl.com/lbrq84
14:48:42 <randomuser> c0mrad3, if you're still around, we can do a GSoC topic if you want to talk about your overall experience, vs the technical things you're working on that we already covered
14:49:42 <randomuser> until then... there are bugs
14:50:20 <randomuser> and I did have some idle thoughts about pagure issues the other day; there's a feature that allows you to use tags to prioritize issues
14:50:43 <randomuser> it seems useful to do that for things about to go eol, or things about to get released
14:52:21 <randomuser> ok then
14:52:25 <randomuser> #topic Open Floor
14:52:30 <randomuser> speak your mind, folks
14:53:26 <terminal__> personally not sure what to work on, sys admin guide was already sorted by the looks
14:54:12 <randomuser> hmm.. we should brainstorm later then
14:54:36 <terminal__> yeah sure
14:55:50 <Capesteve> terminal__: what interests you?
14:56:05 <Capesteve> always easier to do things that you are interested in
14:56:18 <Capesteve> or have knowledge of already I suppose
14:57:39 <randomuser> yes, that
14:57:49 <terminal__> I enjoy configuring and setting up daemons/services, I am currently administering proxy servers and scripting monitoring solutions for them at work. I've completed the LSF101.1x course, I'm quite happy to work on anything really,
14:58:23 <randomuser> hey, we don't have much on monitoring
14:58:31 <Capesteve> there is a bug asking how to do a yum update via a proxy
14:58:52 <Capesteve> not sure how important that is to the average Fedora user
14:59:30 <terminal__> I know how to get yum/dnf to use a proxy, I've done it plenty of times lol
14:59:46 <randomuser> win!
14:59:56 <randomuser> okay, we're out of time
15:00:05 <randomuser> thanks for attending all, see you around
15:00:08 <randomuser> #endmeeting