14:04:25 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:04:25 <zodbot> Meeting started Mon Jun 20 14:04:25 2016 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:04:25 <zodbot> The meeting name has been set to 'docs_project_meeting_-_agenda:_https://fedoraproject.org/wiki/docs_project_meetings'
14:04:27 <randomuser> #meetingname Fedora Docs
14:04:27 <zodbot> The meeting name has been set to 'fedora_docs'
14:04:28 <randomuser> #topic Roll Call
14:04:33 * randomuser unplugs zodbot and plugs it back in
14:04:44 <c0mrad3> .hello dhanvi
14:04:45 <zodbot> c0mrad3: dhanvi 'Tummala Dhanvi' <dhanvicse@gmail.com>
14:04:51 * c0mrad3 waves to randomuser
14:04:58 <randomuser> hello, c0mrad3
14:05:11 <c0mrad3> hello randomuser :)
14:05:39 <terminal__> Hi
14:06:42 * pbokoc 
14:08:53 <randomuser> hello also to terminal__ and pbokoc
14:09:02 <randomuser> #chair pbokoc
14:09:02 <zodbot> Current chairs: pbokoc randomuser
14:09:52 <randomuser> #topic Action Item review
14:10:09 <randomuser> mine are getting carried over
14:10:27 <randomuser> c0mrad3, you have a note "find out about other GSoC student work environment" ?
14:10:45 <randomuser> #action randomuser to build 'prerelease' fedora-release-notes rpm for f25
14:10:53 <randomuser> #action randomuser to clear master branch of release-notes repo
14:11:02 <randomuser> #action randomuser to update docs.fp.o redirects
14:11:12 <randomuser> #action randomuser to publish f23 sysadmin and networking guides
14:11:50 <pbokoc> install guide should be ready today - right, cspicer? :)
14:12:06 <cspicer> yep! just trying to push final changes now :)
14:12:11 <randomuser> niiice
14:12:14 <randomuser> cspicer++
14:12:14 <zodbot> randomuser: Karma for cspicer changed to 1 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:12:36 <c0mrad3> randomuser: yes I did and find out that pagure has to support hooks for doing CI for PR(which he is working on) but we can do continuous deployment easily, will start working on about the same after talking with zoglesby this week
14:13:10 <randomuser> ok, we'll talk more about that in a later topic, thanks c0mrad3
14:13:19 <randomuser> #topic Release Notes
14:14:02 <randomuser> Release Notes are mostly wrapped up at this point, anyone have discussion items for it?
14:14:23 <randomuser> oh, i need to publish
14:14:29 <randomuser> #action randomuser to publish release notes
14:15:58 <randomuser> no clamoring for discussion here, so...
14:16:03 <randomuser> #topic Publishing
14:16:30 <randomuser> okay c0mrad3, tell us us how pagure's CI hooks work and how you will use them
14:18:37 <randomuser> morning, gregdek
14:18:39 <randomuser> ahem
14:18:44 <randomuser> grundblom :)
14:18:51 * grundblom waves sorry I am late
14:18:54 <randomuser> did we lose c0mrad3 ?
14:18:55 <c0mrad3> randomuser: pagure has to set a new hook every time a new pr is created then we can use that hook to ask buildbot / jenkins to verify the pr is okay or the new build fails
14:19:27 <gregdek> randomuser good morning! Even though I'm not the droid you're looking for.
14:19:31 <randomuser> c0mrad3, what does a hook mean in this context? a POST to a restful API call?
14:19:42 * randomuser turns gregdek off and back on
14:19:49 <randomuser> droids getting attitudes...
14:19:57 <gregdek> bleep bloop
14:20:16 <c0mrad3> randomuser: yes similar, ie pagure should send a message when a new pr is created
14:20:30 <randomuser> specifically what kind of message
14:20:50 <c0mrad3> #link https://pagure.io/pagure/pull-request/1030
14:21:37 <c0mrad3> randomuser: message so that the build bot can build again and see if the build is successful or not
14:21:47 <randomuser> I guess we should both read up to find out what constitutes a 'hook' for pagure
14:22:01 <randomuser> I understand what it's purpose is, i'm asking how you intend to implement it
14:22:42 <randomuser> or, if, i suppose
14:22:53 <c0mrad3> implementation is being done by farhan in this pr https://pagure.io/pagure/pull-request/1030
14:23:07 <randomuser> i see that
14:23:36 <c0mrad3> I just need to do the set up the repos and the build bot
14:24:07 <randomuser> ok, can you talk a bit about the plan for that?
14:24:57 <c0mrad3> no I need to talk with zoglesby about the same and how we can implement it
14:26:00 <randomuser> this meeting time would also be a good time to discuss how you'd implement it
14:26:21 <randomuser> but if you're not ready, we can move on
14:26:43 <c0mrad3> I am not yet ready and I need little bit more time
14:27:39 * randomuser nods
14:28:08 * c0mrad3 will have more for sure for the next meeting
14:28:10 <randomuser> it looks like the hook in this fork is POSTing a json object to a jenkins instance over https
14:28:50 * randomuser has no personal progress to report on publishing tools today
14:29:03 <randomuser> #topic Guide Status
14:29:26 <randomuser> #action randomuser to publish f24 install guide when cspicer is ready
14:30:04 <randomuser> also whatever Capesteve said was ready, i didn't do it right away so now I'll have to check logs and stuff :/
14:31:48 <randomuser> are we enjoying pagure for guides so far?
14:32:08 <randomuser> any comments about guides at all?
14:32:47 <grundblom> randomuser, I am behind and not sure what pagure does / benifits us / etc
14:32:59 <grundblom> Could someone point me to somewhere where I can catch up on it?
14:33:21 <terminal__> Still yet to start that yum via proxy stuff for the sysadmin guide, in the process of moving house so been a bit hectic
14:33:55 <randomuser> grundblom, it gives us a forum for discussing work in progress, managing pull requests, issues, etc
14:34:19 <terminal__> Also saw immanetize had assigned it to themselves
14:34:27 <randomuser> hmm?
14:34:44 <randomuser> terminal__, feel free to take it
14:34:57 <terminal__> Ahh that's you haha
14:35:02 <grundblom> ah, more of a integration of discussion and git repo?
14:35:31 <randomuser> right; it makes the branch/fork process easier
14:36:48 <randomuser> discussion in PRs and on individual lines of files was especially cool
14:37:11 <randomuser> #topic GSoC Updates
14:37:31 <terminal__> I think steve said the networking guide was ready randomuser, but i could be wrong
14:38:06 <randomuser> c0mrad3, we talked about publishing tools already, but do you want to say anything in general about your GSoC experience, or other things you're working on for your internship?
14:38:25 <randomuser> terminal__, I think you're right, yeah.  I'll sync up with him.
14:41:29 <randomuser> hm
14:41:38 <randomuser> #topic Outstanding BZ tickets
14:41:45 <randomuser> #link http://tinyurl.com/lbrq84
14:42:38 <randomuser> yup, there's bugs
14:42:56 <randomuser> at some point, we should move all our bugs to pagure issues
14:43:23 <randomuser> and see about disposing of the 'Fedora Documentation' bz product
14:44:55 <randomuser> #topic Open Floor Discussion
14:45:20 <randomuser> well this is going quickly
14:45:37 <randomuser> nothing else on your mind, folks?
14:45:47 <grundblom> With 24 so close to release, is the release notes pretty much closed up?
14:46:07 <randomuser> I wouldn't say that
14:46:49 <randomuser> it might be too late to get edits in the ISO RPM but we can update the website and rpm at any time
14:47:28 <grundblom> Could you tell me what RPM stands for?
14:47:46 <pingou> RPM package manager
14:48:05 <randomuser> ha, i actually did not know
14:48:18 <randomuser> recursive acronyms ftw!
14:48:45 <terminal__> Will there be issues with moving from bz to pagure due to bz being the universally accepted big tracker? Will we have to keep it round for legacy
14:48:56 <terminal__> bug*
14:49:36 <randomuser> terminal__, bugzilla is arguably more thoroughly supported, that's true
14:49:41 <grundblom> oh rpm as in the package manager? I thought it meant something different in this context
14:49:50 <grundblom> Sorry about my density
14:50:11 <terminal__> Or don't many Fedora users generally log docs bugs?
14:50:47 <randomuser> it seems relatively rare, but I don't know how that compares
14:50:56 <terminal__> Is it more the docs team than general users and they won't notice
14:51:20 <randomuser> it makes sense to me for us to put the issues close to the sources
14:51:30 <terminal__> I agree
14:52:37 <terminal__> Just if general Fedora users want to log a bug on it, they'll have to be made aware i guess
14:53:07 <terminal__> Maybe a link/redirect
14:53:22 <terminal__> I imagine it will be a while coming
14:53:31 <terminal__> There's tons to move
14:53:53 <terminal__> Possibly some fixed/redundant
14:54:25 <randomuser> there is purportedly - and I say it that way because I'm not sure how the implementation works - a way that pintail, the new thing we want to build the site with, can build a link to the source pagure project of the relevant doc in the built html
14:54:58 <randomuser> so, user reads a thing, finds a problem or concern, link at bottom of page takes you directly to somewhere actionable
14:55:11 <terminal__> Ah cool
14:57:07 <terminal__> Do we have a process for moving stuff from bz to pagure?
14:57:40 <randomuser> we're just now at the point in the process where I've proposed the idea for discussion
14:58:24 <grundblom> got to go, have a great day everyone
14:58:53 <randomuser> it is about that time
14:59:03 <randomuser> thanks for coming, everyone
14:59:07 <terminal__> Yep, but it's been on the cards since we began using pagure i feel, i'd be happy to help is kinda what i am saying
14:59:29 <randomuser> terminal__, cool - want to take the lead on it, then?
14:59:40 <terminal__> Sure
15:00:05 <randomuser> #action terminal__ to start planning for bz->pagure move
15:00:10 <randomuser> #endmeeting