06:00:40 <pravins> #startmeeting g11n
06:00:40 <zodbot> Meeting started Wed Jun 29 06:00:40 2016 UTC.  The chair is pravins. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:00:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
06:00:40 <zodbot> The meeting name has been set to 'g11n'
06:00:40 <pravins> #meetingname g11n
06:00:40 <zodbot> The meeting name has been set to 'g11n'
06:00:40 <pravins> #topic agenda and roll call
06:00:40 <pravins> #info  Fedora 25 planning
06:00:47 <mfabian> Hi!
06:00:47 <suanand> hi
06:00:52 <pravins> who else available here? :)
06:00:58 <pravins> hi mfabian suanand :)
06:01:01 <pravins> #chair suanand mfabian
06:01:01 <zodbot> Current chairs: mfabian pravins suanand
06:01:01 <epico> hi
06:01:05 <pravins> hi epico :)
06:01:07 <pravins> #chair epico
06:01:07 <zodbot> Current chairs: epico mfabian pravins suanand
06:01:08 <paragan> hi
06:01:30 <pravins> hi paragan :)
06:01:33 <pravins> #chair paragan
06:01:34 <zodbot> Current chairs: epico mfabian paragan pravins suanand
06:01:51 <juhp> hi
06:02:08 <pravins> hi juhp :)
06:02:11 <pravins> #chair juhp
06:02:11 <zodbot> Current chairs: epico juhp mfabian paragan pravins suanand
06:02:14 <aeng> hi
06:02:15 <pravins> ok, lets start
06:02:20 <pravins> hi aeng :)
06:02:29 <pravins> #topic Upcoming schedule
06:02:29 <pravins> #info 2016-07-05   Change Checkpoint: Proposal submission deadline (System Wide Changes)
06:02:29 <pravins> #info 2016-07-26   Branch Fedora 25 from Rawhide (Rawhide becomes future F26)
06:02:39 <pravins> So it like next Tuesday.
06:02:59 <pravins> so, we should do bit hurry
06:03:10 <pravins> #topic #64: Fedora 25 i18n planning
06:03:10 <pravins> #link https://fedorahosted.org/i18n/ticket/64
06:03:48 <pravins> from last meeting, lets see our planned changes
06:03:52 <pravins> System-wide
06:03:54 <pravins> 1. Unicode 9.0
06:04:11 <pravins> mfabian: if you need help i can create Change proposal for this. :)
06:04:26 <mfabian> That would be nice, I am working on the update at the moment.
06:04:43 <pravins> great.
06:04:54 <pravins> #action pravins to create change proposal for Unicode 9.0
06:05:14 <pravins> 2. CLDR sync with Glibc locales (tentative)
06:05:24 <pravins> Are we planning to propose it this time?
06:05:42 <pravins> from last year experience, i think good to propose and if require we can push it for F26.
06:05:44 <mfabian> I am not sure yet how much is possible there.
06:06:11 <pravins> its definitely tricky one, since lots of upstream dependency.
06:06:15 <mfabian> Something is surely possible but I wonder how much. Collation will probably be too difficult.
06:06:26 <juhp> when is the Change freeze?
06:06:36 <pravins> 05th July
06:07:06 <pravins> mfabian: we need to do it stepwise. May be first only localedata few field.
06:07:14 <pravins> then gradually we can move to collation.
06:07:22 <juhp> 26 July!
06:07:27 <juhp> sounds unlikely to me
06:07:51 <aeng> 26 july?
06:07:56 <juhp> also when rawhide branches
06:07:57 <aeng> wohoooo...
06:08:05 <pravins> https://fedoraproject.org/wiki/Releases/25/Schedule
06:08:32 <pravins> aha, you mean completion deadline. True
06:08:36 <juhp> 2016-07-26 	Branch Fedora 25 from Rawhide (Rawhide becomes future F26); Change Checkpoint: Completion deadline (testable)
06:08:50 <paragan> This is a quick release
06:08:59 <paragan> we follow 7-5 months release schedule
06:09:00 <pravins> +1 for system-wide its important to be there before Alpha
06:09:09 <juhp> Alpha is right after flock!
06:09:28 <paragan> that is the reason there is no mass rebuilds
06:09:40 <juhp> the schedule seems very aggressive this time
06:09:49 <pravins> i just wonder why Change completion date is so early, before Alpha freeze. Might be i have not noticed it early.
06:09:53 <juhp> paragan, yeah cos no time lol
06:10:09 <aeng> maybe to make up the delay for fed24
06:10:16 <pravins> 2 weeks in between.
06:10:18 <juhp> to squeeze in F26?
06:10:25 <epico> paragan: 7 month for big changes, and 5 month for more stable release?
06:10:38 <juhp> was the announced?
06:10:41 <juhp> that
06:10:42 <pravins> jkurik not around today :)
06:10:43 <paragan> not exactly
06:11:09 <juhp> anyway there will probably be a little slip - but should be in good time for Xmas
06:11:11 <paragan> epico, its to accommodate conference schedules, Public Holidays specially US holidays
06:11:20 <juhp> okay
06:11:54 <pravins> agree with juhp, CLDR will definitely take more time than this.
06:12:16 <epico> paragan: ah, first time to know 7-5 months release schedule.
06:13:10 <juhp> ah okay F23 was released 2015-11-03
06:13:19 <juhp> epico, seems you're kind of right
06:13:40 <epico> :)
06:13:42 <pravins> so mfabian will drop plan for CLDR this time?
06:13:48 <juhp> I heard it discussed but didn't know it was real
06:13:59 <juhp> good to start though :)
06:14:19 <mfabian> pravins: Yes, I think that is not possible until F26. Of course I’ll start working on it.
06:14:25 <pravins> yeah, definitely good to start. Glibc upstream even patch review sometime take lot time ;)
06:14:29 <pravins> perfect.
06:14:58 <pravins> #agreed dropping plan for CLDR sync with glibc for F25.
06:15:24 <pravins> #idea 3. Centralization of Hunspell (tentative)
06:16:19 <pravins> I feel 1.0 release is definitely possible, but there are many stakeholders for this project
06:16:24 <pravins> anish is not around today
06:16:28 <pravins> lets see if he can make it.
06:16:42 <pravins> #action pravins to ping Anish for Hunspell project
06:17:01 <paragan> right F23 to F24 release there is 7 months gap
06:17:14 <pravins> this is due to slip as well.
06:17:26 <pravins> We had longest release in Fedora. Fedora 21
06:17:28 <paragan> I remember somewhere Mattdm saying to have 8-4 months release cycles
06:17:31 <pravins> it took almost year
06:17:52 <pravins> https://fedoraproject.org/wiki/Releases/21/Schedule
06:18:13 <paragan> If I look at https://fedoraproject.org/wiki/Releases/25/Schedule, it looks like its 5 months release
06:18:56 <pravins> #info Fedora 24 took 7month to release, F25 release plan is 5month as of now.
06:19:11 <pravins> moving to next category
06:19:22 <pravins> #idea 4. Multilingual ibus typing booster
06:19:26 <pravins> again mfabian here :)
06:19:44 <pravins> mfabian: planning to create change page for this?
06:19:59 <fujiwarat> hi
06:20:04 <pravins> hi fujiwarat :)
06:20:07 <pravins> #chair aeng fujiwarat
06:20:07 <zodbot> Current chairs: aeng epico fujiwarat juhp mfabian paragan pravins suanand
06:20:20 <pravins> #idea 5. String breakage monitoring script
06:20:26 <mfabian> pravins: Is a change page necessesary/useful if the change does not affect anything else but ibus-typing-booster?
06:20:55 <mfabian> pravins: Maybe to advertise the change ...
06:20:56 <pravins> from my perspective i am looking for this change more from creating awareness to our users.
06:20:59 <pravins> right
06:21:11 <pravins> since, it came to late Fedora 24 release, we not able to give much attention
06:21:32 <pravins> same time, i feel this is the change people might be looking from long time.
06:21:41 <mfabian> And I will make the UI better to set this up, but maybe not in time for the F26 feature freeze.
06:21:42 <pravins> so just for creating awareness and more testing.
06:22:34 <pravins> mfabian: we can create change page, saying change it 100% complete. :)
06:22:40 <pravins> dunno what other feels..
06:23:07 <mfabian> You can also write 50% as the feature works but the UI for the setup is not nice yet.
06:23:35 <juhp> do you plan to do the UI for F25?
06:24:08 <mfabian> Probably, because it is probably enough if it is done until the beta phase of f25.
06:25:01 <pravins> ye
06:25:02 <pravins> yes
06:25:29 <pravins> If you are planning to improvements in F25, good to highlight it with change. Its self-contained so should be not much issue
06:26:26 <mfabian> pravins: Yes, then  a change proposal might be nice to get some more attention from users.
06:26:42 <pravins> great, i can help with edit in proposal :)
06:26:53 <pravins> will you create one then? should i add action item?
06:27:46 <mfabian> pravins: OK, I’ll create one.
06:27:49 <pravins> #action mfabian will create change proposal for Multilingual Ibus typing booster (self-contained)
06:27:54 <pravins> great, thanks :)
06:28:23 <pravins> suanand: about string breakage monitoring script
06:28:41 <pravins> for update, we (me and suanand ) had quick meeting with aeng.
06:28:52 <suanand> pravins, planning to start work next week..
06:29:03 <pravins> suanand: i remember you mentioned string breakage is not very good title to this.
06:29:24 <suanand> yes.. how about "transdiff" ?
06:29:27 <pravins> i have to propose feature (JIRa) in Zanata sync
06:30:21 <suanand> transdiff -- should provide diff UI for translations. diff between: install po vs upstream po?
06:31:26 <pravins> transdiff yeah, its more functional name
06:31:35 <suanand> pravins, should development of transdiff be in parallel with proposed feature for Zanata Sync?
06:31:39 <pravins> but year, if there are no other suggestions, we can go with it :)
06:31:54 <aeng> suanand, it should be
06:32:06 <suanand> aeng, +1
06:32:14 <pravins> +1
06:32:23 <aeng> we can discuss more when we actually starts implementing
06:32:37 <pravins> aeng: right, i think change proposal can help more here
06:32:37 * suanand nod
06:32:41 <aeng> there's several way to sort this out even without implementation in Zanata
06:32:45 <pravins> suanand: will you create change proposal?
06:33:07 <suanand> aha, sure!
06:33:17 * pravins to be frank each time i discuss this, i get confuse and need to backtrack earlier discussions ;)
06:33:44 <pravins> #action suanand will create change proposal for transdiff.
06:34:12 <pravins> I have not got time to do review on atomic workstation
06:34:24 <pravins> so looks not realistic with deadline time.
06:35:21 <pravins> #topic Fedora 25 planning trans/zanata
06:35:21 <pravins> #link https://fedorahosted.org/G11N/ticket/24
06:35:55 <pravins> from translation perspective.
06:36:23 <pravins> Noriko suggested couple of ideas
06:36:37 <pravins> #idea 1. Glossary Project
06:36:58 <pravins> #idea 2. Bug triage and fixes from F24 trans test day.
06:37:14 <pravins> we had some discussion already on mailing list, hope she can create change proposal for same.
06:39:03 <pravins> #idea 3. Introductory course for starting localization with Fedora.
06:40:05 <pravins> aeng: same time, when we are planning deployment of Zanata with Fedmsg
06:40:21 <aeng> same time?
06:40:31 <pravins> oops, means discussion with other topics :)
06:41:25 <pravins> i think, you might be having some discussions already with hubs team.
06:41:33 <aeng> yes
06:42:29 <pravins> would be nice to see updates on ticket :)
06:43:24 <pravins> #link https://fedorahosted.org/G11N/ticket/19
06:43:42 <pravins> #link https://fedorahosted.org/G11N/ticket/22
06:45:20 <aeng> i will try
06:45:52 <aeng> just had the meeting this morning.. alot to triage and need to discuss with team. i will update the tickets once i got more information
06:46:12 <aeng> ah... but that 2 tickets...
06:46:20 <aeng> yes, i will update it.. its alright done
06:47:54 <pravins> great, thanks aeng :)
06:48:22 <pravins> there is already thread on trans list regarding change planning for F25. So we can stop here today
06:48:26 <pravins> #topic Open Floor
06:48:39 <pravins> Did we missed anything urgent or any other topic to discuss?
06:49:30 <fujiwarat> I have the plan to integrate Emoji typing but not sure if it's on time for f25.
06:49:53 <pravins> Emoji tying will be great.
06:50:27 <pravins> As of now, may be just create change proposal. It can give more ideas at least
06:50:44 <pravins> i think emoji will be self contained change.
06:50:50 <pravins> does it depend on any other packages?
06:51:13 <pravins> As far as i know, we are more relaxed for self contained change in Fedora.
06:51:17 <fujiwarat> Recently I'm thinking to get the data from nodejs-emojione
06:51:25 <fujiwarat> https://bugzilla.redhat.com/show_bug.cgi?id=1350700
06:51:37 <pravins> So even, if its getting complete by Beta, it should be fine. If i am correct, we can ask to jkurik again.
06:53:05 <fujiwarat> pravins: ok
06:53:10 <pravins> fujiwarat: i will recommend to create change proposal at least for now.
06:53:14 <pravins> and lets see how it goes.
06:53:24 <pravins> if its not complete by Beta, we can postpone to F26
06:53:39 <fujiwarat> sure
06:53:45 <aeng> gtg now guys. Thanks for meeting
06:54:03 <pravins> thanks fujiwarat, should i add action item for you?
06:54:26 <fujiwarat> pravins: yes, please.
06:54:30 <pravins> #idea Emoji typing in Fedora.
06:54:41 <pravins> #action fujiwarat will create change proposal for emoji typing.
06:54:46 <pravins> thanks fujiwarat :)
06:54:54 <pravins> aeng: we are done. :)
06:54:58 <pravins> thanks all for meeting
06:55:02 <pravins> #endmeeting