14:00:29 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:00:29 <zodbot> Meeting started Mon Jul 25 14:00:29 2016 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:29 <zodbot> The meeting name has been set to 'docs_project_meeting_-_agenda:_https://fedoraproject.org/wiki/docs_project_meetings'
14:00:29 <randomuser> #meetingname Fedora Docs
14:00:29 <zodbot> The meeting name has been set to 'fedora_docs'
14:00:29 <randomuser> #topic Roll Call
14:00:37 * Capesteve waves
14:01:32 * grundblom is here
14:01:59 <bexelbie> .fas bex
14:02:00 <zodbot> bexelbie: ybexwqmxnx 'ybexwqmxnx yhdgb' <ybexwqmxnx@nowmymail.com> - lonelyibex 'fungo' <lonelyibex@gmail.com> - moko 'moko lee' <ibex@msn.cn> - sfarr01 'Steven Farr' <sfarr@bex.net> - tqtwr 'gsafd' <mesabexudi@top1mail.ru> - bexhet '' <bexhet@hotmail.it> - mcreps 'Merl Creps Jr' <merljr@bex.net> - tbex 'Tony Beckham' <t2yb5m@gmail.com> - efjiwmos 'takagiatuko' <bexroll@gmail.com> - makubex 'Bruno Lopes de Mello' (2 more messages)
14:02:15 <pkovar> /me is here
14:02:40 <bexelbie> .hello bex
14:02:41 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
14:02:46 <bexelbie> wrong cmd
14:03:24 <shaunm> hello
14:04:10 <randomuser> morning, shaunm
14:04:13 <pkovar> shaunm: hi there
14:04:46 <randomuser> #topic Follow Up on Action Items
14:04:58 <randomuser> #action randomuser to deal with FreeIPA guides in some way
14:05:04 <randomuser> carrying over, did not do
14:05:14 <randomuser> zoglesby, defensive coding guide?
14:05:42 <pkovar> are you planning on unpublishing freeipa docs, randomuser?
14:06:50 <randomuser> oops
14:07:16 <randomuser> pkovar, i'll try, but a robots.txt directing crawlers to ignore it is more immediately feasible
14:07:54 <randomuser> afaik you have to run remove_book with sources where all the variables are the same as when the book was published, and we don't always have a coinciding git checkout
14:08:36 <randomuser> we'll catch up with defensive coding later on
14:08:47 <randomuser> #topic New Writers
14:08:47 <pkovar> randomuser: that's correct. i don't think the freeipa docs got branched after releases
14:09:52 <pkovar> randomuser: not for fedora, anyway https://git.fedorahosted.org/cgit/docs/freeipa-guide.git/
14:10:24 <randomuser> yeah, pbokoc looked at it somewhat recently
14:11:09 <randomuser> it will most likely be a more.. manual effort to actually unpublish them
14:11:18 <pbokoc> yeah, they're not branched. But you could work around that by finding the web.git commit that published them, and finding the most recent commit in the guide's repo from before the web.git commit
14:11:45 <pbokoc> except that doesn't work because the F17 guide was originally published for F16, and then somehow the version number was bumped in web.git, so it's a complete mess
14:13:24 <randomuser> the version number was bumped without an accompanying commit
14:13:52 <pkovar> manual bump then
14:13:53 <randomuser> so you have to find the right combination of version declarations in the book sources and publican.cfg
14:13:58 <randomuser> right
14:14:14 <randomuser> #undo
14:14:14 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x43358850>
14:14:35 <randomuser> do you want to take a try at it, pkovar ?
14:14:45 <pkovar> what matters i think that remove_book uses the right path to the guide, and that's it
14:15:13 <pkovar> randomuser: i could try next week
14:15:18 * randomuser nods
14:15:25 <randomuser> I'll let you know if I don't get it done
14:15:31 <pkovar> randomuser: ty
14:15:36 <randomuser> #topic New Writers
14:16:17 <randomuser> here we like to hear from those new to docs, people working with such new folks, and related subjects
14:17:42 <randomuser> nothing?
14:17:49 <randomuser> okay
14:17:58 <randomuser> #topic Publishing
14:18:20 <randomuser> I have no news here; anyone work on publishing stuff this week?
14:18:32 <grundblom> I am working on a ticket for the web interface.
14:18:50 <grundblom> it will need to be published to the web when I am finished, I am thinking two or three days?
14:18:54 <bexelbie> I hope to do some experimentation with the new stuff prior to Flock but nothing directly to report
14:19:04 <shaunm> I've been working on it
14:19:18 <shaunm> working on translation stuff at the moment
14:20:40 <randomuser> #info steady progress upstream, https://github.com/projectmallard/pintail/commits/master
14:20:47 <randomuser> shaunm++
14:20:47 <zodbot> randomuser: Karma for shaunm changed to 1 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:21:37 <pkovar> looks great
14:21:42 <shaunm> search works pretty well
14:21:50 <randomuser> grundblom, you're working on a ticket for the pintail web interface?
14:22:07 <shaunm> but I need to figure out the best strategy for actually hosting it
14:22:16 <grundblom> randomuser, no I am working on a ticket about type-os and the firefox version number being wrong
14:22:24 <randomuser> ah
14:22:30 <grundblom> just a sec #dayjob just got interesting...
14:22:50 <randomuser> shaunm, hosting an elasticsearch instance?
14:23:02 <shaunm> randomuser: yes
14:23:07 <randomuser> what's the roadblock?
14:23:46 <shaunm> is it something we can securely host on fedora infra?
14:23:58 <shaunm> there are paid elasticsearch hosts as well
14:24:48 <randomuser> yeah, I think it's possible to get an appropriately isolated elasticsearch instance in the fedora infra environment
14:24:58 <shaunm> I've tried standing on a secure public instance, but securing elasticsearch kind of hurts my brain
14:25:08 <shaunm> s/on/up/
14:25:55 <linuxmodder> .hello linuxmodder
14:25:56 <zodbot> linuxmodder: linuxmodder 'Corey W Sheldon' <sheldon.corey@openmailbox.org>
14:25:59 <randomuser> it's on my list to spend some time on for $dayjob too; i can look into setting it up for Fedora
14:26:42 <randomuser> hey linuxmodder
14:26:52 <linuxmodder> randomuser,  sorry I've missed mtgs lately
14:26:56 <randomuser> np
14:27:10 <linuxmodder> $dayjob (the tutoring bit been busy as crap
14:27:36 <randomuser> #action randomuser to work on secure dev environment elasticsearch for shaunm to play with
14:27:52 <linuxmodder> randomuser,  about defensive coding guide you mean just a review for version bump right?
14:28:25 <linuxmodder> randomuser,  shaunm    look at  my  modified  centos secure-install script
14:28:29 <randomuser> linuxmodder, zoglesby was dealing with it, so I didn't get the full story
14:29:22 <linuxmodder> we are both security team guys that seems to be the thing I remember especially as its part of the onboarding bits for security_team_appre3nticeship
14:30:04 <randomuser> maybe in a moment, when the topic of guides comes up...
14:30:26 <linuxmodder> shaunm,  http://65.19.183.167/ameridea/secure-configuration.cfg
14:30:34 <randomuser> what's the secure-install script? have you been working on a playbook for elasticsearch?
14:31:16 <linuxmodder> not for elasticsearch but that is a  DISA blessed install script that you can then containerize or  chroot in
14:31:26 <randomuser> ahh everything on that level we'd inherit from the existing fedora infra vm templates
14:31:29 <linuxmodder> its what my  install uses even
14:32:03 <linuxmodder> noted I may PR the virthost playbooks then
14:32:20 <shaunm> so, best I can tell, we need a standard add-on module for elasticsearch called shield
14:32:58 <shaunm> and, I think, that will allow us to require credentials when updating indexes, but allow open access for getting search results
14:33:07 <linuxmodder> shaunm,  its in the repos already?  sorry novice on es  myself
14:33:25 <shaunm> linuxmodder: does not seem to be
14:33:44 <shaunm> linuxmodder: all of elasticsearch's docs have you installing stuff with kibana or something, not rpms
14:34:11 <shaunm> because we needed yet another package system in the mix
14:34:12 <randomuser> shaunm, i'm not read up; do you feel allowing internal communication only to elasticsearch is not feasible or desired?
14:34:15 <linuxmodder> shaunm,  will look into that some this week see if I can be more help
14:34:57 <shaunm> randomuser: the way the search works is that the browser talks directly to elasticsearch, because es's api is just json over http. that means we don't need any cgi. it's all client-side.
14:35:04 <randomuser> aaaahh
14:35:08 <randomuser> okay, i get it
14:35:55 <shaunm> you have to enable CORS in elasticsearch for that to work. that's easy, though it seems to just allow all origins, and we should see if we can restrict the origin just to the docs site
14:36:17 <randomuser> #info an elasticsearch deployment needs auth capability, 'shield' plugin most likely solution
14:37:50 <randomuser> yeah, i definitely need to do some reading
14:39:54 <randomuser> how about the translations bit, shaunm ? how is that going?
14:40:48 <randomuser> like, $source->docbook->itstool->zanata?
14:41:12 <linuxmodder> randomuser,  same here I suck at  es
14:42:02 <shaunm> randomuser: it's what I'm working on right now. nothing buildable yet.
14:42:16 <randomuser> ok, cool
14:42:51 <randomuser> let's move this along, thanks for the hacking, shaunm
14:43:00 <randomuser> #topic Guide Status
14:43:15 <randomuser> okay, guide talk
14:43:39 <randomuser> linuxmodder, you'll want to check in with zoglesby about the defensive coding guide
14:44:09 <linuxmodder> if nothing else I'll bug him on thursday mtg
14:44:12 <randomuser> afaik Sparks asked for it to be published so zoglesby was going to check over the meta bits
14:44:20 <linuxmodder> security-team mtg
14:44:28 <randomuser> sure
14:44:33 <zoglesby> yes, and I will do it
14:45:03 <randomuser> what other guide stuff is happening this week?
14:45:12 <zoglesby> but I am on vacation this week, and I have already talk to Sparks and told him such
14:46:17 <randomuser> you vacation, zoglesby.
14:46:53 <zoglesby> to late, already here. reading back log.
14:47:07 <randomuser> heh
14:48:26 <randomuser> hearing nothing about past or future guide work, so
14:48:54 <randomuser> #info F25 Change Proposals have started, relnotes prep can begin
14:48:57 <randomuser> #topic Outstanding BZ Tickets
14:49:07 <randomuser> #link http://tinyurl.com/lbrq8
14:49:15 <randomuser> there's bugs, y'all
14:49:47 <grundblom> got to go, sorry everyone, will try to make the next one
14:50:25 <randomuser> we still need to clean that up and move the actionable ones to pajure
14:50:32 <randomuser> PAGURE
14:51:55 <randomuser> hm, i suspect there may be defensive coding guide bugs that have been fixed
14:52:08 <randomuser> #topic Open floor discussion
14:52:21 <randomuser> any items for open floor today?
14:52:23 <zoglesby> I have two things since I am here
14:52:27 <randomuser> yay!
14:52:39 <zoglesby> One, easy'ish ticket for someone to work on
14:52:40 <zoglesby> https://pagure.io/docs-fp-o/issue/23
14:53:25 <zoglesby> we need to make pintails confs for each of our current docs so that people can do local builds of them while they are editing to check how things look in pintail, etc
14:53:47 <randomuser> makes sense
14:53:51 <zoglesby> I think that it will even get you some badge love for some many commits to pagure repos
14:53:54 <bexelbie> zoglesby, I'll contribute tot hat this week (after tuesday) as I prep for Flock - as is appropriate
14:54:02 <bexelbie> zoglesby, I believe htat badge is broke atm
14:54:04 <bexelbie> broken
14:54:05 <zoglesby> randomuser: it should make sense you made the issue
14:54:27 <randomuser> i have a deft understanding of my ideas
14:54:35 <randomuser> better than most, even
14:55:42 <randomuser> you said two things, zoglesby ?
14:56:22 <zoglesby> #2
14:56:31 <zoglesby> shaunm: I need help working out how to link to docbook sources we include in a config
14:56:50 <zoglesby> that is really my only hold up on most of what I want to try and get done in the short term
14:57:29 <zoglesby> if it is a code change and you are not free (or it is not super easy), can you point me in the right direction so that I can take a look at it
14:58:10 <zoglesby> also, if this is not clear, what I am asking about is generating links on the index to docs on the side without manually entering each one in the index source
14:58:13 <shaunm> zoglesby: what format are you linking from?
14:58:35 <shaunm> oh, like a standard sidebar across all pages?
14:58:45 <zoglesby> I think our plan is to use ducktype for all of the index page
14:58:57 <randomuser> hm, that seems like an important feature
14:58:58 <zoglesby> shaunm: just an index page for now
15:00:09 <randomuser> our time is up here, see you in #fedora-docs
15:00:13 <randomuser> #endmeeting