18:00:52 <mattdm> #startmeeting Council (2016-08-15)
18:00:52 <zodbot> Meeting started Mon Aug 15 18:00:52 2016 UTC.  The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:52 <zodbot> The meeting name has been set to 'council_(2016-08-15)'
18:00:53 <mattdm> #meetingname council
18:00:53 <zodbot> The meeting name has been set to 'council'
18:00:55 <mattdm> #chair mattdm jkurik jwb cwickert langdon robyduck tatica
18:00:55 <zodbot> Current chairs: cwickert jkurik jwb langdon mattdm robyduck tatica
18:00:57 <mattdm> #topic Introductions, Welcomes
18:01:10 <mattdm> hi everyone
18:01:13 <jkurik> .hello jkurik
18:01:14 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
18:01:18 <jkurik> hi mattdm
18:01:22 <jwb> hello
18:01:31 <mattdm> as I noted in #fedora-council, I'm having some net issues so my connection may be flaky
18:01:49 <mattdm> if I stop talking for a little bit at some point, it's probably because I'm thinking REALLLY deeply on the topic
18:01:54 <mattdm> or else my internet has dropped.
18:01:57 <mattdm> one or the other
18:02:25 <langdon> .hello langdon
18:02:26 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
18:02:49 <mattdm> cwickert noted that he can't make it
18:03:00 <mattdm> and tatica generally hasn't been able to :(
18:03:20 <mattdm> robyduck ?
18:07:11 <langdon> mattdm, are you thinking deeply about the next person to ask about?
18:07:15 <langdon> mattdm, or MIA?
18:08:02 <mattdm> irc
18:08:10 <mattdm> mia :)
18:08:12 <mattdm> back now
18:08:21 <mattdm> sorry. :)
18:08:24 <mattdm> ok, so,
18:08:27 <mattdm> #topic agenda
18:08:38 <mattdm> I got:
18:08:50 <mattdm> 1. Third-party/nonfree software policy discussion
18:09:09 <mattdm> 2. The weak deps for third-party repos thing
18:09:15 <mattdm> 3. PRD reviews followup
18:09:35 <mattdm> and if jzb is around, possibly an update on action/impact lead
18:09:42 <mattdm> anyone have anything else?
18:10:12 <jkurik> nothing else
18:10:24 <mattdm> ok let's do it :)
18:10:38 <mattdm> if I vanish again someone pleaes continue without me :)
18:10:50 <mattdm> #topic third-party nonfree software policy discussion
18:10:56 <mattdm> #link https://fedorahosted.org/council/ticket/57
18:11:12 <mattdm> we've had a pretty good discussion in the ticket
18:11:42 <mattdm> langdon, do you have anything to add?
18:12:12 <mattdm> as i noted early today, we all seem agreed on the free software third party part
18:12:14 <langdon> mattdm, sorry.. i was just reading the last two responses
18:12:24 <langdon> yeah.. im good on that part to
18:12:25 <langdon> o
18:12:33 <mattdm> and it seems like wer'e generally coming to a consensus on the nonfree part
18:13:03 <langdon> yeah.. i am unclear from reading what the proposal is for like sort ordering/promoting free results/etc
18:13:52 <mattdm> aday (the designer for gnome who is working on this from that perspective) felt like that was getting too deeply into details
18:14:12 <langdon> for the ticket?
18:14:23 <mattdm> for the council-level policy, I think
18:14:52 <langdon> i don't know, personally.. isn;t this directly connected to one of the Fs (that was fun to say ;) )
18:15:13 <langdon> i would propose.. close with tentative approval, reopen when they have a strawman
18:16:03 <mattdm> "We think you know what we're getting at here; we'd like to have something tangible and we'll tell you if we're on the same page?"
18:16:05 <langdon> but back and forth in a ticket definitely seems unlikely to get to a resolution
18:16:11 <langdon> righto
18:16:28 <langdon> if you could work in the word "agile" .. it would make jwb happier
18:16:59 <mattdm> sure, I'll put that on the backlog and we'll chart the burndown
18:16:59 <jwb> yes, because i'd know for sure the ticket had jumped the shark
18:17:26 * langdon notes he is in the office so making him giggle is awkward for everyone
18:19:15 <mattdm> okay so
18:19:33 <mattdm> I'll put that proposal in the ticket and if no one objects in the next few days close it
18:19:42 <mattdm> I will probably word it differently :)
18:19:54 <mattdm> #topic weak dependencies
18:20:18 <mattdm> I'm kind of inclined to kick this one back down to fesco
18:20:28 * langdon was gonna do an #agreed on including "agile" in the tickket
18:20:29 <jwb> why
18:20:54 <langdon> #link https://fedorahosted.org/council/ticket/61
18:21:19 <mattdm> because all the suggests vs recommends stuff seems like technical implementation
18:21:31 <sgallagh> mattdm: I think the Council needs to decide if such a thing is *desirable* and then FESCo can figure out how to implement it if so
18:21:46 <sgallagh> You're right that the ticket has gotten too far into implementation questions
18:22:22 <jwb> mattdm: yeah, but the question is whether it's allowed to have that stuff on THIRD PARTY REPOS
18:22:36 <jwb> emphasis intended not to be shouting
18:22:45 <mattdm> lol I wondered why the yelling :)
18:23:04 <sgallagh> /me always reads all-caps in robot voice. It's far more enjoyable.
18:23:05 <langdon> personally, i am +1 on cwickerts last comment ..
18:23:12 <mattdm> I sent a message to legal, but if I got a reply I lost it...
18:23:45 <sgallagh> At the risk of veering into implementation, Suggests: is meaningless.
18:24:10 <sgallagh> But it has nothing to do with the core question: may packages depend *in any way* on non-Fedora repositories?
18:24:13 <mattdm> sgallagh: does Software not follow Suggests?
18:24:20 <langdon> sorry.. i guess i meant -1 on requiring from remote; +1 on "any other indication that something might be useful from remote"
18:24:23 <sgallagh> mattdm: Not to my knowledge.
18:24:31 <mattdm> #action mattdm to follow up with legal
18:24:41 <jwb> this is a relatively binary question.  do we allow weak-deps against non-Fedora repositories or is that forbidden
18:24:50 <jwb> everything else is up to FESCo
18:24:56 <sgallagh> mattdm: Right now, Suggests: really only functions as a cue for when two packages would otherwise both satisfy a dep (e.g. MariaDB vs MySQL)
18:25:12 <mattdm> jwb Ok, I can get behind that.
18:25:18 <mattdm> Do you have an opinion?
18:25:26 <langdon> jwb, to be clear... the ticket actually only asks about "suggests".. isn't requires currently disallowed?
18:25:42 <sgallagh> langdon: It's asking about "Recommends:" really
18:25:43 <jwb> langdon: yes, which is why i said "weak-deps"
18:25:49 <jwb> Requires is not weak
18:25:58 <langdon> sgallagh, yeah.. my bad
18:26:00 <sgallagh> Requires is presently explicitly disallowed (and should clearly remain that way)
18:26:02 <langdon> jwb, right
18:26:12 <jwb> mattdm: my opinion is we should not
18:26:40 <langdon> i guess i was saying.. poorly.. is i wouldn't want to change requires but don't see any problems with weak against remotes
18:26:53 <jwb> grrrrr
18:26:58 <langdon> jwb, :)
18:26:58 <jwb> sorry, message got truncated
18:27:04 <mattdm> I guess my inclination is "No; this is what Enhances and Suppliments are for"
18:27:14 <jwb> mattdm: my opinion is we should not disallow this
18:27:15 <sgallagh> langdon: There are plenty of problems with it. The question is whether the benefits outweigh them, really
18:27:28 <mattdm> jwb Oh -- that's important phrasing :)
18:27:29 <langdon> sgallagh, what problem?
18:27:48 <jwb> mattdm: yeah.  though i have no idea what you mean by Enhances and Suppliments
18:28:07 <langdon> like the only one i actually see is the political one.. and i don't think weak-deps imply endorsement
18:28:07 <mattdm> https://fedoraproject.org/wiki/Packaging:WeakDependencies
18:28:10 <jwb> like... are those RPM things?  have i totally forgotten what they do vs. Suggests/Recommends?
18:28:11 <mattdm> Supplements
18:28:14 <sgallagh> langdon: Well, one cited example was if two unrelated 3rd-party repos both decided to offer something that Provides: the same thing we Recommends:
18:28:24 <sgallagh> jwb: Those are the reverse deps
18:28:57 <jwb> sgallagh: oh... so 3rd party repos would put those in their RPMs against Fedora packages?
18:29:23 <sgallagh> jwb: Yes, so for example you could have "kmod-nvidia Supplements: kernel"
18:29:28 <sgallagh> (As a horrific example)
18:29:35 <jwb> mattdm: i guess i could get behind that
18:29:49 <langdon> sgallagh, i guess i am thinking about it from a logical perspective.. but, in fact, it should really be from a user perspective... where we don't want to break end user experience.. (esp. with things that are hidden from most end users)
18:30:12 <jwb> langdon: i don't think we're breaking anything, since precedent says DO NOT DO THIS
18:30:24 <sgallagh> I mean, technically we can't prevent them from doing this (which is why I don't love reverse-deps in the first place) but I suppose we could decide to make a clear statement that we won't try to prevent it.
18:30:46 <jwb> langdon: if anything, either Recommends/Suggests or Enhances/Supplements are ... er... enhancing user experience
18:30:50 <langdon> jwb, no.. i meant... allowing it.. potentially breaks an end user experience .. which is bad.. but from a logical perspective, i don't think it implies endorsement
18:31:28 <jwb> langdon: if you're breaking an end user experience that is currently "crap doesn't work", then i'm not sure that's really all that bad
18:31:36 <langdon> jwb, :)
18:31:48 <mattdm> Is there a use for this which is going to be other than "Suggests: forbidden-patented-package"?
18:31:56 <jkurik> sgallagh: I do not think "a statement" will help. Once we allow this it starts to be "fragile" by design
18:32:22 <sgallagh> mattdm: Sure: "Recommends: forbidden-patented-package" :-P
18:32:43 <jwb> sgallagh: the statement on the backwards deps is superfluous and they're going to ignore it anyway
18:32:57 <mattdm> sgallagh: lol sigh
18:33:10 <jwb> mattdm: i'm sure our developers can come up with all kinds of strawman cases
18:33:12 <sgallagh> mattdm: I think the core of the issue is that if people have made the choice to install $repo-that-must-not-be-named, then that step has already absolved us of the major question about whether the user believes they are at risk
18:33:29 <jwb> and patents are terrible and not equally applicable
18:33:44 <sgallagh> jwb: So far they have not (partly because the packaging guidelines say not to use them except in individually approved cases)
18:34:21 <mattdm> I don't know; I think I have to defer to legal on that as to whether that puts *us* and/or Red hat at risk too
18:34:32 <jwb> sgallagh: if you ask a group of engineers explicitly "can we come up with uses for $THING" they will ALWAYS come up with uses for $THING.  we haven't asked them
18:35:25 <jwb> anyway, i'm fine with deferring to legal but we shouldn't sit around waiting to come to a conclusion until they reply
18:35:39 <sgallagh> mattdm: For a less dubious answer: a package that has experimental loadable modules.
18:36:00 <mattdm> I'll send email as soon as meeting is over.
18:36:11 <mattdm> next topic?
18:36:16 <langdon> one more thing
18:36:23 <langdon> can i propose an idea?
18:36:29 <mattdm> langdon: yes :)
18:37:14 <langdon> what if we "allowed it" .. but if any bugs were filed about any misuse (or conflicts or whatnot) .. that would trigger an immediate package review and potential "denial by exception" (wording rough)..
18:37:49 <langdon> assuming legal is down with it (this is how i refer to all legal rulings..)
18:37:50 <mattdm> Hmmmm.
18:38:55 <mattdm> That seems like details :)
18:39:38 <langdon> well.. as i read above.. the only "arguments against" are technical.. i didn't see any philosophical arguments aside from "endorsement"..
18:39:39 <sgallagh> mattdm: A better phrasing might be: "Under what conditions would it be acceptable to do so?"
18:39:46 <jkurik> it looks for me like we are just postponing the denial of it
18:40:03 <langdon> so .. in my mind.. legal say +1 then council says +1 then it is kicked to fesco/fpc
18:40:36 <langdon> jkurik, if legal approved, what would be the "non-technical argument" against it?
18:41:18 <langdon> fesco/fpc could still say.. this is terrible technically.. but that doesn't make it any more or less philosophically correct.. and the council is responsible for the latter not the former
18:42:00 <jkurik> langdon: I feel it like it opens a door for a misuse more than we would like to
18:42:36 <langdon> jkurik, so let fesco kick it to the curb.. that is a technical reason.. and a valid (potentially) one.. but that isn't a council decision, right?
18:42:41 <mattdm> Other than the legal concern I don't really have a strong opinion, I guess.
18:43:41 <mattdm> next thing?
18:43:42 <langdon> i don't know.. table? move on?
18:43:45 <mattdm> yeah :)
18:43:57 <mattdm> #topic PRD refresh
18:44:16 <mattdm> jkurik: do you want to update on this?
18:45:56 <jkurik> I have not read all the responses as I was on PTO the previous week
18:46:32 <mattdm> jkurik: ok, so maybe do this next week? :)
18:46:41 <jkurik> so, there was a  workshop on FLOCK and we put together some draft PRDs
18:46:58 * cwickert_mobile lurks from his mobile
18:47:24 <jkurik> now these PRDs are under review back on WGs
18:48:07 <jkurik> I have seen discussion on Server WG, but not read it yet
18:48:24 <mattdm> jkurik: do we need to press the WGs, or should we wait?
18:48:33 <jkurik> mattdm: I will be on PTO the next week as well, but I might update the ticket before I leave
18:49:02 <jwb> i've not really seen anything on the WG lists at all aside from Server
18:49:20 <jkurik> mattdm: how critical the PRDs are ?
18:49:35 <mattdm> jkurik: I think keeping them up to date is an essential exercise
18:49:36 <jwb> maybe it's post-Flock deflate, but i was at least expecting some kind of email kickoff
18:49:44 <jwb> particularly for cloud
18:49:45 <mattdm> jwb agreed
18:49:57 * langdon also notes there are a lot of people on PTO in august
18:50:10 <langdon> like all of france
18:50:30 <mattdm> langdon: true
18:51:04 <mattdm> well, let's see what happens in this week
18:51:16 <jkurik> so, is it ok to review the state of PRD during september ?
18:51:44 <langdon> do they have a deadline
18:52:06 <langdon> ??
18:52:11 <mattdm> langdon: no. should we set one? what are the consequences of missing?
18:52:21 <langdon> mattdm flies to your house?
18:52:29 <langdon> budget?
18:52:30 <jwb> you are no longer an Edition.
18:52:36 <bconoboy> The Server WG is changing its leadership post-flock, so it'll be a couple weeks before they're really able to tackle the PRD
18:53:00 <mattdm> jwb=+
18:53:02 <langdon> how about f25 drop date?
18:53:04 <mattdm> ++ that is :)
18:53:21 <langdon> with drafts due 1 month before?
18:53:27 <mattdm> that seems like plenty of time
18:53:40 <mattdm> and gives time to make adjustments for f26
18:53:44 <mattdm> which is kind of the point anyway
18:53:48 <mattdm> so yeah.
18:53:50 <langdon> right.. thats what i was thinking
18:53:57 <mattdm> jkurik does that sound good to you?
18:54:01 <langdon> could make it a definitive rule..
18:54:06 <jkurik> mattdm: yes
18:54:10 <langdon> like always due at the halloweed release
18:54:22 <mattdm> langdon: I like that
18:54:22 * langdon wonders "freudian slip"?
18:54:54 <langdon> what was the budget deadline again?
18:54:58 <langdon> should they "align"
18:55:06 <langdon> or, actually, be opposite?
18:55:18 <langdon> e.g. budget by easter release (ish), right?
18:56:27 <mattdm> well, we need to submit a budget proposal to RH sometime in september
18:56:42 <langdon> ohh right.. nm
18:56:57 <mattdm> I think these things are _largely_ different parts of the project, so I don't think overlap is necessarily bad
18:57:17 <mattdm> the primary overlap problem is with people working to actually get stuff tested and out the door
18:57:24 <langdon> true
18:57:40 <langdon> maybe 2 weeks after drop..
18:57:55 <langdon> but.. no idea.. im just thinking out loud now
18:58:03 <mattdm> aka "during the chance people have to catch a breath" :)
18:58:06 <mattdm> yeah :)
18:58:10 * mattdm looks at clock
18:58:22 <mattdm> let's come back to this next week, hopefully with good news
18:58:28 <mattdm> #topic anything else real quick?
18:58:43 <jwb> yay flock
18:58:45 <jwb> was great
18:58:47 <langdon> yay!
18:58:56 <mattdm> it was! it was amazing!
18:59:03 <mattdm> thanks flock team for being awesome
18:59:21 <mattdm> #info thanks flock team for being awesome
18:59:22 <langdon> mattdm, #agreed?
18:59:28 <mattdm> yeah :)
18:59:37 <mattdm> okay. now, to dig through mountains of email!
18:59:41 <mattdm> #endmeeting