06:01:41 <pravins> #startmeeting i18n
06:01:41 <zodbot> Meeting started Wed Aug 17 06:01:41 2016 UTC.  The chair is pravins. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:01:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
06:01:41 <zodbot> The meeting name has been set to 'i18n'
06:01:41 <pravins> #meetingname i18n
06:01:41 <zodbot> The meeting name has been set to 'i18n'
06:01:41 <pravins> #topic agenda and roll call
06:01:41 <pravins> #link https://fedoraproject.org/wiki/I18N/Meetings/2016-08-17
06:01:45 <suanand> hi
06:01:47 <mfabian>06:01:58 <pravins> hi suanand mfabian :)
06:02:02 <epico> hi
06:02:19 <paragan> hi
06:03:02 <pravins> hi epico paragan :)
06:03:02 <juhp> hi
06:03:10 <pravins> #chair suanand mfabian paragan epico juhp
06:03:10 <zodbot> Current chairs: epico juhp mfabian paragan pravins suanand
06:03:14 <pravins> hi juhp :)
06:03:21 <pravins> lets see upcoming schedule
06:03:27 <pravins> #topic Upcoming schedule
06:03:28 <pravins> #info 2016-08-23 	Alpha Release
06:03:28 <pravins> #info 2016-09-06 	Software Translation Deadline
06:03:28 <pravins> #info 2016-09-20 	Beta Freeze (*)
06:03:28 <pravins> #info 2016-09-20   Change Checkpoint: 100% Code Complete Deadline
06:03:57 <pravins> Alpha release is happening next week. May be this time i will switch quickly from F24 stable to Alpha..
06:04:39 <pravins> #topic Outstanding task
06:04:39 <pravins> #info #36: Disabling/blacklisting Indic XKB keyboard layouts in Gnome (mfabian)
06:04:40 <pravins> #link https://fedorahosted.org/i18n/ticket/36
06:04:48 <pravins> mfabian: any chance to ping Peter here?
06:05:05 <mfabian> I’ll try again.
06:05:23 <pravins> mfabian: ohh, you did missed Gnome Summit? it was in Germany
06:05:26 <fujiwarat> hi
06:05:43 <pravins> hi fujiwarat :)
06:05:45 <pravins> #chair fujiwarat
06:05:45 <zodbot> Current chairs: epico fujiwarat juhp mfabian paragan pravins suanand
06:05:51 <mfabian> Going to GUADEC and Flock was a bit too much for me.
06:06:05 <pravins> s/Gnome Summit/GUADEC
06:06:24 <pravins> mfabian: agree !! even flock itself was much for me :)
06:07:07 <pravins> #topic #63: Bug triaging activity post F24 Beta release
06:07:08 <pravins> #link https://fedorahosted.org/i18n/ticket/63
06:07:43 <pravins> Somehow we got delayed for this activity. I will start looking into this again.
06:08:22 <pravins> As we know, for Fedora 22 EOL many bugs got auto closed, having this activity soon will help for F23.
06:09:03 <pravins> TODO for now is : Dividing bugs, so one can simply pick for triaging.
06:09:11 <pravins> Announcement, blogs etc.
06:09:42 <pravins> #link https://fedoraproject.org/wiki/FLTG/F24_I18N_Bug_Triaging
06:10:16 <pravins> If anyone interested to participate in organizing this event, please ping me.
06:10:49 <juhp> https://ghc.haskell.org/trac/ghc/wiki/Platforms
06:10:55 <juhp> sorry oops
06:11:29 <pravins> juhp: :)
06:11:45 <pravins> moving to next topic
06:11:46 <pravins> #info #64: Fedora 25 planning (pravins)
06:11:46 <pravins> #link https://fedorahosted.org/i18n/ticket/64
06:12:49 <juhp> are we happy with all the f22 closures?
06:13:19 <pravins> juhp: at least i did check for my F22 bugs, not sure about others.
06:13:36 <pravins> but yeah, we must check all F22 closed bugs once again and triage accordingly.
06:13:46 <juhp> right
06:14:04 <pravins> that is also one of the task before organizing triaging day.
06:14:21 <pravins> Satya is away presently.
06:15:20 <pravins> #info Unicode 9.0
06:15:22 <pravins> #link https://fedoraproject.org/wiki/Changes/Unicode_9.0
06:16:31 <pravins> last update was:
06:16:33 <pravins> Symbola font is already updated for Unicode 9.0 in rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=14808397 101 new characters have been added to this font.
06:16:51 <pravins> basically going well.
06:17:07 <pravins> #info IBus Emoji typing
06:17:11 <pravins> #link https://fedoraproject.org/wiki/Changes/IBus_Emoji_Typing
06:20:41 <pravins> fujiwarat: i was just checking whether latest build available in F24 for testing.
06:21:25 <fujiwarat> pravins: it's F25?
06:21:50 <pravins> fujiwarat: aha, ok, i will download it manually :)
06:21:57 <juhp> how about having a an ibus copr for testing/backports?
06:21:58 <mfabian> It would be nice to have the cairo patch for coloured emoji ...
06:22:05 <juhp> s/a/an
06:22:15 <pravins> juhp: good idea !!
06:22:22 <juhp> mfabian: perhaps that could be in the copr too...
06:22:29 <juhp> or another one
06:22:30 <pravins> fujiwarat: yeah, having Copr repo will be helpful for early testing of this feature in F24.
06:22:56 <mfabian> https://copr.fedorainfracloud.org/coprs/hadess/emoji/
06:23:12 <mfabian> That is cairo with the colour emoji patch.
06:23:19 <juhp> cool
06:23:23 <mfabian> Sometimes not easy to install though.
06:23:32 <juhp> oh
06:23:47 <pravins> mfabian: does it work?
06:24:12 <fujiwarat> pravins: ok
06:24:49 <mfabian> pravins: Yes, see the screenshots  for ibus-typing-booster on github.
06:25:09 <mfabian> pravins: https://mike-fabian.github.io/ibus-typing-booster/documentation.html#emoji-predictions
06:25:20 <pravins> wow
06:25:40 <pravins> mfabian: awesome !!
06:25:57 <mfabian> But installing sometimes has dependency problems:
06:25:58 <pravins> mfabian++ nice screenshots on ibus-typing-booster doc page
06:26:05 <mfabian> $ sudo dnf install cairo --best
06:26:05 <mfabian> Last metadata expiration check: 2:15:41 ago on Wed Aug 17 06:09:47 2016.
06:26:05 <mfabian> Package cairo-1.14.6-2.fc24.x86_64 is already installed, skipping.
06:26:05 <mfabian> Package cairo-1.14.6-2.fc24.i686 is already installed, skipping.
06:26:08 <mfabian> Error: cannot install both cairo-1.14.6-4.emoji.fc24.x86_64 and cairo-1.14.6-2.fc24.x86_64
06:26:12 <mfabian> (try to add '--allowerasing' to command line to replace conflicting packages)
06:26:15 <mfabian> 
06:26:30 <pravins> #info Color emoji possible with latest Cairo latest packages https://copr.fedorainfracloud.org/coprs/hadess/emoji/packages/
06:26:50 <paragan> mfabian, dnf update not dnf install
06:26:59 <mfabian> If I add --allowerasing it wants to remove a lot of stuff on my main machine.
06:27:12 <mfabian> paragan: dnf update doesn't  want to do it at all.
06:27:27 <mfabian> $ sudo dnf update cairo
06:27:27 <mfabian> Last metadata expiration check: 2:17:32 ago on Wed Aug 17 06:09:47 2016.
06:27:27 <mfabian> Dependencies resolved.
06:27:27 <mfabian> Nothing to do.
06:27:30 <mfabian> Complete!
06:27:32 <mfabian> 
06:27:51 <mfabian> This worked in a vm though, the screenshots are from a F24 VM.
06:27:56 <paragan> right so install both the arched rpms
06:28:11 <mfabian> But on my F24 "real" machine, I have the dependency problems.
06:28:12 <paragan> i686 and x86_64 as cairo is multilib package
06:29:11 <paragan> mfabian, always build in copr for any testing and use that copr repo
06:29:22 <pravins> mfabian: i will try to do it this week, will write article about this :)
06:29:41 <pravins> next change
06:29:55 <pravins> #info IBus typing booster Multilingual
06:29:56 <pravins> #link https://fedoraproject.org/wiki/Changes/Ibus-typing-booster_multilingual_support
06:30:12 <pravins> this is also already done.
06:30:29 <pravins> #info Help need for Change proposal documentation improvements
06:30:34 <pravins> #chair
06:30:34 <zodbot> Current chairs: epico fujiwarat juhp mfabian paragan pravins suanand
06:30:53 <pravins> We were discussing this in Flock, to ask help for Fedora Docs team to improve change proposal documentation.
06:31:16 <pravins> juhp: suggested to have inside team review first, rather than asking Docs help
06:31:35 <pravins> So if everyone of us can help to clean/improve other change proposal it will really help
06:31:51 <pravins> I would like to takeover Multilingual support change proposal.
06:31:54 <mfabian> paragan: This worked indeed: “sudo dnf install cairo.x86_64 cairo.i686 --best”, thank you! But it upgraded only the x86_64 packages:
06:32:02 <mfabian> Upgraded:
06:32:02 <mfabian> cairo.x86_64 1.14.6-4.emoji.fc24
06:32:02 <mfabian> cairo-devel.x86_64 1.14.6-4.emoji.fc24
06:32:02 <mfabian> cairo-gobject.x86_64 1.14.6-4.emoji.fc24
06:32:06 <mfabian> cairo-gobject-devel.x86_64 1.14.6-4.emoji.fc24
06:32:08 <pravins> #action pravins to cleanup IBus typing booster multilingual change proposal
06:32:09 <mfabian> 
06:32:12 <mfabian> Complete!
06:32:35 <pravins> can anyone would like to over IBus Emoji and Unicode 9.0
06:32:39 <paragan> because of --best?
06:33:13 <mfabian> Without --best, it refused to work.
06:33:38 <paragan> then still some deps issue on your machine
06:33:43 <mfabian> $ sudo dnf install cairo.x86_64 cairo.i686
06:33:43 <mfabian> Last metadata expiration check: 2:20:18 ago on Wed Aug 17 06:09:47 2016.
06:33:43 <mfabian> Package cairo-1.14.6-2.fc24.x86_64 is already installed, skipping.
06:33:43 <mfabian> Package cairo-1.14.6-2.fc24.i686 is already installed, skipping.
06:33:47 <mfabian> Dependencies resolved.
06:33:50 <mfabian> ================================================================================
06:33:53 <mfabian> Package                Arch      Version                 Repository       Size
06:33:57 <mfabian> ================================================================================
06:34:00 <mfabian> Skipping packages with conflicts:
06:34:00 <mfabian> (add '--best --allowerasing' to command line to force their upgrade):
06:34:06 <mfabian> cairo                  x86_64    1.14.6-4.emoji.fc24     hadess-emoji    720 k
06:34:09 <mfabian> cairo-devel            x86_64    1.14.6-4.emoji.fc24     hadess-emoji    369 k
06:34:09 <mfabian> cairo-gobject          x86_64    1.14.6-4.emoji.fc24     hadess-emoji     30 k
06:34:12 <mfabian> cairo-gobject-devel    x86_64    1.14.6-4.emoji.fc24     hadess-emoji     23 k
06:34:15 <mfabian> 
06:34:18 <mfabian> Transaction Summary
06:34:22 <mfabian> ================================================================================
06:34:25 <mfabian> Skip  4 Packages
06:34:28 <mfabian> 
06:34:31 <mfabian> Nothing to do.
06:34:36 <mfabian> Complete!
06:34:39 <mfabian> 
06:34:42 <juhp> mfabian: how about cairo\* ?
06:34:57 <paragan> mfabian, lets discuss this in #fedora-g11n, we are in meeting now
06:35:35 <pravins> yeah.
06:35:41 <pravins> Coming back to topic
06:35:43 <pravins> can anyone would like to over IBus Emoji and Unicode 9.0?
06:36:06 <pravins> basically improve documentation/change proposal page.
06:36:16 <pravins> s/over/takeover :)
06:36:22 <juhp> I would volunteer but if someone else could do a first time that would be helpful
06:36:35 <juhp> about to travel next week so quite busy
06:36:43 <juhp> s/time/take
06:37:01 <pravins> juhp: sure, may be take only one change proposal IBus Emjoi
06:37:06 <juhp> okay
06:37:33 <pravins> #action juhp helping to clean/improve IBus emoji change proposal.
06:38:07 <pravins> only remaining one is Unicode 9.0 now, i have wrote most of the things there. So cant review it ;)
06:38:21 * epico maybe for Unicode 9.0.
06:38:31 <pravins> epico: nice, thanks :)
06:38:37 <epico> welcome :)
06:38:46 <pravins> #action epico helping to clean up Unicode 9.0 change proposal.
06:38:55 <pravins> moving to next topic
06:38:59 <pravins> #info #66: F25 Documentation beat (pravins)
06:38:59 <pravins> #link https://fedorahosted.org/i18n/ticket/66
06:40:51 <epico> could I write the Documentation beat now?
06:41:00 <pravins> epico: yes
06:41:01 <epico> for ibus-libpinyin.
06:41:05 <pravins> we should start it now
06:41:16 <pravins> problem is we are always late for it
06:43:06 <pravins> hmm, page is not clear yet. https://fedoraproject.org/wiki/Documentation_I18n_Beat
06:43:27 <epico> but it seems Immanetize will change the page status...
06:43:59 <pravins> yeah. Nothing changes from 12th April
06:44:14 <pravins> #action pravins to ping docs team for Beat info.
06:44:24 <epico> thanks!
06:44:52 <pravins> its always confusing for me https://fedorapeople.org/groups/schedule/f-25/f-25-docs-tasks.html :(
06:46:37 <pravins> Wiki Freeze: Beta Release Notes 	Mon 2016-09-12 	Mon 2016-09-12 	0
06:47:11 <pravins> Comb Beats and Changes Pages for Alpha 	Tue 2016-08-02 	Thu 2016-08-04
06:47:17 <pravins> Looks they are also delayed for it.
06:47:29 <pravins> will have look into it again
06:47:35 <pravins> moving to last topic
06:47:39 <pravins> #topic Open Floor
06:47:48 <pravins> I would like to update on flock
06:48:02 <pravins> flock 2016 was excellent conference and i will say more action oriented this time.
06:48:21 <juhp> yes I agree
06:48:39 <pravins> it was good to meet mfabian and juhp as well :)
06:49:27 <pravins> Also there was dedicated workshops on Fedora Hub, Taskotron
06:49:32 <pravins> even on Docs
06:49:50 <pravins> Almost all leaders were there.
06:51:37 <pravins> hmm, cant see flock 2016 talks https://www.youtube.com/channel/UCnIfca4LPFVn8-FjpPVc1ow
06:52:45 <pravins> ok, talks are not yet available but i think soon that will happen
06:53:15 <pravins> Same time, FUDCon 2016 is happening in Cambodia, it will be around late October
06:53:20 <pravins> gnokii: is here :)
06:53:29 <juhp> aha
06:53:38 <gnokii> half I sitting in a RL meeting for FUDCon
06:54:01 <pravins> ha ha, just thought will update team regarding FUDCon 2016 and plan for talks and workshops
06:55:04 <pravins> did we missed anything?
06:55:23 <pravins> if not lets close meeting in couple of minute..
06:57:20 <pravins> Thanks all for meeting.
06:57:24 <pravins> #endmeeting