14:01:07 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:01:07 <zodbot> Meeting started Mon Sep  5 14:01:07 2016 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:07 <zodbot> The meeting name has been set to 'docs_project_meeting_-_agenda:_https://fedoraproject.org/wiki/docs_project_meetings'
14:01:07 <randomuser> #meetingname Fedora Docs
14:01:07 <zodbot> The meeting name has been set to 'fedora_docs'
14:01:07 <randomuser> #topic Roll Call
14:01:50 * pbokoc 
14:02:39 * randomuser is present, inadequately caffeinated
14:03:29 * Capesteve waves
14:04:17 <bexelbie> .hello bex
14:04:18 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
14:04:58 <pbokoc> actually I have to run, I'll reappear in about 20 minutes
14:05:08 * randomuser boo hiss
14:05:16 <pbokoc> :-(
14:05:43 <randomuser> #topic New Writers
14:06:14 <randomuser> do we have any new writers today?
14:07:48 <randomuser> sounds like a no
14:08:06 <randomuser> #info Release Notes are a good place for new writers to get started
14:08:36 * bexelbie removes my Groucho Marx glasses and frowns for being too slow
14:09:23 <randomuser> #chair bexelbie
14:09:23 <zodbot> Current chairs: bexelbie randomuser
14:09:31 <randomuser> did you have something for this topic?
14:09:35 <bexelbie> nope
14:09:41 <bexelbie> was going to pretend to be a new writer
14:09:52 <bexelbie> my efforts ahve been focused on publishing alternatives
14:10:10 <randomuser> heh
14:10:13 <randomuser> #topic follow up on action items
14:10:27 <randomuser> #action randomuser to update beats table
14:10:34 <randomuser> yeah, that didn't get done
14:10:54 <randomuser> bexelbie, you had one for talking to marketing/commblock about relnotes?
14:11:04 <bexelbie> I spoke with jflory7
14:11:10 <bexelbie> at this time there are no writers committed for new features
14:11:28 <bexelbie> He has agreed to push them towards us for trying to get them help with RN if they do appear
14:11:33 <randomuser> they seem to have developed content regardless
14:12:11 * randomuser shrugs
14:12:49 <randomuser> odd, there's not a publishing topic in the agenda
14:12:52 <randomuser> let's hit that anyway
14:12:56 <randomuser> #topic Publishing
14:13:21 <bexelbie> my feeling as well (re: content)
14:13:38 <bexelbie> I will continue to watch the magazine/commblog for people to hit up
14:14:00 <randomuser> bexelbie, i was thinking... if we build with pintail and publish a site, then change the theme/css/xslt and make it look different,
14:14:20 * bexelbie listens
14:14:57 <bexelbie> randomuser, ?
14:14:59 <randomuser> the resulting change to the site will not be differently disruptive to the consumer as compared to building it with some other thing then changing to pintail or whatever
14:15:14 <randomuser> ... i couldn't recall the name of the thing you've been playing with
14:15:17 <bexelbie> asciibinder
14:15:23 <bexelbie> if we go with asciibinder - there is no pintail
14:15:27 <randomuser> yes, asciibinder
14:15:52 <bexelbie> I have done some more work on that - I am fairly close to being able to publish a multi-lingual site
14:16:28 <randomuser> if we put our production content in an asciibinder site now then switch to pintail for the expanded featureset down the road, it won't be more disruptive to the reader than any other kind of presentation layer change
14:16:41 <bexelbie> I agree
14:16:57 <bexelbie> a second conversation I'd like to have is "what advanced featureset?"
14:17:01 <bexelbie> but sticking to your point
14:17:17 <bexelbie> yes, no matter what tool we use to the user the links will all change and themeing /layout
14:17:22 <bexelbie> but in the end it is just like a refresh
14:17:30 <bexelbie> and theoretically all of the changes led to improved experiences
14:17:42 <randomuser> yeah, my point is that the presentation/build layer can comfortably be more dynamic
14:17:45 <bexelbie> i think we re going to drive ourselves crazy if we try to maintain backwards compatiblity with urls
14:17:48 <bexelbie> yes
14:18:11 <bexelbie> I agree that we can continue to change tools as we find good reasons to do so
14:18:36 <bexelbie> I also believe we can get there faster with asciibinder and a full upfront conversion to asciidoc (but that is convo #2b)
14:19:05 <bexelbie> Convo #3 is "Why aren't you on Labor Day Holiday"
14:19:16 <bexelbie> s/"$/?"/
14:19:21 <randomuser> convo #2 being "what content do we consider mission critical"
14:19:29 <randomuser> ha
14:19:48 <bexelbie> actually in this case #2 for me is ... what is this advanced feature set you see pintail having
14:19:57 <bexelbie> expanded I mean
14:20:02 <bexelbie> I think I've got everything we have today
14:20:10 <bexelbie> and I believe search can be added with relative ease
14:20:30 <randomuser> elasticsearch and site heirarchy inclusive of multiple sources
14:21:30 <bexelbie> ok
14:21:35 <bexelbie> elasticsearch I think is solveable
14:21:40 <bexelbie> but I concede upfront I know nothing about it
14:21:52 <bexelbie> however asciibinder delivers a sitemap.xml that I think can drive it
14:22:10 <c0mrad3> .hello dhanvi
14:22:11 <bexelbie> site hierarchy inclusive of multiple sources - I believe we need two layers
14:22:12 <zodbot> c0mrad3: dhanvi 'Tummala Dhanvi' <dhanvicse@gmail.com>
14:22:19 <randomuser> in the near term, the presentation has far enough to go that I'd like to explore the idea of publishing an asciibinder site
14:22:22 <bexelbie> Lang->Release->document_set
14:22:31 <bexelbie> I believe I can make that work
14:22:55 <bexelbie> I hope to have an English + Japanese site up by the end of the day for you to see
14:23:03 <randomuser> sweeet
14:23:16 <bexelbie> I could use some help on the elasticsearch side as I have never even looked up
14:23:19 <bexelbie> up == at it
14:23:24 <bexelbie> not sure where "up" came from
14:23:43 <bexelbie> and then there are the issues with the docbook->asciidoc conversion - but again - I think we are close
14:23:46 <randomuser> yeah, i have a tab up with https://www.elastic.co/guide/en/elasticsearch/guide/current/_preface.html
14:24:07 <bexelbie> that makes you an expert compared to me :)
14:24:37 <randomuser> ha
14:24:42 <bexelbie> I wonder if this can be fed to it
14:24:43 <bexelbie> https://fedorapeople.org/~bex/asciibinder/sitemap.xml
14:24:47 <bexelbie> warning that url is fragile
14:24:53 * c0mrad3 reading logs
14:25:29 <randomuser> eh, i think you put more data in elasticsearch
14:25:31 <randomuser> ideally
14:26:17 <randomuser> but it's not a pivotal area for now imo, i'd rather hear about the process you're using to make asciibinder do multiple source repos
14:26:49 <randomuser> iirc you said there were some manual steps
14:27:12 <bexelbie> randomuser, I suspect we can do more with elasticsearch - but today I believe we have no search
14:27:18 <bexelbie> so anything is a win
14:27:27 <bexelbie> I am working on a builder script that automates it completely
14:27:36 <bexelbie> I have it done except for the application of the .po files
14:27:38 <bexelbie> working on that now
14:27:46 <randomuser> nice
14:27:55 <bexelbie> obviously it will require more refinement overtime as we go to automation
14:28:03 <bexelbie> but it is a shell script of preprocessing magic
14:28:06 <bexelbie> short version
14:28:16 <randomuser> iterative development, check
14:28:26 <bexelbie> In each doc repo is a full ascibinder build out for a single book
14:28:36 <bexelbie> and the ability to produce (manually) books in other languages for checking
14:28:57 <bexelbie> in the docs-fp-o repo there is a script that builds out a hierarchy asciibinder can handle to build the whole megillah
14:29:36 * bexelbie drops some Yiddish-American Idiom magic!
14:30:02 <bexelbie> if you'll be around for a few - I can probalby upload it for people to see
14:30:18 <randomuser> script? have you pushed this?
14:30:36 <randomuser> ah
14:31:11 <randomuser> yeah, i'd like to catch up with you where I can
14:31:37 <bexelbie> let me check
14:31:47 <randomuser> ideally, I'd like to be able to replicate your builds enough to spend time on further content conversion while you're making progress with the builds
14:31:59 <bexelbie> randomuser, good goal
14:33:39 <bexelbie> randomuser, https://pagure.io/docs-fp-o-asciibinder/tree/master-adoc
14:33:42 <bexelbie> builder.sh
14:34:00 <bexelbie> WARNING!!!! I am fairly constantly overwriting the last commit in this repo
14:34:10 <bexelbie> so history is not stable
14:35:22 <randomuser> this is where all the 500 response codes pagure is handing out are coming from :)
14:35:49 <bexelbie> ??
14:35:58 <randomuser> i'm joking, probably not
14:36:02 <bexelbie> heh
14:36:12 <randomuser> there were some backend problems earlier, i think
14:36:37 <bexelbie> ahh, probably my fault :)
14:36:46 <bexelbie> there are some caveats with this script that are not noted
14:36:49 <randomuser> we must assume so
14:36:55 <bexelbie> specifically, it assumes a clean working environment
14:37:06 <bexelbie> I'll try to add a reset script or a cleanup routine
14:37:12 <randomuser> cool
14:37:50 <bexelbie> boom and now your history is wrong :)
14:38:08 <bexelbie> I actually have a reason for doing that .. I wouldn't normally just break history
14:38:17 <bexelbie> if you become active I'll move to a topic branch
14:38:26 <bexelbie> but I need some commits temporarily so this is easier
14:38:33 <randomuser> yeah, it's fine
14:39:32 <randomuser> your scripts are pulling from bex prefixed things, a direct merge isn't applicable anyway
14:39:43 <bexelbie> that is just so I didn't mess with the books
14:39:50 <bexelbie> obvs that has to go ...
14:39:58 <bexelbie> or we have to come up with a fantastic acronym for bex :)
14:40:08 <bexelbie> I also rewrite those a lot
14:40:16 <bexelbie> and the bex-virt-.... has a good readme in it now
14:40:19 <bexelbie> one other note
14:40:26 <bexelbie> I am working in a set of branches name *-adoc
14:40:33 <bexelbie> and I use master-adoc as my "master"
14:40:37 <randomuser> ++
14:40:38 <bexelbie> there isn't a good reason for it - it just happened
14:40:40 <bexelbie> and will be fixed
14:41:04 <randomuser> bexelbie on Fedora full time is a good thing, it seems
14:41:46 <bexelbie> randomuser, not official until 3 October - but this is tied (albeit loosely) to somthing in my $dayjob now
14:41:48 <bexelbie> :)
14:42:57 <randomuser> i think I can work with this
14:44:04 <randomuser> thanks for working on it, bexelbie
14:44:16 <randomuser> #topic F25 Release Cycle
14:44:27 <randomuser> #link https://fedorapeople.org/groups/schedule/f-25/f-25-docs-tasks.html
14:44:39 <randomuser> obviously I still need to clear the beats table
14:44:52 <randomuser> and send a kickoff mail that's way overdue
14:45:59 <randomuser> there are a small number of reported Changes, however, so the work will either be light, or require a bunch of research
14:46:51 <randomuser> #info relnotes need writing
14:47:20 <randomuser> #topic Specific Doc Status
14:47:50 <randomuser> in this part of the show, we discuss specific changes needed in specific pieces of content
14:48:07 <kushal> Hi everyone :)
14:48:24 <randomuser> Hi kushal, welcome
14:49:23 <randomuser> i'd call out the installation guide here, there's a new default deliverable probably that writes images, and I don't know that we're covering it
14:49:30 <randomuser> cspicer1, are you aware of this thing?
14:50:08 <randomuser> https://fedoraproject.org/wiki/Changes/FedoraMediaWriterAsPrimaryDownloadable specifically
14:50:10 <cspicer1> Uh, no I'm not sure if i am
14:50:49 <cspicer1> ah i see
14:51:42 <randomuser> are you up for throwing together some procedural content for this tool?
14:52:17 <pbokoc> hah, we can finally get rid of that powershell BS
14:52:41 <randomuser> win!
14:52:48 <cspicer1> right well, yeah sure
14:53:00 <randomuser> win win!
14:53:32 <randomuser> any other content changes to call out? kushal, did you have something?
14:54:08 <kushal> randomuser, /me and trishnag slowly filling up http://fedoracloud.rtfd.org/
14:54:20 <cspicer1> I'll have a look at it tonight and come up with a procedure for the basic use case, etc, at some point soon
14:54:22 <randomuser> ohh exciting
14:54:32 <kushal> randomuser, also trying to build a sphinx theme for fedora based projects.
14:54:50 <randomuser> except... i don't know anyone that uses vagrant for production :)
14:54:52 <kushal> ryan is working that.
14:55:22 <kushal> randomuser, :)
14:55:32 <randomuser> sorry, this is a pet peeve of mine
14:55:54 <bexelbie> kushal, before we do that can we decide why we need it when we are moving to an easy to use asciidoc system?
14:56:28 <randomuser> from what little I know, it seems like a legit atomic deployment needs one to have a build pipeline for both atomic host images and the containers that live on them
14:56:36 <kushal> bexelbie, because all of our python apps are using sphinx, that is why we are keeping it in rst, can be converted to anything in future as required.
14:56:46 <randomuser> yes, also that
14:57:30 <kushal> We have few patches ready at https://github.com/fedora-cloud/fedoracloud/pulls will merge those this week.
14:58:00 <kushal> randomuser, I just started having a production atomic instance from yesterday, building the images there only :(
14:58:28 <randomuser> i think bex's point is that the designer that was going to do docs site styling for us is now doing docs styling that does not help Fedora Docs at all, and that's disappointing
14:59:24 <kushal> randomuser, this is for standard projects, not for any particular projects.
14:59:42 <kushal> Many of our apps keep docs in sphinx, we can apply this theme there.
14:59:49 <randomuser> but yeah, when we actually dig into atomic docs, I really want to document how to do a real production deployment, not a vagrant proof of concept on a macbook
15:00:23 <randomuser> or vagrant on libvirt, as the case may be
15:00:41 <randomuser> ... and, time is up
15:00:52 <kushal> randomuser, can I talk after meeting?
15:00:57 <randomuser> #action randomuser to look into conversion/inclusion of fedora cloud user guide
15:01:09 <randomuser> absolutely, kushal, #fedora-docs
15:01:12 <randomuser> #endmeeting