15:00:43 <adamw> #startmeeting Fedora QA meeting
15:00:44 <zodbot> Meeting started Mon Sep 12 15:00:43 2016 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:44 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:00:45 <adamw> #meetingname fedora-qa
15:00:46 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:47 <adamw> #topic Roll call
15:00:49 <adamw> ahoyhoy folks, who's here for the qa meeting?
15:00:54 * kparal is here
15:01:06 * tenk is here
15:01:30 * tflink is here
15:01:38 * pschindl is here
15:01:41 <sumantro> \me is here
15:01:44 * a2batic is here
15:01:47 * sumantro is here
15:01:47 * garretraziel is here
15:02:23 <adamw> morning everyone
15:02:31 <adamw> or, you know, timezone-appropriate-greeting
15:02:33 <adamw> :)
15:03:05 <adamw> #topic Previous meeting follow-up
15:03:19 <adamw> hmm, looks like we had no action items last time
15:03:19 <sumantro> morning adamw :)
15:03:31 <adamw> can anyone think of anything that needs following up on that we won't hit otherwise?
15:03:45 <garretraziel> good tea at five??
15:04:39 * coremodule is here.
15:05:09 <adamw> garretraziel: ...is that some sort of code?
15:05:24 <garretraziel> it's timezone-appropriate-greeting
15:07:12 <adamw> i see
15:07:29 <adamw> but clearly not culturally appropriate...don't try telling me you're drinking tea
15:07:31 <adamw> :P
15:07:37 <adamw> alrighty, seems like we have no follow up
15:07:51 <adamw> #info no action items or other follow-up from 2016-08-22 meeting
15:08:14 <adamw> #topic Fedora 25 Beta status
15:08:30 <adamw> i didn't really have anything specific for this, but it seemed a sensible thing to stick on the meeting agenda
15:08:49 <adamw> for now we're just rolling towards the freeze with nightly testing, we got a nightly nominated last week, blocker review will be after this meeting
15:09:02 <cmurf> megablockerreview
15:09:04 <adamw> anyone have any specific notes or concerns for the beta?
15:09:12 <adamw> yeah, get your tea ready
15:09:29 <cmurf> tea tree
15:09:47 <garretraziel> haha, I like that we are all saying "tea" but mean "whiskey"
15:10:08 <cmurf> irish tea/coffee
15:10:28 <cmurf> besides, it's morning here
15:10:38 <adamw> cmurf: make sure you pick a smooth, er, tea then
15:10:51 <kparal> I've started reporting all wayland issues I see, originally it was terrible, now it's improving
15:11:07 <kparal> it's even almost usable now
15:11:15 <cmurf> i ran into some weird copy paste stuff from Terminal to gedit
15:11:45 <adamw> kparal: awesome, thanks for that
15:12:00 <cmurf> there's going to be a crazy edge case ;-)
15:12:08 * adamw did for a while but was driven out by the password prompt paste bug...
15:12:32 <cmurf> that sucks everywhere, not just wayland
15:12:38 <kparal> I also started updating "known wayland issues" wiki and will link it to common bugs
15:12:59 <cmurf> that it works ok on X is a rare thing in the world of Windows and macOS where pasting from a password manager is, "is it gonna work? should it work?"
15:14:01 <adamw> kparal: awesome again
15:14:18 <adamw> kparal: are there any major wayland issues you're worried might compromise the beta and won't be fixed by then?
15:14:24 <kparal> today I had to play 5 FPS games
15:14:33 <kparal> awful job this is
15:14:34 <cmurf> had to haha
15:15:11 * adamw hands kparal a copy of Chex Quest
15:15:27 <kparal> adamw: at this moment I know only about https://bugzilla.redhat.com/show_bug.cgi?id=1373169 that could delay Beta
15:15:37 <tflink> adamw: no copies of the taco bell FPS from the same era?
15:15:45 <adamw> CHEX 4 LIFE YO
15:15:47 <kparal> everything else is either Final or cosmetic
15:16:13 <adamw> alrighty
15:16:17 <adamw> looks like that one's getting attention
15:16:28 <cmurf> yeah i'm not running into 1373169 on F24 on Wayland
15:19:02 <adamw> #info Fedora 25 Beta testing is rolling along, 20160909.n.0 nightly is the current validation test compose, freeze will be 2016-09-27, we are not aware of any major issues that may affect the Beta schedule at this stage outside of the usual blocker process
15:19:11 <adamw> #topic Test Day status
15:19:22 <adamw> #chair sumantro kparal
15:19:22 <zodbot> Current chairs: adamw kparal sumantro
15:19:35 <adamw> sumantro: i think you're the most up to date on test days...what's the current status?
15:20:08 <sumantro> mbiza was on leave and  Fedora Media Writer test day is going to be on 20th
15:20:41 <sumantro> the test cases are ready to start with except for the website part which Paul assured will be taken care
15:21:06 <cmurf> What's the Windows and macOS code signing status?
15:21:13 <kparal> is there a rewrite of FMW or it stayed the same as in F24?
15:21:23 <kparal> mbriza was talking about rewriting it to C
15:21:35 <cmurf> Yeah I"m not sure good question
15:21:54 <sumantro> yes kparal he was , I am yet to hear from him about the signing status although
15:22:49 <kparal> in case he has some beta with new code, we should get it to updates-testing asap
15:22:53 <kparal> just noting
15:23:08 <adamw> the github repo hasn't really been touched since june: https://github.com/lmacken/liveusb-creator/commits/develop
15:23:12 <adamw> dunno if he's working on it elsewhere
15:23:31 <sumantro> but mbriza asked me to go ahead with the test day after one week of his return which is 20th
15:23:37 <adamw> #info Media Writer Test Day will be on 2016-09-20
15:23:58 <cmurf> ok so the test day needs to be moved is what it sounds like
15:24:05 <adamw> cmurf: ...why?
15:24:24 <adamw> sumantro just talked to the maintainer within the last couple of days and decided on the date.
15:24:39 <kparal> please don't forget to add it to fedocal
15:24:45 <cmurf> oh i interpretted that as he's getting back on the 20th
15:24:51 <sumantro> yes , its final . I already had "go" from him
15:24:55 <cmurf> okok
15:25:02 <sumantro> no he is geting back today itself
15:25:13 <adamw> #action sumantro to list Media Writer test day in fedocal
15:25:21 <adamw> sumantro: do you know about fedocal?
15:25:22 <sumantro> done :)
15:25:25 <adamw> ah k :)
15:25:29 <sumantro> Yes I do :)
15:25:33 <adamw> #undo
15:25:33 <zodbot> Removing item from minutes: ACTION by adamw at 15:25:13 : sumantro to list Media Writer test day in fedocal
15:25:34 <adamw> ok
15:26:00 <adamw> have we checked if the testdays web app is working?
15:26:29 <sumantro> It was working the last time we did it couple of months ago :)
15:26:54 <kparal> things change!
15:27:14 <kparal> you must not trust our tools :)
15:27:38 <sumantro> I will check it myself :)
15:27:47 <kparal> thanks
15:28:02 <adamw> #action sumantro to check testdays webapp is working ahead of test days starting up
15:28:27 <adamw> pschindl: https://fedorahosted.org/fedora-qa/ticket/488 is assigned to you - any news on that one?
15:28:35 <adamw> that's "Modem support", for those playing along at home
15:30:57 <cmurf> what's a modem?
15:31:03 <adamw> can someone check if pschindl is passed out under his chair, clutching a whisky bottle?
15:31:05 <pschindl> I looked on it last week and found out that this test day is over. But no one has announced it
15:31:37 <kparal> self-organizing testdays, awesome
15:31:43 <cmurf> it's over as in it happened?
15:31:59 <adamw> haha, okay
15:32:04 <pschindl> yes it happened
15:32:14 <adamw> well, that solves that problem, i guess?
15:32:42 <sumantro> \me wrote an article on how to organize your own test days , people took that seriously
15:32:51 <pschindl> But I will probably suggest to lkundrak to run it again in better time (not in alpha release time) and with some announcement.
15:33:15 <adamw> sumantro: we normally kinda figure there'll be an announcement on the mailing list at least, but hey
15:33:38 <adamw> #info "Modem support" Test Day already happened without much fanfare, pschindl may suggest re-running it later in the cycle
15:34:18 <adamw> so the other one we have on the list is storaged, sumantro you and I discussed that a bit, are you OK moving forward with it from here?
15:34:27 <sumantro> adamw yes , my eyes are always on the mailing list
15:34:37 <sumantro> adamw yes I am making progress with it
15:34:41 <adamw> great
15:34:48 <cmurf> seems to be going ok so far
15:34:55 <cmurf> i'm hitting all the same bugs I did with udisksd
15:34:58 <cmurf> :-P
15:35:07 <adamw> #info sumantro is also moving forward with storaged test day - https://fedorahosted.org/fedora-qa/ticket/489
15:35:25 <adamw> cmurf: that's...great...i guess? :)
15:35:57 <cmurf> most of the time that's probably true as weird as it sounds
15:35:58 <adamw> hmm, the thing that looks like it's missing from that list is wayland
15:36:13 <adamw> i have a horrible feeling i might have volunteered to do something about that at some point
15:36:17 <adamw> but unless anyone can show me a log i'm gonna deny it
15:37:21 <cmurf> adamw you need to give up this computer stuff and run for office
15:38:04 <adamw> nah, if i was a good politician i would never have brought it up in the first place, then if someone mentioned it i would've said that wasn't me, it was an intern
15:38:56 <cmurf> that you're aware of this makes you a good politician, the problem is you currently lack sufficient staff
15:39:35 <adamw> hmmm! good point. i could certainly do with more human shields^H^H^H^H^H^H^H^H^H^H^H^H^H^H^Hinterns
15:39:43 <cmurf> haha see!
15:39:47 <cmurf> minions
15:40:04 <adamw> #action adamw to do something about a wayland test day
15:40:14 <adamw> alrighty, now i've set up THAT hostage to fortune...
15:40:20 <adamw> anyone have any other test day-ish topics?
15:40:28 <cmurf> graphics switching?
15:40:39 <cmurf> GPUs switching thingy
15:41:08 <cmurf> I don't really know how that gets tested is the thing
15:41:30 <adamw> we don't do anything specific for that.
15:41:45 <adamw> it's just another hardware enablement topic where if it's broken, people file bugs...
15:41:55 <adamw> if we wanted to have a test day for it it'd be an appropriate topic, for sure.
15:41:56 <cmurf> a.) have a computer with two GPUs b.) do some activity that causes it to switch from one to the other GPU, and then back again
15:42:32 <cmurf> i'm willing to bet exactly no one encountering related bugs will know it has anything to do with GPU switching
15:43:04 <cmurf> you'd have to already be suspicious of this
15:43:07 <adamw> um
15:43:11 <adamw> i'm not sure that's really how it works
15:43:37 <adamw> i haven't exactly kept up that much, but my understanding is that GPU switching *doesn't* really work on linux in general unless you jump through some hoops to make it.
15:43:52 <cmurf> I thought the feature was to make it automatic
15:44:10 <adamw> oh, we're talking about a specific feature here? i thought you jsut meant the topic in general
15:44:27 <adamw> ah, https://fedoraproject.org/wiki/Changes/BetterSwitchableGraphicsSupport
15:44:29 <kparal> it's a change of f25
15:44:57 <kparal> but I haven't seen any progress report
15:45:12 <cmurf> yeah last updated july 18
15:45:32 <cmurf> "OS can choose to switch to the dgpu when more gpu-power is necessary" sounds automagic
15:45:46 <adamw> yeah, it does.
15:46:10 <adamw> the page has good info on what would need to be tested too
15:46:32 <adamw> sumantro: do you think you could work on a test day for this too, or are you fully loaded now?
15:47:09 <sumantro> No i still have enough bandwidth to take it up, I will start off by sending mails to change owners
15:47:13 <cmurf> kinda amusing it's not a system wide change but suspend should be tested to make sure you get back a working display upon wake
15:47:43 <adamw> cmurf: the 'system wide change' concept isn't exactly from the perspective of the end user sitting in front of a single 'system', but from the perspective of the distro as a whole. it could use some refining, though, i guess
15:47:53 <adamw> i think it was my idea, which is probably why it's awful
15:48:01 <cmurf> gotcha
15:48:13 <adamw> things like this don't fit comfortably in either bucket
15:48:14 <adamw> alrighty
15:48:25 <adamw> #action sumantro to organize a test day for https://fedoraproject.org/wiki/Changes/BetterSwitchableGraphicsSupport
15:48:33 <adamw> sumantro: and create a trac ticket so we can track it
15:48:44 <adamw> oooh, hey, that reminds me
15:48:46 <adamw> guerilla topic change!
15:48:48 <sumantro> sure! :)
15:48:52 <adamw> #topic Fedorahosted retirement
15:49:10 <adamw> so, for anyone who didn't catch the announcement, fedorahosted is going away in February
15:49:39 <sumantro> Yes are we shifting to pagure ?
15:49:46 <adamw> we currently host a few little bits and pieces of code in the fedora-qa fedorahosted git repository; this shouldn't be a major problem, we can easily migrate that to pagure or phab or something
15:50:08 <adamw> what's more difficult is the question of what we do with trac
15:50:28 <adamw> we still use the fedorahosted trac instance - https://fedorahosted.org/fedora-qa - as our 'non-code issue tracker'
15:50:39 <sumantro> can't we create or migrate the tickets to pagure?
15:50:48 <adamw> the most obvious use is for test days, but we have also used it for stuff like keeping track of proposed major changes to a policy or something
15:51:06 <adamw> sumantro: we could, yeah, it's an option...but i'm not totally sure if it fits comfortably with the pagure design
15:51:22 <adamw> pagure is designed kinda like github, it's very focused on 'projects', i.e. code projects
15:51:33 <adamw> we could i guess just create a 'fedora-qa-issues' project with no code or something and use the issue tracking
15:52:00 <adamw> we only have 9 mins left so i guess we can't settle this right now, but i thought i'd bring the issue up quickly and see if anyone has thoughts...
15:52:15 <kparal> can we add tags to tickets, or use ticket categories?
15:52:52 <adamw> dunno. i've got one project hosted on pagure but really haven't used the issue tracking much (i think only with you :>)
15:53:09 <kparal> ok
15:53:25 <adamw> nirik replied to my mail to devel@ about this and said pagure *is* the recommended migration path for non-code tracs, so i guess unless we want to self-host trac or some other issue tracker, that's the most likely path...
15:53:48 <nirik> pagure issues are pretty reasonable for the simple cases.
15:53:54 <kparal> currently we link to our track to "test days" category from the test days wiki page, which is handy to see all relevant tickets
15:53:56 <nirik> and getting improvements all the time
15:53:58 <kparal> *trac
15:54:04 <nirik> you can tag issues.
15:54:18 <nirik> support just landed for reports (sets of tags)
15:54:31 <adamw> okay. sounds good.
15:54:42 <kparal> sounds good enough, we don't handle that many tickets anyway
15:54:53 <adamw> is there any kind of migration tool?
15:54:58 <kparal> there is
15:55:00 <nirik> yeah, pgimporter
15:55:07 <nirik> there's a copr for it and a pagure project for it.
15:55:22 <nirik> it can move tags and milestones too. (although the milestone support has some bugs I think)
15:55:29 <adamw> cool.
15:55:50 <nirik> https://pagure.io/pagure-importer
15:55:57 <nirik> if folks want to test, you can use stg.pagure.io
15:56:05 <adamw> #info pagure is the recommended migration path for non-code tracs, it has tag support and just got 'report' support (sets of tags), there is a migration tool called 'pgimporter'
15:56:29 <nirik> https://copr.fedorainfracloud.org/coprs/cverna/pagure-importer/
15:56:43 <adamw> does anyone want to take charge of handling this migration? might be an interesting and not-too-big project
15:57:04 <sumantro> i want to , I want to! :)
15:57:20 <a2batic> Me too :)
15:57:54 <adamw> maybe you can work together on it?
15:58:01 <tflink> are there any required permissions?
15:58:27 <adamw> tflink: not sure...if anything they may need elevated permissions to read all the data out of trac for export
15:58:30 <sumantro> adamw we are both based out of the same office as interns :)
15:58:30 * kparal is seeing volunteers, maybe he should cut down on the beer
15:58:40 <adamw> sumantro: yep, that was what i thought :)
15:58:48 <adamw> kparal: i know, i'm scared too
15:59:11 <adamw> sumantro: if you need trac permissions to read the data for export, just let me and/or tflink know
15:59:17 <nirik> you need xmlrpc enabled on the trac and a login/pass... I guess you might need perms to look at private tickets if you have any
15:59:19 <sumantro> sure! :)
15:59:26 <a2batic> Ya we can work together !!
16:00:10 <tflink> would we be migrating it to a team/group on pagure?
16:00:23 * tflink doesn't recall how groups work in pagure
16:00:24 <adamw> #action sumantro and a2batic to work on planning migration from trac: so, see if there's any reasonable alternative to pagure and write up a comparison if so, once we pick an option, look into the details of the migration and propose a plan (with timeline) for activating the new system and shutting down the old one
16:00:31 <tflink> and hopes this hasn't been discussed already
16:00:41 <adamw> tflink: this is all stuff i figure sumantro and a2batic can look into and come back with info for us
16:00:58 <adamw> does that sound good to you two?
16:01:03 <sumantro> sure! :D
16:01:09 <adamw> okay :)
16:01:09 <a2batic> adamw, yep :)
16:01:23 <irina__> tross: ping
16:01:24 <zodbot> irina__: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
16:01:39 <adamw> ok great
16:01:44 <adamw> so we're over time, but let's do a quick:
16:01:46 <adamw> #topic Open floor
16:01:50 <adamw> any other really urgent business?
16:03:27 <adamw> that sounds like a no!
16:03:37 <adamw> i kinda wanted to throw in a "modularity update" topic but i guess that can wait.
16:04:56 <adamw> thanks for coming, folks!
16:05:07 <adamw> blocker review starting up in #fedora-blocker-review now, see you all over there. RIGHT? ;)
16:05:21 <sumantro> Thanks for chairing adamw
16:05:24 <sumantro> :)
16:05:29 <a2batic> thanks adamw :)
16:08:46 <adamw> #endmeeting