14:01:19 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:01:20 <zodbot> Meeting started Mon Sep 12 14:01:19 2016 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:20 <zodbot> The meeting name has been set to 'docs_project_meeting_-_agenda:_https://fedoraproject.org/wiki/docs_project_meetings'
14:01:20 <randomuser> #meetingname Fedora Docs
14:01:20 <zodbot> The meeting name has been set to 'fedora_docs'
14:01:20 <randomuser> #topic Roll Call
14:01:50 <c0mrad3> .hello dhanvi
14:01:54 <zodbot> c0mrad3: dhanvi 'Tummala Dhanvi' <dhanvicse@gmail.com>
14:02:11 <bexelbie> .hello bex
14:02:13 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
14:04:20 <randomuser> #chair bexelbie
14:04:21 <zodbot> Current chairs: bexelbie randomuser
14:04:32 <randomuser> #chair zoglesby
14:04:33 <zodbot> Current chairs: bexelbie randomuser zoglesby
14:05:40 * pbokoc 
14:05:46 <randomuser> quiet today
14:06:04 <bexelbie> then my vote to move us all to tex will go smoothly muahahahah
14:06:12 <randomuser> #topic Release Cycle Status
14:06:21 <randomuser> ha
14:06:34 <randomuser> #link https://fedorapeople.org/groups/schedule/f-25/f-25-docs-tasks.html
14:07:16 <randomuser> this week the schedule has us porting relnotes wiki content to docbook/git
14:07:26 <pbokoc> hah!
14:07:38 <randomuser> we're behind on content creation... so this also means writing the content
14:08:09 <randomuser> I got a small bit of it done over the weekend, should probably send out some kind of mail
14:08:24 <pbokoc> beta release is supposed to be a month from now, that's doable
14:08:39 <randomuser> definitely doable
14:08:50 <randomuser> #action randomuser to send mail about release notes
14:09:15 <randomuser> although it might be more expedient to jump directly to git at this point, skip the wiki stuff
14:10:25 <randomuser> there aren't a whole lot of declared Changes, but there are probably some undeclared Changes
14:10:38 <randomuser> 'undeclared changes' i mean
14:10:39 <pbokoc> yeah, +1 on going straight to git
14:11:20 <randomuser> I'd just as soon let the release notes represent the Change process at this point and spend the extra time on our other work
14:12:18 <pbokoc> just 20 changes... maybe we could track progress in pagure? Create an issue under Release Notes for each Change + anything other we can find, and people can assign them to themselves if they work on anything
14:12:34 <randomuser> I like it
14:12:57 <randomuser> bexelbie, ?
14:13:09 <c0mrad3> +1 pagure
14:13:20 <bexelbie> +1 pagure tracking
14:13:32 <bexelbie> would let us think about a new process moving forward
14:13:43 <pbokoc> alright, I'll create issues in the evening
14:13:50 <bexelbie> where issues + zoglesby's magical issue conglomerator can show it all on one page
14:13:51 <bexelbie> :)
14:13:55 <randomuser> #agreed we will file pagure issues for each Change against the release notes project
14:14:08 <randomuser> #action pbokoc to file release notes issues
14:14:32 <randomuser> #action randomuser to find stuff telling people how to get content in release notes and put pagure issues there
14:14:33 <pbokoc> I'll cover the official stuff. If anyone finds anything not listed in https://fedoraproject.org/wiki/Releases/25/ChangeSet open one as well
14:14:49 <randomuser> terminal, welcome
14:15:12 <terminal> Thanks, hi
14:15:38 <terminal> Keep dropping out...
14:16:04 <pbokoc> oh btw, grundblom was asking on the list whether we're still doing docbook for this release's RNs... I'm assuming don't have plans on doing them in ADoc, is that correct?
14:16:14 <pbokoc> ...or tex :))
14:16:27 <bexelbie> I don't think anything but kuneiform or docbook is possible for F25
14:16:36 <randomuser> that's a good question... I'd say docbook is the safe bet for now
14:16:45 <bexelbie> I think we should think about an F25 midstream conversion goal
14:17:44 <randomuser> sounds reasonable
14:18:13 <randomuser> anything else we should cover re: release cycle?
14:18:50 <pbokoc> also someone should close all beats if we're skipping wiki
14:19:02 <randomuser> oh, good call
14:19:11 <pbokoc> have fun with that :P
14:19:17 <randomuser> #action randomuser to close beats when sending mail saying we're skipping wiki
14:19:49 <randomuser> pbokoc, there's a mostly functional script in tools.git for the header on the individual beats pages
14:20:09 <randomuser> #topic Specific Doc Status
14:20:37 <pbokoc> I hear SpaceX had a mostly functional rocket until about a week ago :)
14:20:53 <randomuser> i was looking for a mail about the translation quick start guide
14:21:38 <randomuser> it seems like I skimmed such an email while not quite awake
14:22:07 <pbokoc> randomuser, there's something on fedora-trans
14:22:13 <randomuser> yeah, that was it
14:22:20 <pbokoc> er, trans@lists.fp.o
14:23:08 <randomuser> i didn't think that had been updated in a while
14:23:19 <pbokoc> I wonder how relevant that guide is now, though. I don't recall seeing a commit to the english version, like ever
14:23:27 <randomuser> https://git.fedorahosted.org/cgit/docs/translation-quick-start-guide.git/
14:23:44 <randomuser> we didn't update for zanata or even get the commits into pagure
14:23:59 <bexelbie> ugh - a translation guide was somethign I was going to ask about
14:24:05 <bexelbie> do we have a designated contact on that team?
14:24:10 <randomuser> they've been doing the wiki... we'll probably be asked to unpublish
14:24:58 <pbokoc> bexelbie, Noriko Mizumoto (noriko@fedoraproject.org) is a good person to talk to, I'd say
14:25:30 <pbokoc> I recall she coordinated the move to Zanata, for example
14:25:37 <randomuser> yeah, noriko has been quite active lately
14:25:56 <randomuser> although the trans@list gets read fairly widely
14:26:06 <pbokoc> true
14:27:02 <bexelbie> ok
14:27:12 * bexelbie goes off looking for the translist page too
14:27:32 <randomuser> bexelbie, I don't see a lot to do there at the moment - we can offer to convert their wiki pages, or make sure their content for talking to us is up to date
14:27:55 <randomuser> but iirc they've been good about checking with us on such things
14:28:12 <bexelbie> I think we should just start a conversation with them about making sure the page is up to date so we can rely on it with regards to the new toolchain proposals
14:28:20 <bexelbie> which wiki page?
14:28:55 <randomuser> I really can't say, sorry
14:29:31 <randomuser> it's a wiki situation, I assume there are five and three of them explicitly conflict (through no fault of the l10n team)
14:29:43 <bexelbie> +1 3 and 7
14:30:22 <randomuser> I'm all for engaging them, bexelbie, go for it
14:30:35 <bexelbie> I will - I am almost ready to engage them around asciidoc translations
14:30:41 <bexelbie> for my proposed toolchain
14:30:47 <bexelbie> which I want to ask a question about in new business
14:30:59 <randomuser> yes, let's get onto that
14:31:25 <randomuser> actually, you're chaired, change the topic to something apropos
14:32:07 <bexelbie> #topic New ToolChain for Publishing (and ruling the world)
14:32:29 <bexelbie> So ... I'll be upfront - I am at a point where I am ready to either spend my time this week trying to document
14:32:35 <bexelbie> my full proposal with demos, etc.
14:32:47 <bexelbie> or I want to know we are not going with it so I can stop working on the Fedora use case
14:32:52 <bexelbie> how do we get to a rough answer
14:33:03 <bexelbie> knowing that once everyone see the whole thing they may still vote it down
14:33:19 <bexelbie> in other words are we willing to change away from pintail, if I finish it up to a point that we could publish
14:33:37 <bexelbie> the big issue, in my mind is that this is an asciidoc ONLY toolchain
14:33:56 <bexelbie> it will not publish our legacy books in docbook - so I would propose not doing it for F25 and move for Asciidoc for F26 docs and forward
14:34:01 <bexelbie> and slowly deprecating the old site with EOL
14:34:05 <randomuser> but there are conversion tools, so it could be the end component of a not-asciidoc-only toolchain
14:34:07 <bexelbie> or doing retro-conversions as we have time
14:34:25 <bexelbie> conversion tools from DocBook -> AsciiDoc are not the most automatable
14:34:39 <bexelbie> I haven't found anyone who could do it without some manual effort
14:34:51 <bexelbie> and we need to still have a semantic discussion (see list)
14:34:52 <randomuser> sure
14:35:09 <randomuser> I need to reply to that - IMO you have an elegant solution for that
14:35:11 <bexelbie> now other formats -> asciidoc are probably more successful
14:35:21 <shaunm> I haven't seen this proposal. did I miss something?
14:35:37 <bexelbie> It has mostly been talkeda bout here
14:35:46 <bexelbie> I was going to finally write up the full details for this week
14:35:50 <randomuser> he's been playing with asciibinder, shaunm
14:35:52 <bexelbie> it is replacing pintail with asciibinder
14:36:03 <bexelbie> solves the xsl issues
14:36:13 <bexelbie> amongst others
14:36:44 <randomuser> I'll be honest here, I haven't gotten either tool to build something that looks good and easily navigable, and I don't think I've even gotten them to build something as good as others have produced with the same tools
14:37:25 <bexelbie> I won't consider a proposal successful until it can be recreated - mine included
14:37:44 <shaunm> what are the xsl issues?
14:37:44 <randomuser> shaunm, https://fedorapeople.org/~bex/asciibinder/en-US/f24/Welcome/docs-guide.html#
14:38:10 <randomuser> shaunm, there isn't any
14:38:12 <bexelbie> ignore the display error - it is an old display
14:38:43 <randomuser> there isn't any xsl, i mean
14:38:49 <randomuser> ... I think that's the issue?
14:39:06 <bexelbie> and https://fedorapeople.org/~bex/asciibinder/ja/rawhide/virt-getting-started-guide/What_Is_It.html
14:39:20 <bexelbie> I think of xsl as an issue affecting our ability to theme the docs
14:39:28 <bexelbie> I believe shaunm is the only person who has a handle on it
14:39:43 <bexelbie> iirc I heard that fedora design didn't have anyone who could work with it
14:39:52 <bexelbie> but that may be heresay and this may not be an issue
14:40:55 <shaunm> they don't have people who can write html?
14:41:03 <randomuser> I probably have not done it correctly or recently, but Design has not shown an interest in aiding our cause
14:41:13 <randomuser> 'done it' being try to get them to help
14:41:24 * randomuser drinks more coffee, attempts to compose complete sentences
14:41:34 <bexelbie> I was under the impression that pintail generated html via xsl and therefore theming was a combination of modifying the xsl and then writing a css
14:42:39 <bexelbie> please correct me if I am misunderstanding
14:42:50 <bexelbie> my work with pintail has solely been around generation - not actually trying to do anything with the output
14:44:55 <randomuser> my feeling at this point is that bexelbie's solution looks immediately publishable but doesn't have some of the features we like in pintail
14:44:55 <shaunm> bexelbie: my point is that what's in the xslt is literally just html. it's not black magic.
14:45:05 <bexelbie> so assuming we want to consider both proposals - perhaps we should talk about how they should be written up move forward?  Should I just do a string of blog posts with demos?
14:47:12 <randomuser> shaunm, I understand html and css, but reading the language doesn't make me a competent web designer
14:48:40 <shaunm> randomuser: I don't quite understand what you mean
14:48:53 * c0mrad3 googling for xslt!
14:49:07 <shaunm> I'm not saying that everybody who knows html and css is a competent web designer. I know html and css, and I'm a terrible designer.
14:49:14 <randomuser> heh
14:49:49 <randomuser> I'm saying the same thing, and that a competent web designer is probably needed to do that stuff
14:50:27 <shaunm> yeah, but I don't think designers should get hung up on backend technology. that's not their job.
14:50:42 * randomuser shrugs
14:50:51 <randomuser> there are no participating designers, it's a moot point
14:51:06 <shaunm> a long time ago, when I worked for wolfram, our designers gave me mockups as photoshop images, and I'd recreate them in html+css
14:51:28 <shaunm> and that's back when html+css sucked
14:52:11 <bexelbie> let's leave xsl alone then
14:52:21 <bexelbie> it sounds like pintail's use of xsl will never impact a designer
14:52:26 <bexelbie> as the docs can be themed solely with css
14:52:28 <bexelbie> is this right, shaunm ?
14:52:37 <bexelbie> we won't need to tweak the xsl ?
14:52:51 <shaunm> fwiw, for the minimal themeing that's there now, I literally just recreated the header on getfedora.org
14:52:54 * bexelbie last use xslt regularly for my Masters paper
14:53:25 <randomuser> well, we're saying that actual implementation work of any kind isn't in scope for designers
14:54:26 <randomuser> perhaps it's not helpful to have a design discussion at this point?
14:55:28 <shaunm> do you happen to remember the requirements we had on the board at the FAD?
14:56:00 <randomuser> not verbatim, but go on
14:56:43 <shaunm> I don't. I was hoping you did.
14:56:54 <shaunm> I took pictures, but I'd have to dig to find them.
14:57:19 <randomuser> multiple sources, automatable, good indexing, new markup
14:57:25 <randomuser> git sources
14:58:15 <bexelbie> https://ethercalc.org/txnb0f8lewsz ?
14:58:18 <c0mrad3> https://ethercalc.org/txnb0f8lewsz
14:58:33 * c0mrad3 ahh!
14:58:42 <randomuser> nice, good find
14:58:44 <c0mrad3> #link https://communityblog.fedoraproject.org/event-report-fedora-docs-fad/
14:58:55 <pbokoc> I was just gonna paste the same link as well :-D
14:59:15 <c0mrad3> :)
14:59:27 <randomuser> Well, our time is up
14:59:48 <randomuser> the struggle continues ...
14:59:57 <randomuser> thanks for coming, everyone, see you around
14:59:58 <bexelbie> :)
15:00:02 <randomuser> #endmeeting