15:06:07 <rdieter> #startmeeting kde-sig
15:06:07 <zodbot> Meeting started Tue Nov 22 15:06:07 2016 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:06:07 <zodbot> The meeting name has been set to 'kde-sig'
15:06:09 <rdieter> #topic roll call
15:06:17 <rdieter> hi all, friendly kde-sig meeting, who is present today?
15:06:25 <lupinix> .hello lupinix
15:06:26 <zodbot> lupinix: lupinix 'Christian Dersch' <lupinix@mailbox.org>
15:06:27 <heliocastro> here
15:06:43 <lupinix> but i'm at a conference, so will be quite quiet today
15:07:02 <pino|work> rdieter: o/
15:07:34 <tosky> o/
15:07:40 <linuxmodder> bkp,  remember seeing it but not replied :\
15:07:46 <than> present
15:07:55 <rdieter> #info lupinix heliocastro pino|work tosky than present
15:07:59 <rdieter> #info rdieter present
15:08:00 <rdieter> :)
15:08:06 <rdieter> #chair lupinix heliocastro pino|work tosky than
15:08:06 <zodbot> Current chairs: heliocastro lupinix pino|work rdieter than tosky
15:08:09 <pino|work> -_-'
15:08:13 <dvratil> hi guys
15:08:18 <rdieter> #info dvratil present
15:08:20 <rdieter> #chair dvratil
15:08:20 <zodbot> Current chairs: dvratil heliocastro lupinix pino|work rdieter than tosky
15:08:26 <rdieter> dvratil: hi
15:08:34 <pino|work> oh a (drunk|wild) dvratil appears
15:08:37 <pino|work> :p
15:08:42 <dvratil> pff :D
15:09:03 <rdieter> #topic agenda
15:09:07 <rdieter> ok, what to discuss today?
15:09:19 * rdieter can give status on qt-5.6.2, plasma-5.8.x updates
15:10:09 * heliocastro doesn't have anything new
15:10:21 <rdieter> heliocastro: qt-5.7.1 ?
15:10:36 <heliocastro> Oh yeah
15:10:43 * linuxmodder hanging out to catch up on kde things
15:10:44 <heliocastro> For some reason is blocked on copr
15:11:00 <heliocastro> Didn't had time to investigate
15:11:08 * jreznik_ is here
15:11:10 <rdieter> oh :(, good idea testing there first, I did same with 5.6.2
15:11:19 <rdieter> #info jreznik_ present
15:11:21 <rdieter> #chair jreznik_
15:11:21 <zodbot> Current chairs: dvratil heliocastro jreznik_ lupinix pino|work rdieter than tosky
15:11:26 * heliocastro using on his both machines
15:11:34 <rdieter> let's get started
15:11:51 <rdieter> #topic updates: plasma-5.8.x, qt-5.6.2, qt-5.7.1
15:12:24 <rdieter> this past week, (finally) queue'd plasma-5.8.3 and qt-5.6.2 for f24 -testing
15:12:47 <rdieter> https://bodhi.fedoraproject.org/updates/FEDORA-2016-47a1d520ae
15:12:57 <rdieter> f25 too, https://bodhi.fedoraproject.org/updates/FEDORA-2016-58403bce23 (but less interesting)
15:13:24 <rdieter> qt-5.6.2 for f24: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ee7faa4b02
15:13:36 <rdieter> started working on qt-5.6.2/f23 builds yesterday
15:13:42 <tosky> (less interesting unless you upgrade to f25)
15:14:13 <rdieter> only less intersting in that the f25 one is a minor update compared to f24's plasma-5.7 => plasma-5.8 bump
15:14:14 <tosky> I guess that 5.6.2 will be the last f23 upgrade
15:14:17 <tosky> ah, right
15:14:28 <rdieter> tosky: likely so, yes
15:14:47 <rdieter> I was tempted not to do it, until Kevin_Kofler mentioned that qt5-qtwebengine includes a fair number of security fixes
15:15:30 <rdieter> just downloaded plasma-5.8.4 tarballs now
15:15:54 <rdieter> so one open question: f24 feedback has been generally good, though a few reports of oddness have come in too recently
15:16:13 <Kevin_Kofler> Yeah, QtWebEngine 5.6.2 fixes: CVE-2016-1710, CVE-2016-1711, CVE-2016-5127, CVE-2016-5128, CVE-2016-5129, CVE-2016-5130, CVE-2016-5131, CVE-2016-1706, CVE-2016-5134, CVE-2016-5137, QTBUG-53800 (crash), CRBUG-394055 (crash) (private, see https://codereview.chromium.org/1714063002 for what we are allowed to see).
15:16:27 <rdieter> So, push 5.8.3 now'ish?  or wait for 5.8.4?  (if waiting, that complicates matters a small amount, due to qt-5.6.2)
15:16:41 <Kevin_Kofler> The list is similar in 5.7.1, by the way.
15:17:45 <Kevin_Kofler> The problem is that Plasma 5.8.3 has at least one bad regression, doesn't it?
15:17:50 <rdieter> plasma-5.8.3 oddities include: ksmserver 100% cpu usage reported (see bodhi comment)
15:17:57 <Kevin_Kofler> (Compared to 5.7 at least.)
15:18:33 <rdieter> Kevin_Kofler: someone mentioned a multidisplay issue (fixed in 5.8.4), don't recall the details though
15:19:05 <Kevin_Kofler> Yeah, that's the one I was thinking of.
15:19:45 <rdieter> https://phabricator.kde.org/D3319  this fix I believe
15:20:12 <rdieter> starting to regret I didn't backport the fix then :-/
15:20:56 <rdieter> anyway, opinions on whether we wait for plasma-5.8.4 that includes ^^ fix ?
15:21:26 <Son_Goku> would that particular issue be why my screens are always scrambled on load?
15:21:27 <heliocastro> If is iminent, yes
15:21:32 <heliocastro> no reason to double the work
15:21:33 <Kevin_Kofler> I'd wait at this point, the release is imminent.
15:21:37 <rdieter> (the implication will likely mean having to batch qt-5.6.2 and plasma-5.8.4 together)
15:21:58 <rdieter> heliocastro: ^^ means waiting will be more work :-/
15:22:14 <heliocastro> Ok. so whatever option do less work
15:22:20 <pino|work> according to the release page, 5.8.4 seems due for... today
15:22:27 <pino|work> https://community.kde.org/Schedules/Plasma_5
15:22:27 <rdieter> Son_Goku: my impresion is that it is a race condition
15:22:34 <Son_Goku> ah
15:22:34 <pino|work> so it makes sense to wait for .4
15:22:36 <rdieter> Son_Goku: so, not necessarily *always*
15:22:44 <Son_Goku> maybe I'm just unlucky then
15:23:00 <rdieter> Son_Goku: may be always for some users/machines, depends of course
15:23:23 <rdieter> ok, consensus seems to be to wait, will do
15:23:54 <rdieter> #action don't send plasma-5.8.3 to f24 stable updates, wait for 5.8.4
15:23:58 <rdieter> #undo
15:23:59 <zodbot> Removing item from minutes: ACTION by rdieter at 15:23:54 : don't send plasma-5.8.3 to f24 stable updates, wait for 5.8.4
15:24:05 <rdieter> #agreed don't send plasma-5.8.3 to f24 stable updates, wait for 5.8.4
15:24:18 <rdieter> heliocastro: qt-5.7.1 status ?
15:24:58 * rdieter probably won't have time to help qith qt-5.7.1 until after qt-5.6.2/plasma-5.8.4 is done first
15:25:55 <rdieter> heliocastro: you mentioned waiting on copr ?
15:29:36 <rdieter> hrm, maybe lost him, anything else on the topic before moving on?
15:31:06 <rdieter> moving on then...
15:31:10 <rdieter> #topic open discussion
15:31:14 <rdieter> anything else for today?
15:31:56 <rdieter> ah, small item came up on irc this past week, a user needed kdebugdialog, and appears we don't install that by default, any objection to adding it (for f26+) ?
15:32:37 <lupinix> what is the advantage?
15:32:50 <than> no objection from my side
15:32:57 <lupinix> IMHO we should keep the default small
15:33:42 <lupinix> so imho there should be a significant advantage for many users
15:34:49 <rdieter> it's a pretty small package, let me get details
15:35:20 <rdieter> sorry, package was kdebugsettings => 209k
15:35:44 <rdieter> it's a gui for newer qCDebug enablement
15:36:04 <rdieter> we already ship kdebugdialog/kdebugdialog5
15:36:17 <rdieter> (for older qWarnings and friends)
15:36:22 <Kevin_Kofler> I guess let's be consistent then and also ship kdebugsettings.
15:36:34 <Kevin_Kofler> kdebugdialog is for old kDebug, IIRC.
15:36:51 <lupinix> yes, then ship both
15:36:59 <rdieter> lupinix: since we already stray a bit from upstream by disabling debug by default
15:37:12 <rdieter> including this allows users an easy opt-in
15:37:40 <rdieter> k, I'll add it after meeting
15:37:43 <tosky> kdebugdialog will be probably not needed *as default* in few Applications releases
15:37:57 <rdieter> <nod>
15:38:18 <rdieter> it's part of kde-runtime, currently, unless we choose to split it out though
15:38:27 <rdieter> (kde4's kde-runtime)
15:44:05 <rdieter> looks like things have gotten quiet, will close meeting in soon if there's nothing else
15:45:11 <heliocastro> Wow, lost in time
15:45:15 <heliocastro> Sorry, work duty
15:46:07 <rdieter> heliocastro: want to give qt-5.7.1 status here/now, or rather later in #fedora-kde ?
15:46:12 <heliocastro> Quick overview:
15:46:20 <heliocastro> 5.7.1 gone to branching, but not released
15:46:32 <heliocastro> copr has all packages, including webengine free from kevin
15:46:48 <heliocastro> all compiles locally, but copr seens like to ignore my nre qt5 package
15:46:54 <heliocastro> and blocking compilation
15:47:10 <heliocastro> So far no difference felt from 5.7.0
15:47:16 <rdieter> I'd say go ahead with getting stuff in rawhide asap
15:47:26 <heliocastro> Ok, can do that
15:47:52 <heliocastro> I would love to fix copr, but i don't want to bother guys from buildsys again
15:48:01 * heliocastro too annoying this days
15:48:10 <rdieter> <nod>, can worry about that later
15:50:45 <rdieter> #action heliocastro will work on importing qt-5.7.1 into rawhide
15:51:06 <heliocastro> ok
15:51:25 <rdieter> thanks, anything else before closing?
15:51:42 <heliocastro> nope
15:52:56 <rdieter> k, thanks everyone
15:52:58 <rdieter> #endmeeting