19:01:06 <Rhea> #startmeeting Fedora DotNet (2016-11-29)
19:01:06 <zodbot> Meeting started Tue Nov 29 19:01:06 2016 UTC.  The chair is Rhea. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:06 <zodbot> The meeting name has been set to 'fedora_dotnet_(2016-11-29)'
19:01:07 <Rhea> #meetingname dotnet
19:01:07 <zodbot> The meeting name has been set to 'dotnet'
19:01:10 <Rhea> #nick dotnet
19:01:25 <Rhea> #topic Agenda
19:01:30 <Rhea> #link https://fedoraproject.org/wiki/Meeting:DotNet_2016-11-29
19:01:40 <Rhea> #info (1) Roll Call
19:01:42 <Rhea> #info (2) Announcements
19:01:47 <Rhea> #info (3) Action items and Tickets
19:01:48 <Rhea> #info (4) Packaging progress
19:01:52 <Rhea> #info (7) Open Floor
19:02:01 <Rhea> #topic Roll Call
19:02:11 <Rhea> #info Name; Timezone; Sub-projects/Interest Areas
19:02:14 * jflory7 watches from the back row
19:02:16 <bt0> .hello bt0dotninja
19:02:17 <zodbot> bt0: bt0dotninja 'Alberto Rodriguez Sanchez' <hotgalan@gmail.com>
19:02:19 <Rhea> #action dotnet New members, make sure you introduce yourself on the DotNet mailing list [ https://fedoraproject.org/wiki/DotNet ]
19:02:25 <Rhea> If this is your first time at a DotNet meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
19:02:26 <rkieley> .hello roddiekieley
19:02:27 <zodbot> rkieley: roddiekieley 'Roddie Kieley' <rkieley@unifiedsoftworx.com>
19:02:29 <bt0> #info Alberto Rodriguez S;UTC-6;Commops, Metrics, Packaging and more.
19:02:35 <Rhea> .hello rhea
19:02:36 <zodbot> Rhea: rhea 'Radka Janek' <radka.janek@redhat.com>
19:02:37 <Rhea> #info Radka Janek; UTC+1; CommOps, Diversity, DotNet,...
19:02:42 <Rhea> :]
19:02:45 <nmilosev> .fas nmilosev
19:02:46 <zodbot> nmilosev: nmilosev 'Nemanja Milosevic' <nmilosevnm@gmail.com>
19:03:22 <Rhea> Okay lets wait a few for others to show up :p
19:03:39 <tmds> hi all!
19:03:46 * Rhea waves
19:03:49 <rkieley> hey tmds
19:04:22 <bt0> hello everybody o/
19:04:44 <omajid> hello!
19:05:26 <Rhea> #chair omajid bt0 rkieley nmilosev tmds
19:05:26 <zodbot> Current chairs: Rhea bt0 nmilosev omajid rkieley tmds
19:05:36 <Rhea> #topic Announcements
19:05:58 <Rhea> I don't really have anything today, other than what we all know about - 1.1, tooling, ...all the things released
19:06:19 <Rhea> As for discussion / dev updates, that we should take on later
19:06:31 <Rhea> Anyone else knows about anything cool happening somewhere around dotnet? o.o
19:06:38 <Rhea> (or around Fedora...)
19:06:46 <tmds> there is the IDE from jetbrains: https://www.jetbrains.com/rider/
19:07:03 <tmds> runs on linux
19:07:04 <rkieley> tmds have you gotten a chance to try it out?
19:07:05 <Rhea> Oh yeah, i didn't look into that yet but I definitely will, it seems interesting
19:07:19 <nmilosev> I was in private preview program
19:07:25 <rkieley> tmds rhea given intellij I'm thinking it should be pretty good
19:07:30 <tmds> I just downloaded it and started it, seems you can use it for a month or so
19:07:32 <nmilosev> It is a really good tool
19:07:32 <rkieley> nmilosev thoughts?
19:07:42 <nmilosev> (like all jetbrains stuff)
19:07:53 <nmilosev> They aim more to be like VS rather than VS code
19:07:59 <nmilosev> So all-in-one solution
19:08:11 <nmilosev> Definitely try it when you have time
19:08:13 <rkieley> nmilosev will have to check it out; been using VS code so far
19:08:16 <jflory7> So Dotnet is officially built on Fedora, if I heard right?
19:08:20 <nmilosev> it's pretty good
19:08:20 <Rhea> #info New IDE from jetbrains
19:08:25 <Rhea> #link https://www.jetbrains.com/rider
19:08:50 <mhroncok> dhanesh95, jflory7: thank you
19:09:24 <tmds> compared to vscode I think it will integrate better with unit testing and offer profiling tools
19:09:27 <Rhea> jflory7: dotnet is available from dot.net website for F23 and F24... the build process is what we are looking into, to get it working for all things Fedora (23+)
19:09:33 * rkieley grabs the early build
19:09:52 <jflory7> Ooh, okay, got it. When you all hit that milestone, it would be a super cool thing to brag about on the Fedora Magazine... :)
19:10:06 <Rhea> I'm gonna go ahead and spam out the next topic..
19:10:11 <Rhea> jflory7: will do :]
19:10:18 <Rhea> #topic Action items and Tickets
19:10:20 <Rhea> #link https://meetbot.fedoraproject.org/teams/dotnet/dotnet.2016-11-11-13.03.html
19:10:23 <Rhea> #link https://pagure.io/fedora-dotnet/issues?tags=meeting
19:10:27 <Rhea> #info How This Works: We look at past #action items from the last meeting for quick follow-up. If a task is completed, we move on to the next one. If it isn't, we get an update and re-action it if needed. If no status, we'll try to get a quick update and move forward.
19:10:33 <Rhea> #info === [INCOMPLETE] dotnet Discuss dependencies and modularity. ===
19:10:44 <Rhea> I'm not sure if we want to keep this action item open...
19:11:56 <Rhea> Seems to me that our workflow is a little bit more... whatever comes up, rather than planned discussion on topic :P
19:12:05 <omajid> can someone point me to what "modularity" in fedora looks like?
19:12:11 <rkieley> rhea at least for the moment
19:12:17 <Rhea> #topic Packaging progress
19:13:57 <Rhea> Modularity... there is a bunch of info on the wiki page
19:14:15 <Rhea> https://fedoraproject.org/wiki/Modularity
19:14:43 <omajid> thanks
19:15:14 <Rhea> I'm There is FAQ that provides some useful points i guess o.o
19:16:04 <omajid> just wondering if/when we get .net packaged, would it have to be a normal rpm or part of this "modularity" thing.
19:16:29 <moto-timo> .hello ttorling
19:16:30 <zodbot> moto-timo: ttorling 'Tim Orling' <ticotimo@gmail.com>
19:16:33 * moto-timo late
19:16:46 <rkieley> isn't modularity more for a future version still at this point?
19:16:54 <Rhea> What does it mean for us is that we should get packages nice and tidy and throw them on copr, and after it's all checked out we would proceed towards "something more official"
19:17:20 <moto-timo> +1
19:17:24 <bt0> +1
19:17:31 <rkieley> +1
19:17:34 <moto-timo> and yes, modularity is still WIP
19:17:50 <Rhea> I didn't really look into what would be that far though, I don't want to get ahead of myself chasing some far future...
19:18:17 <moto-timo> I am a member of Modularity-WG and attend the meetings... I can keep you posted
19:18:25 <Rhea> Aaaanyway tmds, got some info about your awesome findings? :]
19:18:30 <rkieley> moto-timo sounds good
19:18:35 <Rhea> moto-timo++
19:19:23 <tmds> well, I ran the rover tool on fedora 25 and it worked
19:19:42 <tmds> actually it failed the first time, and when I tried to reproduce the fail, it was working
19:20:03 <tmds> *strange* but anyhow: 'Hello world' from dotnet :)
19:20:24 <tmds> let me find the instructions on how I built it
19:20:33 <moto-timo> I wonder what it picked up the second time...
19:20:58 <rkieley> so from an upgrade perspective is it better to move from f23 to f25 atm wrt dotnet instead of to f24?
19:21:07 <Rhea> So do you think that it is viable for us to use that?
19:21:14 * rkieley still running f23
19:21:27 <moto-timo> f23 EOL 12/20
19:21:34 <nmilosev> rkieley, f24 has packages for dotnet (from MS)
19:21:36 <Rhea> If dotnet runs on F25, then go for that...
19:21:41 <tmds> build instructions: https://github.com/dotnet/core/pull/326#issuecomment-262479168
19:21:49 <tmds> the rover tool has been merged to master
19:21:53 <Rhea> I think that this will be my kind of thing, taking the even Fedora numbers only :P
19:22:01 <tmds> so no need to use the branch
19:22:14 <rkieley> sounds like could be good either way from a dotnet perspective
19:22:38 <Rhea> #info The Rover tool works with F25
19:22:39 <tmds> I put in the comment the exact commit ids
19:22:43 <Rhea> #link https://github.com/dotnet/core/pull/326#issuecomment-262479168
19:23:44 <Rhea> I'm not sure if I will have any time before the end of this year to play with F25 stuff...
19:24:12 <Rhea> hmm
19:24:31 <Rhea> Damn so many things I want to do >_<
19:24:59 <Rhea> Anyway we should try to create a package for F25 on copr then
19:27:22 <Rhea> I'll look into that -if- i happen to have a few days of time, but I can't promise anything as i'm really busy
19:28:03 <tmds> can we package the rover tool output?
19:28:25 <tmds> or do we want a more clean build?
19:28:48 <tmds> anyhow, I can provide you a tar.gz of what I've built using rover
19:28:48 * Rhea has no idea, it has to be "looked at"
19:28:48 <omajid> tmds: does rover build things from scratch? or does it take a binary, build a few things and update the contents of the binary with the built-from-source bits?
19:29:06 <nmilosev> tmds, these are really good build instructions
19:29:13 <omajid> afaik, the binary that microsoft publishes (and rover uses for bootstrap?) are not open sourced.
19:29:16 <nmilosev> tmds++ great job
19:29:39 <tmds> it takes a tar.gz sdk as input and then it overwrites the native parts after compiling them for your platform
19:29:43 <tmds> thx nmilosev
19:29:52 <omajid> "we license the specific build that MSFT does differently": https://github.com/dotnet/core-setup/issues/676
19:30:02 <omajid> :(
19:30:50 <Rhea> Can't we just build it all though? o.o
19:31:05 <omajid> yes... and they are okay with that.
19:31:07 <moto-timo> there has to be a way
19:31:14 <Rhea> If we can't take the product of the build, we still can take the source
19:31:34 <Rhea> (and build our own the same way as they would)
19:31:51 <omajid> from my understanding, if we build everything from source, the result is open source. but if we take microsoft's binaries, the result is under their proprietary license.
19:32:14 <moto-timo> ah, one of "those" licenses
19:32:46 <omajid> ianal, license is here: https://www.microsoft.com/net/dotnet_library_license.htm
19:33:04 <Rhea> So we need to build a copy, then run rover with that, and then see about packaging it...
19:33:09 <Rhea> Right.
19:33:20 <Rhea> The easiest build process in the universe
19:33:30 * Rhea shushes before saying too much
19:33:32 <Rhea> :D
19:34:07 <omajid> you can get binaries from RHEL/CentOS for bootstrapping. i built it, it's licensed under MIT/Apache.
19:34:10 <moto-timo> similar to many other MS and Oracle build processes
19:34:20 <omajid> moto-timo: yup :(
19:34:30 <Rhea> oh that could potentially make it easier
19:35:30 <moto-timo> omajid: did you have a chance to rebuild since the 1.1 release?
19:35:35 <Rhea> omajid: are these already somewhere available? iirc 1.1 will happen in two weeks or something
19:36:10 <omajid> upstream 1.1 went out a few weeks ago. Red Hat released it today. http://developers.redhat.com/blog/2016/11/29/net-core-1-1-available-rhel-and-openshift/
19:36:34 <Rhea> Oh today... i don't'know why did I think half-december
19:38:43 <moto-timo> ride the wave! (moving target)
19:40:17 <Rhea> Okay sooo i'll poke you about the rh build, omajid
19:40:24 <omajid> sure.
19:40:31 <Rhea> And i'll see about building it all.. o.o
19:40:44 <Rhea> Within a week or two.. huhu
19:41:04 <Rhea> #action dotnet Attempt to create F25 package
19:41:07 <Rhea> :D
19:41:17 <moto-timo> \o/
19:41:32 <omajid> centos spec file might also be worth looking at.
19:41:40 <moto-timo> indeed :)
19:42:22 <Rhea> #topic Open Floor
19:42:31 <Rhea> So if there is nothing else
19:42:33 <Rhea> lets call it
19:42:40 <Rhea> :]
19:42:58 <tmds> one interesting point, I was looking at running a .net core library on mono
19:43:12 <tmds> it didn't run because of some missing stuff
19:43:31 <tmds> and looking at the source code, I saw much of it was added recently
19:43:46 <Rhea> Yeah about that IDE actually.. Any idea if there will ever be MonoDevelop support for dotnet core / netstandard things? o_o
19:43:55 <tmds> apparently the next 4.8 release of mono will cover a large part of the netstandard api
19:44:22 <tmds> http://www.mono-project.com/docs/about-mono/releases/4.8.0/
19:44:30 <rkieley> interesting
19:44:32 <nmilosev> There is a plugin in the alpha repository last time I checked
19:44:37 <nmilosev> it's called DNX i think
19:45:26 <Rhea> Can't help it, I just want to be stubborn and use mono develop :]
19:46:17 <Rhea> #endmeeting