16:00:37 <maxamillion> #startmeeting FESCO (2016-12-09)
16:00:37 <zodbot> Meeting started Fri Dec 9 16:00:37 2016 UTC. The chair is maxamillion. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:37 <zodbot> The meeting name has been set to 'fesco_(2016-12-09)'
16:00:37 <maxamillion> #meetingname fesco
16:00:37 <zodbot> The meeting name has been set to 'fesco'
16:00:37 <maxamillion> #chair maxamillion dgilmore jwb nirik paragan jsmith kalev sgallagh Rathann
16:00:37 <zodbot> Current chairs: Rathann dgilmore jsmith jwb kalev maxamillion nirik paragan sgallagh
16:00:40 <maxamillion> #topic init process
16:00:43 <maxamillion> .hello maxamillion
16:00:47 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
16:01:26 <jwb> hi
16:01:31 <maxamillion> jwb: welcome
16:01:43 <jsmith> .hello jsmith
16:01:44 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
16:03:19 <dgilmore> kinda here
16:04:03 <jsmith> Almost a quorum...
16:05:03 <maxamillion> almost :)
16:05:12 <jwb> sgallagh: and paragn are out
16:05:26 <maxamillion> dgilmore: how "here" is kinda? ... will you be available to vote on things?
16:05:45 <jsmith> I'm double-booked, so I'm context switching between this meeting and a ${DAYJOB} meeting
16:06:44 <dgilmore> maxamillion: maybe, in a interview
16:06:52 <dgilmore> and need to pack
16:06:55 <maxamillion> alright ...
16:07:14 <maxamillion> we'll give it a few more minutes and then call it a day
16:08:26 <Rathann> hi
16:08:30 <Rathann> .hello rathann
16:08:31 <zodbot> Rathann: rathann 'Dominik Mierzejewski' <dominik@greysector.net>
16:09:45 <maxamillion> quorum!
16:10:07 <maxamillion> #topic #1635 F26 Self Contained Changes (Java Security Policy)
16:10:07 <maxamillion> .fesco 1635
16:10:07 <maxamillion> https://pagure.io/fesco/issue/1635#comment-43494
16:10:08 <zodbot> maxamillion: Issue #1635: F26 Self Contained Changes - fesco - Pagure - https://fedorahosted.org/fesco/ticket/1635
16:10:43 <maxamillion> this was discussed last week but we never came to any conclusion on it, it was deferred to this week
16:12:06 <maxamillion> and according to the mailing list, this has already been included in an update to F24 and F25 ... so I'm not sure there even needs to be a change proposal
16:12:11 <jwb> apologies, but i missed last week. summary of why it was deferred?
16:13:26 <maxamillion> jwb: needed more information on if this even really needs to be a Change, also waiting on more discussion on the mailing list (at the time there hadn't been much ... but it doesn't look there is any more than there was) .... also, everyone was surprised this Change was not already a reality so there was just some general confusion/uncertainty
16:13:33 <Rathann> wasn't the change reverted in f24/f25?
16:13:43 <Rathann> I see https://bodhi.fedoraproject.org/updates/FEDORA-2016-1305a61687
16:13:54 <maxamillion> Rathann: it might have been, I hadn't seen it though
16:13:56 <Rathann> and https://bodhi.fedoraproject.org/updates/FEDORA-2016-ab8b0ffc96
16:14:08 <Rathann> Notes about this update: disabled accidentally enabled (not working) system security settings
16:14:30 <sgallagh> .hello sgallagh
16:14:31 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:14:36 <sgallagh> (my conflict ended early)
16:14:44 <maxamillion> sgallagh: good news :)
16:15:10 <Rathann> so it looks like it's still F26+ at the moment
16:15:13 <jwb> ok, so (as with all Changes) assuming they can make this work then I'm +1
16:15:18 <sgallagh> Right, so it looks like the push to F24 and 25 was a mistake and has been reverted.
16:15:26 <sgallagh> So it's clearly an F26 Change
16:15:54 <maxamillion> +1
16:16:06 <sgallagh> I'm +1 on this Change, as it brings us closer to the glorious centrally-managed policy we all want
16:16:12 <maxamillion> I'm +1 to this change as well
16:16:32 <Rathann> +1
16:16:37 <maxamillion> jsmith: dgilmore: ? ^^^
16:17:00 <jsmith> +1, I guess...
16:17:15 * jsmith has no reason not to vote for it
16:18:13 <maxamillion> we have enough votes for quorum on the topic and dgilmore is likely not really paying attention if he's giving an interview so we'll move on unless there are objections
16:18:30 <jwb> agreed
16:18:37 <Rathann> sure
16:18:40 <maxamillion> #agreed Approve F26 Self Contained Change Java Security Policy (+1: 5, -1: 0, +0: 0)
16:18:50 <maxamillion> #topic #1646 No appropriate sudo directory for user scripts
16:18:50 <maxamillion> .fesco 1646
16:18:50 <maxamillion> https://pagure.io/fesco/issue/1646
16:18:51 <zodbot> maxamillion: Issue #1646: No appropriate sudo directory for user scripts - fesco - Pagure - https://fedorahosted.org/fesco/ticket/1646
16:19:19 <sgallagh> We discussed this at length last week, but we came up basically deadlocked
16:19:28 <Rathann> indeed
16:20:06 <maxamillion> we did and since some of those opposed aren't here to discuss I'd prefer not to vote just yet until we can hash it out and make sure everyone's opinion is well represented
16:20:15 <jsmith> +1 to deferring
16:20:26 <jsmith> (that'll give me a better chance to form a strong opinion)
16:20:30 <Rathann> +1 to deferring, too
16:20:36 <maxamillion> +1 to defer
16:20:42 <sgallagh> Sure, fine with me. +1 to defer
16:21:05 <jwb> hm, ok
16:21:28 <maxamillion> #agreed Defer decision of Issue #1646 until 2016-12-16
16:21:35 <maxamillion> #topic #1635 F26 Self contained Changes - Zend Framework 3
16:21:35 <maxamillion> .fesco 1635
16:21:35 <maxamillion> https://pagure.io/fesco/issue/1635#comment-45817
16:21:36 <zodbot> maxamillion: Issue #1635: F26 Self Contained Changes - fesco - Pagure - https://fedorahosted.org/fesco/ticket/1635
16:21:55 <maxamillion> I'm +1 to Zend 3
16:22:06 <maxamillion> nirik voted in ticket also +1
16:22:20 <jsmith> I'm +1 on the change
16:22:25 <sgallagh> +1
16:23:22 <jwb> +1
16:23:36 <maxamillion> Rathann: ?
16:24:10 <Rathann> ah
16:24:38 <Rathann> +1
16:24:53 <maxamillion> #agreed F26 Self Contained Change - Zend Framework 3 (+1: 6, -1: 0, +0: 0)
16:24:58 * Rathann has confidence in Remi and the PHP SIG
16:25:01 <maxamillion> (note: I included nirik's +1 from the ticket)
16:25:05 <maxamillion> Rathann: +1
16:25:21 <maxamillion> #topic #1652 i686 is not on primary mirror location
16:25:21 <maxamillion> .fesco 1635
16:25:21 <maxamillion> https://pagure.io/fesco/issue/1652
16:25:22 <zodbot> maxamillion: Issue #1635: F26 Self Contained Changes - fesco - Pagure - https://fedorahosted.org/fesco/ticket/1635
16:25:22 <Rathann> also, all new packages are in already
16:26:00 <sgallagh> .fesco 1652
16:26:01 <zodbot> sgallagh: Issue #1652: i686 is not on primary mirror location - fesco - Pagure - https://fedorahosted.org/fesco/ticket/1652
16:26:42 <sgallagh> jwb: Wnat to lead this off?
16:26:49 <maxamillion> sgallagh: bah, sorry
16:26:57 <jwb> sure
16:27:37 <jwb> so there's two aspects here. the most important one is a) why was this change done without formal discussion and communication. the other is b) is FESCo OK with this technical change
16:28:08 <jwb> before anyone thinks i'm defending i686 and love it and want to keep it, i'm not
16:28:38 <maxamillion> for some reason I thought we had talked about this in some capacity in the past ... I just don't remember if we ever actually said "yes, let's demote i686 to secondary"
16:29:00 <jwb> the other changes around i686 we've discussed make this move a somewhat logical conclusion. but i AM interested in making sure that changes like this get proper discussion and visibility and i don't think that was done here
16:29:06 <maxamillion> jwb: +1 - I think you have valid points, regardless of opinion about i686 as a platform
16:29:40 <jsmith> jwb: I completely agree -- while I personally don't really give much attention to i686, I too am very concerned about the communication
16:29:40 <jwb> as i see it, this is essentially the final technical step in demotion under the new (intentionally) fuzzy primary/alternate reality that we approved
16:30:05 <jwb> so if we're going to declare that, we need to vote on it and announce
16:30:14 <maxamillion> agreed
16:30:16 <jwb> and to be honest, we should probably run it past the Council
16:30:38 <jwb> particularly since mattdm has been looking at user statistics and such surrounding all the architectures
16:30:39 <maxamillion> jwb: +1
16:30:49 <jsmith> jwb: +1 to involving the Council
16:30:54 <Rathann> and there's a clear downwards trend
16:31:36 <jwb> Rathann: there is. i believe mattdm's query there though is "is there a downward trend that accelerated because of our other de-emphasis of i686 and did that lead to a _faster_ loss of users?"
16:31:50 <jwb> or, did those users simply migrate to i686
16:32:01 <jwb> er, x86_64
16:32:03 <jwb> sorry
16:32:17 <Rathann> so, not release blocking -> not primary?
16:32:29 <jwb> i'm not sure we'll be able to answer that question with the data we have, but f24 did show a sharp 10% drop in users
16:32:39 <jwb> and it was the first release we de-emphasized i686
16:32:56 <jwb> Rathann: that may be one possible conclusion
16:33:05 <jwb> it would make sense
16:34:25 <jwb> Proposal: FESCo will draft an announcement for the demotion of i686 to an alternative architecture and seek Council input before publishing
16:34:33 <maxamillion> alright, so is there enough here that someone can write up and take to the Council for effectively "Round 1" of official process discussion/approval to demote i686, then we as FESCo can be brought in for "Phase 2" if/when the Council deems it necessary?
16:34:37 <maxamillion> and there it is :)
16:34:45 <maxamillion> jwb: +1
16:34:54 <sgallagh> jwb: +1
16:35:51 <maxamillion> Rathann: ?
16:35:53 <maxamillion> jsmith: ?
16:35:59 <jwb> multilib will need to be considered, but that is handled in the buildsystem for the most part and i believe it should be reasonably working still
16:36:02 <Rathann> right, +1
16:36:06 <maxamillion> jwb: safe to assume you're a +1 to you're proposal?
16:36:24 <Rathann> speaking of multilib, any idea when manual updates to the multilib set will be done?
16:36:32 <jwb> i am, though it doesn't alleviate my concerns about doing this after the fact
16:36:59 <jwb> we probably need to write up something on what "non-release blocking" means for an architecture as Rathann suggested
16:37:08 <jwb> separate from the announcement itself
16:37:11 <maxamillion> jwb: +1
16:37:34 <maxamillion> jsmith: need your vote when you're available please
16:38:07 <Rathann> never mind my last question
16:39:36 <Rathann> right, an official process (or set of conditions) for moving between alternate and primary... don't we have one already?
16:39:47 <Rathann> hm, there's https://fedoraproject.org/wiki/Secondary_Architecture_Promotion_Requirements
16:40:53 <jwb> that's promotion
16:41:02 <maxamillion> yeah, there's promotion policy, we need a demotion policy
16:41:05 <jwb> for demotion, we've only done it twice, with totally difference processes
16:41:31 <jwb> the first was powerpc, where basically everyone said "we don't like this", fesco talked about it, and cut it off
16:41:38 <maxamillion> I suspect *eventually* 32-bit ARM will need it once the world has migrated to AArch64 (probably many years out, but still)
16:42:07 <jwb> the second is now i686, where it was a somewhat more staged demotion. kernel, some images, all images, non-release blocking, now.
16:42:32 <jsmith> maxamillion: Sorry, got pulled into another work meeting
16:42:36 <Rathann> I'm fine with staged
16:42:39 <jsmith> maxamillion: Gimme a second to catch up
16:42:42 <maxamillion> jsmith: no worries
16:42:48 <jwb> maxamillion: possibly. IoT may drive armhfp to remain primary. depending.
16:42:58 <maxamillion> jwb: ah, good point
16:43:10 <Rathann> it might be better than a cut-off
16:43:16 <jsmith> OK, I'm +1 for the proposal
16:43:23 <jsmith> (thanks for being patient with me)
16:43:29 <jwb> Proposal: FESCo will draft an announcement for the demotion of i686 to an alternative architecture and seek Council input before publishing. Separately, FESCo will draft an architecture demotion process
16:43:41 <jwb> ok, so i changed it somewhat to add the demotion process creation
16:43:52 <Rathann> +1
16:44:09 <jsmith> +1
16:45:15 <sgallagh> +1
16:45:22 <maxamillion> #agreed Proposal: FESCo will draft an announcement for the demotion of i686 to an atlernative architecture and seek Council input before publishing (+1: 5, -1: 0, +0: 0)
16:45:32 <maxamillion> sorry, was waiting on jsmith's vote for last Proposal
16:45:38 <maxamillion> +1 to new Proposal
16:46:29 <maxamillion> bleh
16:46:32 <maxamillion> #undo
16:46:32 <zodbot> Removing item from minutes: AGREED by maxamillion at 16:45:22 : Proposal: FESCo will draft an announcement for the demotion of i686 to an atlernative architecture and seek Council input before publishing (+1: 5, -1: 0, +0: 0)
16:46:39 <maxamillion> #agreed Proposal: FESCo will draft an announcement for the demotion of i686 to an atlernative architecture and seek Council input before publishing. Secondly, FESCo will draft an architecture demotion process. (+1: 5, -1: 0, +0: 0)
16:46:54 <maxamillion> alright, I'll update that ticket after the meeting
16:47:31 <maxamillion> is anyone currently taking the action item to write up the announcement and the demotion process?
16:47:40 <jwb> i can
16:47:58 <jwb> i'll create a separate ticket for the process part
16:48:05 <jwb> use this ticket for the announcement part
16:48:10 <maxamillion> jwb: awesome, thanks
16:48:21 <maxamillion> #topic Next week's chair
16:48:27 <maxamillion> who's up?
16:48:35 <jwb> i'll note that i guess we just leave the i686 bits at the location they currently are under the assumption the Council won't overrule
16:48:59 <jsmith> Since I flaked out last week, I can handle next week
16:49:09 <maxamillion> jwb: yeah, I have no idea what amount of work it would be to revert the change that landed the content in the current location
16:49:22 <jsmith> jwb: +1 (reluctantly, but don't know the scope of changing that)
16:49:26 <maxamillion> #info jsmith to chair FESCo Meeting 2016-12-16
16:49:37 <maxamillion> #topic Open Floor
16:50:12 <maxamillion> I wanted to point out that elections are open and 5 of our seats are up for grabs
16:50:27 <maxamillion> #info Reminder that 5 FESCo seats are open for elections now https://fedoraproject.org/wiki/Elections
16:51:32 <jsmith> Thinking ahead -- do we want to pre-emptively cancel the meetings on the 23rd and/or 30th?
16:51:41 * jsmith won't be able to make either of those dates
16:52:05 <sgallagh> I will similarly be unavailable
16:52:18 <maxamillion> I'll be here on the 23rd but not the 30th
16:52:42 <maxamillion> but I suspect most people will be out on the 23th and 30th so it might make sense to go ahead and call it
16:52:57 <maxamillion> I'm +1 for cancelling those
16:53:01 <jsmith> Proposal: Cancel the meetings on the 23rd and 30th
16:53:08 <jwb> i wont be here for either
16:53:29 <jsmith> Sounds like we're all in violent agreement :-)
16:54:48 <maxamillion> +1
16:55:01 <Rathann> I could probably use the afternoon of 23rd for shopping, so I'm not opposed at all
16:55:26 <Rathann> I'm on vacation the following week, so +1
16:57:27 <jwb> ok, i have to bail for today. thanks everyone
16:57:33 <maxamillion> jwb: sgallagh: we don't have explicit +1's from you two and I don't want to assume a vote contextually
16:58:01 <maxamillion> bah!
16:58:16 <jwb> +1
16:58:19 <maxamillion> :D
16:58:19 <jwb> Sorry
16:58:21 <maxamillion> jwb: have a good one
16:58:26 <maxamillion> jwb: no worries, have a good weekend
17:00:48 <maxamillion> meh
17:00:51 <maxamillion> #agreed Cancel FESCo Meetings on 2016-12-23 and 2016-12-30
17:01:00 <maxamillion> anything else for open floor?
17:02:03 <maxamillion> #endmeeting