15:00:37 <jkurik> #startmeeting Prioritized_bugs_and_issues
15:00:37 <zodbot> Meeting started Wed Dec 14 15:00:37 2016 UTC.  The chair is jkurik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:37 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
15:00:45 <jkurik> #meetingname Fedora Prioritized bugs and issues
15:00:45 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
15:00:53 <jkurik> #topic Roll Call
15:01:01 <jkurik> #chair jkurik mattdm mcatanzaro dustymabe sgallagh
15:01:01 <zodbot> Current chairs: dustymabe jkurik mattdm mcatanzaro sgallagh
15:01:11 <sgallagh> .hello sgallagh
15:01:12 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:01:20 * mattdm is here; wrapping up FAmSCo meeting in another channel
15:01:24 <jkurik> Hi Stephen
15:01:29 <jkurik> Hi mattdm
15:02:54 <sgallagh> FYI, I have a hard-stop in one hour.
15:03:06 <jkurik> I have it as well
15:03:09 <sgallagh> But there are only two proposed BZs, so that's not likely to be an issue
15:03:45 <jkurik> ok, lets move on
15:03:50 <jkurik> #topic Purpose of this meeting
15:03:54 <jkurik> #info The purpose of this process is to help with processing backlog of bugs and issues found during the development, verification and use of Fedora distribution.
15:03:59 <jkurik> #info The main goal is to raise visibility of bugs and issues to help contributors focus on the most important issues.
15:04:07 <jkurik> #link https://fedoraproject.org/wiki/Fedora_Program_Management/Prioritized_bugs_and_issues_-_the_process?rd=Fedora_Program_Management/Important_bugs_and_issues_process
15:04:16 <jkurik> #topic Evaluation of proposed bugs
15:04:23 <jkurik> #link https://bugzilla.redhat.com/buglist.cgi?cmdtype=dorem&list_id=6795225&namedcmd=FedoraPrioritized_Nomination&remaction=run&sharer_id=352756
15:04:53 <jkurik> So, as far as I can see there are no new bugs nominated for the list of prioritized bugs
15:05:08 <jkurik> we only have the two we have reviewed the last meeting
15:05:24 <mattdm> so let's see where those are?
15:05:30 <jkurik> https://fedoraproject.org/wiki/Fedora_Program_Management/Prioritized_bugs_and_issues
15:06:19 <dustymabe> no new bugs! woot
15:06:34 <jkurik> So, https://bugzilla.redhat.com/show_bug.cgi?id=1366897 seems to be on it way to be fixed
15:07:55 <dustymabe> jkurik: +1
15:08:17 <rdieter> silly question, is PrioritizedBug for rawhide only ?
15:08:20 <jkurik> From my POV we can leave the BZ 1366897 as it is as it seems we will have the fix soon
15:08:34 <rdieter> (if not, I have a good one I just added)
15:08:36 <jkurik> rdieter: no, it is for any issue we have
15:10:14 <mattdm> #info Bug #1366897 (many crashes on GNOME logout) on QA now
15:10:40 <jkurik> thanks mattdm
15:10:49 <jkurik> lets move to the one rdieter proposed
15:11:04 <jkurik> .bug 1399396
15:11:04 <zodbot> jkurik: Bug 1399396 – Plasmashell freezes - https://bugzilla.redhat.com/1399396
15:11:20 <jkurik> #topic Bug 1399396 – Plasmashell freezes
15:11:51 <jkurik> rdieter: any justification, why this should be on the list of prioritized bugs ?
15:12:20 <mattdm> (I do want to review the other open one at some point)
15:12:36 <rdieter> jkurik: because it's bad and affects lots of users?
15:12:39 <sgallagh> jkurik: Looks to be affecting a pretty large cross-section of our users
15:14:04 <rdieter> recent evidence seems to point at a regression in xorg-x11-server since GA release of xorg-x11-server-1.19.0-0.3.20161026.fc25
15:14:15 <jkurik> ok, reading the bug it seems to be quite serios for me, so I am +1
15:15:07 <jkurik> what other people on the meeting think of it ?
15:16:17 <sgallagh> I'm also +1
15:16:28 <dustymabe> +1
15:16:56 <mattdm> It does seem serious — I can at least try to bring it to the attention of the Xorg devs who might not be looking at plasma
15:17:06 <sgallagh> (Actually, I could see a real argument to this being a blocker as well)
15:17:36 <sgallagh> I'm also not sure it's limited to plasma; I've been seeing some odd long freezes (every couple hours) that recover after 20-30s on GNOME
15:18:01 <mattdm> sgallagh: on Wayland?
15:18:22 <sgallagh> mattdm: Yes on Wayland, but that doesn't rule out the thirty XWayland apps I have running all the time :)
15:19:57 <jkurik> If I understand correctly we do not even know for sure whether it is caused by mesa, Xorg or graphic card driver
15:20:15 <sgallagh> Yeah, it's delightfully vague
15:20:27 <sgallagh> Anyway, let's tag it as "prioritized" and move on.
15:20:39 <sgallagh> Someone with more domain-specific knowledge can take over from there.
15:20:54 <mattdm> "move on" does imply that we try to find that someone with domain-specific knowledge. do you know who that'd be in this case?
15:21:28 <jkurik> proposed #agreed Bug 1399396 has been agreed on the list of Prioritized bugs as it affects pretty large cross-section of our users
15:21:53 <jkurik> proposed #agreed Bug 1399396 has been agreed on the list of Prioritized bugs as it affects pretty large cross-section of our users and is also probably a candidate to a Blocker bug
15:22:43 <dustymabe> ack
15:22:57 <jkurik> mattdm, sgallagh ^^^ is it ok ?
15:23:01 <mattdm> jkurik: yep
15:23:07 <sgallagh> jkurik: ack
15:23:09 <jkurik> #agreed Bug 1399396 has been agreed on the list of Prioritized bugs as it affects pretty large cross-section of our users and is also probably a candidate to a Blocker bug
15:23:19 <jkurik> .bug 1394755
15:23:19 <zodbot> jkurik: Bug 1394755 – screen recording freezes GNOME under Wayland when gstreamer cache is updated - https://bugzilla.redhat.com/1394755
15:23:30 <jkurik> #topic Bug 1394755 – screen recording freezes GNOME under Wayland when gstreamer cache is updated
15:23:51 <sgallagh> This bug has meandered quite a bit.
15:24:41 <mattdm> Yeah. I'm going to nominate it for de-prioritization, since it seems to be narrowed down to a specific screen recorder problem
15:24:54 <mattdm> rather than OMG random freeze for everyone for no known reason
15:25:10 <mattdm> And by "I'm going to", I mean "I do so nominate, now"
15:25:20 <jkurik> from the comment #30:
15:25:22 <jkurik> From the upstream bug report:
15:25:23 <jkurik> "The only sane way forward is to stop using gstreamer in the compositor which is in the plans."
15:25:42 <jkurik> so it seems like the upstream does not want to work on a fix here
15:26:20 <sgallagh> jkurik: The purpose of this group is to determine if it's worth spending our limited influence pushing for a fix here.
15:26:52 <sgallagh> I agree with mattdm that with what we know now, it's probably not.
15:27:12 <jkurik> what I mean is that there is no need to push for a fix if the upstream is going to implement a workaround
15:28:11 <jkurik> anyway ...
15:28:13 <jkurik> proposed #agreed Bug 1394755 is de-prioritization, since it seems to be narrowed down to a specific screen recorder problem
15:28:19 <sgallagh> patch
15:28:49 <sgallagh> proposed #agreed Bug 1394755 is de-prioritized, since further investigation has revealed that the scope of affected users is much smaller than originally believed.
15:28:53 <mattdm> +1
15:29:03 <jkurik> ack
15:29:48 <dustymabe> sounds good
15:30:02 <jkurik> #agreed Bug 1394755 is de-prioritized, since further investigation has revealed that the scope of affected users is much smaller than originally believed.
15:30:06 <jkurik> sgallagh: thanks
15:30:21 <jkurik> so that is all from the bugs we have ....
15:30:26 <mattdm> jkurik++
15:30:27 <jkurik> #topic Open Floor
15:30:27 <zodbot> mattdm: Karma for jkurik changed to 3 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:30:28 <sgallagh> jkurik: I have something for open floor
15:30:48 <jkurik> I have rewritten the process a bit as agreed on the last meeting
15:31:04 <sgallagh> Two weeks ago, during this meeting we came up with a general set of criteria for how to make these decisions. I don't see them on https://fedoraproject.org/wiki/Fedora_Program_Management/Prioritized_bugs_and_issues_-_the_process
15:32:42 <jkurik> hmmm... I have not made an action for me to put it on the process page so ...
15:32:56 <jkurik> I will fix it till the next meeting
15:32:59 <sgallagh> Thanks
15:33:15 <sgallagh> #action jkurik to update the process page to describe the consensus-based decision process
15:33:18 <jkurik> thanks for chasing me :)
15:34:02 <jkurik> Anything else for the Open Floor ?
15:34:19 <mattdm> thanks jkurik and sgallagh for your work on this -- definitely making Fedora better for everyone!
15:34:52 <jkurik> ok, so I am going to close the meeting in one minute ....
15:34:59 <jkurik> thanks all for comming
15:36:03 <jkurik> #endmeeting