19:01:59 <Rhea> #startmeeting Fedora DotNet (2017-01-10)
19:01:59 <zodbot> Meeting started Tue Jan 10 19:01:59 2017 UTC.  The chair is Rhea. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:59 <zodbot> The meeting name has been set to 'fedora_dotnet_(2017-01-10)'
19:02:03 <Rhea> #meetingname dotnet
19:02:03 <zodbot> The meeting name has been set to 'dotnet'
19:02:06 <Rhea> #nick dotnet
19:02:11 <Rhea> #topic Agenda
19:02:14 <Rhea> #info (1) Roll Call
19:02:19 <Rhea> #info (2) Announcements
19:02:22 <Rhea> #info (3) Action items and Tickets
19:02:24 <Rhea> #info (4) Packaging progress
19:02:28 <Rhea> #info (5) Open Floor
19:02:32 <Rhea> #topic Roll Call
19:02:37 <Rhea> #info Name; Timezone; Sub-projects/Interest Areas
19:02:41 <Rhea> #action dotnet New members, make sure you introduce yourself on the DotNet mailing list [ https://fedoraproject.org/wiki/DotNet ]
19:02:44 <Rhea> If this is your first time at a DotNet meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
19:02:54 <Rhea> Spam over!
19:02:56 <Rhea> .hello rhea
19:02:57 <zodbot> Rhea: rhea 'Radka Janek' <radka.janek@redhat.com>
19:02:59 <Rhea> #info Radka Janek; UTC+1; CommOps, Diversity, DotNet,...
19:03:07 * nmilosev o/ rhea
19:03:09 <nmilosev> .fas nmilosev
19:03:10 <zodbot> nmilosev: nmilosev 'Nemanja Milosevic' <nmilosevnm@gmail.com>
19:03:12 <rkieley> .hello roddiekieley
19:03:13 <zodbot> rkieley: roddiekieley 'Roddie Kieley' <rkieley@unifiedsoftworx.com>
19:03:16 <moto-timo> .hello ttorling
19:03:17 <zodbot> moto-timo: ttorling 'Tim Orling' <ticotimo@gmail.com>
19:03:24 <tmds> .hello tmds
19:03:25 <zodbot> tmds: tmds 'Tom Deseyn' <tom.deseyn@gmail.com>
19:03:26 <bt0> #info Alberto Rodriguez, UTC-6, Commops,DotNet, Infra, Metrics, and more
19:03:30 <vukovinski> .hello vukovinski
19:03:31 <zodbot> vukovinski: vukovinski 'None' <filip.vukovinski@net.hr>
19:03:39 <bt0> .hello bt0dotninja
19:03:40 <zodbot> bt0: bt0dotninja 'Alberto Rodriguez Sanchez' <hotgalan@gmail.com>
19:03:53 <vukovinski> #info Filip Vukovinski, UTC+1, DotNet, Haskell
19:04:10 <rkieley> #info Roddie Kieley; UTC-3.5; DotNet,PowerShell,MSBuild
19:05:40 <Rhea> #chair rkieley bt0 moto-timo nmilosev tmds
19:05:40 <zodbot> Current chairs: Rhea bt0 moto-timo nmilosev rkieley tmds
19:05:43 <Rhea> #topic Announcements
19:05:48 <Rhea> #info === "Early previews of netcore vNext should be available in february after devconf, vNext was announced to be netcore 2.0 to catch up with netstandard versions." ===
19:05:53 <Rhea> #link https://github.com/dotnet/core/blob/master/roadmap.md
19:06:11 <Rhea> hmmm
19:06:14 <Rhea> #undo
19:06:14 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x291b36d0>
19:06:16 <Rhea> #undo
19:06:16 <zodbot> Removing item from minutes: INFO by Rhea at 19:05:48 : === "Early previews of netcore vNext should be available in february after devconf, vNext was announced to be netcore 2.0 to catch up with netstandard versions." ===
19:06:20 <Rhea> wrong month haha
19:06:47 <Rhea> #info === "Early previews of netcore vNext should be available in late spring, vNext was announced to be netcore 2.0 to catch up with netstandard versions." ===
19:06:52 <Rhea> #link https://github.com/dotnet/core/blob/master/roadmap.md
19:07:00 <Rhea> #info === "Visual Studio 2017 RC was announced with some netcore tooling improvements." ===
19:07:03 <Rhea> #link https://blogs.msdn.microsoft.com/dotnet/2016/12/12/updating-visual-studio-2017-rc-net-core-tooling-improvements/
19:07:07 <Rhea> #info === "Observations on Porting from .NET Framework to .NET Core" ===
19:07:08 <Rhea> #link https://developers.redhat.com/blog/2016/12/08/observations-porting-from-net-framework-to-net-core
19:07:14 <Rhea> #info A blog post by Todd about porting to netcore, worth looking at if you plan to "go through that."
19:07:26 <Rhea> That's about it, i'm not sure if anything new happened in last few days tho
19:07:37 <Rhea> That's all that was missed over last... month or so
19:08:04 <Rhea> #topic Action items and Tickets
19:08:05 <Rhea> #link https://meetbot.fedoraproject.org/teams/dotnet/dotnet.2016-12-06-19.11.html
19:08:08 <Rhea> #link https://pagure.io/fedora-dotnet/issues?tags=meeting
19:08:11 <Rhea> #info How This Works: We look at past #action items from the last meeting for quick follow-up. If a task is completed, we move on to the next one. If it isn't, we get an update and re-action it if needed. If no status, we'll try to get a quick update and move forward.
19:08:31 <Rhea> nmilosev did you manage to create F25 package the way we discussed?
19:08:44 <Rhea> Using RH built source -> rovertool
19:09:05 <nmilosev> no sadly, got stuck with building it :(
19:09:11 <Rhea> #info === [INCOMPLETE] dotnet Attempt to create F25 package. ===
19:09:13 <Rhea> #action dotnet Attempt to create F25 package.
19:09:18 <Rhea> #info === [INCOMPLETE] Rhea Seek legal counsel regarding the different dotnet licenses. ===
19:09:20 <nmilosev> I think it's my setup
19:09:21 <Rhea> #action Rhea Seek legal counsel regarding the different dotnet licenses.
19:09:27 <nmilosev> I'll have to setup a VM to try it out
19:09:31 <nmilosev> sorry
19:09:32 <Rhea> #topic Packaging progress
19:09:53 <tmds> nmilosev: what part broke?
19:10:09 <nmilosev> building the rovertool
19:10:29 <nmilosev> although to be honest, I didn't have much time to figure out what it was
19:10:36 <nmilosev> (university stuff)
19:10:42 <moto-timo> and the magic of holidays
19:10:50 <nmilosev> yes
19:10:55 <bt0> :)
19:11:00 <tmds> nmilosev: this may help: https://github.com/dotnet/core/pull/326#issuecomment-262479168
19:11:07 * moto-timo has no idea what happened to the last month
19:11:20 <vukovinski> is it a tool to migrate RHEL-built stuff to Fedora, with preserving keys?
19:11:23 <nmilosev> Can I just ask, does the new versioning scheme means .net core 1.2 will actually be .net core 2.0?
19:11:24 <Rhea> Yeah, i'm extremely busy with conferences (devconf + i'll be talking at two others) til late March I'm not sure I can get anywhere in my free time... plus my lovely dotnet application is growing exponentially and i need to rewrite it to support living in a cluster...
19:11:55 <tmds> nmilosev: yes, 1.2 became 2.0
19:12:18 <nmilosev> tmds, thanks for the link
19:12:57 <tmds> so it is a major release as described here: https://www.microsoft.com/net/core/support, 3 year support cycle
19:13:42 <nmilosev> I will definitely try to have a build ready in one-two weeks using RH build with rovertool
19:13:45 <nmilosev> sorry guys
19:13:47 <Rhea> vukovinski: No, it's just that MS-built is using their license which we can not use, we built it from source for RHEL packages, which is Apache, so to not have to reinvent the same wheel we can use the same thing as we did at RH
19:14:08 <vukovinski> thx
19:14:08 <tmds> it also brings a much larger common api surface with the desktop framework, called netstandard 2.0
19:14:26 <moto-timo> which is a GoodThing(TM)
19:14:31 <moto-timo> I hope!!!!
19:14:55 <tmds> Rhea: I think ms are changing their licenses
19:15:00 <Rhea> nmilosev: told you that you're getting ahead of ourselves with that talk :P
19:15:21 <tmds> the windows binaries would keep the microsoft license, but other binaries would get the MIT license
19:15:22 <Rhea> tmds: oh, did they mention anything anywhere where i did not log in for a few weeks? :D
19:15:33 <Rhea> That would be nice
19:16:15 <tmds> let me find a link
19:16:38 <tmds> https://github.com/dotnet/cli/pull/5112
19:17:31 <nmilosev> why is this so complicated, two licenses? :(
19:18:07 <moto-timo> because MS has not been FOSS before... so they have a hard time changing
19:18:08 <Rhea> ah okay
19:18:51 <Rhea> So hey i wanted to ask, who else is going to devconf? tmds, nmilosev, myself...
19:19:06 <moto-timo> I wish I had a travel budget. But I don't.
19:19:13 <tmds> I think this way they can be protective about what happens on Windows while allowing others to build themselves
19:19:31 <moto-timo> tmds: and that :)
19:19:51 <nmilosev> Rhea, can I mention that you are our fearless leader in my talk
19:19:55 <nmilosev> :D
19:20:01 <vukovinski> :D
19:20:06 <Rhea> lol fearless okay
19:20:20 <Rhea> I've been called many things but never fearless, thumbsup :D
19:20:51 <moto-timo> Her Royal Highness the Fearless Dotnet Leader
19:20:52 <tmds> I will also be giving a talk at devconf
19:20:55 <Rhea> nmilosev: when do you arrive/leave to/from Brno?
19:20:57 <Rhea> :D
19:21:01 <bt0> :D
19:21:14 <Rhea> yup, tmds is taking over omajid who can't make it
19:21:23 <Rhea> I mean.. not taking over him but his talk? :D
19:21:24 <nmilosev> get there 26th leave 29th
19:21:28 <nmilosev> haha
19:21:31 <Rhea> :D
19:21:38 <nmilosev> Did you check the schedule?
19:21:46 <Rhea> I kinda zoomed through only
19:21:51 <nmilosev> There are two kinda similar talks about .NET
19:22:01 <nmilosev> One is then with tmds
19:22:11 <nmilosev> The other I think is someone else
19:22:31 <Rhea> Who's the someone else?
19:22:33 <nmilosev> (Day 2 towards the end)
19:22:34 <Rhea> or the title
19:22:37 * nmilosev checks
19:23:05 <nmilosev> Building ASP.NET Core applications on Linux - Gunnar Peipman
19:23:46 <Rhea> oh right, that's the web one yep
19:23:59 <nmilosev> ahhh I see
19:24:07 <nmilosev> one is .NET other is ASP.NET
19:24:08 <nmilosev> mybad
19:24:22 <Rhea> nmilosev how will you arrive, when, time!
19:24:30 <nmilosev> Don't ask
19:24:34 <nmilosev> bus from serbia
19:24:37 <nmilosev> 6am arrival
19:24:40 <nmilosev> 14h trip
19:24:40 <Rhea> ouch
19:24:41 <nmilosev> :D
19:24:46 <moto-timo> goat drawn carriage?
19:24:56 <nmilosev> moto-timo, close
19:24:57 <Rhea> that's friday?
19:25:15 <nmilosev> thursday, day before devconf actually starts
19:25:16 <nmilosev> 26th
19:25:20 <Rhea> oh
19:25:33 <Rhea> that's kinda good... where do you stay
19:25:44 <nmilosev> Avanti
19:25:46 <Rhea> 6am thursday?
19:25:52 <nmilosev> yes
19:25:58 <moto-timo> I hope you got an early check-in!!
19:26:03 <nmilosev> (stalker mode Rhea)
19:26:10 <moto-timo> lol
19:26:12 <nmilosev> I checked with the hotel, it's 2PM :D
19:26:27 <Rhea> Okay hmm
19:27:31 <Rhea> tmds you said Friday right
19:27:40 <tmds> yes, in the afternoon I'll get there
19:27:42 <Rhea> yup
19:27:45 <nmilosev> We can go for some beer coffee
19:27:51 <nmilosev> If you want before the conference
19:28:37 <Rhea> Yeah I'm not sure when will we have time during the conference, i was thinking about feeding you guys some local / slovak food (slovak != local //but there are restaurants)
19:28:42 <Rhea> :D
19:29:19 <nmilosev> sure :)
19:29:36 <tmds> I'd like that too
19:30:12 <Rhea> okay lets end the meeting i guess :D
19:30:15 <Rhea> #meetingend
19:30:19 <bt0> :D
19:30:22 <Rhea> I'll get back to you about foods and stuff
19:30:26 <Rhea> oh i made it wrong
19:30:28 <Rhea> #endmeeting