15:00:02 <adamw> #startmeeting Fedora QA meeting
15:00:02 <zodbot> Meeting started Mon Mar 13 15:00:02 2017 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:02 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:00:08 <adamw> #meetingname fedora-qa
15:00:08 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:14 <adamw> #topic Roll call
15:00:21 <adamw> morning everyone, who's here for qa meeting?
15:00:36 * tenk is here
15:00:42 * kparal is here
15:00:43 * pschindl_wfh is here
15:00:59 * Sumantrom is here
15:01:02 * coremodule is here.
15:02:05 * roshi is here
15:02:29 * a2batic is here
15:02:36 <adamw> morning folks
15:02:39 * cmurf thinks DST is for the birds, but then realizes even they've rejected this nonsense
15:02:47 <adamw> #chair kparal roshi
15:02:47 <zodbot> Current chairs: adamw kparal roshi
15:02:49 <adamw> cmurf: right?
15:03:00 <cmurf> Or did I say that 6 months ago?
15:03:01 <adamw> let's all move to alberta
15:03:16 <Sumantrom> Morning adamw
15:03:17 <roshi> is there good fishing in alberta?
15:03:24 <adamw> pretty sure
15:03:36 <adamw> i mean, i guess it depends whether you're the fish
15:03:43 <roshi> if I can hunt and fish, sign me up :p
15:06:22 <adamw> welp. let's get going then!
15:06:37 <adamw> #topic What Adam Didn't Do Last Week
15:06:39 <adamw> ;)
15:06:42 <adamw> #topic Previous meeting follow-up
15:07:45 <adamw> #info "adamw to look into Kerberos credential cache Change and see if it's significant" - didn't do that yet as there are more urgent breakages in FreeIPA bits
15:07:51 <adamw> #action adamw to look into Kerberos credential cache Change and see if it's significant
15:07:59 <adamw> that was the only action item on the list, any other follow-up?
15:09:22 * roshi has nothing
15:09:46 <adamw> aallllrighty
15:09:53 <adamw> #topic Fedora 26 status
15:09:57 <adamw> so, just a quick F26 check-in
15:10:19 <adamw> #info Fedora 26 Alpha freeze is in effect, Go/No-Go meeting is this Thursday
15:10:35 <adamw> we'll have blocker review after this meeting, there seems to be quite a mess with FreeIPA ATM
15:10:50 <roshi> ooh, fun
15:11:22 <adamw> I've mostly been following up on that, are things looking OK in other areas?
15:11:31 <adamw> anyone know of any other significant issues?
15:11:46 * roshi has been slacking in the Alpha readiness dept, but I don't know of anything
15:14:01 * Sumantrom and coremodule has mailed the test day owners of for dnf 2.0 , MBS and anaconda blivet GUI. The dnf change owners have replied that they will respond to ticket on Pagure #495 .
15:14:33 <Sumantrom> Awaiting response from rest of the change owners
15:14:57 <roshi> so we sent out the call for test days or were you reaching out directly to change owners?
15:15:22 <adamw> we sent out the call a while back, right sumantro?
15:15:33 <Sumantrom> Directly to the change owners. We didn't call anything yet.
15:15:34 * pwhalen notes arm should look good, checking on the selinux build (fix loading kernel modules)
15:15:40 <adamw> #info there are several problems in the area of FreeIPA for Alpha, aside from that we're not aware of major issues at the present time
15:15:47 <adamw> pwhalen: thanks
15:17:05 <Sumantrom> Yes adamw we sent out the call and most of the owners were waiting for the branch ..Now that it's out , we are all set to move along
15:18:20 <roshi> if we haven't sent out the call for test days to test-announce, we probably should
15:20:21 <cmurf> Changes have to appear in alpha don't they?
15:20:24 <adamw> it went out a while ago.
15:20:30 <adamw> cmurf: they're supposed to be 'code complete' by alpha, yeah.
15:21:37 <adamw> #info Test Day process is moving along now Alpha freeze is in place, sumantro is following up with proposed Test Day owners
15:23:06 <adamw> welp, sounds like that's it
15:23:08 <adamw> #info Automated update testing
15:23:34 <adamw> so just wanted to mention this, for anyone who missed it: we're now running some of the openQA tests on Bodhi updates
15:25:20 <kparal> \o/
15:25:24 <adamw> you can see the results at https://openqa.fedoraproject.org/group_overview/2
15:25:26 <roshi> shiny
15:25:29 <cmurf> It lives
15:25:39 <adamw> it's broken for F26 updates ATM, which explains the ones where there's a ton of failures, i'll look into that today
15:26:19 <adamw> #info openQA testing of Bodhi updates to critical path packages is now live: see https://openqa.fedoraproject.org/group_overview/2
15:26:23 <Sumantrom> Adamw yeeeh!!
15:26:36 <adamw> #info currently broken for Branched, we will try and fix this soon
15:26:57 <adamw> we're planning to hook this up to the Bodhi web UI soon, so the results will be visible there alongside the taskotron results
15:27:16 <cmurf> fedfind seems confused about -r 26
15:27:43 <adamw> that's not the problem the openqa tests are having...
15:27:45 <adamw> how do you mean?
15:28:07 <cmurf> no results
15:29:04 <cmurf> Oh I see - it just doesn't like -r by itself
15:29:16 <cmurf> nevermind
15:30:29 <adamw> yeah, it'll treat that as 'stable release 26'.
15:30:36 <adamw> anyhoo
15:30:46 <adamw> any thoughts / notes on the update testing stuff?
15:31:01 * roshi has nada
15:31:36 <Sumantrom> The ticket on test day with update testing.. when are we planning for that ?
15:32:04 <Sumantrom> It's like final freeze - 2 weeks or something much closer?
15:33:32 <adamw> Sumantrom: sorry, which test day?
15:33:47 <Sumantrom> Adamw , it's the email that you sent me and coremodule
15:34:15 <Sumantrom> Which mentioned something about calling for a update testing test day.
15:34:35 <Sumantrom> Somewhere closer to the final freeze.
15:36:30 <adamw> oh
15:36:32 <adamw> *upgrade* testing
15:36:53 <Sumantrom> Oops my bad ... Really sorry !!!
15:37:13 <adamw> it's ok, just update/upgrade can be confusing :)
15:37:41 <adamw> i think yeah, the initial idea of a little before Final freeze would be best
15:38:37 <Sumantrom> Got it :)
15:40:43 <adamw> #topic Atomic PRD
15:40:50 <adamw> so...roshi, I believe this is a thing now?
15:40:56 <roshi> it is
15:40:57 <cmurf> Is it done?
15:40:59 <roshi> has been for a bit
15:41:36 <roshi> it's been brought up the last few QA meetings calling for feedback, and I haven't seen any, so I was under the impression people thought it was good to go (I might have missed feedback though?)
15:42:13 <adamw> yeah, I just wanted to give it a bit more prominence
15:42:19 <adamw> what's the link again?
15:42:40 <roshi> jas
15:42:53 <cmurf> https://fedoraproject.org/wiki/Atomic/PRD
15:42:56 <roshi> https://fedoraproject.org/wiki/Atomic/PRD
15:43:02 <roshi> lol
15:43:38 <cmurf> adamw loses urls so just as well we give them in duplicate
15:43:39 <adamw> heh
15:44:19 <roshi> ha
15:44:29 * roshi should look before he pastes
15:44:42 <adamw> feedback still to cloud@ ? or is there an atomic list now?
15:45:10 <roshi> still to cloud, or file an issue on pagure
15:45:18 <adamw> rgr
15:45:21 <roshi> https://pagure.io/atomic-wg
15:45:28 <adamw> #info the updated Atomic PRD is available at https://fedoraproject.org/wiki/Atomic/PRD , please read through it to familiarize yourself with the aims for the Atomic deliverables, and send any feedback you have to cloud@ (or file an issue at https://pagure.io/atomic-wg )
15:45:32 <roshi> that's where they seem to be tracking pretty much everything
15:46:00 <cmurf> I'm not certain what deliverables are blockign
15:46:09 <adamw> roshi: have you given any thought yet to getting from the PRD to some kind of testing requirements definition?
15:46:42 <cmurf> this doesn't seem to be any different
15:46:42 <adamw> cmurf: well, https://fedoraproject.org/wiki/Releases/26/ReleaseBlocking is for tracking that, but the question is a bit tricky for Atomic
15:46:45 <cmurf> https://fedoraproject.org/wiki/Releases/26/ReleaseBlocking
15:46:52 <adamw> as Atomic doesn't really follow the release schedule
15:46:56 <cmurf> right
15:47:02 <cmurf> so blocking doesn't mean the same thing anywya
15:47:28 <roshi> adamw: from what I can tell, I really think it's going to be whatever we (Atomic WG) can get automated, with random smoke tests
15:47:34 <cmurf> DST drunkeness, can't type, duplicate urls, can't use fedfind, what's next?
15:47:50 <adamw> cmurf: =)
15:48:16 <roshi> between autoQA doing the install testing, and the tests we're working to get into taskotron, I think that's going to be the extent of the testing
15:48:32 <tflink> roshi: openqa
15:48:48 <roshi> damnit, that's what I typed first, and erased it because I thought it was wrong
15:48:50 <adamw> =)
15:48:51 <roshi> lol
15:48:51 <tflink> you weren't even around during the autoqa days - how do you manage to mix those up?
15:48:54 <adamw> one day, i'll get you all reprogrammed
15:48:57 <adamw> inorite?
15:49:19 <roshi> I knew it was a buzzprefix-qa of some kind
15:49:33 <roshi> open, auto, cloud, synergy, TPSReport
15:49:38 <tflink> maybe we should have kept the autoqa name - it certainly seems to have staying power :)
15:49:41 <adamw> roshi: hmm, okay. do you think it would be useful to at least have a formal definition of the functionality requirements the automated tests are supposed to be enforcing, or can the PRD serve that purpose on its own?
15:49:52 <adamw> tflink: i'll see if the suse folks want to rename openqa :P
15:50:00 <adamw> SynergyQA!
15:50:11 <roshi> I think having it formally declared would be good, but I haven't gotten to it yet
15:50:21 <roshi> or gotten to telling the WG that would be a good idea
15:50:37 <adamw> OK
15:51:01 <adamw> is it OK if I give you an action item to move forward with that somehow? you got an idea of where to go, or need any help?
15:51:10 <roshi> yeah, that's fine
15:51:25 <roshi> I don't think so, but I'll write a thing up and get some feedback
15:52:08 <adamw> #action roshi to draft up some sort of formal functional requirements / release criteria / something for Atomic
15:52:12 <adamw> there, that's nice and vague!
15:52:51 <adamw> #topic Open floor
15:52:57 <adamw> alrighty, that brings us to open floor
15:52:59 <adamw> any other business?
15:54:49 * roshi has nothing
15:55:12 <adamw> .fire roshi
15:55:12 <zodbot> adamw fires roshi
15:55:40 <roshi> not the first time, and certainly not the last :p
15:55:51 <roshi> .fire up the smoker
15:55:51 <zodbot> adamw fires up the smoker
15:56:44 <adamw> :P
15:56:48 <adamw> allllrighty then, thanks for coming, folks
15:56:52 <cmurf> go no go thursday?
15:57:03 <adamw> there'll be a blocker meeting in #fedora-blocker-review in 3 minutes, led by some doofus who just got fired
15:57:08 <adamw> cmurf: yup yup
15:57:16 <adamw> thanks for coming out, everyone!
15:57:18 * adamw sets teh fuse
15:57:30 <roshi> whee!
15:57:35 <cmurf> exit
15:58:19 <adamw> #endmeeting