15:02:41 <rdieter> #startmeeting kde-sig
15:02:41 <zodbot> Meeting started Tue Mar 28 15:02:41 2017 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:41 <zodbot> The meeting name has been set to 'kde-sig'
15:02:45 <rdieter> #topic roll call
15:02:55 <rdieter> hi all, friendly kde-sig meeting, who's present today?
15:03:09 <jgrulich> hello
15:03:50 <lupinix> hi
15:04:04 <rdieter> #info rdieter jgrulich lupinix present
15:04:05 <mbriza> hello
15:04:12 <rdieter> #chair jgrulich lupinix mbriza
15:04:12 <zodbot> Current chairs: jgrulich lupinix mbriza rdieter
15:04:17 <rdieter> #info mbriza present
15:04:28 <pino|work> o/
15:05:14 * jreznik is around
15:05:37 <rdieter> #info pino|work jreznik present
15:05:40 <rdieter> #chair pino|work jreznik
15:05:40 <zodbot> Current chairs: jgrulich jreznik lupinix mbriza pino|work rdieter
15:06:38 <dvratil> hi
15:07:14 <jreznik> hi
15:07:19 <tosky> hi
15:07:25 <rdieter> #info dvratil tosky present
15:07:28 <rdieter> #chair dvratil tosky
15:07:28 <zodbot> Current chairs: dvratil jgrulich jreznik lupinix mbriza pino|work rdieter tosky
15:08:49 <rdieter> #topic agenda
15:08:53 <rdieter> ok, what to discuss today?
15:09:31 <rdieter> one item: f26 (alpha, theming, blockers)
15:09:32 <lupinix> what about sorting out some stuff from default install? (i think about k3b mostly)
15:10:14 <RaphGro> k3b is useful, why do you think it's not needed?
15:10:29 <rdieter> agenda only for now, can actually discuss later
15:10:39 <RaphGro> ok
15:10:41 <rdieter> lupinix: can add that to f26 topic
15:10:46 <lupinix> ok
15:11:12 <rdieter> I can give an update on Qt 5.8 status, apper
15:11:50 <rdieter> anything else?
15:11:59 <lupinix> nothing else here
15:12:20 <rdieter> #topic f26 (alpha, theming, default apps, etc...)
15:12:46 <rdieter> fyi, new f26-backgrounds landed (kinda late... as usual), and kde spin needs minor changes to use that by default
15:13:26 <rdieter> .bug 1435423
15:13:26 <zodbot> rdieter: Bug 1435423 – Need to fix wallpaper / background packaging situation - https://bugzilla.redhat.com/1435423
15:13:27 <rdieter> see also ^^
15:14:14 <rdieter> not sure if wallpaper is considered an alpha blocker or not (guessing not)
15:14:30 <rdieter> but I can probably work on that sooner or later
15:15:00 <rdieter> lupinix: you wanted to disucss apps to include (by default)?
15:15:09 <rdieter> in particular, k3b.
15:15:10 <lupinix> yes
15:16:19 <lupinix> in case of k3b: more and more computers don't have optical drives, k3b pulls in some stuff like wodim. we may get a lighter default install
15:16:36 * rdieter checks, k3b has an installed-size footprint of ~30mb (itself, not including dependencies)
15:17:06 <rdieter> lupinix: k3b is useful beyond burning optical media too, mind you
15:17:14 <tosky> that's going to change a bit as the next version is Frameworks-based, but not too relevant in this case
15:17:16 <lupinix> yes of course
15:17:17 <rdieter> can also be used to create .iso images
15:18:04 <lupinix> question is: do we want to have a full-featured default or a default providing the commonly used apps
15:18:17 <lupinix> (i'm not sure about that one)
15:18:41 <rdieter> lupinix: did you have any other examples of things to consider removing?
15:18:58 <lupinix> browsers, we have 3 now if we count konqueror
15:18:59 <rdieter> otherwise, the broader discussion is probably not worth it
15:19:11 <rdieter> ah, we can definitely omit konqueror now
15:19:23 <rdieter> at least consider it
15:20:10 <lupinix> *imho* one is enough (and i'm not asking the question here which one it should be, different point)
15:20:16 <rdieter> I think it (still) makes sense to keep primary browser (firefox) + tech-preview (qupzilla)
15:20:48 <lupinix> well, qupzilla is not tech-preview anymore, it is stable
15:20:53 <rdieter> though we could make the tech-preview spin-only (not sure if that's the case yet or not)
15:21:24 <rdieter> lupinix: tech-preview in the sense that it's a candidate worthy of future consideration of default browser too
15:21:47 <lupinix> ok
15:21:58 <rdieter> anyone else want to speak in for/against k3b, konqueror inclusion?
15:22:20 <Southern_Gentlem> rdieter, this is just in the spin correct?
15:22:22 <rdieter> (else, I'll consider silence as support for status quo mostly)
15:22:40 <jgrulich> +1 for including k3b, not that I use it, but we need dvd/usb anyway for our spin so size doesn't matter that much
15:22:45 <rdieter> Southern_Gentlem: probably also affects folks who install "kde desktop environment" afterward
15:22:55 <lupinix> jgrulich: why do we need that?
15:23:10 <lupinix> ok, misread
15:23:11 <Southern_Gentlem> lupinix,  dvd are not DEAD yet
15:23:21 <jreznik> DEAD :)
15:23:28 <pino|work> -_-'
15:23:40 <rdieter> only mostly dead (princess bride plug)
15:23:41 <jgrulich> lupinix: I mean that our users will have to use dvd or usb for our spin anyway, we don't need to fit to cd anymore so not a real problem
15:23:52 <lupinix> Southern_Gentlem: i never said that, but it is less important nowadays in many countries and it is easy to install
15:23:55 <pino|work> rdieter: "the walking dead"
15:24:13 <jgrulich> and +1 for removing konqueror, I think right now nobody uses it anyway when we have firefox/qupzilla
15:24:15 <lupinix> jgrulich: i'm not focusing on cd size, that is impossible nowayds with any desktop
15:24:30 <Southern_Gentlem> lupinix,  but for those poorer countries it is still a need
15:24:30 <lupinix> i'm just thinking about a smaller footprint in general
15:24:44 <rdieter> lupinix has a point, we shouldn't gratuitously bloat things either
15:25:01 <rdieter> and keep things as slim as reasonably possible
15:25:19 <lupinix> Southern_Gentlem: it is just a point if default, k3b will be availbe as package anyway
15:25:47 <lupinix> s/if/of
15:26:02 * rdieter double-checks k3b appdata
15:26:21 * rdieter confirmed, available in discover
15:26:24 <lupinix> nice
15:26:43 <rdieter> so if we did remove it, should be reasonably discover'able (pun)
15:27:30 <rdieter> while on topic of possibly removing stuff, any comment on konqueror (to remove it?)
15:28:20 <Southern_Gentlem> lupinix,  but in countries with very limited bandwidth thats even an issue
15:28:24 <rdieter> reminds me, jgrulich, you've been doing a little discover work upstream?  (I have a gripe or 2 I'd like to discuss after meeting, if possible)
15:28:42 <mbriza> with countries with limited bandwidth, it's an issue to update a package you didn't need in the first place, too
15:28:45 <rdieter> wrt konqueror, that one I could be in favor of removing
15:28:55 <jgrulich> rdieter: sure
15:29:26 <lupinix> mbriza: good argument
15:29:36 <jgrulich> as I said, I would remove it, no need to have three different browsers
15:29:46 <rdieter> jgrulich: one gripe, just searched for konqueror, it showed only f25 GA konqueror-16.08 version, not latest version , wonder if that's something fixable
15:30:16 * rdieter bets the GA version may not even be installable
15:30:30 <jgrulich> rdieter: I haven't looked into the PackageKit backend just yet, but I plan to as soon as possible, still stucked with flatpak support
15:30:38 <rdieter> jgrulich: ok, thx
15:30:50 <rdieter> anyone opposed to removing konqueror ?
15:30:56 <lupinix> +1 @remove
15:31:38 <pino|work> +0.5
15:31:44 <mbriza> +1 @remove
15:32:13 <rdieter> ok, that's good enough for me
15:32:27 <rdieter> #agreed remove konqueror from default f26 kde install
15:33:10 <rdieter> wrt k3b, sounds like there was some opposition to that so far. lupinix, is that sufficient or would you like a formal vote?
15:34:05 <lupinix> i justed wanted to discuss that => fine, maybe we can make a new evaluation for f27 with some more investigation
15:34:12 <rdieter> ok
15:34:17 <lupinix> and maybe discussion with users @mailing list
15:34:27 <rdieter> anyone else have f26-related topics ?
15:34:33 <lupinix> nothing else here
15:35:06 <rdieter> #topic Qt 5.8 status
15:35:33 <rdieter> just an update:  Kevin_Kofler heroically imported stuff from Qt 5.8 copr into master/ branch git
15:36:11 <rdieter> I started bootstrap builds yesterday, qt5-qtbase completed, then rawhide buildroot isn't updating (package remains unsigned)
15:36:54 <rdieter> I poked #fedora-admin earlier, but not fixed yet, as far as I can tell
15:37:08 <rdieter> https://koji.fedoraproject.org/koji/buildinfo?buildID=873133  still in f27-pending
15:37:20 <rdieter> I'll monitor things and pick up when the buildroot updates
15:37:28 <rdieter> any questions or comments ?
15:38:03 <rdieter> oh, related topic: with minor packaging adjustments, it looks like qt5-qtwebengine-5.8 is buildable with f25/f26's current Qt-5.7
15:38:06 <lupinix> yes, qtwebengine, you saif you were successful with webengine 5.8 @qt 5.7?
15:38:16 <lupinix> *said
15:38:21 <rdieter> *maybe* even Qt 5.6, but I haven't tried that one yet
15:38:41 <lupinix> does qupzilla (or other packages) have to be rebuilt?
15:38:50 <rdieter> could be an approach to concerns that previous qtwebengine releases have unresolved security issues
15:39:03 <jgrulich> that's good, then there is no need to push Qt 5.8 to F26/F25, at least for now when it breaks Plasma
15:39:08 <rdieter> lupinix: good question, I tested a non-rebuilt qupzilla so far, it seems ok
15:39:33 <rdieter> lupinix: may not be a bad idea to rebuild stuff anyway
15:40:11 <lupinix> for qupzilla kevin wrote something about new features available then, but i'm not sure if this is limited to webengine or whole qt 5.8
15:40:11 * rdieter looks for copr link
15:40:31 <rdieter> https://copr.fedorainfracloud.org/coprs/g/kdesig/qtwebengine/
15:40:48 * lupinix will test
15:41:32 <rdieter> when Qt 5.8 is otherwise done, I'll adjust qtwebengine fedpkg/git sources with necessary adjustments too
15:41:33 <RaphGro> what's the replacement for konqueror?
15:41:50 <lupinix> RaphGro: no replacement
15:41:53 <rdieter> RaphGro: we already have 2 other browsers (firefox, qupzilla), and filemanager (dolphin)
15:42:03 <rdieter> is that enough? :)
15:42:07 <RaphGro> ah, dolphin. I forgot. sorry
15:42:19 <lupinix> and also krusader @file manager
15:42:22 <rdieter> actually, krusader may end up there too
15:42:39 <rdieter> <shrug>
15:42:49 <lupinix> :D
15:43:09 <rdieter> ok, moving on...
15:43:10 <rdieter> #topic apper
15:43:24 <rdieter> so, nothing gets things fixed like threatening to remove it :-P
15:43:41 <rdieter> 2 big bugs that supported the case for removing it from default install were fixed recently
15:44:04 <rdieter> cosmetic: breeze theming progress bars now appear correctly
15:44:23 <rdieter> bigger: plasma-pk-session helper, crasher was fixed
15:45:29 <lupinix> were there any other annoying bugs?
15:45:44 <lupinix> except the "groups not supported by backend"
15:46:19 <rdieter> the stuff that it made it a poor package manager still remains
15:46:31 <rdieter> but at least it (kinda) supports PK session interface now
15:46:32 * lupinix wonders whether we should think about undo the removal
15:47:29 <rdieter> org.freedesktop.PackageKit.Modify only is supported, not the newer org.freedesktop.PackageKit.Modify2 one
15:48:35 <rdieter> lupinix: we could, yes
15:49:56 <rdieter> I think it may be premature to decide for sure, the fixed builds are still in -testing, let's get some feedback/testing forst
15:49:58 <rdieter> first
15:50:08 <lupinix> ack
15:50:38 <rdieter> i'll try retesting, codec-installer after meeting
15:50:58 <rdieter> anything else on apper?
15:51:11 <lupinix> nothing else here
15:51:23 <rdieter> #topic open discussion
15:51:28 <x3mboy> !
15:51:31 <rdieter> I think that's all the agenda, anything else?
15:51:41 <rdieter> x3mboy: yes?
15:51:41 <x3mboy> Sorry to interrupt your meeting
15:51:55 <x3mboy> I'm in representation of the marketing team
15:52:04 <rdieter> hi
15:52:11 <x3mboy> And I'm here to ask for your help
15:52:14 <lupinix> hi x3mboy
15:52:20 <x3mboy> Hi!
15:52:24 <x3mboy> :D
15:52:50 <x3mboy> As you should know, we prepare Talking Points to help marketing and ambassadors to publicize Fedora
15:52:56 <rdieter> x3mboy: (for posterity, feel free to stop by #fedora-kde any time too)
15:53:07 <x3mboy> And we are asking all SIGs and WGs to help us
15:53:14 <x3mboy> https://fedoraproject.org/wiki/Fedora_26_talking_points#Fedora_Cloud
15:53:41 <x3mboy> Sorry, is this one: https://fedoraproject.org/wiki/Fedora_26_talking_points#KDE_Desktop
15:53:56 <x3mboy> Can you give us a hand with this???
15:54:11 <lupinix> x3mboy: feel free to bother me @LXQt too (i created the new spin)
15:54:12 <x3mboy> rdieter, Thanks! I will be there next time ;)
15:54:38 <x3mboy> lupinix, good to know!
15:54:58 <tosky> uhm, starting with the name (which is not KDE Desktop)
15:55:01 <x3mboy> lupinix, https://fedoraproject.org/wiki/Fedora_26_talking_points#LXQt is there for you :D
15:55:34 <tosky> so is it kind of marketing release notes for Fedora 26?
15:56:52 <x3mboy> Kind of
15:57:17 <x3mboy> Basically is like a list of highlights to focus in marketing campaigns and to ambassadors to talk to in events
15:58:36 <rdieter> x3mboy: how to help?  tell you stuff?  edit the wiki directly? other?
15:58:45 <x3mboy> Any of them
15:58:55 <x3mboy> If you want to tell me, I will be happy to add to the wiki
15:59:25 <x3mboy> Atomic SIG ask for a ticket in their pagure, and there they will release the notes, and I will pass that to the wiki
16:00:38 <rdieter> we probably should jump on the pagure bandwagon sooner or later too
16:01:16 <x3mboy> But as you like. If you edit the wiki directly is faster, but for me, it works in the way that fit your needs better
16:01:31 <x3mboy> ML, maybe, or in your IRC channel...
16:02:48 <x3mboy> So, I think you pass the time of meeting. Let me know if I should throw an email in your ML
16:02:59 <x3mboy> Or contact me in any IRC channel
16:03:55 <rdieter> x3mboy: asking onlist would be a good idea too
16:04:21 <rdieter> (there are contributors that could help that aren't here)
16:04:27 <x3mboy> rdieter, Good, I'll do that better
16:04:38 <x3mboy> rdieter, thanks for your time and for your efforts
16:04:55 <x3mboy> A lor of people is using fedora kde thanks to you
16:06:28 <rdieter> x3mboy: thanks for stopping by
16:06:37 <rdieter> any last words before we close the meeting anyone?
16:06:47 <lupinix> nothing else here
16:08:34 <rdieter> ok,, thanks everyone!
16:08:38 <rdieter> #endmeeting