15:03:31 <rdieter> #startmeeting kde-sig
15:03:31 <zodbot> Meeting started Tue Apr 18 15:03:31 2017 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:31 <zodbot> The meeting name has been set to 'kde-sig'
15:03:36 <rdieter> #meetingname kde-sig
15:03:36 <zodbot> The meeting name has been set to 'kde-sig'
15:03:39 <rdieter> #topic roll call
15:03:41 <pino|work> o/
15:03:45 <rdieter> hi all, friendly kde-sig meeting, who's present today
15:03:47 <rdieter> ?
15:04:22 <lupinix> hi
15:04:53 <tosky> hi
15:05:10 <Kevin_Kofler> Me.
15:06:15 <rdieter> #info rdieter pino|work lupinix tosky Kevin_Kofler present
15:07:16 * jgrulich is present
15:07:50 <rdieter> #info jgrulich present
15:07:57 <rdieter> #chair pino|work lupinix tosky Kevin_Kofler jgrulich
15:07:57 <zodbot> Current chairs: Kevin_Kofler jgrulich lupinix pino|work rdieter tosky
15:09:39 <rdieter> #topic agenda
15:09:45 <rdieter> hi all, what to discuss today?
15:10:08 * rdieter has f25/plasma-5.9.4
15:10:15 <rdieter> kde-apps status/update
15:10:57 <rdieter> anyone else?
15:10:58 <x3mboy> rdieter, F26 Talking Points???
15:11:00 <x3mboy> :D
15:11:02 <x3mboy> Sorry
15:11:18 <x3mboy> I just didn't receive feedback from ML
15:11:27 <rdieter> I don't have anything to add on the topic (yet), sorry
15:11:33 <Kevin_Kofler> Do we want to discuss the usability and functionality regression of apps no longer working as root / under kdesu (KWrite, Kate, Dolphin) here? Or was the discussion on #fedora-kde sufficient?
15:12:17 <rdieter> Kevin_Kofler: I think #fedora-kde and/or mailing list is sufficient for now (I think we're still far from agreement on any action)
15:12:37 <Kevin_Kofler> So by default nothing will happen? Sigh!
15:12:53 <rdieter> on consensus means no action, true
15:13:02 <rdieter> s/on/no/
15:13:06 <Kevin_Kofler> But that changes the status quo of 16.12.
15:13:27 <Kevin_Kofler> The safe thing to do would be to keep the status quo in the 17.04 upgrades unless there is agreement to follow upstream.
15:13:42 <Kevin_Kofler> For the meeting log: See https://phabricator.kde.org/D4634#100456 for the issues.
15:13:53 <rdieter> you're welcome to make that argument (outside this meeting)
15:14:14 <rdieter> I just want to save meeting time for non-debates
15:14:17 <rdieter> (in general)
15:14:39 <x3mboy> rdieter, +1
15:14:54 <rdieter> #topic f25/plasma-5.9.4
15:15:16 <rdieter> ok, so plasma-5.9.x update for f25 has been in -testing for at least a week now, generally good feedback
15:15:42 <rdieter> https://bodhi.fedoraproject.org/updates/FEDORA-2017-3f38641f48
15:15:47 <rdieter> was in copr for long before that too
15:15:59 <rdieter> any comments or objections to sending this to stable updates ?
15:16:22 <Markus_KMi_[m]> Used it from copr for a while. Looked OK
15:16:36 <jgrulich> works for me, +1 for pushing to stable
15:16:42 <tosky> I could not test it so far, but yeah, let's go
15:17:03 <lupinix> works fine here on 4 machines => +1 @push
15:17:09 <tosky> there is an objection on a plasma-nm bug, jgrulich, is it all fine?
15:17:22 <jgrulich> tosky: should be fixed now
15:17:48 <rdieter> wasn't the change of behavior with NM-1.6 only anyway?
15:18:05 <rdieter> some default changed?
15:18:12 <jgrulich> rdieter: yeah, it was due to NM 1.6 changing default value for auto-negotiation in wired setting
15:18:24 <rdieter> jgrulich: so theoretically it should affect only f26+
15:18:30 <rdieter> but user mentioned f25 I thought
15:18:47 <rdieter> (or maybe they were confused)
15:19:02 <jgrulich> rdieter: well, I didn't know that this change was in NM 1.6 only, so I changed the default for all NM versions, then I had to partially change it back
15:19:05 <tosky> jgrulich: thanks
15:20:28 <rdieter> jgrulich: ok
15:20:53 <rdieter> #agreed plasma-5.9.4 headed to f25 stable updates soon
15:21:14 <rdieter> #topic recent updates
15:21:32 <rdieter> got some baby-steps done importing kde-apps-17.04.0 into rawhide
15:21:38 <rdieter> core modules so far
15:22:04 <rdieter> big change there is that translations are now in individual modules now (instead of kde-l10n)
15:22:11 <tosky> only for Qt5 applications
15:22:19 <rdieter> sorry, right, only kf5 apps
15:22:24 <tosky> which will mean "all applications" in two cycles
15:22:27 <rdieter> which is most of them now
15:22:31 <rdieter> yay
15:22:52 <rdieter> anyway, means a lot of manual updates/fixing/tweaking of .spec files are required
15:23:05 <Kevin_Kofler> What is left using kdelibs4 in the "official" kde-apps?
15:23:15 <rdieter> mostly just adding Conflicts: kde-l10n < 17.03, and usage of %find_lang
15:23:33 <tosky> most of kdeaccessibility, half of games, kremotecontrol and sweeper from kdeutils
15:23:46 <rdieter> unfortunately, %find_lang still lacks support for kf5 HTML handbooks
15:24:12 <pino|work> where is %find_lang coming from?
15:24:21 <rdieter> rpm itself
15:24:44 <pino|work> couldn't we roll-out a custom %kf5_find_lang or so?
15:24:53 <tosky> part of multimedia (kscd, juk); kget, kppp; kdewebdev; ksaneplugin
15:24:56 <rdieter> pino|work: possible, yes
15:24:56 <tosky> and that's mostly it
15:25:10 <rdieter> short term, use custom macro, long term: add support to upstream rpm
15:25:21 <tosky> rdieter: but kf5 HTML handbooks should be almost the same as kdelibs4-ones
15:25:32 <tosky> just the DTD is different, but the location in Fedora is the same
15:25:35 <pino|work> rdieter: tbh i would keep it local, instead of in rpm itself
15:25:37 <rdieter> tosky: problem being is rpm currently groks the path from kde4-config output
15:25:38 <Kevin_Kofler> It's actually the lack of kde4-config that is the issue.
15:25:49 <Kevin_Kofler> If you BR kdelibs-devel, it'll actually find the KF5 handbooks.
15:25:53 <tosky> rdieter: ah
15:26:00 <Kevin_Kofler> (or even just kdelibs I guess)
15:26:17 <Kevin_Kofler> Yeah, kdelibs main pkg is sufficient.
15:26:28 <rdieter> ideally, I think *a* fix is to keep query for kde-config/kde4-config, and then fallback to hard-coded /usr/share/doc/HTML default
15:26:32 <tosky> do you know if there is some macro which referes to /usr/share/help ?
15:26:50 <tosky> I have a long-term plan to move the default location there - but that's unrelated to the present issue
15:27:03 <Kevin_Kofler> I'd just add a BR kdelibs to the package, with a comment saying:
15:27:12 <Kevin_Kofler> # for kde4-config, used by %%find_lang
15:27:22 <rdieter> tosky: I'm guessing no
15:27:25 <tosky> oki
15:27:30 <Kevin_Kofler> Similarly to how we BR desktop-file-utils for desktop-file-validate etc.
15:27:44 <rdieter> in fact, rpm -q -f /usr/share/help => file /usr/share/help is not owned by any package
15:27:55 <rdieter> so that probably needs love/fixing too
15:27:56 <pino|work> desktop-file-utils is a much lighter BR than kdelibs though
15:28:23 <rdieter> Kevin_Kofler: eww, pulling in kde4 runtime just for kde4-config is doable, but heavy-handed
15:28:40 <Kevin_Kofler> You don't actually need kde-runtime, only kdelibs. ;-)
15:28:52 <rdieter> a kde4 runtime lib, like kdelibs
15:29:18 <Kevin_Kofler> The alternative is to get %find_lang fixed.
15:29:45 <rdieter> anyway, anyone wanting to work on any of those proposed solutions is ok with me.
15:29:45 <tosky> then at least BR to kdelibs4support and change it to kf5-config, even if deprecated
15:29:56 <rdieter> I likely won't have time to finish working on the rest of kde-apps for awhile
15:30:25 <rdieter> tosky: <nod>, my proposed solution would add support for kf5-config + hard-coded fallback
15:30:46 <rdieter> if none of kde-config,kde4-config,kf5-config are present
15:30:48 <tosky> I wonder how Gnome handls it
15:30:55 <tosky> for their documentation
15:31:29 <rdieter> tosky: it appears find_lang hard-codes <prefix>/share/help
15:31:52 <rdieter> oh, and /usr/share/gnome/help too
15:31:55 <tosky> rdieter: so maybe it could make sense to hardcode that prefix too
15:32:08 <Kevin_Kofler> IMHO, they should also hardcode the KDE location and stop trying to run *-config tools at all.
15:32:13 <tosky> but yeah, that basically means the fallback
15:32:30 <Kevin_Kofler> There is also the longstanding issue that they run kde-config and process everything found there, then they run kde4-config and process everything found there.
15:32:50 <Kevin_Kofler> So for those odd packages that BR both kdelibs 3 and 4, the docs are found twice (because the location returned is one and the same).
15:32:50 <rdieter> Kevin_Kofler: for completeness, any fix I work on would fix that duplicates problem as well
15:33:06 <rdieter> query for locations, and search them (at most) once
15:33:48 <rdieter> (I hadn't considered that when I submitted support for kde4-config in the past)
15:34:21 <rdieter> anyway, anyone else with recent updates or status reports?
15:34:29 <Kevin_Kofler> Yeah, me.
15:34:44 <Kevin_Kofler> qt5-qtwebengine 5.8.0 finally went out to the stable updates (F25/F26 only).
15:34:50 <rdieter> wow, that was fast
15:34:57 <rdieter> nice
15:35:21 <Kevin_Kofler> qt5-qtwebengine-freeworld 5.8.0 is also being pushed now, it just takes time to process (since they picked up the Fedora tooling… IIRC, it used to be much faster before :-( ).
15:35:43 <Kevin_Kofler> And I submitted updates to QupZilla for testing that enable spell checking.
15:35:56 <Kevin_Kofler> (I had to patch the version checks and then build against QtWebEngine 5.8.)
15:36:14 <Kevin_Kofler> (I had to patch the version checks because we have only Qt 5.7.)
15:36:30 <Kevin_Kofler> http://pkgs.fedoraproject.org/cgit/rpms/qupzilla.git/tree/QupZilla-2.1.2-mixed-versions.patch
15:36:54 <rdieter> <nod>, previously used QT_VERSION_CHECK
15:37:04 <Kevin_Kofler> I should probably file a pull request upstream for that.
15:37:19 <Kevin_Kofler> (2.1 branch only, master requires 5.8, so does not have those checks at all anymore.)
15:38:34 <rdieter> Kevin_Kofler: thanks
15:40:16 <rdieter> moving on...
15:40:20 <rdieter> #topic open discussion
15:40:31 <rdieter> I think that's all we had for formal topics, anything else to discuss?
15:40:41 <rdieter> oh, there's one f26 blocker I recall
15:41:14 <rdieter> the plasma-pk-updates reports updates on live image one
15:41:36 <rdieter> .bug 1436873
15:41:36 <zodbot> rdieter: An error has occurred and has been logged. Please contact this bot's administrator for more information. - https://bugzilla.redhat.com/1436873
15:41:42 <rdieter> anyone able/willing to look into that?
15:41:53 <rdieter> https://bugzilla.redhat.com/show_bug.cgi?id=1436873
15:42:15 <rdieter> looks like our prior hack no longer works
15:43:03 <rdieter> X-KDE-PluginInfo-EnabledByDefault=false in plasma-applet-org.kde.plasma.pkupdates.desktop
15:43:16 <rdieter> via 'sed'
15:44:15 <rdieter> I suspect it's because plasma now generates/uses defaults from buildtime, and not runtime
15:44:53 <rdieter> (just a guess)
15:45:03 <tosky> uhm, that needs some plasma expert
15:46:12 <Kevin_Kofler> FYI: https://github.com/QupZilla/qupzilla/pull/2309
15:49:00 <rdieter> ok, well, think on it.
15:49:09 <rdieter> anything else before we end the today's meeting?
15:50:16 * tosky says "nothing"
15:52:11 <rdieter> alright, thanks everyone!
15:52:14 <rdieter> #endmeeting