15:02:27 <rdieter> #startmeeting kde-sig
15:02:27 <zodbot> Meeting started Tue May  9 15:02:27 2017 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:27 <zodbot> The meeting name has been set to 'kde-sig'
15:02:31 <rdieter> #topic roll call
15:02:36 <tosky> o/
15:02:39 <rdieter> hi all, friendly kde-sig meeting, who's present today?
15:02:39 <lupinix> .hello lupinix
15:02:43 <zodbot> lupinix: lupinix 'Christian Dersch' <lupinix@mailbox.org>
15:03:19 <rdieter> #info rdieter tosky lupinix present
15:03:36 <jgrulich> hi
15:04:04 <rdieter> #info jgrulich  present
15:04:08 <rdieter> #chair tosky lupinix jgrulich
15:04:08 <zodbot> Current chairs: jgrulich lupinix rdieter tosky
15:04:08 * pino|work too
15:04:19 <rdieter> #info pino|work present
15:04:21 <heliocastro> here
15:04:30 <rdieter> #info heliocastro present
15:04:33 <rdieter> #chair pino|work heliocastro
15:04:33 <zodbot> Current chairs: heliocastro jgrulich lupinix pino|work rdieter tosky
15:04:57 <rdieter> #topic agenda
15:05:04 <rdieter> alright, topics to discuss today?
15:05:22 <rdieter> probably plasma-5.9.5 update, push to stable?
15:05:28 * lupinix has plasma 5.9.5 f25 update and a suggestion for f26 default stuff
15:05:44 <rdieter> lupinix: ok
15:05:51 <rdieter> maybe a Qt-5.9 status report too
15:05:57 <rdieter> anything else?
15:05:58 <than> present
15:06:02 <rdieter> #info than present
15:06:04 <rdieter> hi
15:06:05 <rdieter> #chair than
15:06:05 <zodbot> Current chairs: heliocastro jgrulich lupinix pino|work rdieter than tosky
15:06:07 <mbriza> hello there
15:06:12 <rdieter> #info mbriza present
15:06:13 <heliocastro> Informed on list that in the *secret* sprint plasma will start ti depend on 5.9 now
15:06:14 <rdieter> #chair mbrize
15:06:14 <zodbot> Current chairs: heliocastro jgrulich lupinix mbrize pino|work rdieter than tosky
15:06:29 <tosky> are there blockers for F26? I was totally working upstream in the last weeks
15:06:30 <rdieter> heliocastro: plasma-5.10 ?
15:06:33 <pino|work> #chair mbriza
15:06:33 <zodbot> Current chairs: heliocastro jgrulich lupinix mbriza mbrize pino|work rdieter than tosky
15:06:35 <heliocastro> Yep
15:06:37 <rdieter> k
15:06:48 <rdieter> yikes, means f25 will need that or stay on plasma-5.9.x
15:06:49 <tosky> heliocastro: 5.10? But it should go out before 5.9
15:07:02 <rdieter> (f26 too I guess)
15:07:04 <tosky> plasma 5.10 and qt 5.9, I mean
15:07:07 <tosky> but let's go in order
15:07:09 <heliocastro> tosky: Upstream info
15:07:21 <rdieter> #topic plasma-5.9.3
15:07:24 <rdieter> #undo
15:07:24 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x421caed0>
15:07:30 <rdieter> #topic plasma-5.9.5
15:07:46 <rdieter> there, so this has been in -testing for ... a week or so?  any objections to stable push?
15:07:49 <Kevin_Kofler> So first they refuse to support the latest stable Qt, and now they require an unreleased Qt? <SARCASM>Congratulations!</SARCASM>
15:07:51 <rdieter> or other comment/feedback
15:08:00 <lupinix> +1 @stable push
15:08:09 <heliocastro> +1 as well
15:08:18 <rdieter> +1 here too
15:08:18 <heliocastro> i'm quite happy with latest build
15:08:24 <than> +1
15:08:56 <rdieter> #agreed plasma-5.9.5 is ready for stable updates
15:08:59 <lupinix> as i submitted that update i'll hit the push to stable button now
15:09:06 <rdieter> lupinix: thanks
15:09:16 <rdieter> #topic Qt 5.9 status
15:09:26 <rdieter> heliocastro (or anyone else working on it)?
15:09:36 <heliocastro> No, only kevin maybe on webengine
15:09:42 <rdieter> just a brief status report
15:09:59 <heliocastro> But i'm on streak today, and will be done tonight except for webengine
15:10:07 <heliocastro> Then we need start rebuilds
15:10:16 <rdieter> good news
15:10:37 <Kevin_Kofler> I haven't started doing QtWebEngine yet.
15:10:39 <rdieter> anyone know offhand when f26 freeze hits?
15:10:47 <rdieter> wonder if we can get this in time for f26 GA
15:10:49 <Kevin_Kofler> Most likely during the weekend, but let's see.
15:10:49 <heliocastro> I'm compiling both on rawhide and for rawhide, 26, 25 and epel on copr as well
15:11:05 <lupinix> 16th may
15:11:08 <tosky> so, let's clear one point: Plasma 5.10 can't release until Qt 5.9 is released
15:11:10 <lupinix> @beta freeze
15:11:20 <lupinix> final freeze 13th june
15:11:23 <rdieter> k, a whole week, plenty of time, what could go wrong?
15:11:32 <tosky> this is a clear thing that will generate discussion upstream, regardless of what people told heliocastro
15:11:33 <Kevin_Kofler> Things can still sneak in between Beta and Final. :-)
15:11:44 <Kevin_Kofler> There's a short merge window there.
15:11:46 <rdieter> ah, true
15:11:54 <rdieter> k, non-sarcastic plenty of time then :)
15:12:15 <rdieter> anyhthing else wrt Qt 5.9 ?
15:12:26 <Kevin_Kofler> But do you want Qt 5.9 prereleases in F26 GA?
15:12:30 <heliocastro> Maybe push those extra packages to aproval
15:12:45 <rdieter> Kevin_Kofler: good question, I haven't checked Qt release schedule
15:12:55 <rdieter> forgot we're only dealing with beta3 here
15:12:59 <Kevin_Kofler> I'd rather try to get 5.8 in there, though you'd have to track down regression fixes.
15:13:24 <rdieter> personally, I think 5.9beta is in better shape than 5.8
15:13:31 <heliocastro> Agreed
15:13:45 <heliocastro> No reason to go after 5.8, is even not maintained upstream
15:13:45 <lupinix> i got some comments from LXQt devs that 5.9 is already better than 5.8.0
15:14:30 <Kevin_Kofler> I'm going to need some time for QtWebEngine, they switched from gyp to gn, so there may be specfile changes needed, and at least some parts of the sse2 patch need updating.
15:14:38 <rdieter> but we'll see how smoothly rawhide Qt 5.9 builds progress before making any final judgements
15:15:05 <lupinix> yes
15:15:10 <heliocastro> If anyone interested in help push to review, i have at lkeast this one: https://copr.fedorainfracloud.org/coprs/g/kdesig/qt-5.9/package/qt5-qtremoteobjects/
15:15:32 <heliocastro> Did not make the other 3 yest
15:15:36 <rdieter> oh right, I recall you mentioning a few other new modules
15:15:52 <heliocastro> qtpurchasing
15:15:58 <heliocastro> qtspeech
15:15:59 <Kevin_Kofler> Bumping the version numbers of the bundled inferno is also always "fun".
15:16:13 <heliocastro> qtnetworkauth
15:16:15 <rdieter> I forget, there's 1 or 2 other pkgs in fedora that can optionally use qtspeech
15:16:29 <tosky> qtpurchasing is not so urgent; on the other side, few applications would benefit by qtspeech
15:16:43 <heliocastro> The "alexa" like KDE module ise speech
15:16:45 <heliocastro> *use
15:17:03 <tosky> no, even stuff part of KDE Applications
15:17:04 <rdieter> Kevin_Kofler: fun fun fun
15:17:10 <heliocastro> This packages are relatively small
15:17:14 <tosky> QtSpeech replaces Jovie basically
15:17:40 <rdieter> tosky: good to know, thanks
15:18:02 <rdieter> anything else?  move on?
15:18:21 <Kevin_Kofler> Not an official part of Qt 5.9, but the QtWebKit community branch should also be shippable now (as I pointed out recently on #fedora-kde).
15:18:41 <heliocastro> Yep, is in my plan for tonight if had time
15:18:57 <heliocastro> Will be the first time that we have everything
15:19:03 <rdieter> <nod>, that's good news too
15:19:04 <heliocastro> since webkit demise
15:20:07 <rdieter> moving on...
15:20:13 <rdieter> #topic f26+ defaults
15:20:14 <rdieter> lupinix:  ?
15:20:35 <lupinix> workstation are promoting a new feature: night light https://fedoramagazine.org/native-screen-color-temperature-tweaking-night-light/
15:20:41 <heliocastro> What is in the queue to be updated today: qtquickcontrols qtvirtualkeyboard qtlocation qttools qtscript qttranslations qtdoc
15:20:49 <lupinix> i think we should add plasma-applet-redshift-control
15:20:59 <lupinix> which provides the same functionality for plasma
15:21:25 * rdieter installed that awhile back, it's nice
15:21:33 <rdieter> I'm ok with that suggestion, +1
15:21:38 <Kevin_Kofler> Is that enabled by default if you install it?
15:21:44 <rdieter> I don't think so
15:21:45 <Kevin_Kofler> I think most users probably do not expect that.
15:21:48 <rdieter> I had to add the applet
15:21:59 <Kevin_Kofler> If it's off by default, I guess shipping it doesn't hurt though.
15:21:59 <lupinix> yes, not active @default
15:22:13 <lupinix> but very easy to add then :)
15:22:33 <lupinix> thats all i have @f26 defaults
15:22:52 <lupinix> ah wait, maybe one more thing
15:23:03 <rdieter> if there's no objection, feel free to submit a pagure pull request to fedora-comps to add it
15:23:09 <lupinix> ok, will do
15:23:27 <lupinix> .bug 1449134
15:23:27 <zodbot> lupinix: Bug 1449134 – KDE has two SW management/updater applications/icons on the Task manager - https://bugzilla.redhat.com/1449134
15:23:38 <lupinix> that has to be fixed in dnfdragora
15:24:04 <rdieter> lupinix: oh, dnfdragora installs a systray applet?
15:24:15 <lupinix> yes, this is new
15:24:19 <rdieter> I don't recall seeing that
15:24:32 <Kevin_Kofler> dnfdragora doesn't, dnfdragora-gui now does.
15:24:34 <rdieter> ok, re-open and reassign to dnfdragora then
15:24:39 <Kevin_Kofler> Just install only the main package.
15:24:40 <lupinix> besser82 made it a bit too default
15:24:43 <Kevin_Kofler> .bug 1448812
15:24:43 <zodbot> Kevin_Kofler: Bug 1448812 – RFE: Rename dnfdragora-gui subpackage to dnfdragora-updater - https://bugzilla.redhat.com/1448812
15:24:51 <Kevin_Kofler> I already filed that one.
15:25:01 <lupinix> Kevin_Kofler: +1 i'll ask björn to change that
15:25:04 <rdieter> I thought we only install dnfdragora
15:25:07 * rdieter forgets
15:25:17 <rdieter> whatever, we know what we want :)
15:25:22 <Kevin_Kofler> I think Björn changed it in comps at some point.
15:25:44 <Kevin_Kofler> We'll want to change it back.
15:25:51 <rdieter> any volunteer(s) to work on fixing this?
15:26:00 * lupinix will do that with björn
15:26:09 <rdieter> lupinix: ok, thanks again
15:26:47 <rdieter> while on the subject of f26, may as well mention other issues, bugs, blockers now
15:26:51 <rdieter> .bug 1436873
15:26:51 <zodbot> rdieter: Bug 1436873 – KDE live environment notifies of available updates - https://bugzilla.redhat.com/1436873
15:26:52 <rdieter> is one I know about
15:27:13 <rdieter> the previous way of disabling the applet on live image no longer works
15:27:23 <rdieter> (apparently)
15:28:15 <rdieter> that one is a release blocker, fyi
15:29:13 <rdieter> any help there would be appreciated, any other f26-related issues to mention?
15:29:33 <lupinix> not that i know of
15:30:11 <rdieter> k, moving on...
15:30:14 <rdieter> #topic open discussion
15:30:22 <rdieter> anything else before we close the meeting?
15:30:30 <lupinix> nothing else here
15:30:30 * rdieter saw kde-apps-17.04.1 release today
15:31:14 <rdieter> another call for help/assistance: updating to kde-apps-17.04 in rawhide, requires some manual package tweaking, mostly due to now-included translations
15:31:43 <tosky> rdieter: it's the tag today, respins still possible iirc
15:31:59 <rdieter> one thing I could do, if it would help... I could run my auto-update script anyway, even though many builds would probably fail as-is
15:32:14 <rdieter> then all that would need fixing is generally adding %find_lang ... calls
15:33:15 <rdieter> would my doing so make anyone more likely to help? :)
15:33:32 <rdieter> maybe I'll just-do-it anyway
15:33:55 <lupinix> maybe, but have a high workload, so expect delays…
15:34:06 <lupinix> some deadlines until next week
15:34:18 <rdieter> I theoretically could script adding %find_lang, but newer rpm is "helpful" in that builds will fail if foo.lang is empty :-/
15:34:24 <rdieter> (older rpm did not fail in that case)
15:34:50 <rdieter> may have to look if it's possible to disable that behavior
15:37:32 <heliocastro> Bahh, waiting for s390x takes ages
15:37:48 <rdieter> even slower than arm ?
15:37:53 <heliocastro> way slower
15:37:58 <rdieter> ouch
15:38:24 <tosky> strange, on Debian they are the faster machines iirc
15:38:29 <heliocastro> qt5-qtquickcontrols2 is taking 50% of the time of the whole build only on s390x
15:38:42 <sharkcz> I guess it depend what is slower, s390x should be among the fastest
15:39:09 <rdieter> quickcontrols2 isn't big either
15:39:12 * tosky wonders if sharkcz has an highlight rules for s390
15:39:18 <sharkcz> I have :-)
15:39:22 <tosky> :D
15:39:37 <rdieter> maybe it's a particular builder being slow?
15:39:45 <heliocastro> Can't say
15:39:54 <rdieter> heliocastro: has it happened often or every time?
15:40:03 <rdieter> or just noticed this once?
15:40:16 <sharkcz> it could be waiting for a builder, the disadvatage of the setup is that the builders are connected over WAN to the hub
15:40:31 <sharkcz> but a quite fast wan
15:40:36 <heliocastro> rdieter: Started after qtquick packages
15:40:39 <heliocastro> so not everytime
15:41:10 <heliocastro> sharkcz: Was not the case: 19475699 buildArch (qt5-qtquickcontrols2-5.9.0-0.beta.3.fc27.src.rpm, s390x): free
15:41:20 <sharkcz> also s39p lacks some JITs (openjdk to added in openjdk9)
15:41:25 <rdieter> https://koji.fedoraproject.org/koji/taskinfo?taskID=19475691
15:41:31 <rdieter> ah, s390x hasn't even started yet
15:41:49 <rdieter> so, not that builds are slow, there's no available builders
15:41:59 <sharkcz> yup
15:42:08 <rdieter> that's not good either
15:42:31 <rdieter> already waited ~30 minutes for a builder
15:42:35 <heliocastro> more in the case that this specific build need to be ordered
15:42:37 <sharkcz> we should be able to add more builder when we reduce the builders for F<27
15:43:43 <rdieter> anything else to discuss before we close the meeting ?
15:44:07 <heliocastro> Not from me
15:44:27 <lupinix> nothing else here
15:49:56 <rdieter> k, thanks everyone
15:49:58 <rdieter> #endmeeting